OpenLayers.Base Namespace

[image]

OpenLayers for .NET Documentation
OpenLayers.Base Namespace
Send Feedback
Provides a programming interface for Open Layers-compatible hardware devices.

Classes

 | Class | Description
Public class | AnalogInputSubsystem | The AnalogInputSubsystem class provides the properties, methods, and events for performing analog input operations.
Public class | AnalogOutputSubsystem | The AnalogOutputSubsystem class provides the properties, methods, and events for performing analog output operations.
Public class | AnalogSubsystem | The AnalogSubsystem class is an abstract base class and is accessible only by using the following derived classes: AnalogInputSubsystem and/or AnalogOutputSubsystem.
Public class | BridgeSensorTeds | The BridgeSensorTeds class provides the properties for a bridge-based sensor that supports TEDS.
Public class | BufferDoneEventArgs | A BufferDoneEventArgs object is passed to one of the following delegates when the associated event occurs: BufferDoneHandler delegate when the event BufferDoneEvent occurs or PreTriggerBufferDoneHandler delegate when the event PreTriggerBufferDoneEvent occurs. BufferDoneEventArgs contains the data that is associated with the event, including the subsystem that raised the event, the time stamp of when the event occurred, and the completed OlBuffer object.
Public class | BufferQueue | The BufferQueue class provides an interface for queuing OlBuffer objects to a device's subsystem for continuous I/O operations.
Public class | ChannelList | A ChannelList specifies a collection of ChannelListEntry objects for use in a continuous I/O operation. Each ChannelListEntry object encapsulates a physical channel connection for a specific subsystem.
Public class | ChannelListEntry | A ChannelListEntry object encapsulates a physical channel connection that is associated with a specific subsystem. A ChannelList object is a collection of ChannelListEntry objects.
Public class | Clock | The Clock class provides an interface for controlling the clock of a subsystem.
Public class | CounterTimerSubsystem | The CounterTimerSubsystem class provides the properties, methods, and events for performing counter/timer operations.
Public class | Device | A Device object encapsulates an Open Layers device and manages and distributes subsystems for the device.
Public class | DeviceMgr | The DeviceMgr is a singleton class that is responsible for managing Open Layers devices in the system and for assigning Device objects.
Public class | DigitalInputSubsystem | The DigitalInputSubsystem class provides the properties, methods, and events for performing digital input operations.
Public class | DigitalOutputSubsystem | The DigitalOutputSubsystem class provides the properties, methods, and events for performing digital output operations.
Public class | DriverRunTimeErrorEventArgs | A DriverRunTimeErrorEventArgs object is passed to the DriverRunTimeErrorEventHandler delegate when when the event DriverRunTimeErrorEvent occurs. DriverRunTimeErrorEventArgs contains the error/warning that is generated by the device driver, an error message that describes the error/warning, the subsystem that raised the event, and the time stamp of when the event occurred.
Public class | EventDoneEventArgs | An EventDoneEventArgs object is passed to the EventDoneHandler delegate when the event EventDoneEvent occurs. EventDoneEventArgs contains the data that is associated with the event EventDoneEvent, including the subsystem that raised the event and the time stamp of when the event occurred.
Public class | GeneralEventArgs | GeneralEventArgs is the base class for all event data. GeneralEventArgs contains the data that is passed to all events, including the subsystem that raised the event, and the time stamp of when the event occurred.
Public class | InterruptOnChangeEventArgs | An InterruptOnChangeEventArgs object is passed to the InterruptOnChangeHandler delegate when the event InterruptOnChangeEvent occurs. InterruptOnChangeEventArgs contains the data that is associated with the event InterruptOnChangeEvent, including the subsystem that raised the event, the time stamp of when the event occurred, the digital input lines that changed state, and the current state of the digital input port.
Public class | IOCompleteEventArgs | An IOCompleteEventArgs object is passed to the IOCompleteHandler delegate when the event IOCompleteEvent occurs. IOCompleteEventArgs contains the data associated with the event IOCompleteEvent. For analog input operations, this includes the total number of samples per channel that were acquired from the time acquisition was started to the last post-trigger sample, and the subsystem that raised the event. For analog output operations, this is the subsystem that raised the event.
Public class | MeasureDoneEventArgs | A MeasureDoneEventArgs object is passed to the MeasureDoneHandler delegate when the event MeasureDoneEvent occurs. MeasureDoneEventArgs contains the data that is associated with the event MeasureDoneEvent, including the subsystem that raised the event, the time stamp of when the event occurred, and the count.
Public class | MultiRecordAcquisition | The MultiRecordAcquisition class provides support for acquiring multiple records from the device.
Public class | OlBuffer | The OlBuffer class encapsulates a data buffer that is used in a continuous I/O operation.
Public class | OlError | An OlError object encapsulates an Open Layers error code.
Public class | OlException | The OlException class provides properites for handling Open Layers errors that can be generated by the library.
Public class | QuadratureDecoderSubsystem | The QuadratureDecoderSubsystem class provides the properties, methods, and events for performing quadrature decoder operations.
Public class | Range | This class is used by the VoltageRange and SupportedVoltageRanges methods to return the lower and upper limits of the voltage range for an analog subsystem.
Public class | ReferenceTrigger | The ReferenceTrigger class provides an interface for controlling the reference trigger of a subsystem. For devices that support a reference trigger, pre-trigger data acquisition stops and post-trigger acquisition starts when the reference trigger event occurs. Post-trigger acquisition stops when the number of samples you specify for the post-trigger scan count has been reached.
Public class | SimultaneousStart | The SimultaneousStart class provides an interface for simultaneously starting multiple subsystems.
Public class | StrainGageTeds | The StrainGageTeds class provides the properties and methods that support TEDS for strain gages.
Public class | SubsystemBase | The SubsystemBase class is an abstract base class that is accessible from the following derived classes: AnalogSubsystem (and its derived classes AnalogInputSubsystem and AnalogOutputSubsystem), DigitalInputSubsystem, DigitalOutputSubsystem, CounterTimerSubsystem, and QuadratureDecoderSubsystem.
Public class | SupportedChannelInfo | The SupportedChannelInfo class describes a specific channel of a subsystem. You access a SupportedChannelInfo object using the SupportedChannels class.
Public class | SupportedChannels | The SupportedChannels class describes, through a collection of SupportedChannelInfo objects, the channels available for a particular subsystem.
Public class | TachSubsystem | The TachSubsystem class provides the properties, methods, and events for performing tachometer operations.
Public class | TedsBase | The TedsBase class is an abstract base class that is accessible from the following derived classes: StrainGageTeds and BridgeSensorTeds.
Public class | Trigger | The Trigger class provides an interface for controlling how a subsystem is triggered. For devices that support a start trigger and a reference trigger, the Trigger class is used to set up the start trigger, which starts pre-trigger data acquisition. Use the ReferenceTrigger class to control the reference trigger.
Public class | TriggeredScan | The TriggeredScan class provides support for scanning the entries in a ChannelList a specified number of times when the device detects a specified retrigger.
Public class | Utility | The Utility class provides service-related properties and methods, allowing you to get information about assemblies and to convert data from raw counts to voltage and from voltage to raw counts.

Structures

 | Structure | Description
Public structure | HardwareInfo | This structure is used by the GetHardwareInfo()()()() method to return information about a Open Layers-compliant device.
Public structure | SingleValuesInfoRaw | Used with SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]), specifies the analog output channel to update and the raw count value to output on that channel.
Public structure | SingleValuesInfoVolts | Used with SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][]), specifies the analog output channel to update and the voltage value to output on that channel.

Delegates

 | Delegate | Description
Public delegate | BufferDoneHandler | The BufferDoneHandler delegate is called when the event BufferDoneEvent occurs.
Public delegate | BufferReusedHandler | The BufferReusedHandler delegate is called when the event BufferReusedEvent occurs.
Public delegate | DeviceRemovedHandler | The DeviceRemovedHandler delegate is called when the event DeviceRemovedEvent occurs.
Public delegate | DriverRunTimeErrorEventHandler | The DriverRunTimeErrorEventHandler delegate is called when the DriverRunTimeErrorEvent occurs.
Public delegate | EventDoneHandler | The EventDoneHandler delegate is called when the event EventDoneEvent occurs.
Public delegate | GeneralFailureHandler | The GeneralFailureHandler delegate is called when the event GeneralFailureEvent occurs.
Public delegate | InterruptOnChangeHandler | The InterruptOnChangeHandler delegate is called when the event InterruptOnChangeEvent occurs.
Public delegate | IOCompleteHandler | The IOCompleteHandler delegate is called when the event IOCompleteEvent occurs.
Public delegate | MeasureDoneHandler | The MeasureDoneHandler delegate is called when the event MeasureDoneEvent occurs.
Public delegate | PreTriggerBufferDoneHandler | The PreTriggerBufferDoneHandler delegate is called when the event PreTriggerBufferDoneEvent occurs.
Public delegate | QueueDoneHandler | The QueueDoneHandler delegate is called when the event QueueDoneEvent occurs.
Public delegate | QueueStoppedHandler | The QueueStoppedHandler delegate is called when the event QueueStoppedEvent occurs.

Enumerations

 | Enumeration | Description
Public enumeration | BridgeConfiguration | Contains the possible values for the BridgeConfiguration property.
Public enumeration | CascadeMode | Contains the possible values for the CascadeMode property.
Public enumeration | ChannelDataType | Contains the possible values for the ChannelDataType parameter that is used by the RawDataFormat property.
Public enumeration | ChannelType | Contains the possible values for the ChannelType property.
Public enumeration | ClockSource | Contains the possible values for the Source property.
Public enumeration | CounterMode | Contains the possible values for the CounterMode property.
Public enumeration | CouplingType | Contains the possible values for the Coupling property.
Public enumeration | DataFilterType | Contains the possible values for the DataFilterType property in the AnalogInputSubsystem class.
Public enumeration | DataFlow | Contains the possible values for the DataFlow property.
Public enumeration | EdgeSelect | Contains the possible values for the EdgeSelect parameter of the StartEdge and StopEdge properties.
Public enumeration | EdgeType | Contains the possible values for the EdgeType property.
Public enumeration | Encoding | Contains the possible values for the SubsystemBase.Encoding and OlBuffer.Encoding properties, and for the Encoding parameter of the VoltsToRawValue(Double, Encoding, Double, Double, Int32) and RawValueToVolts(Int32, Encoding, Double, Double, Int32) methods.
Public enumeration | ErrorCode | Open Layers error codes that are accessible using an OlException object.
Public enumeration | ExcitationCurrentSource | Contains the possible values for the ExcitationCurrentSource property.
Public enumeration | ExcitationVoltageSource | Contains the possible values for the ExcitationVoltageSource property.
Public enumeration | GageType | Topology and rosette orientation of gage
Public enumeration | GateType | Contains the possible values for the GateType property.
Public enumeration | IOType | Contains the possible values for the IOType.
Public enumeration | OlBuffer..::..BufferState | Contains the possible values for the state of an OlBuffer object.
Public enumeration | PhysicalMeasurandUnits | Physical Measurand (Units)
Public enumeration | PowerSource | Contains the possible values for the PowerSource property.
Public enumeration | PulseType | Contains the possible values for the PulseType property.
Public enumeration | QuadratureIndexMode | Contains the possible values for the IndexMode property.
Public enumeration | ReferenceTriggerType | Contains the possible values for the TriggerType property.
Public enumeration | RTDType | Contains the possible values for the RTDType property in the SupportedChannelInfo class.
Public enumeration | SensorWiringConfiguration | Contains the possible values for the SensorWiringConfiguration property in the SupportedChannelInfo class.
Public enumeration | StrainGageBridgeConfiguration | Contains the possible values for the StrainGageBridgeConfiguration property.
Public enumeration | SubsystemBase..::..States | Returns the current state of the subsystem.
Public enumeration | SubsystemType | Contains the possible values for the SubsystemType property.
Public enumeration | SynchronizationModes | Contains the possible values for the SynchronizationMode property.
Public enumeration | TedsBridgeType | Bridge types as defined by TEDS.
Public enumeration | TedsTemplateId | An identification number at the beginning of each template that identifies the template.
Public enumeration | TemperatureFilterType | Obsolete enumeration. This enum have been deprecated and may not be supported in future versions of library. Use DataFilterType enum and DataFilterType property.
Public enumeration | TemperatureUnit | Contains the possible values for the tempUnit parameter that is used by the GetDataAsTemperatureByte(ChannelListEntry, TemperatureUnit, Int32) and GetDataAsTemperatureDouble(ChannelListEntry, TemperatureUnit) methods.
Public enumeration | ThermocoupleType | Contains the possible values for the ThermocoupleType property in the SupportedChannelInfo class.
Public enumeration | TriggerType | Contains the possible values for the TriggerType, PreTriggerSource, and RetriggerSource properties.

Send comments on this topic to Support@datx.com

Copyright © 2015 by Data Translation, Inc.


AnalogInputSubsystem Class

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Class
Members See Also Send Feedback
The AnalogInputSubsystem class provides the properties, methods, and events for performing analog input operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class AnalogInputSubsystem : AnalogSubsystem
Visual Basic
Public Class AnalogInputSubsystem
    Inherits AnalogSubsystem

Remarks

Instances of this class are created using the AnalogInputSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..AnalogSubsystem
OpenLayers.Base..::..AnalogInputSubsystem

See Also

AnalogInputSubsystem Members


AnalogInputSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Members
AnalogInputSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | AnalogInputSubsystem | Returns an AnalogInputSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the subsystem immediately without waiting for the current buffer to be filled. (Overrides SubsystemBase..::..Abort()()()().)
Public method | AutoCalibrate | Calibrates the subsystem through software, performing an auto-zero function.
Public method | Config | Configures the subsystem based on the current property settings. (Overrides SubsystemBase..::..Config()()()().)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOneBuffer | Using continuous acquisition, acquires a buffer of data NumberOfSample long from the specified channel. This method uses the current clock frequency, trigger, etc., for the acquisition. This method is synchronous and returns only after the requested data has been acquired or a calculated timeout value has been exceeded.
Public method | GetSingleCjcValueAsTemperature | For subsystems that support thermocouples (SupportsThermocouple is True) and can return data as floating-point values (ReturnsFloats is True), acquires the CJC temperature for the specified input channel, and returns the CJC temperature, in the units you specify, as a floating-point value.
Public method | GetSingleCjcValuesAsTemperature | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), supports thermocouples (SupportsThermocouple is True), and supports that ability to return data as floating-point values (ReturnsFloats is True), acquires the CJC temperature for each input channel on the subsystem, and returns the CJC temperatures, in the units you specify, as floating-point values.
Public method | GetSingleValueAsBridgeBasedSensor | For subsystems that support SupportsBridgeBasedSensors, acquires a single value from a bridge-based sensor, and returns a value in the engineering units of the sensor based on its SupportedChannelInfo.
Public method | GetSingleValueAsCurrent | For subsystems that support current measurements (SupportsCurrent is True), acquires a single current value from the specified analog input channel, and returns the current measurement as a floating-point value, in amperes.
Public method | GetSingleValueAsNormalizedBridgeOutput | For subsystems that support SupportsBridgeBasedSensors, acquires a single value from the channel and returns the nominal value, in mV/V, based on its SupportedChannelInfo.
Public method | GetSingleValueAsRaw | Acquires a single value from an analog input channel and returns it in raw counts.
Public method | GetSingleValueAsResistance | For subsystems that support resistance measurements (SupportsResistance is True), acquires a single resistance value from the specified analog input channel, and returns the resistance as a floating-point value, in ohms.
Public method | GetSingleValueAsSensor | Acquires a single value from an analog input channel and returns it in the engineering units of the specified sensor.
Public method | GetSingleValueAsStrain | For subsystems that support strain gage measurements (SupportsStrainGage is True), acquires a single microstrain value from the channel based on its SupportedChannelInfo.
Public method | GetSingleValueAsTemperature(Int32, ThermocoupleType, TemperatureUnit) | For subsystems that support thermocouples (SupportsThermocouple is True), acquires a single temperature value from an analog input channel using the specified thermocouple type and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsTemperature(Int32, RTDType, SensorWiringConfiguration, Double, TemperatureUnit) | For subsystems that support RTDs (SupportsRTD is True), acquires a single temperature value from an analog input channel using the specified RTD type, R0 coefficient, sensor wiring configuration, and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsTemperature(Int32, SensorWiringConfiguration, Double, Double, Double, TemperatureUnit) | For subsystems that support thermistors (SupportsThermistor is True), acquires a single temperature value from the specified analog input channel based on the specified wiring configuration, A, B, and C coefficients, and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsVolts | Acquires a single value from an analog input channel and returns the data in voltage.
Public method | GetSingleValuesAsBridgeBasedSensor | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and bridge-based measurements (SupportsBridgeBasedSensors is True), simultaneously acquires a single value from each channel and returns an array of values based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsCurrent | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and current measurements (SupportsCurrent is True), simultaneously acquires a single value from each channel and returns an array of values (in amperes) based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsNormalizedBridgeOutput | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and bridge-based measurements (SupportsBridgeBasedSensors is True), simultaneously acquires a single value from each channel and returns an array of nominal values, in mV/V, based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsRaw | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each input channel and returns the data as an array of raw counts.
Public method | GetSingleValuesAsResistance | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and resistance measurements (SupportsResistance is True), simultaneously acquires a single value from each channel and returns an array of values (in ohms) based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsSensor | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each analog input channel and returns an array of values in the engineering units of the specified sensors.
Public method | GetSingleValuesAsStrain | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and strain gage measurements (SupportsStrainGage is True), simultaneously acquires a single value from each channel, and returns an array of microstrain values based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsTemperature | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and thermocouples (SupportsThermocouple is True), simultaneously acquires a single temperature value from each analog input channel and returns the data, in the units you specify, as an array of floating-point values based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsVolts | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each analog input channel and returns the data as an array of voltages based on each channel's SupportedChannelInfo.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveFromBufferInprocess | Moves samples from the OlBuffer object that is currently being filled into a new OlBuffer object.
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous operation on the analog input subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog input subsystem after the current buffer has been filled. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog input subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFilterType | For devices, like the TEMPpoint and VOLTpoint instruments that support programmable filter types for measuring temperature, gets and sets the filter type.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | ExcitationVoltageSource | Gets and sets the ExcitationVoltageSource to apply to the subsystem.
Public property | ExcitationVoltageValue | Gets and sets the value of the internal excitation voltage that is applied across the bridge for each channel of the subsystem.
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxExcitationVoltageValue | Returns the maximum allowable excitation voltage that is supported by the subsystem if the ExcitationVoltageSource property is set to Internal.
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MinExcitationVoltageValue | Returns the minimum allowable excitation voltage that is supported by the subsystem if the ExcitationVoltageSource property is set to Internal.
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnCjcTemperaturesInStream | Enables or disables the subsystem from returning CJC values in the data stream.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedExcitationCurrentValues | Returns an array containing the available values for the internal excitation current source.
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsACCoupling | Returns True if the subsystem supports AC coupling, where the DC offset is removed; otherwise, returns False.
Public property | SupportsAutoCalibrate | Returns True if the subsystem supports auto-calibration; otherwise, returns False.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBridgeBasedSensors | Returns True if the subsystem supports bridge-based sensors or general-purpose bridge measurements; otherwise, returns False.
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCjcSourceChannel | Returns True if the subsystem supports channels that are used for cold junction compensation (CJC); otherwise, returns False.
Public property | SupportsCjcSourceInternal | Returns True if the subsystem supports a CJC (cold junction compensation) source that is internal to the hardware; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrent | Returns True if the subsystem supports current measurements; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDataFilters | Returns True if the subsystem supports programmable filter types; otherwise, returns False.
Public property | SupportsDCCoupling | Returns True if the subsystem supports DC coupling, where the DC offset is included; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsExternalExcitationCurrentSrc | Returns True if the subsystem supports an external excitation current source; otherwise, returns False.
Public property | SupportsExternalExcitationVoltageSrc | Returns True if the subsystem supports an external excitation voltage source; otherwise, returns False.
Public property | SupportsIepe | Returns True if the subsystem supports IEPE (accelerometer) inputs; otherwise, returns False.
Public property | SupportsInProcessFlush | Returns True if the subsystem allows you to move data from the current OlBuffer object while it is being filled; otherwise, returns False.
Public property | SupportsInterleavedCjcTemperaturesInStream | (Has meaning only if SupportsTemperatureDataInStream is True.) Returns True if the device can optionally interleave CJC temperature data with A/D data (either voltage or temperature depending on the ThermocoupleType), in the data stream; otherwise, returns False.
Public property | SupportsInternalExcitationCurrentSrc | Returns True if the subsystem supports an internal excitation current source; otherwise, returns False.
Public property | SupportsInternalExcitationVoltageSrc | Returns True if the subsystem supports an internal excitation voltage source; otherwise, returns False.
Public property | SupportsMultiRecordAcquisition | Returns True if the subsystem supports multi-record acquisition; otherwise, returns False.
Public property | SupportsMultiSensor | Returns True if the subsystem supports reading data from multiple sensor types; otherwise, returns False.
Public property | SupportsPerChannelVoltageExcitation | Returns True if the device supports setting the voltage excitation source and/or value per channel; otherwise, returns False if the voltage excitation source/value must be set for the subsystem.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsRemoteSense | Returns True if the subsystem supports the use of remote sense leads; otherwise, returns False.
Public property | SupportsResistance | Returns True if the subsystem supports resistance measurements; otherwise, returns False.
Public property | SupportsRTD | Returns True if the subsystem supports RTD inputs; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousSampleHold | Returns True if the subsystem supports acquisition on all channels simultaneously; otherwise, returns False.
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsStrainGage | Returns True if the subsystem supports strain gage measurements; otherwise, returns False.
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTemperatureDataInStream | Returns True if the subsystem supports temperature conversions in hardware, returning temperature data in the stream; otherwise, returns False.
Public property | SupportsTemperatureFilters | Obsolete property. This property have been deprecated and may not be supported in future versions of library. Use SupportsDataFilters instead.
Public property | SupportsThermistor | Returns True if the subsystem supports thermistor inputs; otherwise, returns False.
Public property | SupportsThermocouple | Returns True if the subsystem supports thermocouple inputs; otherwise, returns False.
Public property | SupportsTriggeredScan | Returns True if the subsystem supports triggered scan operations; otherwise, returns False.
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | TemperatureFilterType | Obsolete property. This property have been deprecated and may not be supported in future versions of library. Use DataFilterType.
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | TriggeredScan | Provides an interface to the TriggeredScan object for the analog input subsystem.
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | PreTriggerBufferDoneEvent | Occurs when the OlBuffer object is filled with pre-trigger data (for an analog input operation only).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogInputSubsystem Class


AnalogInputSubsystem Constructor

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Constructor
AnalogInputSubsystem Class See Also Send Feedback
Returns an AnalogInputSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogInputSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.Base..::..Device
The Open Layers Device object with which to associate the analog input subsystem.
element
Type: System..::..Int32
The Element number of the analog input subsystem.

Remarks

It is recommended that you use the AnalogInputSubsystem(Int32) method rather than this constructor to return an analog input subsystem.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Methods
AnalogInputSubsystem Class See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the subsystem immediately without waiting for the current buffer to be filled. (Overrides SubsystemBase..::..Abort()()()().)
Public method | AutoCalibrate | Calibrates the subsystem through software, performing an auto-zero function.
Public method | Config | Configures the subsystem based on the current property settings. (Overrides SubsystemBase..::..Config()()()().)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOneBuffer | Using continuous acquisition, acquires a buffer of data NumberOfSample long from the specified channel. This method uses the current clock frequency, trigger, etc., for the acquisition. This method is synchronous and returns only after the requested data has been acquired or a calculated timeout value has been exceeded.
Public method | GetSingleCjcValueAsTemperature | For subsystems that support thermocouples (SupportsThermocouple is True) and can return data as floating-point values (ReturnsFloats is True), acquires the CJC temperature for the specified input channel, and returns the CJC temperature, in the units you specify, as a floating-point value.
Public method | GetSingleCjcValuesAsTemperature | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), supports thermocouples (SupportsThermocouple is True), and supports that ability to return data as floating-point values (ReturnsFloats is True), acquires the CJC temperature for each input channel on the subsystem, and returns the CJC temperatures, in the units you specify, as floating-point values.
Public method | GetSingleValueAsBridgeBasedSensor | For subsystems that support SupportsBridgeBasedSensors, acquires a single value from a bridge-based sensor, and returns a value in the engineering units of the sensor based on its SupportedChannelInfo.
Public method | GetSingleValueAsCurrent | For subsystems that support current measurements (SupportsCurrent is True), acquires a single current value from the specified analog input channel, and returns the current measurement as a floating-point value, in amperes.
Public method | GetSingleValueAsNormalizedBridgeOutput | For subsystems that support SupportsBridgeBasedSensors, acquires a single value from the channel and returns the nominal value, in mV/V, based on its SupportedChannelInfo.
Public method | GetSingleValueAsRaw | Acquires a single value from an analog input channel and returns it in raw counts.
Public method | GetSingleValueAsResistance | For subsystems that support resistance measurements (SupportsResistance is True), acquires a single resistance value from the specified analog input channel, and returns the resistance as a floating-point value, in ohms.
Public method | GetSingleValueAsSensor | Acquires a single value from an analog input channel and returns it in the engineering units of the specified sensor.
Public method | GetSingleValueAsStrain | For subsystems that support strain gage measurements (SupportsStrainGage is True), acquires a single microstrain value from the channel based on its SupportedChannelInfo.
Public method | GetSingleValueAsTemperature(Int32, ThermocoupleType, TemperatureUnit) | For subsystems that support thermocouples (SupportsThermocouple is True), acquires a single temperature value from an analog input channel using the specified thermocouple type and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsTemperature(Int32, RTDType, SensorWiringConfiguration, Double, TemperatureUnit) | For subsystems that support RTDs (SupportsRTD is True), acquires a single temperature value from an analog input channel using the specified RTD type, R0 coefficient, sensor wiring configuration, and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsTemperature(Int32, SensorWiringConfiguration, Double, Double, Double, TemperatureUnit) | For subsystems that support thermistors (SupportsThermistor is True), acquires a single temperature value from the specified analog input channel based on the specified wiring configuration, A, B, and C coefficients, and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsVolts | Acquires a single value from an analog input channel and returns the data in voltage.
Public method | GetSingleValuesAsBridgeBasedSensor | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and bridge-based measurements (SupportsBridgeBasedSensors is True), simultaneously acquires a single value from each channel and returns an array of values based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsCurrent | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and current measurements (SupportsCurrent is True), simultaneously acquires a single value from each channel and returns an array of values (in amperes) based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsNormalizedBridgeOutput | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and bridge-based measurements (SupportsBridgeBasedSensors is True), simultaneously acquires a single value from each channel and returns an array of nominal values, in mV/V, based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsRaw | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each input channel and returns the data as an array of raw counts.
Public method | GetSingleValuesAsResistance | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and resistance measurements (SupportsResistance is True), simultaneously acquires a single value from each channel and returns an array of values (in ohms) based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsSensor | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each analog input channel and returns an array of values in the engineering units of the specified sensors.
Public method | GetSingleValuesAsStrain | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and strain gage measurements (SupportsStrainGage is True), simultaneously acquires a single value from each channel, and returns an array of microstrain values based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsTemperature | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and thermocouples (SupportsThermocouple is True), simultaneously acquires a single temperature value from each analog input channel and returns the data, in the units you specify, as an array of floating-point values based on each channel's SupportedChannelInfo.
Public method | GetSingleValuesAsVolts | For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each analog input channel and returns the data as an array of voltages based on each channel's SupportedChannelInfo.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveFromBufferInprocess | Moves samples from the OlBuffer object that is currently being filled into a new OlBuffer object.
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous operation on the analog input subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog input subsystem after the current buffer has been filled. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog input subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

See Also

AnalogInputSubsystem Class


AnalogInputSubsystem.Abort Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..Abort Method
AnalogInputSubsystem Class See Also Send Feedback
Stops a continuous operation on the subsystem immediately without waiting for the current buffer to be filled.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Abort()
Visual Basic
Public Overrides Sub Abort

Remarks

This method overrides the Abort method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.AutoCalibrate Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..AutoCalibrate Method
AnalogInputSubsystem Class See Also Send Feedback
Calibrates the subsystem through software, performing an auto-zero function.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void AutoCalibrate()
Visual Basic
Public Sub AutoCalibrate

Remarks

To determine if the specified subsystem supports this capability, use the SupportsAutoCalibrate property. If this property returns a value of True, the subsystem can be calibrated through software. Ensure that the subsystem is not running when you call this method, or an error is returned.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.Config Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..Config Method
AnalogInputSubsystem Class See Also Send Feedback
Configures the subsystem based on the current property settings.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Config()
Visual Basic
Public Overrides Sub Config

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetOneBuffer Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetOneBuffer Method
AnalogInputSubsystem Class See Also Send Feedback
Using continuous acquisition, acquires a buffer of data NumberOfSample long from the specified channel. This method uses the current clock frequency, trigger, etc., for the acquisition. This method is synchronous and returns only after the requested data has been acquired or a calculated timeout value has been exceeded.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer GetOneBuffer(
    SupportedChannelInfo ChannelInfo,
    int NumberOfSamples,
    int TimeoutMSecs
)
Visual Basic
Public Function GetOneBuffer (
    ChannelInfo As SupportedChannelInfo,
    NumberOfSamples As Integer,
    TimeoutMSecs As Integer
) As OlBuffer

Parameters

ChannelInfo
Type: OpenLayers.Base..::..SupportedChannelInfo
ChannelListEntry object, which represents the channel from which to acquire data.
NumberOfSamples
Type: System..::..Int32
Number of samples to acquire
TimeoutMSecs
Type: System..::..Int32
Timeout value, in milliseconds, to wait for buffer completion. A value of -1 means the timeout is infinite.

Return Value

Type: OlBuffer
An OlBuffer object with the specified number of samples.

Remarks

This method allocates a buffer and starts the continuous analog input operation automatically using the current configuration of the analog input subsystem. This method is synchronous and returns only after the requested data has been acquired or the specified timeout value, in milliseconds, has been exceeded. No BufferDoneEvents occur. If the buffer is not filled before the specified timeout value is exceeded, AnalogInputSubsystem.Abort is called and a TimeoutException is raised. If a GeneralFailureEvent or DriverRuntimeErrorEvent occurs during acquisition, an OlException with the appropriate error code is raised. Once the buffer is returned, you can copy the data from the buffer into an array using the OlBuffer methods.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleCjcValueAsTemperature Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleCjcValueAsTemperature Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support thermocouples (SupportsThermocouple is True) and can return data as floating-point values (ReturnsFloats is True), acquires the CJC temperature for the specified input channel, and returns the CJC temperature, in the units you specify, as a floating-point value.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleCjcValueAsTemperature(
    int physicalChannel,
    TemperatureUnit tempUnit
)
Visual Basic
Public Function GetSingleCjcValueAsTemperature (
    physicalChannel As Integer,
    tempUnit As TemperatureUnit
) As Double

Parameters

physicalChannel
Type: System..::..Int32
The physical analog input channel to sample.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The TemperatureUnit of the CJC value that is returned.

Return Value

Type: Double
The CJC temperature of the specified input channel, in the units you specified. This temperature is represented as a floating-point (double) value.

Remarks

This function is seldom needed. It is provided in the rare case when you want to implement your own temperature conversion algorithms in software based on the CJC temperature. To use this function, the subsystem must be configured for a single value operation.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleCjcValuesAsTemperature Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleCjcValuesAsTemperature Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), supports thermocouples (SupportsThermocouple is True), and supports that ability to return data as floating-point values (ReturnsFloats is True), acquires the CJC temperature for each input channel on the subsystem, and returns the CJC temperatures, in the units you specify, as floating-point values.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleCjcValuesAsTemperature(
    TemperatureUnit tempUnit
)
Visual Basic
Public Function GetSingleCjcValuesAsTemperature (
    tempUnit As TemperatureUnit
) As Double()

Parameters

tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The TemperatureUnit of the CJC values that are returned.

Return Value

Type: array<Double>[]()[][]
The CJC temperature of each input channel, in the units you specified. These temperatures are represented as floating-point (double) values.

Remarks

This function is seldom needed. It is provided in the rare case when you want to implement your own temperature conversion algorithms in software based on the CJC values. To use this function, the subsystem must be configured for a single value operation. Refer to your driver documentation for more information.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsBridgeBasedSensor Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsBridgeBasedSensor Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support SupportsBridgeBasedSensors, acquires a single value from a bridge-based sensor, and returns a value in the engineering units of the sensor based on its SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsBridgeBasedSensor(
    int physicalChannel
)
Visual Basic
Public Function GetSingleValueAsBridgeBasedSensor (
    physicalChannel As Integer
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.

Return Value

Type: Double
Value, in engineering units, of the bridge-based sensor that is connected to specified channel.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for Bridge measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsCurrent Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsCurrent Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support current measurements (SupportsCurrent is True), acquires a single current value from the specified analog input channel, and returns the current measurement as a floating-point value, in amperes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsCurrent(
    int physicalChannel
)
Visual Basic
Public Function GetSingleValueAsCurrent (
    physicalChannel As Integer
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.

Return Value

Type: Double
The current value of the specified input channel, in amperes, represented as a floating-point value.

Remarks

When the channel is configured for a current measurement, a built-in resistor is switched in across the channel input terminals. Refer to the user's manual for your device to determine the value of the built-in resistor across the channel input terminals, and to determine the maximum current value that can be measured.

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for Current measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsNormalizedBridgeOutput Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsNormalizedBridgeOutput Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support SupportsBridgeBasedSensors, acquires a single value from the channel and returns the nominal value, in mV/V, based on its SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsNormalizedBridgeOutput(
    int physicalChannel
)
Visual Basic
Public Function GetSingleValueAsNormalizedBridgeOutput (
    physicalChannel As Integer
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.

Return Value

Type: Double
The nominal value, in mV/V, from bridge that is connected to the specified channel.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for Bridge measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsRaw Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsRaw Method
AnalogInputSubsystem Class Example See Also Send Feedback
Acquires a single value from an analog input channel and returns it in raw counts.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int GetSingleValueAsRaw(
    int physicalChannel,
    double gain
)
Visual Basic
Public Function GetSingleValueAsRaw (
    physicalChannel As Integer,
    gain As Double
) As Integer

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.
gain
Type: System..::..Double
Gain to apply to the input signal.

Return Value

Type: Int32
The analog input value in raw counts.

Examples

This example shows a typical use of GetSingleValueAsRaw.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object for element 0.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
ainSS.Config ();
// Acquire a single value from analog input channel 0, apply a gain
// of 1 to the input, and return the data in raw counts.
int rawCount = ainSS.GetSingleValueAsRaw (0,1.0);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
ainSS.Config()
' Acquire a single value from analog input channel 0, apply a gain of 1
' to the input, and return the data in raw counts.
Dim rawValue As Integer = ainSS.GetSingleValueAsRaw(0, 1)

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsResistance Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsResistance Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support resistance measurements (SupportsResistance is True), acquires a single resistance value from the specified analog input channel, and returns the resistance as a floating-point value, in ohms.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsResistance(
    int physicalChannel
)
Visual Basic
Public Function GetSingleValueAsResistance (
    physicalChannel As Integer
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.

Return Value

Type: Double
The resistance value of the specified input channel, in ohms, represented as a floating-point value.

Remarks

The resistance measurement depends on the excitation current setting. See your hardware manual for setting the current source and current value. If the hardware supports more than one current source, use ExcitationCurrentSource propety to set the current source. If the hardware supports internal current Source, use SupportedExcitationCurrentValues to determine the available current values and set ExcitationCurrentValue property to one of the available current values.

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for Resistance measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsSensor Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsSensor Method
AnalogInputSubsystem Class Example See Also Send Feedback
Acquires a single value from an analog input channel and returns it in the engineering units of the specified sensor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsSensor(
    int physicalChannel,
    double gain,
    double sensorGain,
    double sensorOffset
)
Visual Basic
Public Function GetSingleValueAsSensor (
    physicalChannel As Integer,
    gain As Double,
    sensorGain As Double,
    sensorOffset As Double
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.
gain
Type: System..::..Double
Gain to apply to the input signal to get the prescaled voltage value.
sensorGain
Type: System..::..Double
Sensor gain value to apply to the prescaled voltage value. The default value is 1.
sensorOffset
Type: System..::..Double
Sensor offset value to apply to the prescaled voltage value. The default value is 0.

Return Value

Type: Double
The scaled value in the engineering units of the sensor.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for VoltageIn using the MultiSensorType property before calling this method.

The sensor gain and offset are used to scale a sample from raw counts to a sensor format. The scaling occurs in two steps. First, the raw count value is acquired and converted to prescaled voltage using the gain applied to the channel. Then, the sensor gain and sensor offset parameters are applied to the prescaled voltage value using the linear equation y = mx + b, where y is the sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

Examples

This example shows a typical use of GetSingleValueAsSensor.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object for element 0.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
ainSS.Config ();
// Acquire a single value from analog input channel 0, apply a gain of 1
// to the input, and return the data in the engineering units of the
// sensor using a sensor gain of 100 and an offset of 2.
double sensorValue = ainSS.GetSingleValueAsSensor (0,1.0,100,2);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
ainSS.Config()
' Acquire a single value from analog input channel 0, apply a gain of 1
' to the input, and return the data in the engineering units of the
' sensor using a sensor gain of 100 and an offset of 2.
Dim sensorValue As Double = ainSS.GetSingleValueAsSensor(0, 1.0, 100, 2)

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsStrain Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsStrain Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support strain gage measurements (SupportsStrainGage is True), acquires a single microstrain value from the channel based on its SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsStrain(
    int physicalChannel
)
Visual Basic
Public Function GetSingleValueAsStrain (
    physicalChannel As Integer
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.

Return Value

Type: Double
Microstrain value from the strain gage that is connected to the specified channel.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for StrainGage measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsTemperature Method

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsTemperature Method
AnalogInputSubsystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSingleValueAsTemperature(Int32, ThermocoupleType, TemperatureUnit) | For subsystems that support thermocouples (SupportsThermocouple is True), acquires a single temperature value from an analog input channel using the specified thermocouple type and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsTemperature(Int32, RTDType, SensorWiringConfiguration, Double, TemperatureUnit) | For subsystems that support RTDs (SupportsRTD is True), acquires a single temperature value from an analog input channel using the specified RTD type, R0 coefficient, sensor wiring configuration, and temperature unit, and returns the temperature as a floating-point value.
Public method | GetSingleValueAsTemperature(Int32, SensorWiringConfiguration, Double, Double, Double, TemperatureUnit) | For subsystems that support thermistors (SupportsThermistor is True), acquires a single temperature value from the specified analog input channel based on the specified wiring configuration, A, B, and C coefficients, and temperature unit, and returns the temperature as a floating-point value.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValueAsTemperature Method (Int32, ThermocoupleType, TemperatureUnit)

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsTemperature Method (Int32, ThermocoupleType, TemperatureUnit)
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support thermocouples (SupportsThermocouple is True), acquires a single temperature value from an analog input channel using the specified thermocouple type and temperature unit, and returns the temperature as a floating-point value.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsTemperature(
    int physicalChannel,
    ThermocoupleType thermocoupleType,
    TemperatureUnit tempUnit
)
Visual Basic
Public Function GetSingleValueAsTemperature (
    physicalChannel As Integer,
    thermocoupleType As ThermocoupleType,
    tempUnit As TemperatureUnit
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.
thermocoupleType
Type: OpenLayers.Base..::..ThermocoupleType
The ThermocoupleType that is connected to the specified physical channel.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The TemperatureUnit for the specified thermocouple type.

Return Value

Type: Double
The temperature of the specified input channel, in the specified units, represented as a floating-point value.

Remarks

A temperature value is returned only if the specified channel is configured for a ThermocoupleType other than None. If the channel is configured for a ThermocoupleType of None, an exception is raised.

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for Thermocouple measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
GetSingleValueAsTemperature Overload


AnalogInputSubsystem.GetSingleValueAsTemperature Method (Int32, RTDType, SensorWiringConfiguration, Double, TemperatureUnit)

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsTemperature Method (Int32, RTDType, SensorWiringConfiguration, Double, TemperatureUnit)
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support RTDs (SupportsRTD is True), acquires a single temperature value from an analog input channel using the specified RTD type, R0 coefficient, sensor wiring configuration, and temperature unit, and returns the temperature as a floating-point value.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsTemperature(
    int physicalChannel,
    RTDType rtdType,
    SensorWiringConfiguration sensorWiringConfiguration,
    double RtdR0,
    TemperatureUnit tempUnit
)
Visual Basic
Public Function GetSingleValueAsTemperature (
    physicalChannel As Integer,
    rtdType As RTDType,
    sensorWiringConfiguration As SensorWiringConfiguration,
    RtdR0 As Double,
    tempUnit As TemperatureUnit
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.
rtdType
Type: OpenLayers.Base..::..RTDType
The RTDType that is connected to the specified physical channel.
sensorWiringConfiguration
Type: OpenLayers.Base..::..SensorWiringConfiguration
The SensorWiringConfiguration that was used to connect the RTD to the specified physical channel.
RtdR0
Type: System..::..Double
The nominal resistance (RtdR0) of the RTD at zero degrees C.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The TemperatureUnit for the specified RTD.

Return Value

Type: Double
The temperature of the specified input channel, in the specified units, represented as a floating-point value.

Remarks

If the value of the rtdType parameter is set to Custom, you must set the RtdR0, RtdACoefficient, RtdBCoefficient, and RtdCCoefficient properties of the SupportedChannelInfo to supply the coefficients for the Callendar-Van Dusen transfer function. Otherwise, the values that were stored internally for the RtdACoefficient, RtdBCoefficient, and RtdCCoefficient properties are used, based on the value of the rtdType parameter.

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for Rtd measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
GetSingleValueAsTemperature Overload


AnalogInputSubsystem.GetSingleValueAsTemperature Method (Int32, SensorWiringConfiguration, Double, Double, Double, TemperatureUnit)

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsTemperature Method (Int32, SensorWiringConfiguration, Double, Double, Double, TemperatureUnit)
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support thermistors (SupportsThermistor is True), acquires a single temperature value from the specified analog input channel based on the specified wiring configuration, A, B, and C coefficients, and temperature unit, and returns the temperature as a floating-point value.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsTemperature(
    int physicalChannel,
    SensorWiringConfiguration sensorWiringConfiguration,
    double thermistorACoefficient,
    double thermistorBCoefficient,
    double thermistorCCoefficient,
    TemperatureUnit tempUnit
)
Visual Basic
Public Function GetSingleValueAsTemperature (
    physicalChannel As Integer,
    sensorWiringConfiguration As SensorWiringConfiguration,
    thermistorACoefficient As Double,
    thermistorBCoefficient As Double,
    thermistorCCoefficient As Double,
    tempUnit As TemperatureUnit
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.
sensorWiringConfiguration
Type: OpenLayers.Base..::..SensorWiringConfiguration
The SensorWiringConfiguration that is used to connect the thermistor to the specified physical channel.
thermistorACoefficient
Type: System..::..Double
The A coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
thermistorBCoefficient
Type: System..::..Double
The B coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
thermistorCCoefficient
Type: System..::..Double
The C coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The TemperatureUnit for the specified thermistor.

Return Value

Type: Double
The temperature of the specified input channel, in the specified units, represented as a floating-point value.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for Thermistor measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
GetSingleValueAsTemperature Overload


AnalogInputSubsystem.GetSingleValueAsVolts Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsVolts Method
AnalogInputSubsystem Class Example See Also Send Feedback
Acquires a single value from an analog input channel and returns the data in voltage.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsVolts(
    int physicalChannel,
    double gain
)
Visual Basic
Public Function GetSingleValueAsVolts (
    physicalChannel As Integer,
    gain As Double
) As Double

Parameters

physicalChannel
Type: System..::..Int32
The physical analog input channel to sample.
gain
Type: System..::..Double
The gain to apply to the input signal.

Return Value

Type: Double
The acquired value in voltage.

Remarks

For subsystems that support thermocouples (SupportsThermocouple is True), a voltage value is returned only if the specified channel is configured for a ThermocoupleType of None. If the channel is configured for any other ThermocoupleType, an exception is raised.

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that the channel is configured for VoltageIn using the MultiSensorType property before calling this method.

Examples

This example shows a typical use of GetSingleValueAsVolts.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object for element 0.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
ainSS.Config ();
// Acquire a value from analog input channel 0 using a gain of 1, and
// return the data in voltage.
double valueInVolts = ainSS.GetSingleValueAsVolts (0,1.0);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
ainSS.Config()
' Acquire a value from analog input channel 0 using a gain of 1, and
' return the data in voltage.
Dim voltageValue As Double = ainSS.GetSingleValueAsVolts(0, 1)

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsBridgeBasedSensor Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsBridgeBasedSensor Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and bridge-based measurements (SupportsBridgeBasedSensors is True), simultaneously acquires a single value from each channel and returns an array of values based on each channel's SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsBridgeBasedSensor()
Visual Basic
Public Function GetSingleValuesAsBridgeBasedSensor As Double()

Return Value

Type: array<Double>[]()[][]
Array of values in the engineering units of the bridge-based sensor.

Remarks

This method can be used only on subsystems that support simultaneous acquisition.

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that each channel is configured for Bridge measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsCurrent Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsCurrent Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and current measurements (SupportsCurrent is True), simultaneously acquires a single value from each channel and returns an array of values (in amperes) based on each channel's SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsCurrent()
Visual Basic
Public Function GetSingleValuesAsCurrent As Double()

Return Value

Type: array<Double>[]()[][]
Array of current measurement values, in amperes.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that each channel is configured for Current measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsNormalizedBridgeOutput Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsNormalizedBridgeOutput Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and bridge-based measurements (SupportsBridgeBasedSensors is True), simultaneously acquires a single value from each channel and returns an array of nominal values, in mV/V, based on each channel's SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsNormalizedBridgeOutput()
Visual Basic
Public Function GetSingleValuesAsNormalizedBridgeOutput As Double()

Return Value

Type: array<Double>[]()[][]
Array of nominal values, in mV/V.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that each channel is configured for Bridge measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsRaw Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsRaw Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each input channel and returns the data as an array of raw counts.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int[] GetSingleValuesAsRaw(
    double gain
)
Visual Basic
Public Function GetSingleValuesAsRaw (
    gain As Double
) As Integer()

Parameters

gain
Type: System..::..Double
Gain to apply to the input signal.

Return Value

Type: array<Int32>[]()[][]
An array of data values in raw counts. Each index item of the array corresponds to a channel index in the SupportedChannels collection for the analog input subsystem.

Remarks

If your device supports streaming digital inputs, counter/timers, and/or quadrature decoder inputs through the analog input subsystem, this method returns the data for all the analog input channels, digital input ports, counter/timer channels, and/or quadrature decoder channels. For meaningful digital input, counter/timer, and/or quadrature decoder data, ensure that you configure and/or start an operation on these subsystems before calling GetSingleValuesAsRaw.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsResistance Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsResistance Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and resistance measurements (SupportsResistance is True), simultaneously acquires a single value from each channel and returns an array of values (in ohms) based on each channel's SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsResistance()
Visual Basic
Public Function GetSingleValuesAsResistance As Double()

Return Value

Type: array<Double>[]()[][]
Array of resistance values, in ohms.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that each channel is configured for Resistance measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsSensor Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsSensor Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each analog input channel and returns an array of values in the engineering units of the specified sensors.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsSensor(
    double gain,
    double sensorGain,
    double sensorOffset
)
Visual Basic
Public Function GetSingleValuesAsSensor (
    gain As Double,
    sensorGain As Double,
    sensorOffset As Double
) As Double()

Parameters

gain
Type: System..::..Double
Gain to apply to the input signal.
sensorGain
Type: System..::..Double
Sensor gain value to apply to the prescaled voltage value.
sensorOffset
Type: System..::..Double
Sensor offset value to apply to the prescaled voltage value.

Return Value

Type: array<Double>[]()[][]
An array of scaled values in the engineering units of the sensor. Each index item of the array corresponds to a channel index in the SupportedChannels collection for the analog input subsystem.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that each channel is configured for VoltageIn measurements using the MultiSensorType property before calling this method.

The sensor gain and offset are used to scale a sample from raw counts to a sensor format. The scaling occurs in two steps. First, the raw count values are acquired and converted to prescaled voltages using the gain applied to the channels. Then, the sensor gain and sensor offset parameters are applied to the prescaled voltage values using the linear equation y = mx + b, where y is the sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsStrain Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsStrain Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and strain gage measurements (SupportsStrainGage is True), simultaneously acquires a single value from each channel, and returns an array of microstrain values based on each channel's SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsStrain()
Visual Basic
Public Function GetSingleValuesAsStrain As Double()

Return Value

Type: array<Double>[]()[][]
Array of microstrain values.

Remarks

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that each channel is configured for StrainGage measurements using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsTemperature Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsTemperature Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True) and thermocouples (SupportsThermocouple is True), simultaneously acquires a single temperature value from each analog input channel and returns the data, in the units you specify, as an array of floating-point values based on each channel's SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsTemperature(
    TemperatureUnit tempUnit
)
Visual Basic
Public Function GetSingleValuesAsTemperature (
    tempUnit As TemperatureUnit
) As Double()

Parameters

tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The TemperatureUnit of the temperature values that are returned.

Return Value

Type: array<Double>[]()[][]
The temperature value of each input channel, in the units you specified. The temperatures are represented as floating-point (double) values.

Remarks

For subsystems that support thermocouples (SupportsThermocouple is True), any channel that is configured for a ThermocoupleType of None returns a voltage value and any channel that is configured for any other ThermocoupleType returns a temperature value.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.GetSingleValuesAsVolts Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValuesAsVolts Method
AnalogInputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSimultaneousSampleHold is True), simultaneously acquires a single value from each analog input channel and returns the data as an array of voltages based on each channel's SupportedChannelInfo.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetSingleValuesAsVolts(
    double gain
)
Visual Basic
Public Function GetSingleValuesAsVolts (
    gain As Double
) As Double()

Parameters

gain
Type: System..::..Double
Gain to apply to the input signal.

Return Value

Type: array<Double>[]()[][]
An array of analog input values in voltage. Each index item of the array corresponds to a channel index in the SupportedChannels collection for the analog input subsystem.

Remarks

For subsystems that support thermocouples (SupportsThermocouple is True), any channel that is configured for a ThermocoupleType of None returns a voltage value and any channel that is configured for any other ThermocoupleType returns a temperature value.

If your device supports multiple sensor types for each channel (SupportsMultiSensor is True), ensure that each channel is configured for VoltageIn using the MultiSensorType property before calling this method.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.MoveFromBufferInprocess Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..MoveFromBufferInprocess Method
AnalogInputSubsystem Class See Also Send Feedback
Moves samples from the OlBuffer object that is currently being filled into a new OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void MoveFromBufferInprocess(
    OlBuffer dtBuffer,
    int numberOfSamples
)
Visual Basic
Public Sub MoveFromBufferInprocess (
    dtBuffer As OlBuffer,
    numberOfSamples As Integer
)

Parameters

dtBuffer
Type: OpenLayers.Base..::..OlBuffer
The name of the new OlBuffer object in which to copy the data from the OlBuffer object that is being filled.
numberOfSamples
Type: System..::..Int32
The number of samples to copy.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.Start Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..Start Method
AnalogInputSubsystem Class See Also Send Feedback
Starts a continuous operation on the analog input subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Start()
Visual Basic
Public Overrides Sub Start

Remarks

This method overrides the Start method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.Stop Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..Stop Method
AnalogInputSubsystem Class See Also Send Feedback
Stops a continuous operation on the analog input subsystem after the current buffer has been filled.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Stop()
Visual Basic
Public Overrides Sub Stop

Remarks

This method overrides the Stop method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..ToString Method
AnalogInputSubsystem Class See Also Send Feedback
Returns a description of the analog input subsystem and element.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the analog input subsystem and element.

Remarks

This method overrides the ToString method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Properties
AnalogInputSubsystem Class See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFilterType | For devices, like the TEMPpoint and VOLTpoint instruments that support programmable filter types for measuring temperature, gets and sets the filter type.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | ExcitationVoltageSource | Gets and sets the ExcitationVoltageSource to apply to the subsystem.
Public property | ExcitationVoltageValue | Gets and sets the value of the internal excitation voltage that is applied across the bridge for each channel of the subsystem.
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxExcitationVoltageValue | Returns the maximum allowable excitation voltage that is supported by the subsystem if the ExcitationVoltageSource property is set to Internal.
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MinExcitationVoltageValue | Returns the minimum allowable excitation voltage that is supported by the subsystem if the ExcitationVoltageSource property is set to Internal.
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnCjcTemperaturesInStream | Enables or disables the subsystem from returning CJC values in the data stream.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedExcitationCurrentValues | Returns an array containing the available values for the internal excitation current source.
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsACCoupling | Returns True if the subsystem supports AC coupling, where the DC offset is removed; otherwise, returns False.
Public property | SupportsAutoCalibrate | Returns True if the subsystem supports auto-calibration; otherwise, returns False.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBridgeBasedSensors | Returns True if the subsystem supports bridge-based sensors or general-purpose bridge measurements; otherwise, returns False.
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCjcSourceChannel | Returns True if the subsystem supports channels that are used for cold junction compensation (CJC); otherwise, returns False.
Public property | SupportsCjcSourceInternal | Returns True if the subsystem supports a CJC (cold junction compensation) source that is internal to the hardware; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrent | Returns True if the subsystem supports current measurements; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDataFilters | Returns True if the subsystem supports programmable filter types; otherwise, returns False.
Public property | SupportsDCCoupling | Returns True if the subsystem supports DC coupling, where the DC offset is included; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsExternalExcitationCurrentSrc | Returns True if the subsystem supports an external excitation current source; otherwise, returns False.
Public property | SupportsExternalExcitationVoltageSrc | Returns True if the subsystem supports an external excitation voltage source; otherwise, returns False.
Public property | SupportsIepe | Returns True if the subsystem supports IEPE (accelerometer) inputs; otherwise, returns False.
Public property | SupportsInProcessFlush | Returns True if the subsystem allows you to move data from the current OlBuffer object while it is being filled; otherwise, returns False.
Public property | SupportsInterleavedCjcTemperaturesInStream | (Has meaning only if SupportsTemperatureDataInStream is True.) Returns True if the device can optionally interleave CJC temperature data with A/D data (either voltage or temperature depending on the ThermocoupleType), in the data stream; otherwise, returns False.
Public property | SupportsInternalExcitationCurrentSrc | Returns True if the subsystem supports an internal excitation current source; otherwise, returns False.
Public property | SupportsInternalExcitationVoltageSrc | Returns True if the subsystem supports an internal excitation voltage source; otherwise, returns False.
Public property | SupportsMultiRecordAcquisition | Returns True if the subsystem supports multi-record acquisition; otherwise, returns False.
Public property | SupportsMultiSensor | Returns True if the subsystem supports reading data from multiple sensor types; otherwise, returns False.
Public property | SupportsPerChannelVoltageExcitation | Returns True if the device supports setting the voltage excitation source and/or value per channel; otherwise, returns False if the voltage excitation source/value must be set for the subsystem.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsRemoteSense | Returns True if the subsystem supports the use of remote sense leads; otherwise, returns False.
Public property | SupportsResistance | Returns True if the subsystem supports resistance measurements; otherwise, returns False.
Public property | SupportsRTD | Returns True if the subsystem supports RTD inputs; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousSampleHold | Returns True if the subsystem supports acquisition on all channels simultaneously; otherwise, returns False.
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsStrainGage | Returns True if the subsystem supports strain gage measurements; otherwise, returns False.
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTemperatureDataInStream | Returns True if the subsystem supports temperature conversions in hardware, returning temperature data in the stream; otherwise, returns False.
Public property | SupportsTemperatureFilters | Obsolete property. This property have been deprecated and may not be supported in future versions of library. Use SupportsDataFilters instead.
Public property | SupportsThermistor | Returns True if the subsystem supports thermistor inputs; otherwise, returns False.
Public property | SupportsThermocouple | Returns True if the subsystem supports thermocouple inputs; otherwise, returns False.
Public property | SupportsTriggeredScan | Returns True if the subsystem supports triggered scan operations; otherwise, returns False.
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | TemperatureFilterType | Obsolete property. This property have been deprecated and may not be supported in future versions of library. Use DataFilterType.
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | TriggeredScan | Provides an interface to the TriggeredScan object for the analog input subsystem.
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)

See Also

AnalogInputSubsystem Class


AnalogInputSubsystem.DataFilterType Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..DataFilterType Property
AnalogInputSubsystem Class See Also Send Feedback
For devices, like the TEMPpoint and VOLTpoint instruments that support programmable filter types for measuring temperature, gets and sets the filter type.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DataFilterType DataFilterType { get; set; }
Visual Basic
Public Property DataFilterType As DataFilterType
    Get
    Set

Property Value

Type: DataFilterType

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.ExcitationVoltageSource Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..ExcitationVoltageSource Property
AnalogInputSubsystem Class See Also Send Feedback
Gets and sets the ExcitationVoltageSource to apply to the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ExcitationVoltageSource ExcitationVoltageSource { get; set; }
Visual Basic
Public Property ExcitationVoltageSource As ExcitationVoltageSource
    Get
    Set

Property Value

Type: ExcitationVoltageSource

Remarks

By default, the excitation voltage source is disabled for the subsystem.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.ExcitationVoltageValue Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..ExcitationVoltageValue Property
AnalogInputSubsystem Class See Also Send Feedback
Gets and sets the value of the internal excitation voltage that is applied across the bridge for each channel of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ExcitationVoltageValue { get; set; }
Visual Basic
Public Property ExcitationVoltageValue As Double
    Get
    Set

Property Value

Type: Double

Remarks

This value is applicable only when the ExcitationVoltageSource property is set to Internal.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.MaxExcitationVoltageValue Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..MaxExcitationVoltageValue Property
AnalogInputSubsystem Class See Also Send Feedback
Returns the maximum allowable excitation voltage that is supported by the subsystem if the ExcitationVoltageSource property is set to Internal.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaxExcitationVoltageValue { get; }
Visual Basic
Public ReadOnly Property MaxExcitationVoltageValue As Double
    Get

Property Value

Type: Double

Remarks

Set the excitation voltage source to Internal using the ExcitationVoltageSource property.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.MinExcitationVoltageValue Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..MinExcitationVoltageValue Property
AnalogInputSubsystem Class See Also Send Feedback
Returns the minimum allowable excitation voltage that is supported by the subsystem if the ExcitationVoltageSource property is set to Internal.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MinExcitationVoltageValue { get; }
Visual Basic
Public ReadOnly Property MinExcitationVoltageValue As Double
    Get

Property Value

Type: Double

Remarks

Set the excitation voltage source to Internal using the ExcitationVoltageSource property.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.ReturnCjcTemperaturesInStream Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..ReturnCjcTemperaturesInStream Property
AnalogInputSubsystem Class See Also Send Feedback
Enables or disables the subsystem from returning CJC values in the data stream.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool ReturnCjcTemperaturesInStream { get; set; }
Visual Basic
Public Property ReturnCjcTemperaturesInStream As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

This function is seldom needed. It is provided only for analog input subsystems that support the capability of converting temperature data (based on CJC values) in hardware.

If you disable the subsystem from returning CJC values in the data stream (ReturnCjcTemperaturesInStream is False; the default state), the subsystem returns a corrected and linearized value for each input channel. Every sample in the data stream corresponds to a single (typically, floating-point) value that represents either the temperature (in degrees C) or the voltage of the input channel, based on its ThermocoupleType. No CJC values are returned in the data stream.

If you enable the subsystem to return CJC values in the data stream (ReturnCjcTemperaturesInStream is True), the subsystem returns both an input value and CJC value for each channel; you can then implement your own temperature conversion algorithms in software to convert the data as desired. Two (typically floating-point) values are returned in the data stream for each channel: the first value represents the temperature or voltage of the input channel (based on the ThermocoupleType of the input), and the second value represents the CJC temperature, in degrees C. Generally, in this configuration, a thermocouple type of None is specified for each channel. If you return CJC values in the data stream, ensure that you allocate a buffer that is twice as large to accommodate the CJC values (number of samples x 2).

To use this function, the subsystem must be configured for a continuous operation using the DataFlow property. This feature is supported only if the subsystem supports thermocouples (see SupportsThermocouple) and the subsystem supports interleaved CJC values in the data stream (see SupportsInterleavedCjcTemperaturesInStream).

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportedExcitationCurrentValues Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportedExcitationCurrentValues Property
AnalogInputSubsystem Class See Also Send Feedback
Returns an array containing the available values for the internal excitation current source.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] SupportedExcitationCurrentValues { get; }
Visual Basic
Public ReadOnly Property SupportedExcitationCurrentValues As Double()
    Get

Property Value

Type: array<Double>[]()[][]

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsACCoupling Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsACCoupling Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports AC coupling, where the DC offset is removed; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsACCoupling { get; }
Visual Basic
Public ReadOnly Property SupportsACCoupling As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsAutoCalibrate Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsAutoCalibrate Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports auto-calibration; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsAutoCalibrate { get; }
Visual Basic
Public ReadOnly Property SupportsAutoCalibrate As Boolean
    Get

Property Value

Type: Boolean

Remarks

During auto-calibration, the specified subsystem performs an auto-zero function.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsBridgeBasedSensors Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsBridgeBasedSensors Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports bridge-based sensors or general-purpose bridge measurements; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsBridgeBasedSensors { get; }
Visual Basic
Public ReadOnly Property SupportsBridgeBasedSensors As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsCjcSourceChannel Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsCjcSourceChannel Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports channels that are used for cold junction compensation (CJC); otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsCjcSourceChannel { get; }
Visual Basic
Public ReadOnly Property SupportsCjcSourceChannel As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsCjcSourceInternal Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsCjcSourceInternal Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports a CJC (cold junction compensation) source that is internal to the hardware; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsCjcSourceInternal { get; }
Visual Basic
Public ReadOnly Property SupportsCjcSourceInternal As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsCurrent Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsCurrent Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports current measurements; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsCurrent { get; }
Visual Basic
Public ReadOnly Property SupportsCurrent As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsDataFilters Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsDataFilters Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports programmable filter types; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDataFilters { get; }
Visual Basic
Public ReadOnly Property SupportsDataFilters As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsDCCoupling Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsDCCoupling Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports DC coupling, where the DC offset is included; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDCCoupling { get; }
Visual Basic
Public ReadOnly Property SupportsDCCoupling As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsExternalExcitationCurrentSrc Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsExternalExcitationCurrentSrc Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports an external excitation current source; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsExternalExcitationCurrentSrc { get; }
Visual Basic
Public ReadOnly Property SupportsExternalExcitationCurrentSrc As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsExternalExcitationVoltageSrc Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsExternalExcitationVoltageSrc Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports an external excitation voltage source; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsExternalExcitationVoltageSrc { get; }
Visual Basic
Public ReadOnly Property SupportsExternalExcitationVoltageSrc As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsIepe Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsIepe Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports IEPE (accelerometer) inputs; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsIepe { get; }
Visual Basic
Public ReadOnly Property SupportsIepe As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsInProcessFlush Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsInProcessFlush Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem allows you to move data from the current OlBuffer object while it is being filled; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInProcessFlush { get; }
Visual Basic
Public ReadOnly Property SupportsInProcessFlush As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the MoveFromBufferInprocess(OlBuffer, Int32) method to move data from the current OlBuffer object.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsInterleavedCjcTemperaturesInStream Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsInterleavedCjcTemperaturesInStream Property
AnalogInputSubsystem Class See Also Send Feedback
(Has meaning only if SupportsTemperatureDataInStream is True.) Returns True if the device can optionally interleave CJC temperature data with A/D data (either voltage or temperature depending on the ThermocoupleType), in the data stream; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInterleavedCjcTemperaturesInStream { get; }
Visual Basic
Public ReadOnly Property SupportsInterleavedCjcTemperaturesInStream As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsInternalExcitationCurrentSrc Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsInternalExcitationCurrentSrc Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports an internal excitation current source; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInternalExcitationCurrentSrc { get; }
Visual Basic
Public ReadOnly Property SupportsInternalExcitationCurrentSrc As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsInternalExcitationVoltageSrc Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsInternalExcitationVoltageSrc Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports an internal excitation voltage source; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInternalExcitationVoltageSrc { get; }
Visual Basic
Public ReadOnly Property SupportsInternalExcitationVoltageSrc As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsMultiRecordAcquisition Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsMultiRecordAcquisition Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports multi-record acquisition; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsMultiRecordAcquisition { get; }
Visual Basic
Public ReadOnly Property SupportsMultiRecordAcquisition As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsMultiSensor Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsMultiSensor Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports reading data from multiple sensor types; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsMultiSensor { get; }
Visual Basic
Public ReadOnly Property SupportsMultiSensor As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsPerChannelVoltageExcitation Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsPerChannelVoltageExcitation Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the device supports setting the voltage excitation source and/or value per channel; otherwise, returns False if the voltage excitation source/value must be set for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPerChannelVoltageExcitation { get; }
Visual Basic
Public ReadOnly Property SupportsPerChannelVoltageExcitation As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsRemoteSense Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsRemoteSense Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports the use of remote sense leads; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsRemoteSense { get; }
Visual Basic
Public ReadOnly Property SupportsRemoteSense As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsResistance Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsResistance Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports resistance measurements; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsResistance { get; }
Visual Basic
Public ReadOnly Property SupportsResistance As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsRTD Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsRTD Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports RTD inputs; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsRTD { get; }
Visual Basic
Public ReadOnly Property SupportsRTD As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsSimultaneousSampleHold Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsSimultaneousSampleHold Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports acquisition on all channels simultaneously; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSimultaneousSampleHold { get; }
Visual Basic
Public ReadOnly Property SupportsSimultaneousSampleHold As Boolean
    Get

Property Value

Type: Boolean

Remarks

To acquire a single value from all channels simultaneously, use one of the following methods: GetSingleValuesAsRaw(Double), GetSingleValuesAsSensor(Double, Double, Double), GetSingleValuesAsTemperature(TemperatureUnit), or GetSingleValuesAsVolts(Double). For continuous operations, add the channels to a ChannelList.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsStrainGage Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsStrainGage Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports strain gage measurements; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsStrainGage { get; }
Visual Basic
Public ReadOnly Property SupportsStrainGage As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsTemperatureDataInStream Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsTemperatureDataInStream Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports temperature conversions in hardware, returning temperature data in the stream; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsTemperatureDataInStream { get; }
Visual Basic
Public ReadOnly Property SupportsTemperatureDataInStream As Boolean
    Get

Property Value

Type: Boolean

Remarks

For thermocouples, data is converted and linearized based on the specified ThermocoupleType and the value of the internal CJC source on the device. For RTDs, data is converted and linearized based on the specified RTDType.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsTemperatureFilters Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsTemperatureFilters Property
AnalogInputSubsystem Class See Also Send Feedback
Obsolete property. This property have been deprecated and may not be supported in future versions of library. Use SupportsDataFilters instead.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsTemperatureFilters { get; }
Visual Basic
Public ReadOnly Property SupportsTemperatureFilters As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsThermistor Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsThermistor Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports thermistor inputs; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsThermistor { get; }
Visual Basic
Public ReadOnly Property SupportsThermistor As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsThermocouple Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsThermocouple Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports thermocouple inputs; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsThermocouple { get; }
Visual Basic
Public ReadOnly Property SupportsThermocouple As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.SupportsTriggeredScan Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsTriggeredScan Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports triggered scan operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsTriggeredScan { get; }
Visual Basic
Public ReadOnly Property SupportsTriggeredScan As Boolean
    Get

Property Value

Type: Boolean

Remarks

See the TriggeredScan class for more information on triggered scan operations.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.TemperatureFilterType Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..TemperatureFilterType Property
AnalogInputSubsystem Class See Also Send Feedback
Obsolete property. This property have been deprecated and may not be supported in future versions of library. Use DataFilterType.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TemperatureFilterType TemperatureFilterType { get; set; }
Visual Basic
Public Property TemperatureFilterType As TemperatureFilterType
    Get
    Set

Property Value

Type: TemperatureFilterType

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem.TriggeredScan Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..TriggeredScan Property
AnalogInputSubsystem Class See Also Send Feedback
Provides an interface to the TriggeredScan object for the analog input subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TriggeredScan TriggeredScan { get; }
Visual Basic
Public ReadOnly Property TriggeredScan As TriggeredScan
    Get

Property Value

Type: TriggeredScan

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogInputSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Events
AnalogInputSubsystem Class See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | PreTriggerBufferDoneEvent | Occurs when the OlBuffer object is filled with pre-trigger data (for an analog input operation only).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogInputSubsystem Class


AnalogInputSubsystem.PreTriggerBufferDoneEvent Event

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..PreTriggerBufferDoneEvent Event
AnalogInputSubsystem Class See Also Send Feedback
Occurs when the OlBuffer object is filled with pre-trigger data (for an analog input operation only).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event PreTriggerBufferDoneHandler PreTriggerBufferDoneEvent
Visual Basic
Public Event PreTriggerBufferDoneEvent As PreTriggerBufferDoneHandler

Value

Type: OpenLayers.Base..::..PreTriggerBufferDoneHandler

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members


AnalogOutputSubsystem Class

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Class
Members See Also Send Feedback
The AnalogOutputSubsystem class provides the properties, methods, and events for performing analog output operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class AnalogOutputSubsystem : AnalogSubsystem
Visual Basic
Public Class AnalogOutputSubsystem
    Inherits AnalogSubsystem

Remarks

Instances of this class are created using the AnalogOutputSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..AnalogSubsystem
OpenLayers.Base..::..AnalogOutputSubsystem

See Also

AnalogOutputSubsystem Members


AnalogOutputSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Members
AnalogOutputSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | AnalogOutputSubsystem | Returns an AnalogOutputSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the analog output subsystem immediately without waiting for all the data in the current buffer to be output. (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Mute | Attenuates the output voltage of the subsystem to 0 V over a hardware-dependent number of samples.
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | SetSingleValueAsRaw | Writes a single value, as a raw count, to an analog output channel.
Public method | SetSingleValueAsVolts | Writes a single value, as a voltage, to an analog output channel.
Public method | SetSingleValuesAsRaw | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single raw count on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | SetSingleValuesAsVolts | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single voltage value on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | Start | Starts a continuous operation on the analog output subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog output subsystem after all the data in the current buffer has been output. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog output subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | UnMute | If the subsystem is muted, returns the output voltage of the subsystem to its current level over a hardware-dependent number of samples.
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsMute | Returns True if the subsystem supports the ability to mute and/or unmute the output voltage.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SupportsWrapSingle | Returns True if the subsystem supports reusing a single buffer for continuous operations; otherwise, returns False.
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | WrapSingleBuffer | Gets and sets the wrap mode. If WrapSingleBuffer is True, the device driver continuously reuses the first buffer queued to the subsystem. If WrapSingleBuffer is False, the device driver uses all the buffers queued to the subsystem (this is the default mode).

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogOutputSubsystem Class


AnalogOutputSubsystem Constructor

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Constructor
AnalogOutputSubsystem Class See Also Send Feedback
Returns an AnalogOutputSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogOutputSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.Base..::..Device
The Open Layers Device object with which to associate the analog output subsystem.
element
Type: System..::..Int32
The Element number of the analog output subsystem.

Remarks

It is recommended that you use the AnalogOutputSubsystem(Int32) method rather than this constructor to return an analog output subsystem.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Methods
AnalogOutputSubsystem Class See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the analog output subsystem immediately without waiting for all the data in the current buffer to be output. (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Mute | Attenuates the output voltage of the subsystem to 0 V over a hardware-dependent number of samples.
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | SetSingleValueAsRaw | Writes a single value, as a raw count, to an analog output channel.
Public method | SetSingleValueAsVolts | Writes a single value, as a voltage, to an analog output channel.
Public method | SetSingleValuesAsRaw | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single raw count on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | SetSingleValuesAsVolts | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single voltage value on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | Start | Starts a continuous operation on the analog output subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog output subsystem after all the data in the current buffer has been output. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog output subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | UnMute | If the subsystem is muted, returns the output voltage of the subsystem to its current level over a hardware-dependent number of samples.
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

See Also

AnalogOutputSubsystem Class


AnalogOutputSubsystem.Abort Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Abort Method
AnalogOutputSubsystem Class See Also Send Feedback
Stops a continuous operation on the analog output subsystem immediately without waiting for all the data in the current buffer to be output.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Abort()
Visual Basic
Public Overrides Sub Abort

Remarks

This method overrides the Abort method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.Mute Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Mute Method
AnalogOutputSubsystem Class See Also Send Feedback
Attenuates the output voltage of the subsystem to 0 V over a hardware-dependent number of samples.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Mute()
Visual Basic
Public Sub Mute

Remarks

Refer to the user's manual for your device to determine if the subsystem supports the ability to mute and unmute the output, and to determine the number of samples required for the muting process.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.SetSingleValueAsRaw Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValueAsRaw Method
AnalogOutputSubsystem Class Example See Also Send Feedback
Writes a single value, as a raw count, to an analog output channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValueAsRaw(
    int channel,
    int inRawValue
)
Visual Basic
Public Sub SetSingleValueAsRaw (
    channel As Integer,
    inRawValue As Integer
)

Parameters

channel
Type: System..::..Int32
The physical analog output channel to update.
inRawValue
Type: System..::..Int32
The raw count, as an integer, to output.

Examples

This example shows a typical use of SetSingleValueAsRaw.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem (0);
//Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
aoutSS.Config ();
// Send a raw count value of 256 to DAC0
aoutSS.SetSingleValueAsRaw(0, 256);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem(0)
' Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
aoutSS.Config()
' Send a raw count of 256 to DAC0
aoutSS.SetSingleValueAsRaw(0, 256)

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.SetSingleValueAsVolts Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValueAsVolts Method
AnalogOutputSubsystem Class Example See Also Send Feedback
Writes a single value, as a voltage, to an analog output channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValueAsVolts(
    int channel,
    double inValue
)
Visual Basic
Public Sub SetSingleValueAsVolts (
    channel As Integer,
    inValue As Double
)

Parameters

channel
Type: System..::..Int32
The physical analog output channel to update.
inValue
Type: System..::..Double
The voltage value, as a double, to output.

Examples

This example shows a typical use of SetSingleValueAsVolts.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem (0);
//Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
aoutSS.Config ();
// Send a value of 5 V to DAC0
aoutSS.SetSingleValueAsVolts(0, 5);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem(0)
' Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
aoutSS.Config()
' Send a value of 5 V to DAC0
aoutSS.SetSingleValueAsVolts(0, 5)

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.SetSingleValuesAsRaw Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValuesAsRaw Method
AnalogOutputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single raw count on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValuesAsRaw(
    SingleValuesInfoRaw[] singleValuesInfo
)
Visual Basic
Public Sub SetSingleValuesAsRaw (
    singleValuesInfo As SingleValuesInfoRaw()
)

Parameters

singleValuesInfo
Type: array< OpenLayers.Base..::..SingleValuesInfoRaw >[]()[][]
An array of SingleValuesInfoRaw structures, which specify the analog output channels to update and the raw count value to output on each channel.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.SetSingleValuesAsVolts Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValuesAsVolts Method
AnalogOutputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single voltage value on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValuesAsVolts(
    SingleValuesInfoVolts[] singleValuesInfo
)
Visual Basic
Public Sub SetSingleValuesAsVolts (
    singleValuesInfo As SingleValuesInfoVolts()
)

Parameters

singleValuesInfo
Type: array< OpenLayers.Base..::..SingleValuesInfoVolts >[]()[][]
An array of SingleValuesInfoVolts structures, which specify the analog output channels to update and the voltage value to output on each channel.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.Start Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Start Method
AnalogOutputSubsystem Class See Also Send Feedback
Starts a continuous operation on the analog output subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Start()
Visual Basic
Public Overrides Sub Start

Remarks

This method overrides the Start method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.Stop Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Stop Method
AnalogOutputSubsystem Class See Also Send Feedback
Stops a continuous operation on the analog output subsystem after all the data in the current buffer has been output.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Stop()
Visual Basic
Public Overrides Sub Stop

Remarks

This method overrides the Stop method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..ToString Method
AnalogOutputSubsystem Class See Also Send Feedback
Returns a description of the analog output subsystem and element.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the analog output subsystem and element.

Remarks

This method overrides the ToString method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.UnMute Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..UnMute Method
AnalogOutputSubsystem Class See Also Send Feedback
If the subsystem is muted, returns the output voltage of the subsystem to its current level over a hardware-dependent number of samples.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void UnMute()
Visual Basic
Public Sub UnMute

Remarks

Refer to the user's manual for your device to determine if the subsystem supports the ability to mute and unmute the output, and to determine the number of samples required for the muting process.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Properties
AnalogOutputSubsystem Class See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsMute | Returns True if the subsystem supports the ability to mute and/or unmute the output voltage.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SupportsWrapSingle | Returns True if the subsystem supports reusing a single buffer for continuous operations; otherwise, returns False.
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | WrapSingleBuffer | Gets and sets the wrap mode. If WrapSingleBuffer is True, the device driver continuously reuses the first buffer queued to the subsystem. If WrapSingleBuffer is False, the device driver uses all the buffers queued to the subsystem (this is the default mode).

See Also

AnalogOutputSubsystem Class


AnalogOutputSubsystem.SupportsMute Property

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SupportsMute Property
AnalogOutputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports the ability to mute and/or unmute the output voltage.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsMute { get; }
Visual Basic
Public ReadOnly Property SupportsMute As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Mute()()()() method to attenuate the output voltage to 0 V. If the output voltage is muted, use the UnMute()()()() method to return the output voltage to its current level.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.SupportsWrapSingle Property

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SupportsWrapSingle Property
AnalogOutputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports reusing a single buffer for continuous operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsWrapSingle { get; }
Visual Basic
Public ReadOnly Property SupportsWrapSingle As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the WrapSingleBuffer property to use a single buffer for the continuous operation.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem.WrapSingleBuffer Property

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..WrapSingleBuffer Property
AnalogOutputSubsystem Class See Also Send Feedback
Gets and sets the wrap mode. If WrapSingleBuffer is True, the device driver continuously reuses the first buffer queued to the subsystem. If WrapSingleBuffer is False, the device driver uses all the buffers queued to the subsystem (this is the default mode).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool WrapSingleBuffer { get; set; }
Visual Basic
Public Property WrapSingleBuffer As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Set this property to True for waveform generation operations on the AnalogOutputSubsystem.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members


AnalogOutputSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Events
AnalogOutputSubsystem Class See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogOutputSubsystem Class


AnalogSubsystem Class

[image]

OpenLayers for .NET Documentation
AnalogSubsystem Class
Members See Also Send Feedback
The AnalogSubsystem class is an abstract base class and is accessible only by using the following derived classes: AnalogInputSubsystem and/or AnalogOutputSubsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public abstract class AnalogSubsystem : SubsystemBase
Visual Basic
Public MustInherit Class AnalogSubsystem
    Inherits SubsystemBase

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..AnalogSubsystem
OpenLayers.Base..::..AnalogInputSubsystem
OpenLayers.Base..::..AnalogOutputSubsystem

See Also

AnalogSubsystem Members


AnalogSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Members
AnalogSubsystem Class Methods Properties Events See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value.
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VoltsToRawValue | Converts a voltage value into a raw count.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem.
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread.
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogSubsystem Class


AnalogSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Methods
AnalogSubsystem Class See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value.
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VoltsToRawValue | Converts a voltage value into a raw count.

See Also

AnalogSubsystem Class


AnalogSubsystem.RawValueToSensor Method

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToSensor Method
AnalogSubsystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.RawValueToSensor Method (Int32, Double, Double, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToSensor Method (Int32, Double, Double, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count to a sensor value in engineering units.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToSensor(
    int code,
    double gain,
    double sensorGain,
    double sensorOffset
)
Visual Basic
Public Function RawValueToSensor (
    code As Integer,
    gain As Double,
    sensorGain As Double,
    sensorOffset As Double
) As Double

Parameters

code
Type: System..::..Int32
The raw count to convert.
gain
Type: System..::..Double
The gain of the input signal, which is used to convert the raw count to a prescaled voltage value.
sensorGain
Type: System..::..Double
The sensor gain that is applied to the prescaled voltage value.
sensorOffset
Type: System..::..Double
The sensor offset that is applied to the prescaled voltage value.

Return Value

Type: Double
The sensor value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution greater than 16 bits. The scaling occurs in two steps. First, the raw count is converted to a prescaled voltage by applying the gain for the input signal. Then, the prescaled voltage value is scaled using the equation y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToSensor Overload


AnalogSubsystem.RawValueToSensor Method (UInt16, Double, Double, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToSensor Method (UInt16, Double, Double, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count to a sensor value in engineering units.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToSensor(
    ushort code,
    double gain,
    double sensorGain,
    double sensorOffset
)
Visual Basic
Public Function RawValueToSensor (
    code As UShort,
    gain As Double,
    sensorGain As Double,
    sensorOffset As Double
) As Double

Parameters

code
Type: System..::..UInt16
The raw count to convert.
gain
Type: System..::..Double
The gain of the input signal, which is used to convert the raw count to a prescaled voltage value.
sensorGain
Type: System..::..Double
The sensor gain that is applied to the prescaled voltage value.
sensorOffset
Type: System..::..Double
The sensor offset that is applied to the prescaled voltage value.

Return Value

Type: Double
The sensor value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution of 16 bits or less. The scaling occurs in two steps. First, the raw count is converted to a prescaled voltage by applying the gain for the input signal. Then, the prescaled voltage value is scaled using the equation y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToSensor Overload


AnalogSubsystem.RawValueToVolts Method

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToVolts Method
AnalogSubsystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value.
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.RawValueToVolts Method (Int32, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToVolts Method (Int32, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count into a voltage value.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToVolts(
    int code,
    double gain
)
Visual Basic
Public Function RawValueToVolts (
    code As Integer,
    gain As Double
) As Double

Parameters

code
Type: System..::..Int32
The raw count to convert.
gain
Type: System..::..Double
The gain to apply to the value. The gain is typically applied to the input signal at acquisition time.

Return Value

Type: Double
The voltage value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution of greater than 16 bits.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToVolts Overload


AnalogSubsystem.RawValueToVolts Method (UInt16, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToVolts Method (UInt16, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count into a voltage value.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToVolts(
    ushort code,
    double gain
)
Visual Basic
Public Function RawValueToVolts (
    code As UShort,
    gain As Double
) As Double

Parameters

code
Type: System..::..UInt16
The raw count to convert.
gain
Type: System..::..Double
The gain to apply to the value. The gain is typically applied to the input signal at acquisition time.

Return Value

Type: Double
The voltage value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution of 16 bits or less.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToVolts Overload


AnalogSubsystem.VoltsToRawValue Method

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..VoltsToRawValue Method
AnalogSubsystem Class See Also Send Feedback
Converts a voltage value into a raw count.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int VoltsToRawValue(
    double volts,
    double gain
)
Visual Basic
Public Function VoltsToRawValue (
    volts As Double,
    gain As Double
) As Integer

Parameters

volts
Type: System..::..Double
The voltage value to convert.
gain
Type: System..::..Double
The gain that was applied to input signal to produce the voltage.

Return Value

Type: Int32
The raw count that is associated with the voltage value.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Properties
AnalogSubsystem Class See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem.
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread.
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem.

See Also

AnalogSubsystem Class


AnalogSubsystem.NumberOfRanges Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..NumberOfRanges Property
AnalogSubsystem Class See Also Send Feedback
Returns the number of available voltage ranges for the analog subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfRanges { get; }
Visual Basic
Public ReadOnly Property NumberOfRanges As Integer
    Get

Property Value

Type: Int32

Remarks

Use the VoltageRange property to set the range.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.NumberOfSupportedGains Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..NumberOfSupportedGains Property
AnalogSubsystem Class See Also Send Feedback
Returns the number of available gains for the analog subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfSupportedGains { get; }
Visual Basic
Public ReadOnly Property NumberOfSupportedGains As Integer
    Get

Property Value

Type: Int32

Remarks

To get an array of supported gain value for the subsystem, use the SupportedGains property. Use the Gain property to set the gain for a ChannelListEntry object.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.QueuedBufferDones Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..QueuedBufferDones Property
AnalogSubsystem Class See Also Send Feedback
Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int QueuedBufferDones { get; }
Visual Basic
Public ReadOnly Property QueuedBufferDones As Integer
    Get

Property Value

Type: Int32

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.Resolution Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..Resolution Property
AnalogSubsystem Class See Also Send Feedback
Returns the resolution of the analog subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As Short
    Get

Property Value

Type: Int16

Remarks

The resolution is fixed for analog input and analog output subsystem; therefore, the Resolution property cannot be set for an analog input or output subsystem.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.SupportedGains Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..SupportedGains Property
AnalogSubsystem Class See Also Send Feedback
Returns an array of available gains for the analog subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] SupportedGains { get; }
Visual Basic
Public ReadOnly Property SupportedGains As Double()
    Get

Property Value

Type: array<Double>[]()[][]

Remarks

Use the Gain property to set the gain for a ChannelListEntry object.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.SupportedVoltageRanges Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..SupportedVoltageRanges Property
AnalogSubsystem Class See Also Send Feedback
Returns an array of supported voltage ranges for the analog subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range[] SupportedVoltageRanges { get; }
Visual Basic
Public ReadOnly Property SupportedVoltageRanges As Range()
    Get

Property Value

Type: array< Range >[]()[][]

Remarks

Use the VoltageRange property to set the range.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.SynchronousBufferDone Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..SynchronousBufferDone Property
AnalogSubsystem Class See Also Send Feedback
Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SynchronousBufferDone { get; set; }
Visual Basic
Public Property SynchronousBufferDone As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If your program is running under a heavy CPU load and this property is False, .NET may call your Buffer Done delegates out of order under certain circumstances. To avoid this problem, it is recommended that you set this property to True.

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.VoltageRange Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..VoltageRange Property
AnalogSubsystem Class Example See Also Send Feedback
Gets or sets the current voltage range for the analog subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range VoltageRange { get; set; }
Visual Basic
Public Property VoltageRange As Range
    Get
    Set

Property Value

Type: Range

Examples

This example sets the voltage range of the analog input subsystem to the first range in the list of supported voltage ranges.
C# Copy image Copy
ainSS.VoltageRange = ainSS.SupportedVoltageRanges[0];
Visual Basic Copy image Copy
ainSS.VoltageRange = ainSS.SupportedVoltageRanges(0)

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Events
AnalogSubsystem Class See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogSubsystem Class


AnalogSubsystem.DriverRunTimeErrorEvent Event

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..DriverRunTimeErrorEvent Event
AnalogSubsystem Class See Also Send Feedback
Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event DriverRunTimeErrorEventHandler DriverRunTimeErrorEvent
Visual Basic
Public Event DriverRunTimeErrorEvent As DriverRunTimeErrorEventHandler

Value

Type: OpenLayers.Base..::..DriverRunTimeErrorEventHandler

See Also

AnalogSubsystem Class
AnalogSubsystem Members


AnalogSubsystem.IOCompleteEvent Event

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..IOCompleteEvent Event
AnalogSubsystem Class See Also Send Feedback
Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event IOCompleteHandler IOCompleteEvent
Visual Basic
Public Event IOCompleteEvent As IOCompleteHandler

Value

Type: OpenLayers.Base..::..IOCompleteHandler

See Also

AnalogSubsystem Class
AnalogSubsystem Members


BridgeConfiguration Enumeration

[image]

OpenLayers for .NET Documentation
BridgeConfiguration Enumeration
See Also Send Feedback
Contains the possible values for the BridgeConfiguration property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum BridgeConfiguration
Visual Basic
Public Enumeration BridgeConfiguration

Members

Member name | Value | Description
FullBridge | 0 | Full-bridge-based sensor or transducer, such as a load cell, or general-purpose bridge that use four active gages.
HalfBridge | 3 | General-purpose bridge that use two active gages.
QuarterBridge | 5 | General-purpose bridge that uses one active gage. You must supply an external resistor that matches the nominal resistance of the bridge to complete the bridge externally.

See Also


BridgeSensorTeds Class

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds Class
Members See Also Send Feedback
The BridgeSensorTeds class provides the properties for a bridge-based sensor that supports TEDS.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class BridgeSensorTeds : TedsBase
Visual Basic
Public Class BridgeSensorTeds
    Inherits TedsBase

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..TedsBase
OpenLayers.Base..::..BridgeSensorTeds

See Also

BridgeSensorTeds Members


BridgeSensorTeds Members

[image] [image]

OpenLayers for .NET Documentation
BridgeSensorTeds Members
BridgeSensorTeds Class Methods Properties See Also Send Feedback

The BridgeSensorTeds type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadHardwareTeds | Reads data directly from a TEDS-compatible sensor that is associated with the connected channel. (Overrides TedsBase..::..ReadHardwareTeds()()()().)
Public method | ReadVirtualTeds | Reads TEDS data from a virtual TEDS file. (Overrides TedsBase..::..ReadVirtualTeds(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BridgeResistance | Gets the initial (unstrained) gage resistance, in ohms, that was specified in the TEDS data for the channel.
Public property | BridgeType | Gets the type of bridge that was specified in the TEDS data for the channel.
Public property | CalDate | Gets the calibration date that was specified in the TEDS data for the channel.
Public property | CalibrationPeriod | Gets the calibration period that was specified in the TEDS data for the channel.
Public property | CalInitials | Gets the calibration initials that were specified in the TEDS data for the channel.
Public property | ElectricalSignalType | Gets the electrical signal type that was specified in the TEDS data for the channel.
Public property | IsTedsConfigured | Returns True if the TEDS data stream is read successfully; otherwise, returns False. (Inherited from TedsBase.)
Public property | ManufacturerId | Gets identifying information about the manufacturer of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | MaxElecticalValue | Gets the maximum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MaximumExcitationVoltage | Gets the maximum excitation voltage that was specified in the TEDS data for the channel.
Public property | MaxPhysicalValue | Gets the positive full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | MeasID | Gets the measurement location ID that was specified in the TEDS data for the channel.
Public property | MinElecticalValue | Gets the minimum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MinimumExcitationVoltage | Gets the minimum excitation voltage that was specified in the TEDS data for the channel.
Public property | MinPhysicalValue | Gets the negative full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | ModelNumber | Gets the model number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | NominalExcitationVoltage | Gets the nominal excitation voltage that was specified in the TEDS data for the channel.
Public property | PhysicalMeasurand | Gets the physical Measureand (units) that were specified in the TEDS data for the channel.
Public property | ResponseTime | Gets the response time, in seconds, that was specified in the TEDS data for the channel.
Public property | SerialNumber | Gets the serial number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | VersionLetter | Gets the version letter of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | VersionNumber | Gets the version number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)

See Also

BridgeSensorTeds Class


BridgeSensorTeds Methods

[image] [image]

OpenLayers for .NET Documentation
BridgeSensorTeds Methods
BridgeSensorTeds Class See Also Send Feedback

The BridgeSensorTeds type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadHardwareTeds | Reads data directly from a TEDS-compatible sensor that is associated with the connected channel. (Overrides TedsBase..::..ReadHardwareTeds()()()().)
Public method | ReadVirtualTeds | Reads TEDS data from a virtual TEDS file. (Overrides TedsBase..::..ReadVirtualTeds(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BridgeSensorTeds Class


BridgeSensorTeds.ReadHardwareTeds Method

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..ReadHardwareTeds Method
BridgeSensorTeds Class See Also Send Feedback
Reads data directly from a TEDS-compatible sensor that is associated with the connected channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void ReadHardwareTeds()
Visual Basic
Public Overrides Sub ReadHardwareTeds

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.ReadVirtualTeds Method

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..ReadVirtualTeds Method
BridgeSensorTeds Class See Also Send Feedback
Reads TEDS data from a virtual TEDS file.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void ReadVirtualTeds(
    string fileName
)
Visual Basic
Public Overrides Sub ReadVirtualTeds (
    fileName As String
)

Parameters

fileName
Type: System..::..String
The name of the file that contains the TEDS data for the bridge-based sensor.

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds Properties

[image] [image]

OpenLayers for .NET Documentation
BridgeSensorTeds Properties
BridgeSensorTeds Class See Also Send Feedback

The BridgeSensorTeds type exposes the following members.

Properties

 | Name | Description
Public property | BridgeResistance | Gets the initial (unstrained) gage resistance, in ohms, that was specified in the TEDS data for the channel.
Public property | BridgeType | Gets the type of bridge that was specified in the TEDS data for the channel.
Public property | CalDate | Gets the calibration date that was specified in the TEDS data for the channel.
Public property | CalibrationPeriod | Gets the calibration period that was specified in the TEDS data for the channel.
Public property | CalInitials | Gets the calibration initials that were specified in the TEDS data for the channel.
Public property | ElectricalSignalType | Gets the electrical signal type that was specified in the TEDS data for the channel.
Public property | IsTedsConfigured | Returns True if the TEDS data stream is read successfully; otherwise, returns False. (Inherited from TedsBase.)
Public property | ManufacturerId | Gets identifying information about the manufacturer of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | MaxElecticalValue | Gets the maximum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MaximumExcitationVoltage | Gets the maximum excitation voltage that was specified in the TEDS data for the channel.
Public property | MaxPhysicalValue | Gets the positive full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | MeasID | Gets the measurement location ID that was specified in the TEDS data for the channel.
Public property | MinElecticalValue | Gets the minimum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MinimumExcitationVoltage | Gets the minimum excitation voltage that was specified in the TEDS data for the channel.
Public property | MinPhysicalValue | Gets the negative full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | ModelNumber | Gets the model number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | NominalExcitationVoltage | Gets the nominal excitation voltage that was specified in the TEDS data for the channel.
Public property | PhysicalMeasurand | Gets the physical Measureand (units) that were specified in the TEDS data for the channel.
Public property | ResponseTime | Gets the response time, in seconds, that was specified in the TEDS data for the channel.
Public property | SerialNumber | Gets the serial number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | VersionLetter | Gets the version letter of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | VersionNumber | Gets the version number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)

See Also

BridgeSensorTeds Class


BridgeSensorTeds.BridgeResistance Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..BridgeResistance Property
BridgeSensorTeds Class See Also Send Feedback
Gets the initial (unstrained) gage resistance, in ohms, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double BridgeResistance { get; }
Visual Basic
Public ReadOnly Property BridgeResistance As Double
    Get

Property Value

Type: Double

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.BridgeType Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..BridgeType Property
BridgeSensorTeds Class See Also Send Feedback
Gets the type of bridge that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TedsBridgeType BridgeType { get; }
Visual Basic
Public ReadOnly Property BridgeType As TedsBridgeType
    Get

Property Value

Type: TedsBridgeType

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.CalDate Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..CalDate Property
BridgeSensorTeds Class See Also Send Feedback
Gets the calibration date that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DateTime CalDate { get; }
Visual Basic
Public ReadOnly Property CalDate As DateTime
    Get

Property Value

Type: DateTime

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.CalibrationPeriod Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..CalibrationPeriod Property
BridgeSensorTeds Class See Also Send Feedback
Gets the calibration period that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint CalibrationPeriod { get; }
Visual Basic
Public ReadOnly Property CalibrationPeriod As UInteger
    Get

Property Value

Type: UInt32

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.CalInitials Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..CalInitials Property
BridgeSensorTeds Class See Also Send Feedback
Gets the calibration initials that were specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string CalInitials { get; }
Visual Basic
Public ReadOnly Property CalInitials As String
    Get

Property Value

Type: String

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.ElectricalSignalType Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..ElectricalSignalType Property
BridgeSensorTeds Class See Also Send Feedback
Gets the electrical signal type that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string ElectricalSignalType { get; }
Visual Basic
Public ReadOnly Property ElectricalSignalType As String
    Get

Property Value

Type: String

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.MaxElecticalValue Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..MaxElecticalValue Property
BridgeSensorTeds Class See Also Send Feedback
Gets the maximum electrical output, in V/V, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MaxElecticalValue { get; }
Visual Basic
Public ReadOnly Property MaxElecticalValue As Single
    Get

Property Value

Type: Single

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.MaximumExcitationVoltage Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..MaximumExcitationVoltage Property
BridgeSensorTeds Class See Also Send Feedback
Gets the maximum excitation voltage that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaximumExcitationVoltage { get; }
Visual Basic
Public ReadOnly Property MaximumExcitationVoltage As Double
    Get

Property Value

Type: Double

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.MaxPhysicalValue Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..MaxPhysicalValue Property
BridgeSensorTeds Class See Also Send Feedback
Gets the positive full-scale value, in strain, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MaxPhysicalValue { get; }
Visual Basic
Public ReadOnly Property MaxPhysicalValue As Single
    Get

Property Value

Type: Single

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.MeasID Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..MeasID Property
BridgeSensorTeds Class See Also Send Feedback
Gets the measurement location ID that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint MeasID { get; }
Visual Basic
Public ReadOnly Property MeasID As UInteger
    Get

Property Value

Type: UInt32

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.MinElecticalValue Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..MinElecticalValue Property
BridgeSensorTeds Class See Also Send Feedback
Gets the minimum electrical output, in V/V, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MinElecticalValue { get; }
Visual Basic
Public ReadOnly Property MinElecticalValue As Single
    Get

Property Value

Type: Single

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.MinimumExcitationVoltage Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..MinimumExcitationVoltage Property
BridgeSensorTeds Class See Also Send Feedback
Gets the minimum excitation voltage that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MinimumExcitationVoltage { get; }
Visual Basic
Public ReadOnly Property MinimumExcitationVoltage As Double
    Get

Property Value

Type: Double

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.MinPhysicalValue Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..MinPhysicalValue Property
BridgeSensorTeds Class See Also Send Feedback
Gets the negative full-scale value, in strain, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MinPhysicalValue { get; }
Visual Basic
Public ReadOnly Property MinPhysicalValue As Single
    Get

Property Value

Type: Single

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.NominalExcitationVoltage Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..NominalExcitationVoltage Property
BridgeSensorTeds Class See Also Send Feedback
Gets the nominal excitation voltage that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double NominalExcitationVoltage { get; }
Visual Basic
Public ReadOnly Property NominalExcitationVoltage As Double
    Get

Property Value

Type: Double

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.PhysicalMeasurand Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..PhysicalMeasurand Property
BridgeSensorTeds Class See Also Send Feedback
Gets the physical Measureand (units) that were specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public PhysicalMeasurandUnits PhysicalMeasurand { get; }
Visual Basic
Public ReadOnly Property PhysicalMeasurand As PhysicalMeasurandUnits
    Get

Property Value

Type: PhysicalMeasurandUnits

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BridgeSensorTeds.ResponseTime Property

[image]

OpenLayers for .NET Documentation
BridgeSensorTeds..::..ResponseTime Property
BridgeSensorTeds Class See Also Send Feedback
Gets the response time, in seconds, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ResponseTime { get; }
Visual Basic
Public ReadOnly Property ResponseTime As Double
    Get

Property Value

Type: Double

See Also

BridgeSensorTeds Class
BridgeSensorTeds Members


BufferDoneEventArgs Class

[image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Class
Members See Also Send Feedback
A BufferDoneEventArgs object is passed to one of the following delegates when the associated event occurs: BufferDoneHandler delegate when the event BufferDoneEvent occurs or PreTriggerBufferDoneHandler delegate when the event PreTriggerBufferDoneEvent occurs. BufferDoneEventArgs contains the data that is associated with the event, including the subsystem that raised the event, the time stamp of when the event occurred, and the completed OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class BufferDoneEventArgs : GeneralEventArgs
Visual Basic
Public Class BufferDoneEventArgs
    Inherits GeneralEventArgs

Remarks

For input operations, the event BufferDoneEvent is raised when the internal buffer of an OlBuffer object has been filled with post-trigger data. For output operations, this event is raised when all the data in the internal buffer of an OlBuffer object has been output.

If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current OlBuffer object and for up to eight inprocess OlBuffer objects before a QueueStoppedEvent event occurs.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.Base..::..GeneralEventArgs
OpenLayers.Base..::..BufferDoneEventArgs

See Also

BufferDoneEventArgs Members


BufferDoneEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Members
BufferDoneEventArgs Class Methods Properties See Also Send Feedback

The BufferDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | OlBuffer | Returns the completed OlBuffer object.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

BufferDoneEventArgs Class


BufferDoneEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Methods
BufferDoneEventArgs Class See Also Send Feedback

The BufferDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BufferDoneEventArgs Class


BufferDoneEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Properties
BufferDoneEventArgs Class See Also Send Feedback

The BufferDoneEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | OlBuffer | Returns the completed OlBuffer object.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

BufferDoneEventArgs Class


BufferDoneEventArgs.OlBuffer Property

[image]

OpenLayers for .NET Documentation
BufferDoneEventArgs..::..OlBuffer Property
BufferDoneEventArgs Class See Also Send Feedback
Returns the completed OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer OlBuffer { get; }
Visual Basic
Public ReadOnly Property OlBuffer As OlBuffer
    Get

Property Value

Type: OlBuffer

See Also

BufferDoneEventArgs Class
BufferDoneEventArgs Members


BufferDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
BufferDoneHandler Delegate
See Also Send Feedback
The BufferDoneHandler delegate is called when the event BufferDoneEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void BufferDoneHandler(
    Object sender,
    BufferDoneEventArgs eventArgs
)
Visual Basic
Public Delegate Sub BufferDoneHandler (
    sender As Object,
    eventArgs As BufferDoneEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..BufferDoneEventArgs
The BufferDoneEventArgs object that is associated with the event BufferDoneEvent.

Remarks

For input operations, the event BufferDoneEvent is raised when the internal buffer of an OlBuffer object has been filled with post-trigger data. For output operations, this event is raised when all the data in the internal buffer of the OlBuffer object has been output.

See Also


BufferQueue Class

[image]

OpenLayers for .NET Documentation
BufferQueue Class
Members See Also Send Feedback
The BufferQueue class provides an interface for queuing OlBuffer objects to a device's subsystem for continuous I/O operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class BufferQueue
Visual Basic
Public Class BufferQueue

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..BufferQueue

See Also

BufferQueue Members


BufferQueue Members

[image] [image]

OpenLayers for .NET Documentation
BufferQueue Members
BufferQueue Class Methods Properties See Also Send Feedback

The BufferQueue type exposes the following members.

Methods

 | Name | Description
Public method | DequeueBuffer | Removes the OlBuffer object from the front of the subsystem queue, and returns it to the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FreeAllQueuedBuffers | Removes all OlBuffer objects from the subsystem queue and deallocates the associated internal buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | QueueBuffer | Adds an OlBuffer object to the subsystem queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InProcessCount | Returns the number of OlBuffer objects that have been taken from subsystem queue and sent to the device for processing (buffers are in the inprocess state).
Public property | QueuedCount | Returns the number of OlBuffer objects that are on the subsystem queue (OlBuffer objects are in the queued state).

See Also

BufferQueue Class


BufferQueue Methods

[image] [image]

OpenLayers for .NET Documentation
BufferQueue Methods
BufferQueue Class See Also Send Feedback

The BufferQueue type exposes the following members.

Methods

 | Name | Description
Public method | DequeueBuffer | Removes the OlBuffer object from the front of the subsystem queue, and returns it to the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FreeAllQueuedBuffers | Removes all OlBuffer objects from the subsystem queue and deallocates the associated internal buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | QueueBuffer | Adds an OlBuffer object to the subsystem queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BufferQueue Class


BufferQueue.DequeueBuffer Method

[image]

OpenLayers for .NET Documentation
BufferQueue..::..DequeueBuffer Method
BufferQueue Class See Also Send Feedback
Removes the OlBuffer object from the front of the subsystem queue, and returns it to the user.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer DequeueBuffer()
Visual Basic
Public Function DequeueBuffer As OlBuffer

Return Value

Type: OlBuffer
The OlBuffer object from the front of the queue.

See Also

BufferQueue Class
BufferQueue Members


BufferQueue.FreeAllQueuedBuffers Method

[image]

OpenLayers for .NET Documentation
BufferQueue..::..FreeAllQueuedBuffers Method
BufferQueue Class See Also Send Feedback
Removes all OlBuffer objects from the subsystem queue and deallocates the associated internal buffer.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void FreeAllQueuedBuffers()
Visual Basic
Public Sub FreeAllQueuedBuffers

See Also

BufferQueue Class
BufferQueue Members


BufferQueue.QueueBuffer Method

[image]

OpenLayers for .NET Documentation
BufferQueue..::..QueueBuffer Method
BufferQueue Class See Also Send Feedback
Adds an OlBuffer object to the subsystem queue.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void QueueBuffer(
    OlBuffer inBuffer
)
Visual Basic
Public Sub QueueBuffer (
    inBuffer As OlBuffer
)

Parameters

inBuffer
Type: OpenLayers.Base..::..OlBuffer
The OlBuffer object to add to the subsystem queue.

Remarks

If the subsystem is incompatible with the specified OlBuffer object, an exception is raised.

See Also

BufferQueue Class
BufferQueue Members


BufferQueue Properties

[image] [image]

OpenLayers for .NET Documentation
BufferQueue Properties
BufferQueue Class See Also Send Feedback

The BufferQueue type exposes the following members.

Properties

 | Name | Description
Public property | InProcessCount | Returns the number of OlBuffer objects that have been taken from subsystem queue and sent to the device for processing (buffers are in the inprocess state).
Public property | QueuedCount | Returns the number of OlBuffer objects that are on the subsystem queue (OlBuffer objects are in the queued state).

See Also

BufferQueue Class


BufferQueue.InProcessCount Property

[image]

OpenLayers for .NET Documentation
BufferQueue..::..InProcessCount Property
BufferQueue Class See Also Send Feedback
Returns the number of OlBuffer objects that have been taken from subsystem queue and sent to the device for processing (buffers are in the inprocess state).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int InProcessCount { get; }
Visual Basic
Public ReadOnly Property InProcessCount As Integer
    Get

Property Value

Type: Int32

Remarks

When you start a continuous operation, the device takes up to eight OlBuffer objects from the subsystem queue and begins filling the associated internal buffers (for input operations) or outputting data from the associated internal buffers for output operations) at the specified clock rate. The state of these OlBuffer objects changes from queued to inprocess. Every time an OlBuffer object transitions from the queued state to the inprocess state, the value of the QueuedCount property decreases by one and the value of the InProcessCount property increases by 1. For example, assume that you call QueueBuffer for 10 OlBuffer objects; the QueuedCount is now 10 and the InProcessCount is 0. Once you call Start, up to 8 OlBuffer objects are moved from the queued state to the inprocess state. The QueuedCount is now 2 and the InProcessCount is now 8. As each OlBuffer object is completed, an event is generated allowing you to process the buffer. Assume that you do not put the OlBuffer objects back on the queue after processing them. In this case, the QueuedCount decreases while the InProcessCount remains the same (as a new inprocess OlBuffer object replaces a completed OlBuffer object) until the QueuedCount gets to 0, then the InProcessCount starts decreasing until all the OlBuffer objects are completed.

See Also

BufferQueue Class
BufferQueue Members


BufferQueue.QueuedCount Property

[image]

OpenLayers for .NET Documentation
BufferQueue..::..QueuedCount Property
BufferQueue Class See Also Send Feedback
Returns the number of OlBuffer objects that are on the subsystem queue (OlBuffer objects are in the queued state).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int QueuedCount { get; }
Visual Basic
Public ReadOnly Property QueuedCount As Integer
    Get

Property Value

Type: Int32

Remarks

When you start a continuous operation, the device takes up to eight OlBuffer objects from the subsystem queue and begins filling the associated internal buffers (for input operations) or outputting data from the associated internal buffers (for output operations) at the specified clock rate. The state of these OlBuffer objects changes from queued to inprocess. Every time an OlBuffer object transitions from the queued state to the inprocess state, the value of the QueuedCount property decreases by one and the value of the InProcessCount property increases by 1. For example, assume that you call QueueBuffer for 10 OlBuffer objects; the QueuedCount is now 10 and the InProcessCount is 0. Once you call Start, up to 8 OlBuffer objects are moved from the queued state to the inprocess state. The QueuedCount is now 2 and the InProcessCount is now 8. As each OlBuffer object is completed, an event is generated allowing you to process the buffer. Assume that you do not put the OlBuffer objects back on the queue after processing them. In this case, the QueuedCount decreases while the InProcessCount remains the same (as a new inprocess OlBuffer object replaces a completed OlBuffer object) until the QueuedCount gets to 0, then the InProcessCount starts decreasing until all the OlBuffer objects are completed.

See Also

BufferQueue Class
BufferQueue Members


BufferReusedHandler Delegate

[image]

OpenLayers for .NET Documentation
BufferReusedHandler Delegate
See Also Send Feedback
The BufferReusedHandler delegate is called when the event BufferReusedEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void BufferReusedHandler(
    Object sender,
    BufferDoneEventArgs eventArgs
)
Visual Basic
Public Delegate Sub BufferReusedHandler (
    sender As Object,
    eventArgs As BufferDoneEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..BufferDoneEventArgs
The BufferDoneEventArgs object that is associated with the event BufferReusedEvent.

See Also


CascadeMode Enumeration

[image]

OpenLayers for .NET Documentation
CascadeMode Enumeration
See Also Send Feedback
Contains the possible values for the CascadeMode property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum CascadeMode
Visual Basic
Public Enumeration CascadeMode

Members

Member name | Value | Description
Cascade | 900 | Internally connects or cascades the clock output signal from one counter/timer to the clock input signal of the next counter/timer, in software. In this way, you can create a 32-bit counter out of two 16-bit counters, for example.
Single | 901 | The counter/timer is not internally connected to another counter/timer.

See Also


ChannelDataType Enumeration

[image]

OpenLayers for .NET Documentation
ChannelDataType Enumeration
See Also Send Feedback
Contains the possible values for the ChannelDataType parameter that is used by the RawDataFormat property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ChannelDataType
Visual Basic
Public Enumeration ChannelDataType

Members

Member name | Value | Description
Int16 | 0 | Signed, 16-bit values.
Uint16 | 1 | Unsigned, 16-bit values.
Int32 | 2 | Signed, 32-bit values.
Float | 3 | 32-bit float values.
Double | 4 | 64-bit float (double bit) values.

See Also


ChannelList Class

[image]

OpenLayers for .NET Documentation
ChannelList Class
Members Example See Also Send Feedback
A ChannelList specifies a collection of ChannelListEntry objects for use in a continuous I/O operation. Each ChannelListEntry object encapsulates a physical channel connection for a specific subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class ChannelList : CollectionBase
Visual Basic
Public Class ChannelList
    Inherits CollectionBase

Remarks

A ChannelList is typically used in continuous analog input and analog output operations. You can add and/or insert a channel to the ChannelList by physical channel number, by name, or as a ChannelListEntry object.

Examples

The following example demonstrates how to add and insert channels in the ChannelList, and set the gain for a channel.
C# Copy image Copy
// Get a DeviceMgr object and Device object.
Device device = DeviceMgr.Get()
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Create a ChannelListEntry object for analog input channel 0.
ChannelListEntry ch0 = new ChannelListEntry ( ainSS.SupportedChannels.GetChannelInfo (SubsystemType.AnalogInput, 0 ) );
// Add the ChannelListEntry object ch0 to the ChannelList.
ainSS.ChannelList.Add (ch0);

// Insert analog input channel 1 as a physical channel into the first position (index 0) of the channel list.
// This will push ChannelListEntry object ch0 to the 2nd position (index 1) of the channel list.
ainSS.ChannelList.Insert (0, 1);

// For the ChannelListEntry at index 0 (which is analog input channel 1), change the gain to 2 using the Item property.
ainSS.ChannelList[0].Gain = 2;
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
   ' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Create a ChannelListEntry object for analog input channel 0.
Dim ch0 As New ChannelListEntry(ainSS.SupportedChannels.GetChannelInfo(SubsystemType.AnalogInput, 0))
' Add the ChannelListEntry object ch0 to the ChannelList.
ainSS.ChannelList.Add(ch0)

' Insert analog input channel 1 as a physical channel into the first position (index 0) of the channel list.
' This will push ChannelListEntry object ch0 to the 2nd position (index 1) of the channel list.
ainSS.ChannelList.Insert(0, 1)

' For the ChannelListEntry at index 0 (which is analog input channel 1), change the gain to 2 using the Item property.
ainSS.ChannelList(0).Gain = 2

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
OpenLayers.Base..::..ChannelList

See Also

ChannelList Members


ChannelList Members

[image] [image]

OpenLayers for .NET Documentation
ChannelList Members
ChannelList Class Methods Properties See Also Send Feedback

The ChannelList type exposes the following members.

Methods

 | Name | Description
Public method | Add(Int32) | Adds a channel to the end of the ChannelList.
Public method | Add(String) | Adds a channel to the end of the ChannelList.
Public method | Add(ChannelListEntry) | Adds a channel to the end of the ChannelList.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns True if the ChannelList contains a specific ChannelListEntry object; otherwise, returns False.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Int32) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | IndexOf(ChannelListEntry) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | Insert(Int32, ChannelListEntry) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, Int32) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, String) | Inserts a channel at the specified index of the ChannelList.
Public method | Remove | Removes the first occurrence of the specified ChannelListEntry object from the ChannelList.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | CGLDepth | Returns the maximum number of channels or ChannelListEntry objects that the ChannelList can contain.
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Returns or replaces the ChannelListEntry object at the specified index of the ChannelList.

See Also

ChannelList Class


ChannelList Methods

[image] [image]

OpenLayers for .NET Documentation
ChannelList Methods
ChannelList Class See Also Send Feedback

The ChannelList type exposes the following members.

Methods

 | Name | Description
Public method | Add(Int32) | Adds a channel to the end of the ChannelList.
Public method | Add(String) | Adds a channel to the end of the ChannelList.
Public method | Add(ChannelListEntry) | Adds a channel to the end of the ChannelList.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns True if the ChannelList contains a specific ChannelListEntry object; otherwise, returns False.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Int32) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | IndexOf(ChannelListEntry) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | Insert(Int32, ChannelListEntry) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, Int32) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, String) | Inserts a channel at the specified index of the ChannelList.
Public method | Remove | Removes the first occurrence of the specified ChannelListEntry object from the ChannelList.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChannelList Class


ChannelList.Add Method

[image] [image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method
ChannelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Int32) | Adds a channel to the end of the ChannelList.
Public method | Add(String) | Adds a channel to the end of the ChannelList.
Public method | Add(ChannelListEntry) | Adds a channel to the end of the ChannelList.

See Also

ChannelList Class
ChannelList Members


ChannelList.Add Method (Int32)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method (Int32)
ChannelList Class Example See Also Send Feedback
Adds a channel to the end of the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Add(
    int physicalChannelNumber
)
Visual Basic
Public Function Add (
    physicalChannelNumber As Integer
) As ChannelListEntry

Parameters

physicalChannelNumber
Type: System..::..Int32
The number of the physical channel on the specified subsystem to add to the ChannelList.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was added. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Adds a channel, specified as a physical channel number, to the end of the ChannelList and returns a ChannelListEntry object for the channel.

This method provides a simple way to add channels into the ChannelList, particularly if you are adding channels that are native to the subsystem type (such as analog input channels on an analog input subsystem). For native channels, the physical channel number always equals the logical channel number. While non-native channels, such as digital inputs that are streamed through the analog input subsystem, can also be added this way, the physical channel number is not the same as the logical channel number, so you may find it easier to add a channel by name or by ChannelListEntry object instead.

Examples

This example demonstrates how to add a analog input channel 0 by physical channel number to the ChannelList.
C# Copy image Copy
ch = ainSS.ChannelList.Add (0);
Visual Basic Copy image Copy
ch = ainSS.ChannelList.Add(0)

See Also

ChannelList Class
ChannelList Members
Add Overload


ChannelList.Add Method (String)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method (String)
ChannelList Class Example See Also Send Feedback
Adds a channel to the end of the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Add(
    string physicalChannelName
)
Visual Basic
Public Function Add (
    physicalChannelName As String
) As ChannelListEntry

Parameters

physicalChannelName
Type: System..::..String
The name of the channel to add to the ChannelList. The channel name must match a channel name contained in the SupportedChannels object for the specified subsystem.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was added. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Adds a channel, specified by name, to the end of the ChannelList and returns a ChannelListEntry object for the channel.

Examples

This example demonstrates how to add a channel by name to the ChannelList.
C# Copy image Copy
//Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels[1].Name = " Sensor";
//Add the channel named Sensor to the ChannelList.
ch = ainSS.ChannelList.Add("Sensor");
Visual Basic Copy image Copy
'Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels(1).Name = "Sensor"
'Add the channel named Sensor to the ChannelList.
ch = AinSS.ChannelList.Add("Sensor")

See Also

ChannelList Class
ChannelList Members
Add Overload


ChannelList.Add Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method (ChannelListEntry)
ChannelList Class Example See Also Send Feedback
Adds a channel to the end of the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Add(
    ChannelListEntry value
)
Visual Basic
Public Function Add (
    value As ChannelListEntry
) As Integer

Parameters

value
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object to add to the ChannelList.

Return Value

Type: Int32
The index at which the ChannelListEntry object has been added to the ChannelList.

Remarks

Adds the specified ChannelListEntry object to the end of the ChannelList.

Examples

This example demonstrates how to add a ChannelListEntry to the ChannelList.
C# Copy image Copy
// Create a ChannelListEntry object for analog input channel 2
// of the AnalogInputSubsystem (ainSS).
ChannelListEntry ch2 = new ChannelListEntry ( ainSS.SupportedChannels.GetChannelInfo (SubsystemType.AnalogInput, 2 ) );
// Add the ChannelListEntry object ch2 to the ChannelList.
ainSS.ChannelList.Add (ch2);
Visual Basic Copy image Copy
' Create a ChannelListEntry object for analog input channel 2
' of the AnalogInputSubsystem (ainSS).
Dim ch2 As New ChannelListEntry(ainSS.SupportedChannels.GetChannelInfo(SubsystemType.AnalogInput, 2))
' Add the ChannelListEntry object ch2 to the ChannelList.
ainSS.ChannelList.Add(ch2)

See Also

ChannelList Class
ChannelList Members
Add Overload


ChannelList.Contains Method

[image]

OpenLayers for .NET Documentation
ChannelList..::..Contains Method
ChannelList Class See Also Send Feedback
Returns True if the ChannelList contains a specific ChannelListEntry object; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Contains(
    ChannelListEntry value
)
Visual Basic
Public Function Contains (
    value As ChannelListEntry
) As Boolean

Parameters

value
Type: OpenLayers.Base..::..ChannelListEntry
The ChannelListEntry object to locate in the ChannelList.

Return Value

Type: Boolean
Returns True if the ChannelList contains the ChannelListEntry object; otherwise, returns False.

See Also

ChannelList Class
ChannelList Members


ChannelList.IndexOf Method

[image] [image]

OpenLayers for .NET Documentation
ChannelList..::..IndexOf Method
ChannelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(Int32) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | IndexOf(ChannelListEntry) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.

See Also

ChannelList Class
ChannelList Members


ChannelList.IndexOf Method (Int32)

[image]

OpenLayers for .NET Documentation
ChannelList..::..IndexOf Method (Int32)
ChannelList Class See Also Send Feedback
Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int IndexOf(
    int physicalChannelNumber
)
Visual Basic
Public Function IndexOf (
    physicalChannelNumber As Integer
) As Integer

Parameters

physicalChannelNumber
Type: System..::..Int32
The number of the physical channel for the associated subsystem to locate.

Return Value

Type: Int32
If found, returns the zero-based index of the first occurrence of the phyiscal channel number within the ChannelList; otherwise, returns -1.

Remarks

Searches for the specified physical channel number and returns the zero-based index of the first occurrence of the physical channel number within the ChannelList.

See Also

ChannelList Class
ChannelList Members
IndexOf Overload


ChannelList.IndexOf Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
ChannelList..::..IndexOf Method (ChannelListEntry)
ChannelList Class See Also Send Feedback
Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int IndexOf(
    ChannelListEntry value
)
Visual Basic
Public Function IndexOf (
    value As ChannelListEntry
) As Integer

Parameters

value
Type: OpenLayers.Base..::..ChannelListEntry
The ChannelListEntry object to locate.

Return Value

Type: Int32
If found, returns the zero-based index of the first occurrence of the ChannelListEntry object within the ChannelList; otherwise, returns -1.

Remarks

Searches for the specified ChannelListEntry object and returns the zero-based index of the first occurrence of the ChannelListEntry object within the ChannelList.

See Also

ChannelList Class
ChannelList Members
IndexOf Overload


ChannelList.Insert Method

[image] [image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method
ChannelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(Int32, ChannelListEntry) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, Int32) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, String) | Inserts a channel at the specified index of the ChannelList.

See Also

ChannelList Class
ChannelList Members


ChannelList.Insert Method (Int32, ChannelListEntry)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method (Int32, ChannelListEntry)
ChannelList Class Example See Also Send Feedback
Inserts a channel at the specified index of the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Insert(
    int index,
    ChannelListEntry value
)
Visual Basic
Public Sub Insert (
    index As Integer,
    value As ChannelListEntry
)

Parameters

index
Type: System..::..Int32
Zero-based index at which to insert the ChannelListEntry object.
value
Type: OpenLayers.Base..::..ChannelListEntry
The ChannelListEntry object to insert.

Remarks

Inserts a ChannelListEntry object at the specified index of the ChannelList.

Examples

This example inserts ChannelListEntry ch3 at index 1 of the ChannelList for an AnalogInputSubsystem (ainSS).
C# Copy image Copy
// Create a ChannelListEntry object for analog input channel 3
// of the AnalogInputSubsystem (ainSS).
ChannelListEntry ch3 = new ChannelListEntry ( ainSS.SupportedChannels.GetChannelInfo (SubsystemType.AnalogInput, 3 ) );
// Insert the ChannelListEntry object ch3 at index 1 of the ChannelList.
ainSS.ChannelList.Insert (1, ch3);
Visual Basic Copy image Copy
' Create a ChannelListEntry object for analog input channel 3
' of the AnalogInputSubsystem (ainSS).
Dim ch3 As New ChannelListEntry(ainSS.SupportedChannels.GetChannelInfo(SubsystemType.AnalogInput, 3))
' Insert the ChannelListEntry object ch3 at index 1 of the ChannelList.
ainSS.ChannelList.Insert(1, ch3)

See Also

ChannelList Class
ChannelList Members
Insert Overload


ChannelList.Insert Method (Int32, Int32)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method (Int32, Int32)
ChannelList Class Example See Also Send Feedback
Inserts a channel at the specified index of the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Insert(
    int index,
    int physicalChannelNumber
)
Visual Basic
Public Function Insert (
    index As Integer,
    physicalChannelNumber As Integer
) As ChannelListEntry

Parameters

index
Type: System..::..Int32
Zero-based index of the ChannelList at which to insert the ChannelListEntry object.
physicalChannelNumber
Type: System..::..Int32
The physical channel number of the specified subsystem to add to the ChannelList.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was inserted. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Inserts a channel, specified as a physical channel number, at the specified index of the ChannelList and returns a ChannelListEntry object for the channel.

This method provides a simple way to insert channels into the ChannelList, particularly if you are inserting channels that are native to the subsystem type (such as analog input channels on an analog input subsystem). For native channels, the physical channel number always equals the logical channel number. While non-native channels, such as digital inputs that are streamed through the analog input subsystem, can also be inserted this way, the physical channel number is not the same as the logical channel number, so you may find it easier to insert a channel by name or by ChannelListEntry object instead.

Examples

This example demonstrates how to insert analog input channel 3 (by physical channel number) at index 0 of the ChannelList.
C# Copy image Copy
ch = ainSS.ChannelList.Insert (0, 3);
Visual Basic Copy image Copy
ch = ainSS.ChannelList.Insert(0,3)

See Also

ChannelList Class
ChannelList Members
Insert Overload


ChannelList.Insert Method (Int32, String)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method (Int32, String)
ChannelList Class Example See Also Send Feedback
Inserts a channel at the specified index of the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Insert(
    int index,
    string physicalChannelName
)
Visual Basic
Public Function Insert (
    index As Integer,
    physicalChannelName As String
) As ChannelListEntry

Parameters

index
Type: System..::..Int32
Zero-based index of the ChannelList at which to insert the ChannelListEntry object.
physicalChannelName
Type: System..::..String
The name of a channel on the specified subsystem to add to the ChannelList. The channel name must match the name of a channel contained in the SupportedChannels object for the specified subsystem type.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was inserted. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Inserts a channel, specified by name, at the specified index of the ChannelList and returns a ChannelListEntry object for the channel.

Examples

This example inserts the analog input channel with the name Sensor at index 2 of the ChannelList and returns a ChannelListEntry object (ch).
C# Copy image Copy
//Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels[1].Name = " Sensor";
//Insert the channel named Sensor at index 2 of the ChannelList.
ch = ainSS.ChannelList.Insert(2, "Sensor");
///
Visual Basic Copy image Copy
'Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels(1).Name = "Sensor"
'Insert the channel named Sensor at index 2 of the ChannelList.
ch = AinSS.ChannelList.Insert(2, "Sensor")

See Also

ChannelList Class
ChannelList Members
Insert Overload


ChannelList.Remove Method

[image]

OpenLayers for .NET Documentation
ChannelList..::..Remove Method
ChannelList Class Example See Also Send Feedback
Removes the first occurrence of the specified ChannelListEntry object from the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Remove(
    ChannelListEntry value
)
Visual Basic
Public Sub Remove (
    value As ChannelListEntry
)

Parameters

value
Type: OpenLayers.Base..::..ChannelListEntry
The ChannelListEntry object to remove from the ChannelList.

Examples

This example removes the first instance of ChannelListEntry object Ch0 from the ChannelList object.
C# Copy image Copy
AinSS.ChannelList.Remove(Ch0);
Visual Basic Copy image Copy
AinSS.ChannelList.Remove(Ch0)

See Also

ChannelList Class
ChannelList Members


ChannelList Properties

[image] [image]

OpenLayers for .NET Documentation
ChannelList Properties
ChannelList Class See Also Send Feedback

The ChannelList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | CGLDepth | Returns the maximum number of channels or ChannelListEntry objects that the ChannelList can contain.
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Returns or replaces the ChannelListEntry object at the specified index of the ChannelList.

See Also

ChannelList Class


ChannelList.CGLDepth Property

[image]

OpenLayers for .NET Documentation
ChannelList..::..CGLDepth Property
ChannelList Class See Also Send Feedback
Returns the maximum number of channels or ChannelListEntry objects that the ChannelList can contain.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int CGLDepth { get; }
Visual Basic
Public ReadOnly Property CGLDepth As Integer
    Get

Property Value

Type: Int32

See Also

ChannelList Class
ChannelList Members


ChannelList.Item Property

[image]

OpenLayers for .NET Documentation
ChannelList..::..Item Property
ChannelList Class Example See Also Send Feedback
Returns or replaces the ChannelListEntry object at the specified index of the ChannelList.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As ChannelListEntry
    Get
    Set

Parameters

index
Type: System..::..Int32

Property Value

Type: ChannelListEntry

Remarks

Index must be less than ChannelList.Count.

Examples

This example replaces the ChannelListEntry at index 1 of the ChannelList with ChannelListEntry Ch3.
C# Copy image Copy
AinSS.ChannelList[1] = Ch3;
Visual Basic Copy image Copy
AinSS.ChannelList(1) = Ch3

See Also

ChannelList Class
ChannelList Members


ChannelListEntry Class

[image]

OpenLayers for .NET Documentation
ChannelListEntry Class
Members See Also Send Feedback
A ChannelListEntry object encapsulates a physical channel connection that is associated with a specific subsystem. A ChannelList object is a collection of ChannelListEntry objects.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class ChannelListEntry
Visual Basic
Public Class ChannelListEntry

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..ChannelListEntry

See Also

ChannelListEntry Members


ChannelListEntry Members

[image] [image]

OpenLayers for .NET Documentation
ChannelListEntry Members
ChannelListEntry Class Constructors Methods Properties See Also Send Feedback

The ChannelListEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ChannelListEntry | Creates and returns a ChannelListEntry object for a specified channel, based on the SupportedChannelInfo information for that channel.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Gain | Gets and sets the gain to apply to the input signal of the associated ChannelListEntry object.
Public property | Inhibit | Gets and sets the inhibit state for the ChannelListEntry object. If True, the ChannelListEntry object takes up an entry in the ChannelList and is factored into the conversion time, but data is not returned for the ChannelListEntry object. If False (the default value), data is returned for the ChannelListEntry object.
Public property | Name | Gets the name of the channel that is associated with the ChannelListEntry object.
Public property | PhysicalChannelNumber | Returns the physical channel number for the ChannelListEntry object.
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, QuadratureDecoder, or Tachometer) for the ChannelListEntry object.

See Also

ChannelListEntry Class


ChannelListEntry Constructor

[image]

OpenLayers for .NET Documentation
ChannelListEntry Constructor
ChannelListEntry Class See Also Send Feedback
Creates and returns a ChannelListEntry object for a specified channel, based on the SupportedChannelInfo information for that channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry(
    SupportedChannelInfo channelInfo
)
Visual Basic
Public Sub New (
    channelInfo As SupportedChannelInfo
)

Parameters

channelInfo
Type: OpenLayers.Base..::..SupportedChannelInfo
The SupportedChannelInfo object to use when creating the ChannelListEntry object.

Remarks

If you add or insert a channel into a ChannelList by physical channel number or name (using the Add(Int32) or Insert(Int32, Int32) methods), the ChannelListEntry object is automatically created and returned.

See Also

ChannelListEntry Class
ChannelListEntry Members


ChannelListEntry Methods

[image] [image]

OpenLayers for .NET Documentation
ChannelListEntry Methods
ChannelListEntry Class See Also Send Feedback

The ChannelListEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChannelListEntry Class


ChannelListEntry Properties

[image] [image]

OpenLayers for .NET Documentation
ChannelListEntry Properties
ChannelListEntry Class See Also Send Feedback

The ChannelListEntry type exposes the following members.

Properties

 | Name | Description
Public property | Gain | Gets and sets the gain to apply to the input signal of the associated ChannelListEntry object.
Public property | Inhibit | Gets and sets the inhibit state for the ChannelListEntry object. If True, the ChannelListEntry object takes up an entry in the ChannelList and is factored into the conversion time, but data is not returned for the ChannelListEntry object. If False (the default value), data is returned for the ChannelListEntry object.
Public property | Name | Gets the name of the channel that is associated with the ChannelListEntry object.
Public property | PhysicalChannelNumber | Returns the physical channel number for the ChannelListEntry object.
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, QuadratureDecoder, or Tachometer) for the ChannelListEntry object.

See Also

ChannelListEntry Class


ChannelListEntry.Gain Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..Gain Property
ChannelListEntry Class Example See Also Send Feedback
Gets and sets the gain to apply to the input signal of the associated ChannelListEntry object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Gain { get; set; }
Visual Basic
Public Property Gain As Double
    Get
    Set

Property Value

Type: Double

Remarks

The default value is 1. If the gain is not supported, the closest gain value that is supported by the subsystem is applied to the channel. Performing a get on this property after a set will return the actual gain applied to the channel.

Examples

This example sets the gain of the channel at index 0 of the ChannelList to 2.
C# Copy image Copy
ainSS.ChannelList[0].Gain = 2;
Visual Basic Copy image Copy
ainSS.ChannelList(0).Gain = 2

See Also

ChannelListEntry Class
ChannelListEntry Members


ChannelListEntry.Inhibit Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..Inhibit Property
ChannelListEntry Class Example See Also Send Feedback
Gets and sets the inhibit state for the ChannelListEntry object. If True, the ChannelListEntry object takes up an entry in the ChannelList and is factored into the conversion time, but data is not returned for the ChannelListEntry object. If False (the default value), data is returned for the ChannelListEntry object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Inhibit { get; set; }
Visual Basic
Public Property Inhibit As Boolean
    Get
    Set

Property Value

Type: Boolean

Examples

This example sets the inhibit value to True for the channel at index 0 of the ChannelList.
C# Copy image Copy
ainSS.ChannelList[0].Inhibit = 1;
Visual Basic Copy image Copy
ainSS.ChannelList(0).Inhibit = 1

See Also

ChannelListEntry Class
ChannelListEntry Members


ChannelListEntry.Name Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..Name Property
ChannelListEntry Class See Also Send Feedback
Gets the name of the channel that is associated with the ChannelListEntry object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Remarks

This information is included in the SupportedChannelInfo object associated with the channel.

See Also

ChannelListEntry Class
ChannelListEntry Members


ChannelListEntry.PhysicalChannelNumber Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..PhysicalChannelNumber Property
ChannelListEntry Class See Also Send Feedback
Returns the physical channel number for the ChannelListEntry object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannelNumber { get; }
Visual Basic
Public ReadOnly Property PhysicalChannelNumber As Integer
    Get

Property Value

Type: Int32

See Also

ChannelListEntry Class
ChannelListEntry Members


ChannelListEntry.SubsystemType Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..SubsystemType Property
ChannelListEntry Class See Also Send Feedback
Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, QuadratureDecoder, or Tachometer) for the ChannelListEntry object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemType SubsystemType { get; }
Visual Basic
Public ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

Remarks

This information is included in the SupportedChannelInfo object associated with the channel.

See Also

ChannelListEntry Class
ChannelListEntry Members


ChannelType Enumeration

[image]

OpenLayers for .NET Documentation
ChannelType Enumeration
See Also Send Feedback
Contains the possible values for the ChannelType property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ChannelType
Visual Basic
Public Enumeration ChannelType

Members

Member name | Value | Description
SingleEnded | 100 | Single-ended channel configuration. Use this configuration when you want to measure high-level signals, noise is insignificant, the source of the input is close to the device, and all the input signals are referred to the same common ground.
Differential | 101 | Differential channel configuration. Use this configuration when you want to measure low-level signals (less than 1 V), you are using an A/D converter with high resolution (greater than 12 bits), noise is a significant part of the signal, or common-mode voltage exists.

See Also


Clock Class

[image]

OpenLayers for .NET Documentation
Clock Class
Members See Also Send Feedback
The Clock class provides an interface for controlling the clock of a subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class Clock
Visual Basic
Public Class Clock

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..Clock

See Also

Clock Members


Clock Members

[image] [image]

OpenLayers for .NET Documentation
Clock Members
Clock Class Methods Properties See Also Send Feedback

The Clock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseClockFrequency | Returns the frequency of the base clock for the subsystem.
Public property | ExtClockDivider | Gets and sets the current value of the external clock divider.
Public property | Frequency | Gets and sets the frequency of the internal clock source.
Public property | MaxExtClockDivider | Returns the maximum allowable external clock divider value supported by the subsystem.
Public property | MaxFrequency | Returns the maximum allowable internal clock frequency supported by the subsystem.
Public property | MinExtClockDivider | Returns the minimum allowable external clock divider value supported by the subsystem.
Public property | MinFrequency | Returns the minimum allowable internal clock frequency supported by the subsystem.
Public property | Source | Gets and sets the current clock source (Internal or External).
Public property | SupportsExternalClock | Returns True if the subsystem supports an external clock source; otherwise, returns False.
Public property | SupportsInternalClock | Returns True if the subsystem supports an internal clock source; otherwise, returns False.
Public property | SupportsSimultaneousClocking | Returns True if the subsystem supports simultaneous clocking.

See Also

Clock Class


Clock Methods

[image] [image]

OpenLayers for .NET Documentation
Clock Methods
Clock Class See Also Send Feedback

The Clock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Clock Class


Clock Properties

[image] [image]

OpenLayers for .NET Documentation
Clock Properties
Clock Class See Also Send Feedback

The Clock type exposes the following members.

Properties

 | Name | Description
Public property | BaseClockFrequency | Returns the frequency of the base clock for the subsystem.
Public property | ExtClockDivider | Gets and sets the current value of the external clock divider.
Public property | Frequency | Gets and sets the frequency of the internal clock source.
Public property | MaxExtClockDivider | Returns the maximum allowable external clock divider value supported by the subsystem.
Public property | MaxFrequency | Returns the maximum allowable internal clock frequency supported by the subsystem.
Public property | MinExtClockDivider | Returns the minimum allowable external clock divider value supported by the subsystem.
Public property | MinFrequency | Returns the minimum allowable internal clock frequency supported by the subsystem.
Public property | Source | Gets and sets the current clock source (Internal or External).
Public property | SupportsExternalClock | Returns True if the subsystem supports an external clock source; otherwise, returns False.
Public property | SupportsInternalClock | Returns True if the subsystem supports an internal clock source; otherwise, returns False.
Public property | SupportsSimultaneousClocking | Returns True if the subsystem supports simultaneous clocking.

See Also

Clock Class


Clock.BaseClockFrequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..BaseClockFrequency Property
Clock Class See Also Send Feedback
Returns the frequency of the base clock for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double BaseClockFrequency { get; }
Visual Basic
Public ReadOnly Property BaseClockFrequency As Double
    Get

Property Value

Type: Double

See Also

Clock Class
Clock Members


Clock.ExtClockDivider Property

[image]

OpenLayers for .NET Documentation
Clock..::..ExtClockDivider Property
Clock Class See Also Send Feedback
Gets and sets the current value of the external clock divider.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint ExtClockDivider { get; set; }
Visual Basic
Public Property ExtClockDivider As UInteger
    Get
    Set

Property Value

Type: UInt32

Remarks

The external clock divider is used to determine the frequency of the external clock source. The frequency of the external clock input divided by the external clock divider determines the frequency of at which to pace the operation.

See Also

Clock Class
Clock Members


Clock.Frequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..Frequency Property
Clock Class See Also Send Feedback
Gets and sets the frequency of the internal clock source.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Frequency { get; set; }
Visual Basic
Public Property Frequency As Double
    Get
    Set

Property Value

Type: Double

Remarks

The driver sets the frequency of the internal clock as close as possible to the value that you specified in the Frequency property. You can determine the actual frequency that was set on the hardware by reading the value of the Frequency property after the subsystem has been configured (using the Config()()()() method).

See Also

Clock Class
Clock Members


Clock.MaxExtClockDivider Property

[image]

OpenLayers for .NET Documentation
Clock..::..MaxExtClockDivider Property
Clock Class See Also Send Feedback
Returns the maximum allowable external clock divider value supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaxExtClockDivider { get; }
Visual Basic
Public ReadOnly Property MaxExtClockDivider As Double
    Get

Property Value

Type: Double

Remarks

Set the external clock divider using the ExtClockDivider property.

See Also

Clock Class
Clock Members


Clock.MaxFrequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..MaxFrequency Property
Clock Class See Also Send Feedback
Returns the maximum allowable internal clock frequency supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaxFrequency { get; }
Visual Basic
Public ReadOnly Property MaxFrequency As Double
    Get

Property Value

Type: Double

Remarks

Set the frequency of the internal clock using the Frequency property.

See Also

Clock Class
Clock Members


Clock.MinExtClockDivider Property

[image]

OpenLayers for .NET Documentation
Clock..::..MinExtClockDivider Property
Clock Class See Also Send Feedback
Returns the minimum allowable external clock divider value supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MinExtClockDivider { get; }
Visual Basic
Public ReadOnly Property MinExtClockDivider As Double
    Get

Property Value

Type: Double

Remarks

Set the external clock divider using the ExtClockDivider property.

See Also

Clock Class
Clock Members


Clock.MinFrequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..MinFrequency Property
Clock Class See Also Send Feedback
Returns the minimum allowable internal clock frequency supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MinFrequency { get; }
Visual Basic
Public ReadOnly Property MinFrequency As Double
    Get

Property Value

Type: Double

Remarks

Set the frequency of the internal clock using the Frequency property.

See Also

Clock Class
Clock Members


Clock.Source Property

[image]

OpenLayers for .NET Documentation
Clock..::..Source Property
Clock Class See Also Send Feedback
Gets and sets the current clock source (Internal or External).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ClockSource Source { get; set; }
Visual Basic
Public Property Source As ClockSource
    Get
    Set

Property Value

Type: ClockSource

See Also

Clock Class
Clock Members


Clock.SupportsExternalClock Property

[image]

OpenLayers for .NET Documentation
Clock..::..SupportsExternalClock Property
Clock Class See Also Send Feedback
Returns True if the subsystem supports an external clock source; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsExternalClock { get; }
Visual Basic
Public ReadOnly Property SupportsExternalClock As Boolean
    Get

Property Value

Type: Boolean

Remarks

Specify the clock source using the Source property.

See Also

Clock Class
Clock Members


Clock.SupportsInternalClock Property

[image]

OpenLayers for .NET Documentation
Clock..::..SupportsInternalClock Property
Clock Class See Also Send Feedback
Returns True if the subsystem supports an internal clock source; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInternalClock { get; }
Visual Basic
Public ReadOnly Property SupportsInternalClock As Boolean
    Get

Property Value

Type: Boolean

Remarks

Specify the clock source using the Source property.

See Also

Clock Class
Clock Members


Clock.SupportsSimultaneousClocking Property

[image]

OpenLayers for .NET Documentation
Clock..::..SupportsSimultaneousClocking Property
Clock Class See Also Send Feedback
Returns True if the subsystem supports simultaneous clocking.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSimultaneousClocking { get; }
Visual Basic
Public ReadOnly Property SupportsSimultaneousClocking As Boolean
    Get

Property Value

Type: Boolean

Remarks

Some subsystems allow you to read or update multiple channels on a single clock pulse. This property allows you to determine whether multiple channels can be read or updated on a single clock pulse.

See Also

Clock Class
Clock Members


ClockSource Enumeration

[image]

OpenLayers for .NET Documentation
ClockSource Enumeration
See Also Send Feedback
Contains the possible values for the Source property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ClockSource
Visual Basic
Public Enumeration ClockSource

Members

Member name | Value | Description
Internal | 400 | The internal clock is the clock source on the device that paces data acquisition or output for each channel in the ChannelList, or that is used in a counter/timer operation.
External | 401 | An external clock source is an input signal attached to the device that paces data acquisition or output for each channel in the ChannelList, or that is used in a counter/timer operation. This clock source is useful when you want to operate at rates not available with the internal clock or if you want to operate at uneven intervals.

See Also


CounterMode Enumeration

[image]

OpenLayers for .NET Documentation
CounterMode Enumeration
See Also Send Feedback
Contains the possible values for the CounterMode property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum CounterMode
Visual Basic
Public Enumeration CounterMode

Members

Member name | Value | Description
Count | 700 | Event counting mode. Use event counting mode to count events from the counter’s associated clock input source.
RateGenerator | 701 | Rate generator mode. Use rate generation mode to generate a continuous pulse output signal from the counter; this mode is sometimes referred to as continuous pulse output or pulse train output.
OneShot | 702 | One-shot mode. Use one-shot mode to generate a single pulse output signal from the counter when the operation is triggered (determined by the gate input signal).
OneShotRepeat | 703 | Repetitive one-shot mode. Use repetitive one-shot mode to generate a pulse output signal each time the device detects a trigger (determined by the gate input signal).
UpDown | 704 | Up/down counting mode. Use up/down counting mode to increment or decrement the number of rising edges that occur on the counter’s associated clock input, depending on the level of the counter’s associated gate signal. If the gate signal is high, the C/T increments; if the gate signal is low, the C/T decrements.
Measure | 705 | Edge-to-edge measurement mode. Use edge-to-edge measurement to measure the time interval between a specified start edge and a specified stop edge. When the start edge is detected, the counter starts incrementing, and continues incrementing until the stop edge is detected.
ContinuousMeasure | 706 | Continuous edge-to-edge measurement mode. In continuous edge-to-edge measurement mode, the counter automatically performs an edge-to-edge measurement operation, where the counter starts incrementing when it detects the specified start edge and stops incrementing when it detects the specified stop edge. When the operation completes, the counter remains idle until it is next read. On the next read, the current value of the counter (from the previous edge-to-edge measurement operation) is returned and the next edge-to-edge measurement operation is started automatically.

See Also


CounterTimerSubsystem Class

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem Class
Members See Also Send Feedback
The CounterTimerSubsystem class provides the properties, methods, and events for performing counter/timer operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class CounterTimerSubsystem : SubsystemBase
Visual Basic
Public Class CounterTimerSubsystem
    Inherits SubsystemBase

Remarks

Instances of this class are created using the CounterTimerSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..CounterTimerSubsystem

See Also

CounterTimerSubsystem Members


CounterTimerSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
CounterTimerSubsystem Members
CounterTimerSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The CounterTimerSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | CounterTimerSubsystem | Returns a CounterTimerSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the counter/timer subsystem. For this subsystem type, Abort behaves like Stop()()()(). (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadCount | Returns the current count of the counter/timer. This call is typically meaningful only for counter/timer subsystems that are set up for Count, UpDown, or ContinuousMeasure mode.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous counter/timer operation. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops the current continuous counter/timer operation. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the counter/timer subsystem and element. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | CascadeMode | Gets and sets the cascade mode (Cascade or Single) for the subsystem.
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | CounterMode | Gets and sets the counter/timer mode (Count, RateGenerator, OneShot, OneShotRepeat, UpDown, Measure, or ContinuousMeasure) for the subsystem.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | GateType | Gets and sets the gate type (None, HighLevel, LowLevel, HighEdge, LowEdge, or Level) for the subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | PulseType | Gets and sets the output pulse type (HighToLow or LowToHigh) for the subsystem.
Public property | PulseWidth | Gets and sets the output pulse width, in percentage, for the subsystem. By default, the pulse width is 50%.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | StartEdge | Gets and sets the start edge for a Measure or ContinuousMeasure operation on the subsystem.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopEdge | Gets and sets the stop edge for a Measure or ContinuousMeasure operation on the subsystem.
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedEdgeTypes | Returns an array containing the available edge types (of type EdgeSelect) that are supported by the subsystem.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCascading | Returns True if the subsystem supports cascading counter/timers; otherwise, returns False.
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsClockFalling | Returns True if the ClockFalling signal (falling edge of the clock signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsClockRising | Returns True if the ClockRising signal (rising edge of the clock signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousMeasure | Returns True if the subsystem supports ContinuousMeasure operations; otherwise, returns False.
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCount | Returns True if the subsystem supports Count (event counting) operations; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsGateFalling | Returns True if the GateFalling signal (falling edge of the gate signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsGateHighEdge | Returns True if the subsystem supports a HighEdge gate type; otherwise, returns False.
Public property | SupportsGateHighLevel | Returns True if the counter/timer subsystem supports a HighLevel gate type; otherwise, returns False.
Public property | SupportsGateLevel | Returs True if the subsystem supports a Level gate type; otherwise, returns False.
Public property | SupportsGateLowEdge | Returns True if the subsystem supports a LowEdge gate type; otherwise false.
Public property | SupportsGateLowLevel | Returns True if the subsystem supports a LowLevel gate type; otherwise, returns False.
Public property | SupportsGateNone | Returns True if the subsystem supports a software (None) gate type; otherwise, returns False.
Public property | SupportsGateRising | Returns True if the GateRising signal (rising edge of the gate signal can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsHighToLowPulse | Returns True if the subsystem supports HighToLow output pulses; otherwise, returns False.
Public property | SupportsInterrupt | Returns True if the subsystem supports interrupts; otherwise, returns False.
Public property | SupportsLowToHighPulse | Returns True if the subsystem supports LowToHigh output pulses; otherwise, returns False.
Public property | SupportsMeasure | Returns True if the subsystem supports Measure operations; otherwise, returns False.
Public property | SupportsOneShot | Returns True if the subsystem supports OneShot operations; otherwise, returns False.
Public property | SupportsOneShotRepeat | Returns True if the subsystem supports OneShotRepeat operations; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsRateGenerate | Returns True if the subsystem supports RateGenerator operations; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsUpDown | Returns True if the subsystem supports UpDown operations; otherwise, returns False.
Public property | SupportsVariablePulseWidth | Returns True if the subsystem supports programmable pulse widths; otherwise, returns False.
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | EventDoneEvent | Occurs on some devices, such as the DT340, when a digital input line changes state or when an interval timer operation is complete.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | MeasureDoneEvent | Occurs when an edge-to-edge measurement (Measure) operation is complete.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

CounterTimerSubsystem Class


CounterTimerSubsystem Constructor

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem Constructor
CounterTimerSubsystem Class See Also Send Feedback
Returns a CounterTimerSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public CounterTimerSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.Base..::..Device
The Open Layers Device object with which to associate the counter/timer subsystem.
element
Type: System..::..Int32
The Element number of the counter/timer subsystem.

Remarks

It is recommended that you use the CounterTimerSubsystem(Int32) method rather than this constructor to return a counter/timer subsystem.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
CounterTimerSubsystem Methods
CounterTimerSubsystem Class See Also Send Feedback

The CounterTimerSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the counter/timer subsystem. For this subsystem type, Abort behaves like Stop()()()(). (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadCount | Returns the current count of the counter/timer. This call is typically meaningful only for counter/timer subsystems that are set up for Count, UpDown, or ContinuousMeasure mode.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous counter/timer operation. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops the current continuous counter/timer operation. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the counter/timer subsystem and element. (Overrides Object..::..ToString()()()().)

See Also

CounterTimerSubsystem Class


CounterTimerSubsystem.Abort Method

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..Abort Method
CounterTimerSubsystem Class See Also Send Feedback
Stops a continuous operation on the counter/timer subsystem. For this subsystem type, Abort behaves like Stop()()()().

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Abort()
Visual Basic
Public Overrides Sub Abort

Remarks

This method overrides the Abort method in the base class.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.ReadCount Method

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..ReadCount Method
CounterTimerSubsystem Class See Also Send Feedback
Returns the current count of the counter/timer. This call is typically meaningful only for counter/timer subsystems that are set up for Count, UpDown, or ContinuousMeasure mode.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public long ReadCount()
Visual Basic
Public Function ReadCount As Long

Return Value

Type: Int64
The current count of the counter/timer subsystem.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.Start Method

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..Start Method
CounterTimerSubsystem Class See Also Send Feedback
Starts a continuous counter/timer operation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Start()
Visual Basic
Public Overrides Sub Start

Remarks

This method overrides the Start method in the base class.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.Stop Method

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..Stop Method
CounterTimerSubsystem Class See Also Send Feedback
Stops the current continuous counter/timer operation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Stop()
Visual Basic
Public Overrides Sub Stop

Remarks

This method overrides the Stop method in the base class.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..ToString Method
CounterTimerSubsystem Class See Also Send Feedback
Returns a description of the counter/timer subsystem and element.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the counter/timer subsystem and element.

Remarks

This method overrides the ToString method in the base class.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
CounterTimerSubsystem Properties
CounterTimerSubsystem Class See Also Send Feedback

The CounterTimerSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | CascadeMode | Gets and sets the cascade mode (Cascade or Single) for the subsystem.
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | CounterMode | Gets and sets the counter/timer mode (Count, RateGenerator, OneShot, OneShotRepeat, UpDown, Measure, or ContinuousMeasure) for the subsystem.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | GateType | Gets and sets the gate type (None, HighLevel, LowLevel, HighEdge, LowEdge, or Level) for the subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | PulseType | Gets and sets the output pulse type (HighToLow or LowToHigh) for the subsystem.
Public property | PulseWidth | Gets and sets the output pulse width, in percentage, for the subsystem. By default, the pulse width is 50%.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | StartEdge | Gets and sets the start edge for a Measure or ContinuousMeasure operation on the subsystem.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopEdge | Gets and sets the stop edge for a Measure or ContinuousMeasure operation on the subsystem.
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedEdgeTypes | Returns an array containing the available edge types (of type EdgeSelect) that are supported by the subsystem.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCascading | Returns True if the subsystem supports cascading counter/timers; otherwise, returns False.
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsClockFalling | Returns True if the ClockFalling signal (falling edge of the clock signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsClockRising | Returns True if the ClockRising signal (rising edge of the clock signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousMeasure | Returns True if the subsystem supports ContinuousMeasure operations; otherwise, returns False.
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCount | Returns True if the subsystem supports Count (event counting) operations; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsGateFalling | Returns True if the GateFalling signal (falling edge of the gate signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsGateHighEdge | Returns True if the subsystem supports a HighEdge gate type; otherwise, returns False.
Public property | SupportsGateHighLevel | Returns True if the counter/timer subsystem supports a HighLevel gate type; otherwise, returns False.
Public property | SupportsGateLevel | Returs True if the subsystem supports a Level gate type; otherwise, returns False.
Public property | SupportsGateLowEdge | Returns True if the subsystem supports a LowEdge gate type; otherwise false.
Public property | SupportsGateLowLevel | Returns True if the subsystem supports a LowLevel gate type; otherwise, returns False.
Public property | SupportsGateNone | Returns True if the subsystem supports a software (None) gate type; otherwise, returns False.
Public property | SupportsGateRising | Returns True if the GateRising signal (rising edge of the gate signal can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.
Public property | SupportsHighToLowPulse | Returns True if the subsystem supports HighToLow output pulses; otherwise, returns False.
Public property | SupportsInterrupt | Returns True if the subsystem supports interrupts; otherwise, returns False.
Public property | SupportsLowToHighPulse | Returns True if the subsystem supports LowToHigh output pulses; otherwise, returns False.
Public property | SupportsMeasure | Returns True if the subsystem supports Measure operations; otherwise, returns False.
Public property | SupportsOneShot | Returns True if the subsystem supports OneShot operations; otherwise, returns False.
Public property | SupportsOneShotRepeat | Returns True if the subsystem supports OneShotRepeat operations; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsRateGenerate | Returns True if the subsystem supports RateGenerator operations; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsUpDown | Returns True if the subsystem supports UpDown operations; otherwise, returns False.
Public property | SupportsVariablePulseWidth | Returns True if the subsystem supports programmable pulse widths; otherwise, returns False.
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

See Also

CounterTimerSubsystem Class


CounterTimerSubsystem.CascadeMode Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..CascadeMode Property
CounterTimerSubsystem Class See Also Send Feedback
Gets and sets the cascade mode (Cascade or Single) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public CascadeMode CascadeMode { get; set; }
Visual Basic
Public Property CascadeMode As CascadeMode
    Get
    Set

Property Value

Type: CascadeMode

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.CounterMode Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..CounterMode Property
CounterTimerSubsystem Class See Also Send Feedback
Gets and sets the counter/timer mode (Count, RateGenerator, OneShot, OneShotRepeat, UpDown, Measure, or ContinuousMeasure) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public CounterMode CounterMode { get; set; }
Visual Basic
Public Property CounterMode As CounterMode
    Get
    Set

Property Value

Type: CounterMode

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.GateType Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..GateType Property
CounterTimerSubsystem Class See Also Send Feedback
Gets and sets the gate type (None, HighLevel, LowLevel, HighEdge, LowEdge, or Level) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public GateType GateType { get; set; }
Visual Basic
Public Property GateType As GateType
    Get
    Set

Property Value

Type: GateType

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.PulseType Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..PulseType Property
CounterTimerSubsystem Class See Also Send Feedback
Gets and sets the output pulse type (HighToLow or LowToHigh) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public PulseType PulseType { get; set; }
Visual Basic
Public Property PulseType As PulseType
    Get
    Set

Property Value

Type: PulseType

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.PulseWidth Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..PulseWidth Property
CounterTimerSubsystem Class See Also Send Feedback
Gets and sets the output pulse width, in percentage, for the subsystem. By default, the pulse width is 50%.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double PulseWidth { get; set; }
Visual Basic
Public Property PulseWidth As Double
    Get
    Set

Property Value

Type: Double

Remarks

In the case of a OneShot or OneShotRepeat operation, the pulse width is automatically set to 100%. The value of the PulseWidth property is ignored.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.StartEdge Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..StartEdge Property
CounterTimerSubsystem Class See Also Send Feedback
Gets and sets the start edge for a Measure or ContinuousMeasure operation on the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public EdgeSelect StartEdge { get; set; }
Visual Basic
Public Property StartEdge As EdgeSelect
    Get
    Set

Property Value

Type: EdgeSelect

Remarks

To determine which edges are supported for the start edge, use the SupportedEdgeTypes property for the subsystem element.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.StopEdge Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..StopEdge Property
CounterTimerSubsystem Class See Also Send Feedback
Gets and sets the stop edge for a Measure or ContinuousMeasure operation on the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public EdgeSelect StopEdge { get; set; }
Visual Basic
Public Property StopEdge As EdgeSelect
    Get
    Set

Property Value

Type: EdgeSelect

Remarks

To determine which edges are supported for the stop edge, use the SupportedEdgeTypes property for the subsystem element.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportedEdgeTypes Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportedEdgeTypes Property
CounterTimerSubsystem Class See Also Send Feedback
Returns an array containing the available edge types (of type EdgeSelect) that are supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public EdgeSelect[] SupportedEdgeTypes { get; }
Visual Basic
Public ReadOnly Property SupportedEdgeTypes As EdgeSelect()
    Get

Property Value

Type: array< EdgeSelect >[]()[][]

Remarks

These edges are used by the StartEdge and StopEdge properties to set up a measure mode operation.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsCascading Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsCascading Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports cascading counter/timers; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsCascading { get; }
Visual Basic
Public ReadOnly Property SupportsCascading As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the cascade mode using the CascadeMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsClockFalling Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsClockFalling Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the ClockFalling signal (falling edge of the clock signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsClockFalling { get; }
Visual Basic
Public ReadOnly Property SupportsClockFalling As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the edge that starts the operation with the StartEdge property; set the edge that stops the operation with the StopEdge property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsClockRising Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsClockRising Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the ClockRising signal (rising edge of the clock signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsClockRising { get; }
Visual Basic
Public ReadOnly Property SupportsClockRising As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the edge that starts the operation with the StartEdge property; set the edge that stops the operation with the StopEdge property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsContinuousMeasure Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsContinuousMeasure Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports ContinuousMeasure operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsContinuousMeasure { get; }
Visual Basic
Public ReadOnly Property SupportsContinuousMeasure As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the operation mode of the counter/timer using the CounterMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsCount Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsCount Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports Count (event counting) operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsCount { get; }
Visual Basic
Public ReadOnly Property SupportsCount As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the operation mode of the counter/timer using the CounterMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateFalling Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateFalling Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the GateFalling signal (falling edge of the gate signal) can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateFalling { get; }
Visual Basic
Public ReadOnly Property SupportsGateFalling As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the edge that starts the operation with the StartEdge property; set the edge that stops the operation with the StopEdge property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateHighEdge Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateHighEdge Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports a HighEdge gate type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateHighEdge { get; }
Visual Basic
Public ReadOnly Property SupportsGateHighEdge As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the gate type using the GateType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateHighLevel Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateHighLevel Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the counter/timer subsystem supports a HighLevel gate type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateHighLevel { get; }
Visual Basic
Public ReadOnly Property SupportsGateHighLevel As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the gate type using the GateType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateLevel Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateLevel Property
CounterTimerSubsystem Class See Also Send Feedback
Returs True if the subsystem supports a Level gate type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateLevel { get; }
Visual Basic
Public ReadOnly Property SupportsGateLevel As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the gate type using the GateType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateLowEdge Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateLowEdge Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports a LowEdge gate type; otherwise false.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateLowEdge { get; }
Visual Basic
Public ReadOnly Property SupportsGateLowEdge As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the gate type using the GateType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateLowLevel Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateLowLevel Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports a LowLevel gate type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateLowLevel { get; }
Visual Basic
Public ReadOnly Property SupportsGateLowLevel As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the gate type using the GateType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateNone Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateNone Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports a software (None) gate type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateNone { get; }
Visual Basic
Public ReadOnly Property SupportsGateNone As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the gate type using the GateType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsGateRising Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsGateRising Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the GateRising signal (rising edge of the gate signal can be used in a Measure or ContinuousMeasure operation on the subsystem; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsGateRising { get; }
Visual Basic
Public ReadOnly Property SupportsGateRising As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the edge that starts the operation with the StartEdge property; set the edge that stops the operation with the StopEdge property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsHighToLowPulse Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsHighToLowPulse Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports HighToLow output pulses; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsHighToLowPulse { get; }
Visual Basic
Public ReadOnly Property SupportsHighToLowPulse As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the pulse output type using the PulseType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsInterrupt Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsInterrupt Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports interrupts; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInterrupt { get; }
Visual Basic
Public ReadOnly Property SupportsInterrupt As Boolean
    Get

Property Value

Type: Boolean

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsLowToHighPulse Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsLowToHighPulse Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports LowToHigh output pulses; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsLowToHighPulse { get; }
Visual Basic
Public ReadOnly Property SupportsLowToHighPulse As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the pulse output type using the PulseType property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsMeasure Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsMeasure Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports Measure operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsMeasure { get; }
Visual Basic
Public ReadOnly Property SupportsMeasure As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the operation mode of the counter/timer using the CounterMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsOneShot Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsOneShot Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports OneShot operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsOneShot { get; }
Visual Basic
Public ReadOnly Property SupportsOneShot As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the operation mode of the counter/timer using the CounterMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsOneShotRepeat Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsOneShotRepeat Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports OneShotRepeat operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsOneShotRepeat { get; }
Visual Basic
Public ReadOnly Property SupportsOneShotRepeat As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the operation mode of the counter/timer using the CounterMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsRateGenerate Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsRateGenerate Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports RateGenerator operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsRateGenerate { get; }
Visual Basic
Public ReadOnly Property SupportsRateGenerate As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the operation mode of the counter/timer using the CounterMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsUpDown Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsUpDown Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports UpDown operations; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsUpDown { get; }
Visual Basic
Public ReadOnly Property SupportsUpDown As Boolean
    Get

Property Value

Type: Boolean

Remarks

You do not specify the gate type in software for UpDown operations.

Set the operation mode of the counter/timer using the CounterMode property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.SupportsVariablePulseWidth Property

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..SupportsVariablePulseWidth Property
CounterTimerSubsystem Class See Also Send Feedback
Returns True if the subsystem supports programmable pulse widths; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsVariablePulseWidth { get; }
Visual Basic
Public ReadOnly Property SupportsVariablePulseWidth As Boolean
    Get

Property Value

Type: Boolean

Remarks

If the subsystem supports programmable pulse widths, set the pulse width using the PulseWidth property.

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
CounterTimerSubsystem Events
CounterTimerSubsystem Class See Also Send Feedback

The CounterTimerSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | EventDoneEvent | Occurs on some devices, such as the DT340, when a digital input line changes state or when an interval timer operation is complete.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | MeasureDoneEvent | Occurs when an edge-to-edge measurement (Measure) operation is complete.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

CounterTimerSubsystem Class


CounterTimerSubsystem.EventDoneEvent Event

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..EventDoneEvent Event
CounterTimerSubsystem Class See Also Send Feedback
Occurs on some devices, such as the DT340, when a digital input line changes state or when an interval timer operation is complete.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event EventDoneHandler EventDoneEvent
Visual Basic
Public Event EventDoneEvent As EventDoneHandler

Value

Type: OpenLayers.Base..::..EventDoneHandler

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CounterTimerSubsystem.MeasureDoneEvent Event

[image]

OpenLayers for .NET Documentation
CounterTimerSubsystem..::..MeasureDoneEvent Event
CounterTimerSubsystem Class See Also Send Feedback
Occurs when an edge-to-edge measurement (Measure) operation is complete.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event MeasureDoneHandler MeasureDoneEvent
Visual Basic
Public Event MeasureDoneEvent As MeasureDoneHandler

Value

Type: OpenLayers.Base..::..MeasureDoneHandler

See Also

CounterTimerSubsystem Class
CounterTimerSubsystem Members


CouplingType Enumeration

[image]

OpenLayers for .NET Documentation
CouplingType Enumeration
See Also Send Feedback
Contains the possible values for the Coupling property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum CouplingType
Visual Basic
Public Enumeration CouplingType

Members

Member name | Value | Description
DC | 0 | DC coupling, where the DC offset is included.
AC | 1 | AC coupling, where the DC offset is removed.

See Also


DataFilterType Enumeration

[image]

OpenLayers for .NET Documentation
DataFilterType Enumeration
See Also Send Feedback
Contains the possible values for the DataFilterType property in the AnalogInputSubsystem class.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum DataFilterType
Visual Basic
Public Enumeration DataFilterType

Members

Member name Value Description
Raw 1700 No filter. Provides fast response times, but the data may be difficult to interpret. Use when you want to filter the data yourself.

The Raw filter type returns the data exactly as it comes out of the Delta-Sigma A/D converters. Note that Delta-Sigma converters provide substantial digital filtering above the Nyquist frequency.

Generally, the only time it is desirable to use the Raw filter is if you are using fast responding thermocouples/RTDs, sampling them at higher speeds (> 1 Hz), and need as much response speed as possible.

MovingAverage 1701 Provides a compromise of filter functionality and response time. This filter can be used in any application.

This low-pass filter takes the previous 16 samples, adds them together, and divides by 16.

See Also


DataFlow Enumeration

[image]

OpenLayers for .NET Documentation
DataFlow Enumeration
See Also Send Feedback
Contains the possible values for the DataFlow property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum DataFlow
Visual Basic
Public Enumeration DataFlow

Members

Member name | Value | Description
Continuous | 800 | Use continuous mode when you want to acquire or output data from multiple channels continuously. For analog input operations, this is post-trigger mode. For maximum flexibility, you can specify other parameters, such as the ChannelList, clock source and frequency, buffer, and so on.
SingleValue | 801 | In a single-value operation, a single data value is read from or written to a single channel immediately, and then the operation stops. You specify only the channel to read or update, and the gain for the channel.
ContinuousPreTrigger | 804 | Use continuous pre-trigger mode when you want to continuously acquire data before a specific external trigger event occurs. For maximum flexibility, you can specify other parameters, such as the ChannelList, clock source and frequency, buffer, and so on.
ContinuousPrePostTrigger | 805 | Use continuous about-trigger mode when you want to continuously acquire data both before and after a specific external event occurs. This operation is equivalent to doing both a pre-trigger and a post-trigger acquisition For maximum flexibility, you can specify other parameters, such as the ChannelList, clock source and frequency, buffer, and so on.

See Also


Device Class

[image]

OpenLayers for .NET Documentation
Device Class
Members See Also Send Feedback
A Device object encapsulates an Open Layers device and manages and distributes subsystems for the device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class Device : IDisposable
Visual Basic
Public Class Device
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..Device

See Also

Device Members


Device Members

[image] [image]

OpenLayers for .NET Documentation
Device Members
Device Class Constructors Methods Properties See Also Send Feedback

The Device type exposes the following members.

Constructors

 | Name | Description
Public method | Device | Returns a Device object for a specified Open Layers-compliant device.

Methods

 | Name | Description
Public method | AnalogInputSubsystem | Returns an AnalogInputSubsystem object.
Public method | AnalogOutputSubsystem | Returns an AnalogOutputSubsystem object.
Public method | CounterTimerSubsystem | Returns a CounterTimerSubsystem object.
Public method | DiagReadCalPot | Returns the value of the specified calibration potentiometer register. This is an advanced method and is not normally used.
Public method | DiagReadReg | Returns the value of the specified register on the device. This is an advanced method and is not normally used.
Public method | DiagWriteCalPot | Writes to the specified calibration potentiometer. This is an advanced method and is not normally used.
Public method | DiagWriteReg | Writes a value to the specified register on the device. This is an advanced method and is not normally used.
Public method | DigitalInputSubsystem | Returns a DigitalInputSubsystem object.
Public method | DigitalOutputSubsystem | Returns a DigitalOutputSubsystem object.
Public method | Dispose | Terminates the connection to the device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHardwareInfo | Returns hardware-specific information about the current device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumSubsystemElements | Returns the number of available subsystem elements for a given subsystem type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | QuadratureDecoderSubsystem | Returns a QuadratureDecoderSubsystem object.
Public method | SetHardwareInfo | Writes hardware specific info for the current device.
Public method | TachSubsystem | Returns a TachSubsystem object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BoardModelName | Returns the model name of the device.
Public property | DeviceName | Returns the user-defined name of the device. You can modify this name in the Open Layers Control Panel applet.
Public property | DriverName | Returns the name of the driver for this device.
Public property | DriverVersion | Returns the version of the driver for this device.
Public property | PowerSource | Returns whether the device is powered by the internal power source or an external power source.
Public property | SimultaneousStart | Provides an interface to the SimultaneousStart object.
Public property | SupportsInternalAndExternalPower | Returns True if the device is capable of using both an internal and external power source; otherwise, returns False.

See Also

Device Class


Device Constructor

[image]

OpenLayers for .NET Documentation
Device Constructor
Device Class See Also Send Feedback
Returns a Device object for a specified Open Layers-compliant device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Device(
    string deviceName
)
Visual Basic
Public Sub New (
    deviceName As String
)

Parameters

deviceName
Type: System..::..String
Name of the device to open and initialize.

Return Value

Type:
The Device object for the specified device.

See Also

Device Class
Device Members


Device Methods

[image] [image]

OpenLayers for .NET Documentation
Device Methods
Device Class See Also Send Feedback

The Device type exposes the following members.

Methods

 | Name | Description
Public method | AnalogInputSubsystem | Returns an AnalogInputSubsystem object.
Public method | AnalogOutputSubsystem | Returns an AnalogOutputSubsystem object.
Public method | CounterTimerSubsystem | Returns a CounterTimerSubsystem object.
Public method | DiagReadCalPot | Returns the value of the specified calibration potentiometer register. This is an advanced method and is not normally used.
Public method | DiagReadReg | Returns the value of the specified register on the device. This is an advanced method and is not normally used.
Public method | DiagWriteCalPot | Writes to the specified calibration potentiometer. This is an advanced method and is not normally used.
Public method | DiagWriteReg | Writes a value to the specified register on the device. This is an advanced method and is not normally used.
Public method | DigitalInputSubsystem | Returns a DigitalInputSubsystem object.
Public method | DigitalOutputSubsystem | Returns a DigitalOutputSubsystem object.
Public method | Dispose | Terminates the connection to the device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHardwareInfo | Returns hardware-specific information about the current device.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumSubsystemElements | Returns the number of available subsystem elements for a given subsystem type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | QuadratureDecoderSubsystem | Returns a QuadratureDecoderSubsystem object.
Public method | SetHardwareInfo | Writes hardware specific info for the current device.
Public method | TachSubsystem | Returns a TachSubsystem object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Device Class


Device.AnalogInputSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..AnalogInputSubsystem Method
Device Class See Also Send Feedback
Returns an AnalogInputSubsystem object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogInputSubsystem AnalogInputSubsystem(
    int element
)
Visual Basic
Public Function AnalogInputSubsystem (
    element As Integer
) As AnalogInputSubsystem

Parameters

element
Type: System..::..Int32
Instance of the analog input subsystem to open.

Return Value

Type: AnalogInputSubsystem
A new AnalogInputSubsystem object.

See Also

Device Class
Device Members


Device.AnalogOutputSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..AnalogOutputSubsystem Method
Device Class See Also Send Feedback
Returns an AnalogOutputSubsystem object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogOutputSubsystem AnalogOutputSubsystem(
    int element
)
Visual Basic
Public Function AnalogOutputSubsystem (
    element As Integer
) As AnalogOutputSubsystem

Parameters

element
Type: System..::..Int32
Instance of the analog output subsystem to open.

Return Value

Type: AnalogOutputSubsystem
A new AnalogOutputSubsystem object.

See Also

Device Class
Device Members


Device.CounterTimerSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..CounterTimerSubsystem Method
Device Class See Also Send Feedback
Returns a CounterTimerSubsystem object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public CounterTimerSubsystem CounterTimerSubsystem(
    int element
)
Visual Basic
Public Function CounterTimerSubsystem (
    element As Integer
) As CounterTimerSubsystem

Parameters

element
Type: System..::..Int32
Instance of the counter/timer subsystem to open.

Return Value

Type: CounterTimerSubsystem
A new CounterTimerSubsystem object.

See Also

Device Class
Device Members


Device.DiagReadCalPot Method

[image]

OpenLayers for .NET Documentation
Device..::..DiagReadCalPot Method
Device Class See Also Send Feedback
Returns the value of the specified calibration potentiometer register. This is an advanced method and is not normally used.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint DiagReadCalPot(
    uint chipNum,
    uint potNum,
    uint regNum
)
Visual Basic
Public Function DiagReadCalPot (
    chipNum As UInteger,
    potNum As UInteger,
    regNum As UInteger
) As UInteger

Parameters

chipNum
Type: System..::..UInt32
Chip number which contains the potentiometer.
potNum
Type: System..::..UInt32
Potentiometer number within the chip.
regNum
Type: System..::..UInt32
Register number within the potentiometer.

Return Value

Type: UInt32
The value read from the specified register.

See Also

Device Class
Device Members


Device.DiagReadReg Method

[image]

OpenLayers for .NET Documentation
Device..::..DiagReadReg Method
Device Class See Also Send Feedback
Returns the value of the specified register on the device. This is an advanced method and is not normally used.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint DiagReadReg(
    uint offset,
    uint sizeInBytes
)
Visual Basic
Public Function DiagReadReg (
    offset As UInteger,
    sizeInBytes As UInteger
) As UInteger

Parameters

offset
Type: System..::..UInt32
Specifies the offset from the base address of the desired register to read.
sizeInBytes
Type: System..::..UInt32
The size of the register, in bytes.

Return Value

Type: UInt32
The value read from the specified register.

See Also

Device Class
Device Members


Device.DiagWriteCalPot Method

[image]

OpenLayers for .NET Documentation
Device..::..DiagWriteCalPot Method
Device Class See Also Send Feedback
Writes to the specified calibration potentiometer. This is an advanced method and is not normally used.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void DiagWriteCalPot(
    uint chipNum,
    uint potNum,
    uint regNum,
    uint dataVal
)
Visual Basic
Public Sub DiagWriteCalPot (
    chipNum As UInteger,
    potNum As UInteger,
    regNum As UInteger,
    dataVal As UInteger
)

Parameters

chipNum
Type: System..::..UInt32
Chip number which contains the potentiometer.
potNum
Type: System..::..UInt32
Potentiometer number within the chip.
regNum
Type: System..::..UInt32
Register number within the pototentiometer.
dataVal
Type: System..::..UInt32
Value to write to the register.

See Also

Device Class
Device Members


Device.DiagWriteReg Method

[image]

OpenLayers for .NET Documentation
Device..::..DiagWriteReg Method
Device Class See Also Send Feedback
Writes a value to the specified register on the device. This is an advanced method and is not normally used.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void DiagWriteReg(
    uint offset,
    uint data,
    uint sizeInBytes
)
Visual Basic
Public Sub DiagWriteReg (
    offset As UInteger,
    data As UInteger,
    sizeInBytes As UInteger
)

Parameters

offset
Type: System..::..UInt32
Specifies the offset from the base address of the desired register to write to.
data
Type: System..::..UInt32
The value to write to the specified register.
sizeInBytes
Type: System..::..UInt32
The size of the register, in bytes.

See Also

Device Class
Device Members


Device.DigitalInputSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..DigitalInputSubsystem Method
Device Class See Also Send Feedback
Returns a DigitalInputSubsystem object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DigitalInputSubsystem DigitalInputSubsystem(
    int element
)
Visual Basic
Public Function DigitalInputSubsystem (
    element As Integer
) As DigitalInputSubsystem

Parameters

element
Type: System..::..Int32
Instance of the digital input subsystem to open.

Return Value

Type: DigitalInputSubsystem
A new DigitalInputSubsystem object.

See Also

Device Class
Device Members


Device.DigitalOutputSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..DigitalOutputSubsystem Method
Device Class See Also Send Feedback
Returns a DigitalOutputSubsystem object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DigitalOutputSubsystem DigitalOutputSubsystem(
    int element
)
Visual Basic
Public Function DigitalOutputSubsystem (
    element As Integer
) As DigitalOutputSubsystem

Parameters

element
Type: System..::..Int32
Instance of the digital output subsystem to open.

Return Value

Type: DigitalOutputSubsystem
A new DigitalOutputSubsystem object.

See Also

Device Class
Device Members


Device.Dispose Method

[image]

OpenLayers for .NET Documentation
Device..::..Dispose Method
Device Class See Also Send Feedback
Terminates the connection to the device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

Device Class
Device Members


Device.GetHardwareInfo Method

[image]

OpenLayers for .NET Documentation
Device..::..GetHardwareInfo Method
Device Class See Also Send Feedback
Returns hardware-specific information about the current device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public HardwareInfo GetHardwareInfo()
Visual Basic
Public Function GetHardwareInfo As HardwareInfo

Return Value

Type: HardwareInfo
The Board Id, Device Id, Product Id, and Vendor Id within the HardwareInfo structure.

Remarks

This information is retrieved from the firmware of the device.

See Also

Device Class
Device Members


Device.GetNumSubsystemElements Method

[image]

OpenLayers for .NET Documentation
Device..::..GetNumSubsystemElements Method
Device Class See Also Send Feedback
Returns the number of available subsystem elements for a given subsystem type.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int GetNumSubsystemElements(
    SubsystemType ssType
)
Visual Basic
Public Function GetNumSubsystemElements (
    ssType As SubsystemType
) As Integer

Parameters

ssType
Type: OpenLayers.Base..::..SubsystemType
The type of subsystem.

Return Value

Type: Int32
The number of elements for the specified subsystem type.

Remarks

Your device may support multiple instances, or elements, of the same subsystem type. Element numbering is zero-based; that is, the first instance of the subsystem is called element 0, the second instance of the subsystem is called element 1, and so on. For example, if your device has two digital input ports, two subsystems of type DigitalInput are available, differentiated as elements 0 and 1.

See Also

Device Class
Device Members


Device.QuadratureDecoderSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..QuadratureDecoderSubsystem Method
Device Class See Also Send Feedback
Returns a QuadratureDecoderSubsystem object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public QuadratureDecoderSubsystem QuadratureDecoderSubsystem(
    int element
)
Visual Basic
Public Function QuadratureDecoderSubsystem (
    element As Integer
) As QuadratureDecoderSubsystem

Parameters

element
Type: System..::..Int32
Instance of the quadrature decoder subsystem to open.

Return Value

Type: QuadratureDecoderSubsystem
A new QuadratureDecoderSubsystem object.

See Also

Device Class
Device Members


Device.SetHardwareInfo Method

[image]

OpenLayers for .NET Documentation
Device..::..SetHardwareInfo Method
Device Class See Also Send Feedback
Writes hardware specific info for the current device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetHardwareInfo(
    HardwareInfo hardwareInfo,
    int key
)
Visual Basic
Public Sub SetHardwareInfo (
    hardwareInfo As HardwareInfo,
    key As Integer
)

Parameters

hardwareInfo
Type: OpenLayers.Base..::..HardwareInfo
Hardware information to apply to the device
key
Type: System..::..Int32
fixed value that allows this function to be used

See Also

Device Class
Device Members


Device.TachSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..TachSubsystem Method
Device Class See Also Send Feedback
Returns a TachSubsystem object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TachSubsystem TachSubsystem(
    int element
)
Visual Basic
Public Function TachSubsystem (
    element As Integer
) As TachSubsystem

Parameters

element
Type: System..::..Int32
Instance of the tachometer subsystem to open.

Return Value

Type: TachSubsystem
A new TachSubsystem object.

See Also

Device Class
Device Members


Device Properties

[image] [image]

OpenLayers for .NET Documentation
Device Properties
Device Class See Also Send Feedback

The Device type exposes the following members.

Properties

 | Name | Description
Public property | BoardModelName | Returns the model name of the device.
Public property | DeviceName | Returns the user-defined name of the device. You can modify this name in the Open Layers Control Panel applet.
Public property | DriverName | Returns the name of the driver for this device.
Public property | DriverVersion | Returns the version of the driver for this device.
Public property | PowerSource | Returns whether the device is powered by the internal power source or an external power source.
Public property | SimultaneousStart | Provides an interface to the SimultaneousStart object.
Public property | SupportsInternalAndExternalPower | Returns True if the device is capable of using both an internal and external power source; otherwise, returns False.

See Also

Device Class


Device.BoardModelName Property

[image]

OpenLayers for .NET Documentation
Device..::..BoardModelName Property
Device Class See Also Send Feedback
Returns the model name of the device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string BoardModelName { get; }
Visual Basic
Public ReadOnly Property BoardModelName As String
    Get

Property Value

Type: String

Remarks

DT9806 is an example of a model name.

See Also

Device Class
Device Members


Device.DeviceName Property

[image]

OpenLayers for .NET Documentation
Device..::..DeviceName Property
Device Class See Also Send Feedback
Returns the user-defined name of the device. You can modify this name in the Open Layers Control Panel applet.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string DeviceName { get; }
Visual Basic
Public ReadOnly Property DeviceName As String
    Get

Property Value

Type: String

See Also

Device Class
Device Members


Device.DriverName Property

[image]

OpenLayers for .NET Documentation
Device..::..DriverName Property
Device Class See Also Send Feedback
Returns the name of the driver for this device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string DriverName { get; }
Visual Basic
Public ReadOnly Property DriverName As String
    Get

Property Value

Type: String

See Also

Device Class
Device Members


Device.DriverVersion Property

[image]

OpenLayers for .NET Documentation
Device..::..DriverVersion Property
Device Class See Also Send Feedback
Returns the version of the driver for this device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string DriverVersion { get; }
Visual Basic
Public ReadOnly Property DriverVersion As String
    Get

Property Value

Type: String

See Also

Device Class
Device Members


Device.PowerSource Property

[image]

OpenLayers for .NET Documentation
Device..::..PowerSource Property
Device Class See Also Send Feedback
Returns whether the device is powered by the internal power source or an external power source.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public PowerSource PowerSource { get; }
Visual Basic
Public ReadOnly Property PowerSource As PowerSource
    Get

Property Value

Type: PowerSource

See Also

Device Class
Device Members


Device.SimultaneousStart Property

[image]

OpenLayers for .NET Documentation
Device..::..SimultaneousStart Property
Device Class See Also Send Feedback
Provides an interface to the SimultaneousStart object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SimultaneousStart SimultaneousStart { get; }
Visual Basic
Public ReadOnly Property SimultaneousStart As SimultaneousStart
    Get

Property Value

Type: SimultaneousStart

See Also

Device Class
Device Members


Device.SupportsInternalAndExternalPower Property

[image]

OpenLayers for .NET Documentation
Device..::..SupportsInternalAndExternalPower Property
Device Class See Also Send Feedback
Returns True if the device is capable of using both an internal and external power source; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInternalAndExternalPower { get; }
Visual Basic
Public ReadOnly Property SupportsInternalAndExternalPower As Boolean
    Get

Property Value

Type: Boolean

See Also

Device Class
Device Members


DeviceMgr Class

[image]

OpenLayers for .NET Documentation
DeviceMgr Class
Members See Also Send Feedback
The DeviceMgr is a singleton class that is responsible for managing Open Layers devices in the system and for assigning Device objects.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class DeviceMgr
Visual Basic
Public NotInheritable Class DeviceMgr

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..DeviceMgr

See Also

DeviceMgr Members


DeviceMgr Members

[image] [image]

OpenLayers for .NET Documentation
DeviceMgr Members
DeviceMgr Class Methods See Also Send Feedback

The DeviceMgr type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Get | Returns a DeviceMgr object.
Public method | GetDevice | Returns a Device object for the specified device.
Public method | GetDeviceNames | Returns a list of all Open Layers-compatible devices plugged into the system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HardwareAvailable | Returns a Boolean indicating whether an Open Layers-compatible device is plugged into the system;
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceMgr Class


DeviceMgr Methods

[image] [image]

OpenLayers for .NET Documentation
DeviceMgr Methods
DeviceMgr Class See Also Send Feedback

The DeviceMgr type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Get | Returns a DeviceMgr object.
Public method | GetDevice | Returns a Device object for the specified device.
Public method | GetDeviceNames | Returns a list of all Open Layers-compatible devices plugged into the system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HardwareAvailable | Returns a Boolean indicating whether an Open Layers-compatible device is plugged into the system;
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceMgr Class


DeviceMgr.Get Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..Get Method
DeviceMgr Class See Also Send Feedback
Returns a DeviceMgr object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static DeviceMgr Get()
Visual Basic
Public Shared Function Get As DeviceMgr

Return Value

Type: DeviceMgr
A DeviceMgr object.

Remarks

You must call this method before you can perform any operation in the Open Layers for .NET Class Library.

See Also

DeviceMgr Class
DeviceMgr Members


DeviceMgr.GetDevice Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..GetDevice Method
DeviceMgr Class See Also Send Feedback
Returns a Device object for the specified device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Device GetDevice(
    string deviceName
)
Visual Basic
Public Function GetDevice (
    deviceName As String
) As Device

Parameters

deviceName
Type: System..::..String
The name of the device as defined in the Open Layers Control Panel applet.

Return Value

Type: Device
A Device object.

Remarks

You must get a Device object for each Open Layers-compatible device that you want to use.

See Also

DeviceMgr Class
DeviceMgr Members


DeviceMgr.GetDeviceNames Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..GetDeviceNames Method
DeviceMgr Class See Also Send Feedback
Returns a list of all Open Layers-compatible devices plugged into the system.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string[] GetDeviceNames()
Visual Basic
Public Function GetDeviceNames As String()

Return Value

Type: array<String>[]()[][]
An array of strings with the active device names.

See Also

DeviceMgr Class
DeviceMgr Members


DeviceMgr.HardwareAvailable Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..HardwareAvailable Method
DeviceMgr Class See Also Send Feedback
Returns a Boolean indicating whether an Open Layers-compatible device is plugged into the system;

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool HardwareAvailable()
Visual Basic
Public Function HardwareAvailable As Boolean

Return Value

Type: Boolean
Returns True if an Open Layers-compatible device is plugged into the system; otherwise, returns False.

See Also

DeviceMgr Class
DeviceMgr Members


DeviceRemovedHandler Delegate

[image]

OpenLayers for .NET Documentation
DeviceRemovedHandler Delegate
See Also Send Feedback
The DeviceRemovedHandler delegate is called when the event DeviceRemovedEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void DeviceRemovedHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub DeviceRemovedHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event DeviceRemovedEvent.

Remarks

The event DeviceRemovedEvent is raised when a device is removed from your system while your application is running.

See Also


DigitalInputSubsystem Class

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem Class
Members See Also Send Feedback
The DigitalInputSubsystem class provides the properties, methods, and events for performing digital input operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class DigitalInputSubsystem : SubsystemBase
Visual Basic
Public Class DigitalInputSubsystem
    Inherits SubsystemBase

Remarks

Instances of this class are created using the DigitalInputSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..DigitalInputSubsystem

See Also

DigitalInputSubsystem Members


DigitalInputSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
DigitalInputSubsystem Members
DigitalInputSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The DigitalInputSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | DigitalInputSubsystem | Returns a DigitalInputSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Aborts the current continuous digital input operation. (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSingleValue | Returns a single data value from the digital input subsystem.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadInterruptOnChangeMask | Returns a bit mask that indicates which lines within a digital input port will generate the event InterruptOnChangeEvent when they change state.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous operation on the digital input subsystem. Currently, only Open Layers devices that support interrupt-on-change on the digital input subsystem can perform continuous digital input operations. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops the current continuous digital input operation. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the digital input subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | WriteInterruptOnChangeMask | Selects a set of digital input lines on which to perform an interrupt-on-change operation. When any of the specified bits in the interruptOnChangeMask parameter changes state, the event InterruptOnChangeEvent gets raised.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsInterruptOnChange | Returns True if the subsystem supports interrupt-on-change; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | InterruptOnChangeEvent | Add/remove a delegate to be called when the event InterruptOnChangeEvent occurs.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

DigitalInputSubsystem Class


DigitalInputSubsystem Constructor

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem Constructor
DigitalInputSubsystem Class See Also Send Feedback
Returns a DigitalInputSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DigitalInputSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.Base..::..Device
Open Layers Device object with which to associate the digital input subsystem.
element
Type: System..::..Int32
The Element number of the digital input subsystem.

Remarks

It is recommended that you use the DigitalInputSubsystem(Int32) method rather than this constructor to return a digital input subsystem.

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
DigitalInputSubsystem Methods
DigitalInputSubsystem Class See Also Send Feedback

The DigitalInputSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Aborts the current continuous digital input operation. (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSingleValue | Returns a single data value from the digital input subsystem.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadInterruptOnChangeMask | Returns a bit mask that indicates which lines within a digital input port will generate the event InterruptOnChangeEvent when they change state.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous operation on the digital input subsystem. Currently, only Open Layers devices that support interrupt-on-change on the digital input subsystem can perform continuous digital input operations. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops the current continuous digital input operation. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the digital input subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | WriteInterruptOnChangeMask | Selects a set of digital input lines on which to perform an interrupt-on-change operation. When any of the specified bits in the interruptOnChangeMask parameter changes state, the event InterruptOnChangeEvent gets raised.

See Also

DigitalInputSubsystem Class


DigitalInputSubsystem.Abort Method

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..Abort Method
DigitalInputSubsystem Class See Also Send Feedback
Aborts the current continuous digital input operation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Abort()
Visual Basic
Public Overrides Sub Abort

Remarks

For this subsystem type, Abort and Stop()()()() behave identically.

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem.GetSingleValue Method

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..GetSingleValue Method
DigitalInputSubsystem Class See Also Send Feedback
Returns a single data value from the digital input subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int GetSingleValue()
Visual Basic
Public Function GetSingleValue As Integer

Return Value

Type: Int32
The value of the digital input port that is associated with the digital input subsystem.

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem.ReadInterruptOnChangeMask Method

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..ReadInterruptOnChangeMask Method
DigitalInputSubsystem Class See Also Send Feedback
Returns a bit mask that indicates which lines within a digital input port will generate the event InterruptOnChangeEvent when they change state.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint ReadInterruptOnChangeMask()
Visual Basic
Public Function ReadInterruptOnChangeMask As UInteger

Return Value

Type: UInt32
The interrupt-on-change mask, where each bit represents a digital input line. If a bit is set, the event InterruptOnChangeEvent is generated when the corresponding digital line changes state.

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem.Start Method

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..Start Method
DigitalInputSubsystem Class See Also Send Feedback
Starts a continuous operation on the digital input subsystem. Currently, only Open Layers devices that support interrupt-on-change on the digital input subsystem can perform continuous digital input operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Start()
Visual Basic
Public Overrides Sub Start

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem.Stop Method

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..Stop Method
DigitalInputSubsystem Class See Also Send Feedback
Stops the current continuous digital input operation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Stop()
Visual Basic
Public Overrides Sub Stop

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..ToString Method
DigitalInputSubsystem Class See Also Send Feedback
Returns a description of the digital input subsystem and element.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the digital input subsystem and element.

Remarks

This method overrides the ToString method in the base class.

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem.WriteInterruptOnChangeMask Method

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..WriteInterruptOnChangeMask Method
DigitalInputSubsystem Class See Also Send Feedback
Selects a set of digital input lines on which to perform an interrupt-on-change operation. When any of the specified bits in the interruptOnChangeMask parameter changes state, the event InterruptOnChangeEvent gets raised.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void WriteInterruptOnChangeMask(
    uint interruptOnChangeMask
)
Visual Basic
Public Sub WriteInterruptOnChangeMask (
    interruptOnChangeMask As UInteger
)

Parameters

interruptOnChangeMask
Type: System..::..UInt32
Specifies the bit mask, where each bit represents a digital input line. If a bit is set (value of 1), the event InterruptOnChangeEvent is generated when the corresponding digital line changes state. If a bit is not set (value is 0), the InterruptOnChangeEvent is not generated when the corresponding digital line changes state.

Remarks

Use the InterruptOnChangeHandler delegate to handle the InterruptOnChangeEvent events as they occur.

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
DigitalInputSubsystem Properties
DigitalInputSubsystem Class See Also Send Feedback

The DigitalInputSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsInterruptOnChange | Returns True if the subsystem supports interrupt-on-change; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

See Also

DigitalInputSubsystem Class


DigitalInputSubsystem.SupportsInterruptOnChange Property

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..SupportsInterruptOnChange Property
DigitalInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports interrupt-on-change; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInterruptOnChange { get; }
Visual Basic
Public ReadOnly Property SupportsInterruptOnChange As Boolean
    Get

Property Value

Type: Boolean

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalInputSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
DigitalInputSubsystem Events
DigitalInputSubsystem Class See Also Send Feedback

The DigitalInputSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | InterruptOnChangeEvent | Add/remove a delegate to be called when the event InterruptOnChangeEvent occurs.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

DigitalInputSubsystem Class


DigitalInputSubsystem.InterruptOnChangeEvent Event

[image]

OpenLayers for .NET Documentation
DigitalInputSubsystem..::..InterruptOnChangeEvent Event
DigitalInputSubsystem Class See Also Send Feedback
Add/remove a delegate to be called when the event InterruptOnChangeEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event InterruptOnChangeHandler InterruptOnChangeEvent
Visual Basic
Public Event InterruptOnChangeEvent As InterruptOnChangeHandler

Value

Type: OpenLayers.Base..::..InterruptOnChangeHandler

See Also

DigitalInputSubsystem Class
DigitalInputSubsystem Members


DigitalOutputSubsystem Class

[image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem Class
Members See Also Send Feedback
The DigitalOutputSubsystem class provides the properties, methods, and events for performing digital output operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class DigitalOutputSubsystem : SubsystemBase
Visual Basic
Public Class DigitalOutputSubsystem
    Inherits SubsystemBase

Remarks

Instances of this class are created using the DigitalOutputSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..DigitalOutputSubsystem

See Also

DigitalOutputSubsystem Members


DigitalOutputSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem Members
DigitalOutputSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The DigitalOutputSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | DigitalOutputSubsystem | Returns a DigitalOutputSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | SetSingleValue | Writes a single output value to the digital output subsystem.
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a description of the digital output subsystem and element. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

DigitalOutputSubsystem Class


DigitalOutputSubsystem Constructor

[image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem Constructor
DigitalOutputSubsystem Class See Also Send Feedback
Returns a DigitalOutputSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DigitalOutputSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.Base..::..Device
The Open Layers Device object with which to associate the digital output subsystem.
element
Type: System..::..Int32
The Element number of the digital output subsystem.

Remarks

It is recommended that you use the DigitalOutputSubsystem(Int32) method rather than this constructor to return a digital output subsystem.

See Also

DigitalOutputSubsystem Class
DigitalOutputSubsystem Members


DigitalOutputSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem Methods
DigitalOutputSubsystem Class See Also Send Feedback

The DigitalOutputSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | SetSingleValue | Writes a single output value to the digital output subsystem.
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a description of the digital output subsystem and element. (Overrides Object..::..ToString()()()().)

See Also

DigitalOutputSubsystem Class


DigitalOutputSubsystem.SetSingleValue Method

[image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem..::..SetSingleValue Method
DigitalOutputSubsystem Class See Also Send Feedback
Writes a single output value to the digital output subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValue(
    int inCodeValue
)
Visual Basic
Public Sub SetSingleValue (
    inCodeValue As Integer
)

Parameters

inCodeValue
Type: System..::..Int32
The digital value to output.

See Also

DigitalOutputSubsystem Class
DigitalOutputSubsystem Members


DigitalOutputSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem..::..ToString Method
DigitalOutputSubsystem Class See Also Send Feedback
Returns a description of the digital output subsystem and element.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the digital output subsystem and element.

Remarks

This method overrides the ToString method in the base class.

See Also

DigitalOutputSubsystem Class
DigitalOutputSubsystem Members


DigitalOutputSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem Properties
DigitalOutputSubsystem Class See Also Send Feedback

The DigitalOutputSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

See Also

DigitalOutputSubsystem Class


DigitalOutputSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
DigitalOutputSubsystem Events
DigitalOutputSubsystem Class See Also Send Feedback

The DigitalOutputSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

DigitalOutputSubsystem Class


DriverRunTimeErrorEventArgs Class

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Class
Members See Also Send Feedback
A DriverRunTimeErrorEventArgs object is passed to the DriverRunTimeErrorEventHandler delegate when when the event DriverRunTimeErrorEvent occurs. DriverRunTimeErrorEventArgs contains the error/warning that is generated by the device driver, an error message that describes the error/warning, the subsystem that raised the event, and the time stamp of when the event occurred.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class DriverRunTimeErrorEventArgs : GeneralEventArgs
Visual Basic
Public Class DriverRunTimeErrorEventArgs
    Inherits GeneralEventArgs

Remarks

The DriverRunTimeErrorEvent occurs when the device driver detects one of the following error conditions:

FifoOverflow - The driver could not read data from the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO overflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

FifoUnderflow - The driver could not write data to the device FIFO (or Windows USB FIFO) fast enough, resulting in FIFO underflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

DeviceOverClocked - The A/D clock (usually external clock) is running too fast on the device. To deal with this error, slow down the A/D clock.

TriggerError - The driver detected a trigger on the device but did not act on it.

DeviceError - Generated by the driver due to a USB bus or hardware problem. To deal with this error, stop connecting/disconnecting USB devices while streaming data to them.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.Base..::..GeneralEventArgs
OpenLayers.Base..::..DriverRunTimeErrorEventArgs

See Also

DriverRunTimeErrorEventArgs Members


DriverRunTimeErrorEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Members
DriverRunTimeErrorEventArgs Class Methods Properties See Also Send Feedback

The DriverRunTimeErrorEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with the driver error.
Public property | Message | Returns the descriptive string for the driver error.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

DriverRunTimeErrorEventArgs Class


DriverRunTimeErrorEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Methods
DriverRunTimeErrorEventArgs Class See Also Send Feedback

The DriverRunTimeErrorEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DriverRunTimeErrorEventArgs Class


DriverRunTimeErrorEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Properties
DriverRunTimeErrorEventArgs Class See Also Send Feedback

The DriverRunTimeErrorEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with the driver error.
Public property | Message | Returns the descriptive string for the driver error.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

DriverRunTimeErrorEventArgs Class


DriverRunTimeErrorEventArgs.ErrorCode Property

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs..::..ErrorCode Property
DriverRunTimeErrorEventArgs Class See Also Send Feedback
Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with the driver error.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ErrorCode ErrorCode { get; }
Visual Basic
Public ReadOnly Property ErrorCode As ErrorCode
    Get

Property Value

Type: ErrorCode

See Also

DriverRunTimeErrorEventArgs Class
DriverRunTimeErrorEventArgs Members


DriverRunTimeErrorEventArgs.Message Property

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs..::..Message Property
DriverRunTimeErrorEventArgs Class See Also Send Feedback
Returns the descriptive string for the driver error.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

Property Value

Type: String

See Also

DriverRunTimeErrorEventArgs Class
DriverRunTimeErrorEventArgs Members


DriverRunTimeErrorEventHandler Delegate

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventHandler Delegate
See Also Send Feedback
The DriverRunTimeErrorEventHandler delegate is called when the DriverRunTimeErrorEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void DriverRunTimeErrorEventHandler(
    Object sender,
    DriverRunTimeErrorEventArgs eventArgs
)
Visual Basic
Public Delegate Sub DriverRunTimeErrorEventHandler (
    sender As Object,
    eventArgs As DriverRunTimeErrorEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..DriverRunTimeErrorEventArgs
The DriverRunTimeErrorEventArgs object that is associated with the DriverRunTimeErrorEvent.

Remarks

The DriverRunTimeErrorEvent occurs when the device driver detects one of the following error conditions during runtime:

FifoOverflow - The driver could not read data from the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO overflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

FifoUnderflow - The driver could not write data to the device FIFO (or Windows USB FIFO) fast enough, resulting in FIFO underflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

DeviceOverClocked - The A/D clock (usually external clock) is running too fast on the device. To deal with this error, slow down the A/D clock.

TriggerError - The driver detected a trigger on the device but did not act on it.

DeviceError - Generated by the driver due to a USB bus or hardware problem. To deal with this error, stop connecting/disconnecting USB devices while streaming data to them.

See Also


EdgeSelect Enumeration

[image]

OpenLayers for .NET Documentation
EdgeSelect Enumeration
See Also Send Feedback
Contains the possible values for the EdgeSelect parameter of the StartEdge and StopEdge properties.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum EdgeSelect
Visual Basic
Public Enumeration EdgeSelect

Members

Member name | Value | Description
GateRising | 750 | The specified start or stop edge occurs on the rising edge of the counter's associated gate input signal.
GateFalling | 751 | The specified start or stop edge occurs on the falling edge of the counter's associated gate input signal.
ClockRising | 752 | The specified start or stop edge occurs on the rising edge of the counter's associated clock input signal.
ClockFalling | 753 | The specified start or stop edge occurs on the falling edge of the counter's associated clock input signal.
ADCConversionComplete | 754 | The specified start or stop edge occurs when the A/D conversion is complete.
TachometerInputFalling | 755 | The specified start or stop edge occurs on the falling edge of the tachometer input signal.
TachometerInputRising | 756 | The specified start or stop edge occurs on the rising edge of the tachometer input signal.
DigitalInput0Falling | 757 | The specified start or stop edge occurs on the falling edge of digital input signal 0.
DigitalInput0Rising | 758 | The specified start or stop edge occurs on the rising edge of digital input signal 0.
DigitalInput1Falling | 759 | The specified start or stop edge occurs on the falling edge of digital input signal 1.
DigitalInput1Rising | 760 | The specified start or stop edge occurs on the rising edge of digital input signal 1.
DigitalInput2Falling | 761 | The specified start or stop edge occurs on the falling edge of digital input signal 2.
DigitalInput2Rising | 762 | The specified start or stop edge occurs on the rising edge of digital input signal 2.
DigitalInput3Falling | 763 | The specified start or stop edge occurs on the falling edge of digital input signal 3.
DigitalInput3Rising | 764 | The specified start or stop edge occurs on the rising edge of digital input signal 3.
DigitalInput4Falling | 765 | The specified start or stop edge occurs on the falling edge of digital input signal 4.
DigitalInput4Rising | 766 | The specified start or stop edge occurs on the rising edge of digital input signal 4.
DigitalInput5Falling | 767 | The specified start or stop edge occurs on the falling edge of digital input signal 5.
DigitalInput5Rising | 768 | The specified start or stop edge occurs on the rising edge of digital input signal 5.
DigitalInput6Falling | 769 | The specified start or stop edge occurs on the falling edge of digital input signal 6.
DigitalInput6Rising | 770 | The specified start or stop edge occurs on the rising edge of digital input signal 6.
DigitalInput7Falling | 771 | The specified start or stop edge occurs on the falling edge of digital input signal 7.
DigitalInput7Rising | 772 | The specified start or stop edge occurs on the rising edge of digital input signal 7.
CT0ClockInputFalling | 773 | The specified start or stop edge occurs on the falling edge of the clock input signal associated with counter/timer 0.
CT0ClockInputRising | 774 | The specified start or stop edge occurs on the rising edge of the clock input signal associated with counter/timer 0.
CT0GateInputFalling | 775 | The specified start or stop edge occurs on the falling edge of the gate input signal associated with counter/timer 0.
CT0GateInputRising | 776 | The specified start or stop edge occurs on the rising edge of the gate input signal associated with counter/timer 0.

See Also


EdgeType Enumeration

[image]

OpenLayers for .NET Documentation
EdgeType Enumeration
See Also Send Feedback
Contains the possible values for the EdgeType property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum EdgeType
Visual Basic
Public Enumeration EdgeType

Members

Member name | Value | Description
Falling | 600 | Falling edge of the tachometer signal.
Rising | 601 | Rising edge of the tachometer signal.

See Also


Encoding Enumeration

[image]

OpenLayers for .NET Documentation
Encoding Enumeration
See Also Send Feedback
Contains the possible values for the SubsystemBase.Encoding and OlBuffer.Encoding properties, and for the Encoding parameter of the VoltsToRawValue(Double, Encoding, Double, Double, Int32) and RawValueToVolts(Int32, Encoding, Double, Double, Int32) methods.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum Encoding
Visual Basic
Public Enumeration Encoding

Members

Member name | Value | Description
Binary | 200 | Binary data encoding
TwosComplement | 201 | Twos complement data encoding

See Also


ErrorCode Enumeration

[image]

OpenLayers for .NET Documentation
ErrorCode Enumeration
See Also Send Feedback
Open Layers error codes that are accessible using an OlException object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ErrorCode
Visual Basic
Public Enumeration ErrorCode

Members

Member name | Value | Description
NoError | 0 | No error.
Success | 0 | The operation was successful.
InvalidElement | 2 | An invalid subsystem element was specified.
InvalidListSize | 5 | An attempt was made to set the ChannelList to an invalid size.
InvalidListEntry | 6 | An invalid ChannelListEntry entry was specified in the ChannelList.
InvalidChannel | 7 | An invalid ChannelListEntry object was specified.
InvalidChannelType | 8 | An invalid ChannelType was specified.
InvalidTrigger | 10 | An invalid TriggerType was specified.
InvalidResolution | 11 | An invalid Resolution was specified.
InvalidClockSource | 12 | An invalid clock Source was specified.
InvalidFrequency | 13 | An invalid clock Frequency was specified.
InvalidPulseType | 14 | An invalid PulseType was specified.
InvalidPulseWidth | 15 | An invalid PulseWidth was specified.
InvalidCounterMode | 16 | An invalid CounterMode was specified.
InvalidDataFlow | 18 | An invalid DataFlow mode was specified.
SubsystemInUse | 20 | An attempt was made to access a subsystem that is already in use.
SubsystemNotInUse | 21 | An operation was attempted on a subsystem that is not in use.
AlreadyRunning | 22 | An operation was attempted on a running subsystem.
NotConfigured | 26 | An operation was attempted on a subsystem that was not configured (see Config()()()()).
DataFlowMismatch | 27 | An invalid DataFlow mode was set for the current operation.
NotRunning | 28 | The subsystem is not running.
InvalidRange | 29 | An invalid VoltageRange was specified.
NotSupported | 36 | The operation is not supported.
InvalidDivider | 37 | An invalid ExtClockDivider was specified.
InvalidGate | 38 | An invalid GateType was set for the current operation.
InvalidChannelList | 45 | An invalid ChannelList channel entry was specified.
ADOverrun | 61 | Conversion is not complete within timeout period, resulting in A/D overrun condition.
NoQueuedBuffers | 64 | No OlBuffer objects were queued to the subsystem (see QueueBuffer(OlBuffer)).
CannotOpenDriver | 67 | The device driver cannot be initialized.
CantCascade | 72 | The subsystem cannot be cascaded (see CascadeMode).
WrongCounterMode | 82 | An invalid CounterMode was set for the current operation.
InvalidGain | 86 | An invalid Gain was set for the ChannelListEntry object.
InvalidRetriggerFrequency | 90 | An invalid RetriggerFrequency was requested for the current ChannelList.
CommandTimeout | 91 | A command timed out in the device driver.
EventCountOverFlow | 93 | An overflow occured while in event counting mode.
NoSubsystemsOnSimultaneousStartList | 104 | No subsystems have been put on the SimultaneousStart list.
NoChannelInhibitList | 105 | Subsystem does not support channel inhibition (see Inhibit).
NotPrestarted | 107 | The subsystem has not been prestarted on the simultaneous start list (see PreStart()()()()).
InvalidInhibitState | 113 | All ChannelListEntry entries in the ChannelList are inhibited (see Inhibit).
RequiredSubsystemInUse | 118 | The additional subsystem that is required for this operation is in use.
WrapModeMismatch | 119 | WrapSingleBuffer cannot be true for the requested operation.
BadRetriggerSource | 121 | An invalid RetriggerSource was specified.
BadMultiScanCount | 122 | The MultiScanCount value exceeds the maximum number of scans for the ChannelList.
InvalidRetrigger | 123 | Triggered scan is not supported when used with ContinuousPrePostTrigger mode or ContinuousPreTrigger mode. (See DataFlow).
InvalidPreTrigger | 124 | The PreTriggerSource must be Software when using ContinuousPrePostTrigger or ContinuousPreTrigger mode. (See DataFlow).
GeneralFailure | 125 | A general failure occurred in the device driver.
BadEdge | 128 | An invalid counter edge was specified for the current counter/timer mode (see StartEdge or StopEdge).
HalfCounterEntry | 129 | Only one 16-bit word of a 32-bit word was added to the ChannelList. Both words must be added.
InvalidX4IndexCombination | 131 | Invalid combination of IndexMode and X4Scaling was specified.
InvalidCouplingType | 132 | Invalid coupling type for the device.
InvalidCurrentSource | 133 | Invalid excitation current source for the device.
InvalidValue | 134 | Invalid value specified.
InvalidWhenADRunning | 135 | Operation is prohibited while the A/D is running. Refer to your device documentation for details.
InvalidSynchronizationMode | 140 | Invalid synchronization mode specified.
InvalidWhenDARunning | 142 | Operation is prohibited while the D/A is running. Refer to your device documentation for details.
CannotAllocateBuffer | 201 | Cannot allocate the requested OlBuffer object.
BufferAlreadyQueued | 205 | The OlBuffer object has already been queued to a subsystem.
BufferInProcess | 206 | The OlBuffer object has been removed from the queue and sent to the device driver for processing.
InvalidBufferSize | 208 | The OlBuffer The buffer size is invalid for the current operation.
OddSizeBuffer | 220 | The number of samples in the OlBuffer object must be a multiple of two for the current operation.
BufferNotAllocated | 221 | The OlBuffer object has been deallocated.
DataWidthMismatch | 400 | An OlBuffer object has been created using a data type that is not compatible with the subystem's Resolution.
NoValidSamples | 402 | The OlBuffer object has 0 ValidSamples.
ChannelNotInChannelList | 403 | The specified ChannelListEntry object is not in the ChannelList.
SourceBufferTooSmall | 404 | The user-specified array is too small for the requested operation.
DuplicateChannelName | 405 | Each SupportedChannelInfo object in SupportedChannels must have a unique name.
BufferInUse | 406 | The OlBuffer object is in use.
SubsystemIncompatible | 407 | The subsystem is incompatible with the data format of the OlBuffer object.
EmptyChannelList | 408 | The ChannelList must have at least one ChannelListEntry entry for continuous operations.
InvalidChannelListIndex | 409 | An invalid ChannelList index was specified.
SubsystemStopping | 410 | The subsystem is in the process of stopping or aborting. (See Stop()()()() and/or Abort()()()().)
FifoOverflow | 532 | The driver could not read data from the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO overflow condition.
FifoUnderflow | 533 | The driver could not write data to the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO underflow condition.
DeviceOverClocked | 534 | The A/D clock (usually the external A/D clock) is running too fast on the device.
TriggerError | 535 | Generated by the driver when a trigger is detected but not acted on by the hardware.
DeviceError | 536 | Generated by the driver due to a USB bus problem or hardware problem.
InvalidError | 537 | An unknown error string was passed to GetErrorCode().
NoThermocoupleSupport | 538 | The subsystem does not support thermocouples.
NoCjcChannel | 539 | No CJC channel was specified in the ChannelList.
NoThermocoupleTypeSpecified | 540 | A ThermocoupleType was not specified for the requested channel.
ThermocoupleTypeSpecified | 541 | A ThermocoupleType was specified for the requested channel.
SetSingleValuesNotSupported | 542 | The SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) and SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][]) methods are not supported by this subsystem.
DuplicateChannelSpecified | 543 | A duplicate channel was specified for this operation.
AutoCalibrateNotSupported | 544 | Auto-calibrate is not supported by this device.
NoRTDSupport | 545 | The subsystem does not support RTDs.
NoRTDTypeSpecified | 546 | An RTDType was not specified for the requested channel.
RtdTypeSpecified | 547 | An RTDType was specified for the requested channel.
ReturnsOhmsNotSupported | 548 | The subsystem does not support returning values as Ohms.
AccessDenied | 549 | Access was denied to the subsystem or device.
TedsError | 550 | TEDs input streaming error.
NoThermistorSupport | 551 | The subsystem does not support Thermistor measurement.
CollectionNameMismatch | 552 | Device collection name mismatch. There is more than one collection present with the same name.
CollectionDeviceCountMismatch | 553 | Device collection device count mismatch. Not all devices in the collection were found.
ChannelNotOnMaster | 554 | The specified channel is invalid because it is not on the master device.
BufferSizeNotMultiple | 555 | The number samples in all queued OlBuffer objects must be a multiple of the number of channels in the ChannelList for a DeviceCollection.
CollectionNotFound | 556 | Device not found.
LastError | 557 | Last error code in the enumeration.

See Also


EventDoneEventArgs Class

[image]

OpenLayers for .NET Documentation
EventDoneEventArgs Class
Members See Also Send Feedback
An EventDoneEventArgs object is passed to the EventDoneHandler delegate when the event EventDoneEvent occurs. EventDoneEventArgs contains the data that is associated with the event EventDoneEvent, including the subsystem that raised the event and the time stamp of when the event occurred.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class EventDoneEventArgs : GeneralEventArgs
Visual Basic
Public Class EventDoneEventArgs
    Inherits GeneralEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.Base..::..GeneralEventArgs
OpenLayers.Base..::..EventDoneEventArgs

See Also

EventDoneEventArgs Members


EventDoneEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
EventDoneEventArgs Members
EventDoneEventArgs Class Methods Properties See Also Send Feedback

The EventDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Returns the data that is associated with the event EventDoneEvent. The meaning of this data depends on your device and the subsystem used. Refer to your device documentation for more information.
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

EventDoneEventArgs Class


EventDoneEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
EventDoneEventArgs Methods
EventDoneEventArgs Class See Also Send Feedback

The EventDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventDoneEventArgs Class


EventDoneEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
EventDoneEventArgs Properties
EventDoneEventArgs Class See Also Send Feedback

The EventDoneEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Data | Returns the data that is associated with the event EventDoneEvent. The meaning of this data depends on your device and the subsystem used. Refer to your device documentation for more information.
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

EventDoneEventArgs Class


EventDoneEventArgs.Data Property

[image]

OpenLayers for .NET Documentation
EventDoneEventArgs..::..Data Property
EventDoneEventArgs Class See Also Send Feedback
Returns the data that is associated with the event EventDoneEvent. The meaning of this data depends on your device and the subsystem used. Refer to your device documentation for more information.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public long Data { get; }
Visual Basic
Public ReadOnly Property Data As Long
    Get

Property Value

Type: Int64

See Also

EventDoneEventArgs Class
EventDoneEventArgs Members


EventDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
EventDoneHandler Delegate
See Also Send Feedback
The EventDoneHandler delegate is called when the event EventDoneEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void EventDoneHandler(
    Object sender,
    EventDoneEventArgs eventArgs
)
Visual Basic
Public Delegate Sub EventDoneHandler (
    sender As Object,
    eventArgs As EventDoneEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..EventDoneEventArgs
The EventDoneEventArgs object that is associated with the event EventDoneEvent.

Remarks

The event EventDoneEvent is raised by some devices, such as the DT340, when a digital input line changes state or when an interval timer operation is complete

See Also


ExcitationCurrentSource Enumeration

[image]

OpenLayers for .NET Documentation
ExcitationCurrentSource Enumeration
See Also Send Feedback
Contains the possible values for the ExcitationCurrentSource property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ExcitationCurrentSource
Visual Basic
Public Enumeration ExcitationCurrentSource

Members

Member name | Value | Description
Internal | 0 | Internal excitation current source.
External | 1 | External excitation current source.
Disabled | 2 | Excitation current source is disabled (no excitation is applied).

See Also


ExcitationVoltageSource Enumeration

[image]

OpenLayers for .NET Documentation
ExcitationVoltageSource Enumeration
See Also Send Feedback
Contains the possible values for the ExcitationVoltageSource property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ExcitationVoltageSource
Visual Basic
Public Enumeration ExcitationVoltageSource

Members

Member name | Value | Description
Internal | 0 | Internal excitation voltage source.
External | 1 | External excitation voltage source.
Disabled | 2 | Excitation voltage source is disabled (no excitation is applied).

See Also


GageType Enumeration

[image]

OpenLayers for .NET Documentation
GageType Enumeration
See Also Send Feedback
Topology and rosette orientation of gage

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum GageType
Visual Basic
Public Enumeration GageType

Members

Member name | Value | Description
SingleElement | 0 | Single element gage.
TwoPoissonElements | 1 | Two elements with a Poisson arrangement.
TwoOppositeSignedElements | 2 | Two elements, opposite sign (adjacent arms).
TwoSameSignedElements | 3 | Two elements, same sign (opposite arms).
TwoElementChevron | 4 | Two elements, 45° Chevron (torque or shear) arrangement.
FourSameSignElementsPoisson | 5 | Four elements, Poisson strains of same sign in opposite arms.
FourOppositeSignedElements | 6 | Four elements, Poisson strains of opposite sign in adjacent arms.
FourUniaxialElements | 7 | Four elements, equal strains of opposite sign in adjacent arms.
FourElementDualChevron | 8 | Four elements, 45° Chevron (torque or shear) arrangement.
TeeRosetteGrid1_0Degrees | 9 | Tee Rosette grid 1 or a (0°).
TeeRosetteGrid2_90Degrees | 10 | Tee Rosette grid 2 or b (90°).
DeltaRosetteGrid1_0Degrees | 11 | Delta Rosette grid 1 or a (0°).
DeltaRosetteGrid2_60Degrees | 12 | Delta Rosette grid 2 or b (60°).
DeltaRosetteGrid3_120Degrees | 13 | Delta Rosette grid 3 or c (120°).
RectangularRosetteGrid1_0Degrees | 14 | Rectangular Rosette grid 1 or a (0°).
RectangularRosetteGrid2_45Degrees | 15 | Rectangular Rosette grid 2 or a (45°).
RectangularRosetteGrid3_90Degrees | 16 | Rectangular Rosette grid 3 or a (90°).

See Also


GateType Enumeration

[image]

OpenLayers for .NET Documentation
GateType Enumeration
See Also Send Feedback
Contains the possible values for the GateType property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum GateType
Visual Basic
Public Enumeration GateType

Members

Member name | Value | Description
None | 500 | A gate type of None (software) enables the counter/timer operation immediately.
HighLevel | 501 | A HighLevel external gate type enables a counter/timer operation when the external gate signal is high, and disables a counter/timer operation when the external gate signal is low. Note that this gate type is used only for event counting, frequency measurement, and rate generation operations.
LowLevel | 502 | A LowLevel external gate type enables a counter/timer operation when the external gate signal is low, and disables the counter/timer operation when the external gate signal is high. Note that this gate type is used only for event counting, frequency measurement, and rate generation operations.
HighEdge | 503 | A HighEdge external gate type triggers a counter/timer operation on the transition from the low edge to the high edge (rising edge). Note that this gate type is used only for one-shot and repetitive one-shot mode.
LowEdge | 504 | A LowEdge external gate type triggers a counter/timer operation on the transition from the high edge to the low edge (falling edge). Note that this gate type is used only for one-shot and repetitive one-shot mode.
Level | 505 | A Level gate type enables a counter/timer operation on the transition from any level on the gate input signal. Note that this gate type is used only for event counting, frequency measurement, and rate generation operations.

See Also


GeneralEventArgs Class

[image]

OpenLayers for .NET Documentation
GeneralEventArgs Class
Members See Also Send Feedback
GeneralEventArgs is the base class for all event data. GeneralEventArgs contains the data that is passed to all events, including the subsystem that raised the event, and the time stamp of when the event occurred.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class GeneralEventArgs : EventArgs
Visual Basic
Public Class GeneralEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.Base..::..GeneralEventArgs
OpenLayers.Base..::..BufferDoneEventArgs
OpenLayers.Base..::..DriverRunTimeErrorEventArgs
OpenLayers.Base..::..EventDoneEventArgs
OpenLayers.Base..::..InterruptOnChangeEventArgs
OpenLayers.Base..::..IOCompleteEventArgs
OpenLayers.Base..::..MeasureDoneEventArgs

See Also

GeneralEventArgs Members


GeneralEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
GeneralEventArgs Members
GeneralEventArgs Class Methods Properties See Also Send Feedback

The GeneralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred.
Public property | Subsystem | Returns the subsystem that raised the event.

See Also

GeneralEventArgs Class


GeneralEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
GeneralEventArgs Methods
GeneralEventArgs Class See Also Send Feedback

The GeneralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeneralEventArgs Class


GeneralEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
GeneralEventArgs Properties
GeneralEventArgs Class See Also Send Feedback

The GeneralEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred.
Public property | Subsystem | Returns the subsystem that raised the event.

See Also

GeneralEventArgs Class


GeneralEventArgs.DateTime Property

[image]

OpenLayers for .NET Documentation
GeneralEventArgs..::..DateTime Property
GeneralEventArgs Class See Also Send Feedback
Returns the time stamp of when the associated event occurred.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DateTime DateTime { get; }
Visual Basic
Public ReadOnly Property DateTime As DateTime
    Get

Property Value

Type: DateTime

See Also

GeneralEventArgs Class
GeneralEventArgs Members


GeneralEventArgs.Subsystem Property

[image]

OpenLayers for .NET Documentation
GeneralEventArgs..::..Subsystem Property
GeneralEventArgs Class See Also Send Feedback
Returns the subsystem that raised the event.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase Subsystem { get; }
Visual Basic
Public ReadOnly Property Subsystem As SubsystemBase
    Get

Property Value

Type: SubsystemBase

See Also

GeneralEventArgs Class
GeneralEventArgs Members


GeneralFailureHandler Delegate

[image]

OpenLayers for .NET Documentation
GeneralFailureHandler Delegate
See Also Send Feedback
The GeneralFailureHandler delegate is called when the event GeneralFailureEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void GeneralFailureHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub GeneralFailureHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event GeneralFailureEvent.

Remarks

The event GeneralFailureEvent is raised when a general library failure occurs.

See Also


HardwareInfo Structure

[image]

OpenLayers for .NET Documentation
HardwareInfo Structure
Members See Also Send Feedback
This structure is used by the GetHardwareInfo()()()() method to return information about a Open Layers-compliant device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public struct HardwareInfo
Visual Basic
Public Structure HardwareInfo

See Also

HardwareInfo Members


HardwareInfo Members

[image] [image]

OpenLayers for .NET Documentation
HardwareInfo Members
HardwareInfo Structure Methods Fields See Also Send Feedback

The HardwareInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | BoardId | This field contains the year (1 or 2 digits), week (1 or 2 digits), test station (1 digit), and sequence number (3 digits) of the device when it was tested in Manufacturing. For example, if BoardId contains the value 5469419, this device was tested in 2005, week 46, on test station 9, and is unit number 419.
Public field | DeviceId | The version number of the product. If only one version of the product exists, this number is 1. If two versions of the product exist, this number could be 1 or 2.
Public field | ProductId | The product identification number, such as DT9832.
Public field | VendorId | The identification number of the vendor. For most devices, this is 0x087 hexadecimal.

See Also

HardwareInfo Structure


HardwareInfo Fields

[image] [image]

OpenLayers for .NET Documentation
HardwareInfo Fields
HardwareInfo Structure See Also Send Feedback

The HardwareInfo type exposes the following members.

Fields

 | Name | Description
Public field | BoardId | This field contains the year (1 or 2 digits), week (1 or 2 digits), test station (1 digit), and sequence number (3 digits) of the device when it was tested in Manufacturing. For example, if BoardId contains the value 5469419, this device was tested in 2005, week 46, on test station 9, and is unit number 419.
Public field | DeviceId | The version number of the product. If only one version of the product exists, this number is 1. If two versions of the product exist, this number could be 1 or 2.
Public field | ProductId | The product identification number, such as DT9832.
Public field | VendorId | The identification number of the vendor. For most devices, this is 0x087 hexadecimal.

See Also

HardwareInfo Structure


HardwareInfo.BoardId Field

[image]

OpenLayers for .NET Documentation
HardwareInfo..::..BoardId Field
HardwareInfo Structure See Also Send Feedback
This field contains the year (1 or 2 digits), week (1 or 2 digits), test station (1 digit), and sequence number (3 digits) of the device when it was tested in Manufacturing. For example, if BoardId contains the value 5469419, this device was tested in 2005, week 46, on test station 9, and is unit number 419.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int BoardId
Visual Basic
Public BoardId As Integer

Field Value

Type: Int32

See Also

HardwareInfo Structure
HardwareInfo Members


HardwareInfo.DeviceId Field

[image]

OpenLayers for .NET Documentation
HardwareInfo..::..DeviceId Field
HardwareInfo Structure See Also Send Feedback
The version number of the product. If only one version of the product exists, this number is 1. If two versions of the product exist, this number could be 1 or 2.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int DeviceId
Visual Basic
Public DeviceId As Integer

Field Value

Type: Int32

See Also

HardwareInfo Structure
HardwareInfo Members


HardwareInfo.ProductId Field

[image]

OpenLayers for .NET Documentation
HardwareInfo..::..ProductId Field
HardwareInfo Structure See Also Send Feedback
The product identification number, such as DT9832.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ProductId
Visual Basic
Public ProductId As Integer

Field Value

Type: Int32

See Also

HardwareInfo Structure
HardwareInfo Members


HardwareInfo.VendorId Field

[image]

OpenLayers for .NET Documentation
HardwareInfo..::..VendorId Field
HardwareInfo Structure See Also Send Feedback
The identification number of the vendor. For most devices, this is 0x087 hexadecimal.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int VendorId
Visual Basic
Public VendorId As Integer

Field Value

Type: Int32

See Also

HardwareInfo Structure
HardwareInfo Members


HardwareInfo Methods

[image] [image]

OpenLayers for .NET Documentation
HardwareInfo Methods
HardwareInfo Structure See Also Send Feedback

The HardwareInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

HardwareInfo Structure


InterruptOnChangeEventArgs Class

[image]

OpenLayers for .NET Documentation
InterruptOnChangeEventArgs Class
Members See Also Send Feedback
An InterruptOnChangeEventArgs object is passed to the InterruptOnChangeHandler delegate when the event InterruptOnChangeEvent occurs. InterruptOnChangeEventArgs contains the data that is associated with the event InterruptOnChangeEvent, including the subsystem that raised the event, the time stamp of when the event occurred, the digital input lines that changed state, and the current state of the digital input port.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class InterruptOnChangeEventArgs : GeneralEventArgs
Visual Basic
Public Class InterruptOnChangeEventArgs
    Inherits GeneralEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.Base..::..GeneralEventArgs
OpenLayers.Base..::..InterruptOnChangeEventArgs

See Also

InterruptOnChangeEventArgs Members


InterruptOnChangeEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
InterruptOnChangeEventArgs Members
InterruptOnChangeEventArgs Class Methods Properties See Also Send Feedback

The InterruptOnChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ChangedBits | Returns the digital input lines that changed state, causing the event InterruptOnChangeEvent to occur.
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | NewValue | Returns the current value of the digital input port.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

InterruptOnChangeEventArgs Class


InterruptOnChangeEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
InterruptOnChangeEventArgs Methods
InterruptOnChangeEventArgs Class See Also Send Feedback

The InterruptOnChangeEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InterruptOnChangeEventArgs Class


InterruptOnChangeEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
InterruptOnChangeEventArgs Properties
InterruptOnChangeEventArgs Class See Also Send Feedback

The InterruptOnChangeEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ChangedBits | Returns the digital input lines that changed state, causing the event InterruptOnChangeEvent to occur.
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | NewValue | Returns the current value of the digital input port.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

InterruptOnChangeEventArgs Class


InterruptOnChangeEventArgs.ChangedBits Property

[image]

OpenLayers for .NET Documentation
InterruptOnChangeEventArgs..::..ChangedBits Property
InterruptOnChangeEventArgs Class See Also Send Feedback
Returns the digital input lines that changed state, causing the event InterruptOnChangeEvent to occur.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ChangedBits { get; }
Visual Basic
Public ReadOnly Property ChangedBits As Integer
    Get

Property Value

Type: Int32

See Also

InterruptOnChangeEventArgs Class
InterruptOnChangeEventArgs Members


InterruptOnChangeEventArgs.NewValue Property

[image]

OpenLayers for .NET Documentation
InterruptOnChangeEventArgs..::..NewValue Property
InterruptOnChangeEventArgs Class See Also Send Feedback
Returns the current value of the digital input port.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NewValue { get; }
Visual Basic
Public ReadOnly Property NewValue As Integer
    Get

Property Value

Type: Int32

See Also

InterruptOnChangeEventArgs Class
InterruptOnChangeEventArgs Members


InterruptOnChangeHandler Delegate

[image]

OpenLayers for .NET Documentation
InterruptOnChangeHandler Delegate
See Also Send Feedback
The InterruptOnChangeHandler delegate is called when the event InterruptOnChangeEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void InterruptOnChangeHandler(
    Object sender,
    InterruptOnChangeEventArgs eventArgs
)
Visual Basic
Public Delegate Sub InterruptOnChangeHandler (
    sender As Object,
    eventArgs As InterruptOnChangeEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..InterruptOnChangeEventArgs
The InterruptOnChangeEventArgs object that is associated with the event InterruptOnChangeEvent.

Remarks

The event InterruptOnChangeEvent is raised by some devices when a digital input line changes state.

See Also


IOCompleteEventArgs Class

[image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Class
Members See Also Send Feedback
An IOCompleteEventArgs object is passed to the IOCompleteHandler delegate when the event IOCompleteEvent occurs. IOCompleteEventArgs contains the data associated with the event IOCompleteEvent. For analog input operations, this includes the total number of samples per channel that were acquired from the time acquisition was started to the last post-trigger sample, and the subsystem that raised the event. For analog output operations, this is the subsystem that raised the event.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class IOCompleteEventArgs : GeneralEventArgs
Visual Basic
Public Class IOCompleteEventArgs
    Inherits GeneralEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.Base..::..GeneralEventArgs
OpenLayers.Base..::..IOCompleteEventArgs

See Also

IOCompleteEventArgs Members


IOCompleteEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Members
IOCompleteEventArgs Class Methods Properties See Also Send Feedback

The IOCompleteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | LastSampleNumber | (For analog input operations only) returns the total number of samples per channel that were acquired from the time acquisition was started (with the start trigger) to the last post-trigger sample.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

IOCompleteEventArgs Class


IOCompleteEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Methods
IOCompleteEventArgs Class See Also Send Feedback

The IOCompleteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IOCompleteEventArgs Class


IOCompleteEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Properties
IOCompleteEventArgs Class See Also Send Feedback

The IOCompleteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | LastSampleNumber | (For analog input operations only) returns the total number of samples per channel that were acquired from the time acquisition was started (with the start trigger) to the last post-trigger sample.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

IOCompleteEventArgs Class


IOCompleteEventArgs.LastSampleNumber Property

[image]

OpenLayers for .NET Documentation
IOCompleteEventArgs..::..LastSampleNumber Property
IOCompleteEventArgs Class See Also Send Feedback
(For analog input operations only) returns the total number of samples per channel that were acquired from the time acquisition was started (with the start trigger) to the last post-trigger sample.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int LastSampleNumber { get; }
Visual Basic
Public ReadOnly Property LastSampleNumber As Integer
    Get

Property Value

Type: Int32

See Also

IOCompleteEventArgs Class
IOCompleteEventArgs Members


IOCompleteHandler Delegate

[image]

OpenLayers for .NET Documentation
IOCompleteHandler Delegate
See Also Send Feedback
The IOCompleteHandler delegate is called when the event IOCompleteEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void IOCompleteHandler(
    Object sender,
    IOCompleteEventArgs eventArgs
)
Visual Basic
Public Delegate Sub IOCompleteHandler (
    sender As Object,
    eventArgs As IOCompleteEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..IOCompleteEventArgs
The IOCompleteEventArgs object that is associated with the event IOCompleteEvent.

Remarks

For analog input operations that use a reference trigger whose trigger type is something other than software (none), the event IOCompleteEvent is raised when the last post-trigger sample is copied into the user buffer. Devices that do not support a reference trigger will never receive this event for analog input operations.

For analog output operations, the event IOCompleteEvent is raised when the last data point has been output from an analog output channel; in some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after the events BufferDoneEvent and QueueDoneEvents are raised).

See Also


IOType Enumeration

[image]

OpenLayers for .NET Documentation
IOType Enumeration
See Also Send Feedback
Contains the possible values for the IOType.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum IOType
Visual Basic
Public Enumeration IOType

Members

Member name | Value | Description
VoltageIn | 0 | The channel supports a voltage input.
VoltageOut | 1 | The channel supports a voltage output.
DigitalInput | 2 | The channel supports a digital input.
DigitalOutput | 3 | The channel supports a digital output.
QuadratureDecoder | 4 | The channel supports quadrature decoder operations.
CounterTimer | 5 | The channel supports counter/timer operations.
Tachometer | 6 | The channel supports a tachometer input.
Current | 7 | The channel supports a current input.
Thermocouple | 8 | The channel supports a thermocouple input.
Rtd | 9 | The channel supports an RTD input.
StrainGage | 10 | The channel supports a stain gage input.
Accelerometer | 11 | The channel supports an IEPE (accelerometer) input.
Bridge | 12 | The channel supports a bridge-based sensor or general-purpose bridge input.
Thermistor | 13 | The channel supports a thermistor input.
Resistance | 14 | The channel supports a resistance measurement input.
MultiSensor | 15 | The channel supports more than one sensor type. If the IOType propery is MultiSensor, use the MultiSensorType property or the SupportedMultiSensorTypes property to determine which sensor types are supported for the channel.

See Also


MeasureDoneEventArgs Class

[image]

OpenLayers for .NET Documentation
MeasureDoneEventArgs Class
Members See Also Send Feedback
A MeasureDoneEventArgs object is passed to the MeasureDoneHandler delegate when the event MeasureDoneEvent occurs. MeasureDoneEventArgs contains the data that is associated with the event MeasureDoneEvent, including the subsystem that raised the event, the time stamp of when the event occurred, and the count.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class MeasureDoneEventArgs : GeneralEventArgs
Visual Basic
Public Class MeasureDoneEventArgs
    Inherits GeneralEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.Base..::..GeneralEventArgs
OpenLayers.Base..::..MeasureDoneEventArgs

See Also

MeasureDoneEventArgs Members


MeasureDoneEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
MeasureDoneEventArgs Members
MeasureDoneEventArgs Class Methods Properties See Also Send Feedback

The MeasureDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Returns the number of internal clock pulses that were counted during the measure period.
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

MeasureDoneEventArgs Class


MeasureDoneEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
MeasureDoneEventArgs Methods
MeasureDoneEventArgs Class See Also Send Feedback

The MeasureDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeasureDoneEventArgs Class


MeasureDoneEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
MeasureDoneEventArgs Properties
MeasureDoneEventArgs Class See Also Send Feedback

The MeasureDoneEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Count | Returns the number of internal clock pulses that were counted during the measure period.
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

MeasureDoneEventArgs Class


MeasureDoneEventArgs.Count Property

[image]

OpenLayers for .NET Documentation
MeasureDoneEventArgs..::..Count Property
MeasureDoneEventArgs Class See Also Send Feedback
Returns the number of internal clock pulses that were counted during the measure period.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public long Count { get; }
Visual Basic
Public ReadOnly Property Count As Long
    Get

Property Value

Type: Int64

See Also

MeasureDoneEventArgs Class
MeasureDoneEventArgs Members


MeasureDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
MeasureDoneHandler Delegate
See Also Send Feedback
The MeasureDoneHandler delegate is called when the event MeasureDoneEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void MeasureDoneHandler(
    Object sender,
    MeasureDoneEventArgs eventArgs
)
Visual Basic
Public Delegate Sub MeasureDoneHandler (
    sender As Object,
    eventArgs As MeasureDoneEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..MeasureDoneEventArgs
The MeasureDoneEventArgs object that is associated with the event MeasureDoneEvent.

Remarks

The event MeasureDoneEvent is raised when a Measure operation is complete.

See Also


MultiRecordAcquisition Class

[image]

OpenLayers for .NET Documentation
MultiRecordAcquisition Class
Members See Also Send Feedback
The MultiRecordAcquisition class provides support for acquiring multiple records from the device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class MultiRecordAcquisition
Visual Basic
Public NotInheritable Class MultiRecordAcquisition

Remarks

To determine if your device supports multi-record acquisition, use the SupportsMultiRecordAcquisition property.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..MultiRecordAcquisition

See Also

MultiRecordAcquisition Members


MultiRecordAcquisition Members

[image] [image]

OpenLayers for .NET Documentation
MultiRecordAcquisition Members
MultiRecordAcquisition Class Methods Properties See Also Send Feedback

The MultiRecordAcquisition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTimeStampsAsSamples | Returns an array of timestamps, in samples, for records that were acquired after the start trigger occurred. The returned array contains a recordCount worth of timestamps starting with recordIndex.
Public method | GetTimeStampsAsSeconds | Returns an array of timestamps, in seconds, for records that were acquired after the start trigger occurred. The returned array contains a recordCount worth of timestamps starting with recordIndex.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets and sets whether multi-record acquisition mode is enabled for the subsystem. A value of True indicates that multi-record acquisition mode is enabled, and a value of False indicates that multi-record acquisition mode is disabled.
Public property | NumRecordsToAcquire | Gets and sets the number of records to acquire by the subsystem.
Public property | RetriggerDelayInSamples | Gets and sets the delay, in samples, between the end of the last record and acquisition of the next record.
Public property | TriggerDelayInSamples | Gets and sets the delay, in samples, between the start trigger and start of data acquisition.

See Also

MultiRecordAcquisition Class


MultiRecordAcquisition Methods

[image] [image]

OpenLayers for .NET Documentation
MultiRecordAcquisition Methods
MultiRecordAcquisition Class See Also Send Feedback

The MultiRecordAcquisition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTimeStampsAsSamples | Returns an array of timestamps, in samples, for records that were acquired after the start trigger occurred. The returned array contains a recordCount worth of timestamps starting with recordIndex.
Public method | GetTimeStampsAsSeconds | Returns an array of timestamps, in seconds, for records that were acquired after the start trigger occurred. The returned array contains a recordCount worth of timestamps starting with recordIndex.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiRecordAcquisition Class


MultiRecordAcquisition.GetTimeStampsAsSamples Method

[image]

OpenLayers for .NET Documentation
MultiRecordAcquisition..::..GetTimeStampsAsSamples Method
MultiRecordAcquisition Class See Also Send Feedback
Returns an array of timestamps, in samples, for records that were acquired after the start trigger occurred. The returned array contains a recordCount worth of timestamps starting with recordIndex.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ulong[] GetTimeStampsAsSamples(
    int recordIndex,
    int recordCount,
    out int actualRecordIndex
)
Visual Basic
Public Function GetTimeStampsAsSamples (
    recordIndex As Integer,
    recordCount As Integer,
    <OutAttribute> ByRef actualRecordIndex As Integer
) As ULong()

Parameters

recordIndex
Type: System..::..Int32
The index at which to start reading the timestamp.
recordCount
Type: System..::..Int32
The number of records for which to read the timestamp. If recordCount is -1, the timestamps for all available records are returned starting at the specified recordIndex.
actualRecordIndex
Type: System..::..Int32%
The actual index at which the timestamp is available for the record.

Return Value

Type: array<UInt64>[]()[][]
An array of timestamps, in samples, of the actual records that were acquired.

Remarks

The system contains timestamps for up to 65536 (64K) at a time. If the user does not read the records within that time that it takes to acquire 64K records, the system overwrites old data with the new timestamps.

See Also

MultiRecordAcquisition Class
MultiRecordAcquisition Members


MultiRecordAcquisition.GetTimeStampsAsSeconds Method

[image]

OpenLayers for .NET Documentation
MultiRecordAcquisition..::..GetTimeStampsAsSeconds Method
MultiRecordAcquisition Class See Also Send Feedback
Returns an array of timestamps, in seconds, for records that were acquired after the start trigger occurred. The returned array contains a recordCount worth of timestamps starting with recordIndex.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetTimeStampsAsSeconds(
    int recordIndex,
    int recordCount,
    out int actualRecordIndex
)
Visual Basic
Public Function GetTimeStampsAsSeconds (
    recordIndex As Integer,
    recordCount As Integer,
    <OutAttribute> ByRef actualRecordIndex As Integer
) As Double()

Parameters

recordIndex
Type: System..::..Int32
The index at which to start reading the timestamp.
recordCount
Type: System..::..Int32
The number of records for which to read the timestamp. If recordCount is -1, the timestamps for all available records are returned starting at the specified recordIndex.
actualRecordIndex
Type: System..::..Int32%
The actual index at which the timestamp is available for the record.

Return Value

Type: array<Double>[]()[][]
An array of timestamps, in seconds, of the actual records that were acquired.

Remarks

The system contains timestamps for up to 65536 (64K) records at a time. If the user does not read the records within the time that it takes to acquire 64K records, then the system overwrites old data with the new timestamps.

See Also

MultiRecordAcquisition Class
MultiRecordAcquisition Members


MultiRecordAcquisition Properties

[image] [image]

OpenLayers for .NET Documentation
MultiRecordAcquisition Properties
MultiRecordAcquisition Class See Also Send Feedback

The MultiRecordAcquisition type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets and sets whether multi-record acquisition mode is enabled for the subsystem. A value of True indicates that multi-record acquisition mode is enabled, and a value of False indicates that multi-record acquisition mode is disabled.
Public property | NumRecordsToAcquire | Gets and sets the number of records to acquire by the subsystem.
Public property | RetriggerDelayInSamples | Gets and sets the delay, in samples, between the end of the last record and acquisition of the next record.
Public property | TriggerDelayInSamples | Gets and sets the delay, in samples, between the start trigger and start of data acquisition.

See Also

MultiRecordAcquisition Class


MultiRecordAcquisition.Enabled Property

[image]

OpenLayers for .NET Documentation
MultiRecordAcquisition..::..Enabled Property
MultiRecordAcquisition Class See Also Send Feedback
Gets and sets whether multi-record acquisition mode is enabled for the subsystem. A value of True indicates that multi-record acquisition mode is enabled, and a value of False indicates that multi-record acquisition mode is disabled.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

To determine if your device supports multi-record acquisition, use the SupportsMultiRecordAcquisition property. When enabled, the device acquires the number of records specified by the NumRecordsToAcquire property.

See Also

MultiRecordAcquisition Class
MultiRecordAcquisition Members


MultiRecordAcquisition.NumRecordsToAcquire Property

[image]

OpenLayers for .NET Documentation
MultiRecordAcquisition..::..NumRecordsToAcquire Property
MultiRecordAcquisition Class See Also Send Feedback
Gets and sets the number of records to acquire by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumRecordsToAcquire { get; set; }
Visual Basic
Public Property NumRecordsToAcquire As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

When it detects a trigger, the device acquires the number of samples specified in the OlBuffer, and then waits for the next trigger. The process is repeated until the number of records specified by the NumRecordsToAcquire property is reached. If this property is set to zero, acquisition continues until a stop or abort is issued.

See Also

MultiRecordAcquisition Class
MultiRecordAcquisition Members


MultiRecordAcquisition.RetriggerDelayInSamples Property

[image]

OpenLayers for .NET Documentation
MultiRecordAcquisition..::..RetriggerDelayInSamples Property
MultiRecordAcquisition Class See Also Send Feedback
Gets and sets the delay, in samples, between the end of the last record and acquisition of the next record.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int RetriggerDelayInSamples { get; set; }
Visual Basic
Public Property RetriggerDelayInSamples As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

Refer to the user's manual for your device to determine if the subsystem supports this capability.

See Also

MultiRecordAcquisition Class
MultiRecordAcquisition Members


MultiRecordAcquisition.TriggerDelayInSamples Property

[image]

OpenLayers for .NET Documentation
MultiRecordAcquisition..::..TriggerDelayInSamples Property
MultiRecordAcquisition Class See Also Send Feedback
Gets and sets the delay, in samples, between the start trigger and start of data acquisition.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int TriggerDelayInSamples { get; set; }
Visual Basic
Public Property TriggerDelayInSamples As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

Refer to the user's manual for your device to determine if the subsystem supports this capability.

See Also

MultiRecordAcquisition Class
MultiRecordAcquisition Members


OlBuffer Class

[image]

OpenLayers for .NET Documentation
OlBuffer Class
Members See Also Send Feedback
The OlBuffer class encapsulates a data buffer that is used in a continuous I/O operation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class OlBuffer : IDisposable
Visual Basic
Public Class OlBuffer
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..OlBuffer

See Also

OlBuffer Members


OlBuffer Members

[image] [image]

OpenLayers for .NET Documentation
OlBuffer Members
OlBuffer Class Constructors Methods Properties See Also Send Feedback

The OlBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | OlBuffer | Creates and returns an OlBuffer object, and allocates an internal data buffer that will contain a specified number of samples.

Methods

 | Name | Description
Public method | Dispose | Deallocates the internal buffer of the OlBuffer object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataAsBridgeBasedSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.
Public method | GetDataAsBridgeBasedSensor(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.
Public method | GetDataAsCurrent | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into current values, and then copies these current values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsNormalizedBridgeOutput()()()() | Converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.
Public method | GetDataAsNormalizedBridgeOutput(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.
Public method | GetDataAsRawByte()()()() | Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawByte(ChannelListEntry) | Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).
Public method | GetDataAsRawInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).
Public method | GetDataAsRawUInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).
Public method | GetDataAsRawUInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).
Public method | GetDataAsRawUInt32()()()() | Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).
Public method | GetDataAsRawUInt32(ChannelListEntry) | Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).
Public method | GetDataAsResistance | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into resistance values, and then copies these resistance values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsRpm | For a specified ChannelListEntry, converts the tachometer data from the internal buffer of an OlBuffer object into RPM values, and then copies these values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsSensor(ChannelListEntry) | This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsStrain()()()() | Converts the data from the internal buffer of an OlBuffer object into strain values, and then copies these strain values into an array of 64-bit floating-point values (double).
Public method | GetDataAsStrain(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into microstrain values, and then copies these microstrain values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsTemperatureByte | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into temperature values, and then copies these temperature values into a user-declared array of bytes. Each temperature value is stored as an Int32, and takes 4 bytes.
Public method | GetDataAsTemperatureDouble | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into temperature values, and then copies these temperature values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsVolts()()()() | Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts(ChannelListEntry) | For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVoltsByte | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of bytes. Each voltage value is stored as an Int32, and takes 4 bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PutDataAsRaw(array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(ChannelListEntry, array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | Reallocate | Reallocates the internal data buffer of the OlBuffer object to contain the specified number of samples. The existing internal data buffer is deallocated and any data that it contained is lost.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BufferSizeInBytes | Returns the size of the internal data buffer, in bytes.
Public property | BufferSizeInSamples | Returns the size of the internal data buffer, in samples.
Public property | ChannelListOffset | Returns the index into the ChannelList that corresponds to the first sample in the internal buffer of the OlBuffer object.
Public property | Encoding | Returns the data encoding of the raw data (Binary or TwosComplement).
Public property | Item | Returns the data, as a raw count, at the specified index in the internal buffer of the OlBuffer object.
Public property | RawDataFormat | Returns the format of the raw data (Int16, Uint16, Int32, Float, or Double).
Public property | Resolution | Returns the resolution of the associated subsystem.
Public property | SampleSizeInBytes | Returns the size, in bytes, of the samples in the internal buffer of the OlBuffer object.
Public property | State | Returns the current state (Idle, Queued, InProcess, Completed, or Released) of the OlBuffer object.
Public property | Tag | Gets or sets a user-defined value.
Public property | ValidSamples | Returns the number of valid samples in the internal buffer of the OlBuffer object.
Public property | VoltageRange | Returns the upper and lower limits of the voltage range for the associated subsystem.

See Also

OlBuffer Class


OlBuffer Constructor

[image]

OpenLayers for .NET Documentation
OlBuffer Constructor
OlBuffer Class See Also Send Feedback
Creates and returns an OlBuffer object, and allocates an internal data buffer that will contain a specified number of samples.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer(
    int inNumSamples,
    AnalogSubsystem inSubsystem
)
Visual Basic
Public Sub New (
    inNumSamples As Integer,
    inSubsystem As AnalogSubsystem
)

Parameters

inNumSamples
Type: System..::..Int32
Maximum number of samples that the internal buffer can contain. This parameter determines the size of the internal buffer. Note that if you use the ReturnCjcTemperaturesInStream property to return CJC data in the data stream, ensure that you set the size of the internal buffer to be twice as large to accommodate the returned CJC values for each channel (iNumSamples = number of samples per channel x 2).
inSubsystem
Type: OpenLayers.Base..::..AnalogSubsystem
The subsystem (AnalogInputSubsystem or AnalogOutputSubsystem) with which the OlBuffer object is initially associated.

Remarks

The values for voltage range, channel list, data encoding, and resolution that are applied to the OlBuffer object are determined by the subsystem with which it is associated. Initially (and by default), these values are determined by the subsystem that is specified in the constructor above.

If, however, you later use the OlBuffer object with a different subsystem type, these values are determined by subsystem with which it is used. For example, if the OlBuffer object was initially associated with an analog output subsystem, and then put on an analog input subsystem queue, the values for voltage range, channel list, data encoding, and resolution will be updated to reflect the settings of the analog input subsystem when the OlBuffer object is completed by the device driver.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer Methods

[image] [image]

OpenLayers for .NET Documentation
OlBuffer Methods
OlBuffer Class See Also Send Feedback

The OlBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Deallocates the internal buffer of the OlBuffer object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataAsBridgeBasedSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.
Public method | GetDataAsBridgeBasedSensor(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.
Public method | GetDataAsCurrent | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into current values, and then copies these current values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsNormalizedBridgeOutput()()()() | Converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.
Public method | GetDataAsNormalizedBridgeOutput(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.
Public method | GetDataAsRawByte()()()() | Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawByte(ChannelListEntry) | Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).
Public method | GetDataAsRawInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).
Public method | GetDataAsRawUInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).
Public method | GetDataAsRawUInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).
Public method | GetDataAsRawUInt32()()()() | Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).
Public method | GetDataAsRawUInt32(ChannelListEntry) | Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).
Public method | GetDataAsResistance | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into resistance values, and then copies these resistance values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsRpm | For a specified ChannelListEntry, converts the tachometer data from the internal buffer of an OlBuffer object into RPM values, and then copies these values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsSensor(ChannelListEntry) | This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsStrain()()()() | Converts the data from the internal buffer of an OlBuffer object into strain values, and then copies these strain values into an array of 64-bit floating-point values (double).
Public method | GetDataAsStrain(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into microstrain values, and then copies these microstrain values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsTemperatureByte | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into temperature values, and then copies these temperature values into a user-declared array of bytes. Each temperature value is stored as an Int32, and takes 4 bytes.
Public method | GetDataAsTemperatureDouble | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into temperature values, and then copies these temperature values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsVolts()()()() | Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts(ChannelListEntry) | For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVoltsByte | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of bytes. Each voltage value is stored as an Int32, and takes 4 bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PutDataAsRaw(array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(ChannelListEntry, array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | Reallocate | Reallocates the internal data buffer of the OlBuffer object to contain the specified number of samples. The existing internal data buffer is deallocated and any data that it contained is lost.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OlBuffer Class


OlBuffer.Dispose Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Dispose Method
OlBuffer Class See Also Send Feedback
Deallocates the internal buffer of the OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsBridgeBasedSensor Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsBridgeBasedSensor Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsBridgeBasedSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.
Public method | GetDataAsBridgeBasedSensor(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsBridgeBasedSensor Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsBridgeBasedSensor Method
OlBuffer Class See Also Send Feedback
Converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsBridgeBasedSensor()
Visual Basic
Public Function GetDataAsBridgeBasedSensor As Double()

Return Value

Type: array<Double>[]()[][]
Returns a user-specified array of values, represented as 64-bit floating-point values (double).

Remarks

Any non-bridge channels in the ChannelList return 32-bit, raw, unsigned integer values.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsBridgeBasedSensor Overload


OlBuffer.GetDataAsBridgeBasedSensor Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsBridgeBasedSensor Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into native data values from a bridge-based sensor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsBridgeBasedSensor(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsBridgeBasedSensor (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.

Return Value

Type: array<Double>[]()[][]
An array of values, represented as 64-bit floating-point (double) values, that are associated with a specified ChannelListEntry.

Remarks

This method raises an exception if the IOType is not Bridge or Strain Gage.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsBridgeBasedSensor Overload


OlBuffer.GetDataAsCurrent Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsCurrent Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into current values, and then copies these current values into a user-declared array of 64-bit floating-point (double) values.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsCurrent(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsCurrent (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.

Return Value

Type: array<Double>[]()[][]
An array of current values, represented as 64-bit floating-point (double) values, that are associated with a specified ChannelListEntry.

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied. This method raises an exception if the IOType is not set Current.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsNormalizedBridgeOutput Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsNormalizedBridgeOutput Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsNormalizedBridgeOutput()()()() | Converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.
Public method | GetDataAsNormalizedBridgeOutput(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsNormalizedBridgeOutput Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsNormalizedBridgeOutput Method
OlBuffer Class See Also Send Feedback
Converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsNormalizedBridgeOutput()
Visual Basic
Public Function GetDataAsNormalizedBridgeOutput As Double()

Return Value

Type: array<Double>[]()[][]
Returns a user-specified array of mV/V values, represented as 64-bit floating-point values (double).

Remarks

Any non-bridge channels in the ChannelList return 32-bit, raw, unsigned integer values.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsNormalizedBridgeOutput Overload


OlBuffer.GetDataAsNormalizedBridgeOutput Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsNormalizedBridgeOutput Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into (mV/Vexc) data values from a bridge-based sensor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsNormalizedBridgeOutput(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsNormalizedBridgeOutput (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.

Return Value

Type: array<Double>[]()[][]
Returns a user-specified array of mV/V values, represented as 64-bit floating-point values (double), that are associated with a specified ChannelListEntry.

Remarks

This method raises an exception if the IOType is not StrainGage or Bridge.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsNormalizedBridgeOutput Overload


OlBuffer.GetDataAsRawByte Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawByte Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawByte()()()() | Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawByte(ChannelListEntry) | Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsRawByte Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawByte Method
OlBuffer Class See Also Send Feedback
Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public byte[] GetDataAsRawByte()
Visual Basic
Public Function GetDataAsRawByte As Byte()

Return Value

Type: array<Byte>[]()[][]
An array of raw counts represented as bytes.

Remarks

This method copies all the data, as raw counts, from the internal buffer into a user-declared array of bytes. This method is useful for file I/O operations. Since each sample takes more than one array entry, other uses may be limited.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawByte Overload


OlBuffer.GetDataAsRawByte Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawByte Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public byte[] GetDataAsRawByte(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawByte (
    channel As ChannelListEntry
) As Byte()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<Byte>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as bytes.

Remarks

Note that if the ChannelListEntry occurs more than once in the OlBuffer object, the data for each occurrence of the ChannelListEntry is copied. This method is useful for file I/O operations. Since each sample takes more than one array entry, other uses may be limited.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawByte Overload


OlBuffer.GetDataAsRawInt16 Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawInt16 Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).
Public method | GetDataAsRawInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsRawInt16 Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawInt16 Method
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short[] GetDataAsRawInt16()
Visual Basic
Public Function GetDataAsRawInt16 As Short()

Return Value

Type: array<Int16>[]()[][]
An array of raw counts represented as signed 16-bit integers (short).

Remarks

This method copies all the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawInt16 Overload


OlBuffer.GetDataAsRawInt16 Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawInt16 Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short[] GetDataAsRawInt16(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawInt16 (
    channel As ChannelListEntry
) As Short()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<Int16>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as signed 16-bit integers (short).

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawInt16 Overload


OlBuffer.GetDataAsRawUInt16 Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt16 Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawUInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).
Public method | GetDataAsRawUInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsRawUInt16 Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt16 Method
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ushort[] GetDataAsRawUInt16()
Visual Basic
Public Function GetDataAsRawUInt16 As UShort()

Return Value

Type: array<UInt16>[]()[][]
An array of raw counts represented as unsigned 16-bit integers (ushort).

Remarks

This method copies all the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt16 Overload


OlBuffer.GetDataAsRawUInt16 Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt16 Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ushort[] GetDataAsRawUInt16(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawUInt16 (
    channel As ChannelListEntry
) As UShort()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<UInt16>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as unsigned 16-bit integers (ushort).

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt16 Overload


OlBuffer.GetDataAsRawUInt32 Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt32 Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawUInt32()()()() | Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).
Public method | GetDataAsRawUInt32(ChannelListEntry) | Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsRawUInt32 Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt32 Method
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint[] GetDataAsRawUInt32()
Visual Basic
Public Function GetDataAsRawUInt32 As UInteger()

Return Value

Type: array<UInt32>[]()[][]
An array of raw counts represented as unsigned 32-bit integers (uint).

Remarks

This method copies all the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt32 Overload


OlBuffer.GetDataAsRawUInt32 Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt32 Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint[] GetDataAsRawUInt32(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawUInt32 (
    channel As ChannelListEntry
) As UInteger()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<UInt32>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as unsigned 32-bit integers (uint).

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt32 Overload


OlBuffer.GetDataAsResistance Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsResistance Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into resistance values, and then copies these resistance values into a user-declared array of 64-bit floating-point (double) values.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsResistance(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsResistance (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.

Return Value

Type: array<Double>[]()[][]
An array of resistance values, represented as 64-bit floating-point (double) values, that are associated with a specified ChannelListEntry.

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied. This method raises an exception if the IOType property for the channel is not Resistance.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsRpm Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRpm Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the tachometer data from the internal buffer of an OlBuffer object into RPM values, and then copies these values into a user-declared array of 64-bit floating-point (double) values.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsRpm(
    ChannelListEntry channel,
    int pulsesPerRevolution
)
Visual Basic
Public Function GetDataAsRpm (
    channel As ChannelListEntry,
    pulsesPerRevolution As Integer
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.
pulsesPerRevolution
Type: System..::..Int32
Specifies the number of pulses per revolution for the tachometer.

Return Value

Type: array<Double>[]()[][]
An array of RPM values, represented as 64-bit floating-point (double) values, that are associated with a specified ChannelListEntry.

Remarks

This method raises an exception if the SubsystemType is not a tachometer.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsSensor Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsSensor Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsSensor(ChannelListEntry) | This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsSensor Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsSensor Method
OlBuffer Class See Also Send Feedback
Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsSensor()
Visual Basic
Public Function GetDataAsSensor As Double()

Return Value

Type: array<Double>[]()[][]
A user-specified array of sensor values, represented as 64-bit floating-point values (double).

Remarks

This method copies all the samples from the buffer into a user-declared array of 64-bit floating-point values (double).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsSensor Overload


OlBuffer.GetDataAsSensor Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsSensor Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsSensor(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsSensor (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry, which represents the channel whose data you want to copy.

Return Value

Type: array<Double>[]()[][]
A user-declared array of sensor values associated with all the samples for a given ChannelListEntry, represented as 64-bit floating-point values (double).

Remarks

This method converts only the data associated with a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values, then copies this data into a user-declared array of 64-bit floating-point values (double). Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsSensor Overload


OlBuffer.GetDataAsStrain Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsStrain Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsStrain()()()() | Converts the data from the internal buffer of an OlBuffer object into strain values, and then copies these strain values into an array of 64-bit floating-point values (double).
Public method | GetDataAsStrain(ChannelListEntry) | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into microstrain values, and then copies these microstrain values into a user-declared array of 64-bit floating-point (double) values.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsStrain Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsStrain Method
OlBuffer Class See Also Send Feedback
Converts the data from the internal buffer of an OlBuffer object into strain values, and then copies these strain values into an array of 64-bit floating-point values (double).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsStrain()
Visual Basic
Public Function GetDataAsStrain As Double()

Return Value

Type: array<Double>[]()[][]
Returns a user-specified array of strain values, represented as 64-bit floating-point values (double).

Remarks

Any non-Strain Gage channels in the ChannelList return 32-bit, raw, unsigned integer values.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsStrain Overload


OlBuffer.GetDataAsStrain Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsStrain Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into microstrain values, and then copies these microstrain values into a user-declared array of 64-bit floating-point (double) values.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsStrain(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsStrain (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.

Return Value

Type: array<Double>[]()[][]
An array of microstrain values, represented as 64-bit floating-point (double) values, that are associated with a specified ChannelListEntry.

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied. This method raises an exception if the IOType is not StrainGage.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsStrain Overload


OlBuffer.GetDataAsTemperatureByte Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsTemperatureByte Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into temperature values, and then copies these temperature values into a user-declared array of bytes. Each temperature value is stored as an Int32, and takes 4 bytes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public byte[] GetDataAsTemperatureByte(
    ChannelListEntry channel,
    TemperatureUnit tempUnit,
    int scale
)
Visual Basic
Public Function GetDataAsTemperatureByte (
    channel As ChannelListEntry,
    tempUnit As TemperatureUnit,
    scale As Integer
) As Byte()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The units (Celsius, Fahrenheit, or Kelvin) for the temperature values.
scale
Type: System..::..Int32
The amount by which to scale each temperature value. By default, this is 1.

Return Value

Type: array<Byte>[]()[][]
An array of temperature values that is associated with a specified ChannelListEntry, represented as bytes.

Remarks

This method converts only the data associated with a specified ChannelListEntry in the buffer into temperature values, and then copies this data into a user-declared array of bytes.

For thermocouple channels, the data is converted into temperature based on the channel's ThermocoupleType property.

For RTD channels, the data is converted into temperature based on the channel's RTDType, RtdR0, RtdACoefficient, RtdBCoefficient, and RtdCCoefficient properties.

For thermistor channels, the data is converted into temperature based on the channel's ThermistorACoefficient, ThermistorBCoefficient, and ThermistorCCoefficient properties.

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is converted and copied.

If SupportsTemperatureDataInStream is True, this method raises an exception if the ThermocoupleType is set to None. If ReturnCjcTemperaturesInStream is set to True, the CJC values (in temperature) are interleaved with the channel data, where the first value represents the temperature of the input channel and the second value represents the CJC temperature, in degrees C; the returned array will be twice the number of valid samples (ValidSamples).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsTemperatureDouble Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsTemperatureDouble Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into temperature values, and then copies these temperature values into a user-declared array of 64-bit floating-point (double) values.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsTemperatureDouble(
    ChannelListEntry channel,
    TemperatureUnit tempUnit
)
Visual Basic
Public Function GetDataAsTemperatureDouble (
    channel As ChannelListEntry,
    tempUnit As TemperatureUnit
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The units (Celsius, Fahrenheit, or Kelvin) for the temperature values.

Return Value

Type: array<Double>[]()[][]
An array of temperature values that are associated with a specified ChannelListEntry, represented as 64-bit floating-point values (double).

Remarks

This method converts only the data associated with a specified ChannelListEntry in the buffer into temperature values, and then copies this data into a user-declared array of 64-bit floating-point values (double).

For thermocouple channels, the data is converted into temperature based on the channel's ThermocoupleType property.

For RTD channels, the data is converted into temperature based on the channel's RTDType, RtdR0, RtdACoefficient, RtdBCoefficient, and RtdCCoefficient properties.

For thermistor channels, the data is converted into temperature based on the channel's ThermistorACoefficient, ThermistorBCoefficient, and ThermistorCCoefficient properties.

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is converted and copied.

If SupportsTemperatureDataInStream is True, this method raises an exception if the ThermocoupleType is set to None. If ReturnCjcTemperaturesInStream is set to True, the CJC values (in temperature) are interleaved with the channel data, where the first value represents the temperature of the input channel and the second value represents the CJC temperature, in degrees C; the returned array will be twice the number of valid samples (ValidSamples).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsVolts Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVolts Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsVolts()()()() | Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts(ChannelListEntry) | For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.GetDataAsVolts Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVolts Method
OlBuffer Class See Also Send Feedback
Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsVolts()
Visual Basic
Public Function GetDataAsVolts As Double()

Return Value

Type: array<Double>[]()[][]
Returns a user-specified array of voltage values, represented as 64-bit floating-point values (double).

Remarks

This method copies all the data, as voltages, from the internal buffer of an OlBuffer object into a user-declared array of 64-bit floating-point values (double).

For thermocouple channels (IOType is Thermocouple), the ThermocoupleType property is typically set to None before using this method. However, if the ThermocoupleType property is set to a value other than None, this method returns the values of the channels in temperature. Additionally, if ReturnCjcTemperaturesInStream is set to True, the CJC values (in temperature) are interleaved with the channel data, where the first value represents the temperature or voltage of the input channel (based on the ThermocoupleType), and the second value represents the CJC temperature, in degrees C; the returned array will be twice the number of valid samples (ValidSamples).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsVolts Overload


OlBuffer.GetDataAsVolts Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVolts Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsVolts(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsVolts (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<Double>[]()[][]
An array of voltages that are associated with a specified ChannelListEntry, represented as 64-bit floating-point values (double).

Remarks

This method converts only the data associated with a specified ChannelListEntry in the buffer into voltage values, and then copies this data into a user-declared array of 64-bit floating-point values (double). Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

For thermocouple channels (IOType property is Thermocouple), the ThermocoupleType property is typically set to None before using this method. However, if the ThermocoupleType property is set to a value other than None, this method returns the value of the channel in temperature. Additionally, if ReturnCjcTemperaturesInStream is set to True, the CJC values (in temperature) are interleaved with the channel data, where the first value represents the temperature or voltage of the input channel (based on the ThermocoupleType), and the second value represents the CJC temperature, in degrees C; the returned array will be twice the number of valid samples (ValidSamples).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsVolts Overload


OlBuffer.GetDataAsVoltsByte Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVoltsByte Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of bytes. Each voltage value is stored as an Int32, and takes 4 bytes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public byte[] GetDataAsVoltsByte(
    ChannelListEntry channel,
    int scale
)
Visual Basic
Public Function GetDataAsVoltsByte (
    channel As ChannelListEntry,
    scale As Integer
) As Byte()

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.
scale
Type: System..::..Int32
The amount by which to scale each voltage value. By default, this is 1.

Return Value

Type: array<Byte>[]()[][]
An array of voltage values that is associated with a specified ChannelListEntry, represented as bytes.

Remarks

This method converts only the data associated with a specified ChannelListEntry in the buffer into voltage values, and then copies this data into a user-declared array of bytes. Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is converted and copied.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.PutDataAsRaw Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PutDataAsRaw(array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.PutDataAsRaw Method (UInt16[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (array<UInt16>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    ushort[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    data As UShort()
)

Parameters

data
Type: array<System..::..UInt16>[]()[][]
The user-specified array of raw counts to copy, represented as unsigned 16-bit integers (ushort).

Remarks

Used when the resolution of the subsystem is 16 bits or less, copies all the data, as raw counts, from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload


OlBuffer.PutDataAsRaw Method (UInt32[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (array<UInt32>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    uint[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    data As UInteger()
)

Parameters

data
Type: array<System..::..UInt32>[]()[][]
The user-specified array of raw counts to copy, represented as unsigned 32-bit integers (uint).

Remarks

Used when the resolution of the subsystem is greater than 16 bits, copies all the data, as raw counts, from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload


OlBuffer.PutDataAsRaw Method (ChannelListEntry, UInt16[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (ChannelListEntry, array<UInt16>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    ChannelListEntry channel,
    ushort[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    channel As ChannelListEntry,
    data As UShort()
)

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.
data
Type: array<System..::..UInt16>[]()[][]
The user-specified array containing the channel data, in raw counts, to copy. This data is represented as unsigned 16-bit integers (ushort).

Remarks

Used when the resolution of the subsystem is 16 bits or less, copies only the raw count values for a specified ChannelListEntry from a user-specified array into the internal buffer of an OlBuffer object.

Remarks

Note that if the ChannelListEntry occurs more than once in the array, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload


OlBuffer.PutDataAsRaw Method (ChannelListEntry, UInt32[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (ChannelListEntry, array<UInt32>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    ChannelListEntry channel,
    uint[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    channel As ChannelListEntry,
    data As UInteger()
)

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.
data
Type: array<System..::..UInt32>[]()[][]
The user-specified array containing the channel data, in raw counts, to copy. This data is represented as unsigned 32-bit integers (uint).

Remarks

Used when the resolution of the subsystem is greater than 16 bits, copies only the raw count values for a specified ChannelListEntry from a user-specified array into the internal buffer of an OlBuffer object.

Remarks

Note that if the ChannelListEntry occurs more than once in the array, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload


OlBuffer.PutDataAsVolts Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsVolts Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PutDataAsVolts(array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(ChannelListEntry, array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.PutDataAsVolts Method (Double[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsVolts Method (array<Double>[]()[][])
OlBuffer Class See Also Send Feedback
Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsVolts(
    double[] data
)
Visual Basic
Public Sub PutDataAsVolts (
    data As Double()
)

Parameters

data
Type: array<System..::..Double>[]()[][]
The user-specified array containing the voltage values to copy. The data is represented as 64-bit floating-point values (double).

Remarks

This method copies all the voltage values from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsVolts Overload


OlBuffer.PutDataAsVolts Method (ChannelListEntry, Double[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsVolts Method (ChannelListEntry, array<Double>[]()[][])
OlBuffer Class See Also Send Feedback
Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsVolts(
    ChannelListEntry channel,
    double[] data
)
Visual Basic
Public Sub PutDataAsVolts (
    channel As ChannelListEntry,
    data As Double()
)

Parameters

channel
Type: OpenLayers.Base..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.
data
Type: array<System..::..Double>[]()[][]
The user-specified array containing the channel data, in voltage, to copy. This data is represented as 64-bit floating-point values (double).

Remarks

This method copies only the voltage values for a specified ChannelListEntry from a user-specified array into the internal buffer of an OlBuffer object.

Remarks

Note that if the ChannelListEntry occurs more than once in the array, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsVolts Overload


OlBuffer.Reallocate Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Reallocate Method
OlBuffer Class See Also Send Feedback
Reallocates the internal data buffer of the OlBuffer object to contain the specified number of samples. The existing internal data buffer is deallocated and any data that it contained is lost.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Reallocate(
    int inNumSamples
)
Visual Basic
Public Function Reallocate (
    inNumSamples As Integer
) As Boolean

Parameters

inNumSamples
Type: System..::..Int32
Maximum number of samples that the internal data buffer can contain. This parameter determines the size of the internal buffer. Note that if you use the ReturnCjcTemperaturesInStream property to return CJC data in the data stream, ensure that you set the size of the internal buffer to be twice as large to accommodate the returned CJC values for each channel (iNumSamples = number of samples per channel x 2).

Return Value

Type: Boolean
True if allocation was successful; otherwise, returns False.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer Properties

[image] [image]

OpenLayers for .NET Documentation
OlBuffer Properties
OlBuffer Class See Also Send Feedback

The OlBuffer type exposes the following members.

Properties

 | Name | Description
Public property | BufferSizeInBytes | Returns the size of the internal data buffer, in bytes.
Public property | BufferSizeInSamples | Returns the size of the internal data buffer, in samples.
Public property | ChannelListOffset | Returns the index into the ChannelList that corresponds to the first sample in the internal buffer of the OlBuffer object.
Public property | Encoding | Returns the data encoding of the raw data (Binary or TwosComplement).
Public property | Item | Returns the data, as a raw count, at the specified index in the internal buffer of the OlBuffer object.
Public property | RawDataFormat | Returns the format of the raw data (Int16, Uint16, Int32, Float, or Double).
Public property | Resolution | Returns the resolution of the associated subsystem.
Public property | SampleSizeInBytes | Returns the size, in bytes, of the samples in the internal buffer of the OlBuffer object.
Public property | State | Returns the current state (Idle, Queued, InProcess, Completed, or Released) of the OlBuffer object.
Public property | Tag | Gets or sets a user-defined value.
Public property | ValidSamples | Returns the number of valid samples in the internal buffer of the OlBuffer object.
Public property | VoltageRange | Returns the upper and lower limits of the voltage range for the associated subsystem.

See Also

OlBuffer Class


OlBuffer.BufferSizeInBytes Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..BufferSizeInBytes Property
OlBuffer Class See Also Send Feedback
Returns the size of the internal data buffer, in bytes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int BufferSizeInBytes { get; }
Visual Basic
Public ReadOnly Property BufferSizeInBytes As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.BufferSizeInSamples Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..BufferSizeInSamples Property
OlBuffer Class See Also Send Feedback
Returns the size of the internal data buffer, in samples.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int BufferSizeInSamples { get; }
Visual Basic
Public ReadOnly Property BufferSizeInSamples As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.ChannelListOffset Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..ChannelListOffset Property
OlBuffer Class See Also Send Feedback
Returns the index into the ChannelList that corresponds to the first sample in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ChannelListOffset { get; }
Visual Basic
Public ReadOnly Property ChannelListOffset As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.Encoding Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Encoding Property
OlBuffer Class See Also Send Feedback
Returns the data encoding of the raw data (Binary or TwosComplement).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Encoding Encoding { get; }
Visual Basic
Public ReadOnly Property Encoding As Encoding
    Get

Property Value

Type: Encoding

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.Item Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Item Property
OlBuffer Class See Also Send Feedback
Returns the data, as a raw count, at the specified index in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As Integer
    Get

Parameters

index
Type: System..::..Int32

Return Value

Type: Int32
The raw count, represented as a signed, 32-bit integer (int).

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.RawDataFormat Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..RawDataFormat Property
OlBuffer Class See Also Send Feedback
Returns the format of the raw data (Int16, Uint16, Int32, Float, or Double).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelDataType RawDataFormat { get; }
Visual Basic
Public ReadOnly Property RawDataFormat As ChannelDataType
    Get

Property Value

Type: ChannelDataType

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.Resolution Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Resolution Property
OlBuffer Class See Also Send Feedback
Returns the resolution of the associated subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.SampleSizeInBytes Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..SampleSizeInBytes Property
OlBuffer Class See Also Send Feedback
Returns the size, in bytes, of the samples in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int SampleSizeInBytes { get; }
Visual Basic
Public ReadOnly Property SampleSizeInBytes As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.State Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..State Property
OlBuffer Class See Also Send Feedback
Returns the current state (Idle, Queued, InProcess, Completed, or Released) of the OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer..::..BufferState State { get; }
Visual Basic
Public ReadOnly Property State As OlBuffer..::..BufferState
    Get

Property Value

Type: OlBuffer..::..BufferState

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.Tag Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Tag Property
OlBuffer Class See Also Send Feedback
Gets or sets a user-defined value.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Tag { get; set; }
Visual Basic
Public Property Tag As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.ValidSamples Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..ValidSamples Property
OlBuffer Class See Also Send Feedback
Returns the number of valid samples in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ValidSamples { get; }
Visual Basic
Public ReadOnly Property ValidSamples As Integer
    Get

Property Value

Type: Int32

Remarks

For analog input operations, the ValidSamples property is set to the number of samples in the completed buffer under normal circumstances. However, in some cases, like if Abort()()()() is called in the middle of an operation, ValidSamples reflects the number of samples in the buffer when Abort was called. In addition, if Abort or Stop()()()() is called, any OlBuffer objects whose state is Inprocess will have a ValidSamples of 0.

If your device supports thermocouples (SupportsThermocouple is True), and ReturnCjcTemperaturesInStream is set to True, CJC values (in temperature) are interleaved with the channel data in the buffer, where the first value represents the temperature or voltage of the input channel (based on the ThermocoupleType), and the second value represents the CJC temperature, in degrees C. In this case, the returned array will be twice the number of valid samples (ValidSamples).

For analog output operations, ValidSamples is always equal to the maximum number of samples that the buffer was allocated to hold. If you are using thermocouples and ReturnCjcTemperaturesInStream is set to True, CJC values will be interleaved with the channel data; therefore, the returned array will be twice the number of valid samples.

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.VoltageRange Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..VoltageRange Property
OlBuffer Class See Also Send Feedback
Returns the upper and lower limits of the voltage range for the associated subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range VoltageRange { get; }
Visual Basic
Public ReadOnly Property VoltageRange As Range
    Get

Property Value

Type: Range

See Also

OlBuffer Class
OlBuffer Members


OlBuffer.BufferState Enumeration

[image]

OpenLayers for .NET Documentation
OlBuffer..::..BufferState Enumeration
OlBuffer Class See Also Send Feedback
Contains the possible values for the state of an OlBuffer object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum BufferState
Visual Basic
Public Enumeration BufferState

Members

Member name | Value | Description
Idle | 0 | The OlBuffer object has been created, but has not been queued to a subsystem.
Queued | 1 | The OlBuffer object has been queued to a subsystem.
InProcess | 2 | The OlBuffer object has been sent to the device driver for processing. A maximum of eight OlBuffer objects can be in process at one time.
Completed | 3 | For an input operation, the internal buffer of the OlBuffer object has been filled with data, and has not been put back on the queue for the subsystem. For an output operation, all the data in the internal buffer of the OlBuffer object has been output, and the OlBuffer object has not been put back on the queue for the subsystem.
Released | 4 | The internal buffer of the OlBuffer object has been deallocated.

See Also


OlError Class

[image]

OpenLayers for .NET Documentation
OlError Class
Members See Also Send Feedback
An OlError object encapsulates an Open Layers error code.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class OlError
Visual Basic
Public Class OlError

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..OlError

See Also

OlError Members


OlError Members

[image] [image]

OpenLayers for .NET Documentation
OlError Members
OlError Class Constructors Methods See Also Send Feedback

The OlError type exposes the following members.

Constructors

 | Name | Description
Public method | OlError | Creates and returns an OlError object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetErrorCode | Returns the error code that is associated with a specified error message in the DT-Open Layers for .NET Class Library.
 | GetErrorString | Returns a description for the specified error code in the DT-Open Layers for .NET Class Library.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OlError Class


OlError Constructor

[image]

OpenLayers for .NET Documentation
OlError Constructor
OlError Class See Also Send Feedback
Creates and returns an OlError object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlError(
    ErrorCode errorCode
)
Visual Basic
Public Sub New (
    errorCode As ErrorCode
)

Parameters

errorCode
Type: OpenLayers.Base..::..ErrorCode
The Open Layers ErrorCode that is accessible using an OlException object.

See Also

OlError Class
OlError Members


OlError Methods

[image] [image]

OpenLayers for .NET Documentation
OlError Methods
OlError Class See Also Send Feedback

The OlError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetErrorCode | Returns the error code that is associated with a specified error message in the DT-Open Layers for .NET Class Library.
 | GetErrorString | Returns a description for the specified error code in the DT-Open Layers for .NET Class Library.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OlError Class


OlError.GetErrorCode Method

[image]

OpenLayers for .NET Documentation
OlError..::..GetErrorCode Method
OlError Class See Also Send Feedback
Returns the error code that is associated with a specified error message in the DT-Open Layers for .NET Class Library.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static ErrorCode GetErrorCode(
    string ErrString
)
Visual Basic
Public Shared Function GetErrorCode (
    ErrString As String
) As ErrorCode

Parameters

ErrString
Type: System..::..String
The error message for which to return the error code.

Return Value

Type: ErrorCode
The error code that is associated with the specified error message.

See Also

OlError Class
OlError Members


OlError.GetErrorString Method

[image]

OpenLayers for .NET Documentation
OlError..::..GetErrorString Method
OlError Class See Also Send Feedback
Returns a description for the specified error code in the DT-Open Layers for .NET Class Library.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static string GetErrorString(
    ErrorCode ErrCode
)
Visual Basic
Public Shared Function GetErrorString (
    ErrCode As ErrorCode
) As String

Parameters

ErrCode
Type: OpenLayers.Base..::..ErrorCode
The error code for which to return the description.

Return Value

Type: String
A description of the specified error code.

See Also

OlError Class
OlError Members


OlException Class

[image]

OpenLayers for .NET Documentation
OlException Class
Members See Also Send Feedback
The OlException class provides properites for handling Open Layers errors that can be generated by the library.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
[SerializableAttribute]
public class OlException : SystemException,
    ISerializable
Visual Basic
<SerializableAttribute>
Public Class OlException
    Inherits SystemException
    Implements ISerializable

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
OpenLayers.Base..::..OlException

See Also

OlException Members


OlException Members

[image] [image]

OpenLayers for .NET Documentation
OlException Members
OlException Class Constructors Methods Properties See Also Send Feedback

The OlException type exposes the following members.

Constructors

 | Name | Description
Public method | OlException | For internal use only.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with this exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns the descriptive string for the exception. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | Subsystem | Returns the subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that raised the exception. If the exception is not related to a specific subsystem, returns null.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OlException Class


OlException Constructor

[image]

OpenLayers for .NET Documentation
OlException Constructor
OlException Class See Also Send Feedback
For internal use only.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlException(
    SerializationInfo si,
    StreamingContext context
)
Visual Basic
Public Sub New (
    si As SerializationInfo,
    context As StreamingContext
)

Parameters

si
Type: System.Runtime.Serialization..::..SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
Streaming context.

See Also

OlException Class
OlException Members


OlException Methods

[image] [image]

OpenLayers for .NET Documentation
OlException Methods
OlException Class See Also Send Feedback

The OlException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

OlException Class


OlException Properties

[image] [image]

OpenLayers for .NET Documentation
OlException Properties
OlException Class See Also Send Feedback

The OlException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with this exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns the descriptive string for the exception. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | Subsystem | Returns the subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that raised the exception. If the exception is not related to a specific subsystem, returns null.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OlException Class


OlException.ErrorCode Property

[image]

OpenLayers for .NET Documentation
OlException..::..ErrorCode Property
OlException Class See Also Send Feedback
Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with this exception.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ErrorCode ErrorCode { get; }
Visual Basic
Public ReadOnly Property ErrorCode As ErrorCode
    Get

Property Value

Type: ErrorCode

See Also

OlException Class
OlException Members


OlException.Message Property

[image]

OpenLayers for .NET Documentation
OlException..::..Message Property
OlException Class See Also Send Feedback
Returns the descriptive string for the exception.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_Exception..::..Message

See Also

OlException Class
OlException Members


OlException.Subsystem Property

[image]

OpenLayers for .NET Documentation
OlException..::..Subsystem Property
OlException Class See Also Send Feedback
Returns the subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that raised the exception. If the exception is not related to a specific subsystem, returns null.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase Subsystem { get; }
Visual Basic
Public ReadOnly Property Subsystem As SubsystemBase
    Get

Property Value

Type: SubsystemBase

See Also

OlException Class
OlException Members


PhysicalMeasurandUnits Enumeration

[image]

OpenLayers for .NET Documentation
PhysicalMeasurandUnits Enumeration
See Also Send Feedback
Physical Measurand (Units)

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum PhysicalMeasurandUnits
Visual Basic
Public Enumeration PhysicalMeasurandUnits

Members

Member name | Value | Description
Temperature_Kelvin | 0 | Temperature (Kelvin)
Temperature_Celsius | 1 | Temperature (Celsius)
Strain | 2 | Strain
Microstrain | 3 | Microstrain
Newton | 4 | Force/Weight (Newton)
Pounds | 5 | Force/Weight (pounds)
kilogramForcePerKilopound | 6 | Force/Weight (kilogram-force/kilopound)
Acceleration_m_ss | 7 | Acceleration (m/s²)
Acceleration_g | 8 | Acceleration (g)
Torque_Nm_Radian | 9 | Torque (Nm/radian)
Torque_Nm | 10 | Torque (Nm)
Torque_oz_in | 11 | Torque (oz-in)
Pressure_Pascal | 12 | Pressure (Pascal)
Pressure_PSI | 13 | Pressure (PSI)
Mass_Kg | 14 | Mass (kg)
Mass_g | 15 | Mass (g)
Distance_m | 16 | Distance (m)
Distance_mm | 17 | Distance (mm)
Distance_inches | 18 | Distance (inches)
Velocity_m_s | 19 | Velocity (m/s)
Velocity_mph | 20 | Velocity (mph)
Velocity_fps | 21 | Velocity (fps)
AngularPosition_radian | 22 | Angular Position (radian)
AngularPosition_degrees | 23 | Angular Position (degrees)
RotationalVelocity_radian_s | 24 | Rotational Velocity (radian/s)
RotationalVelocity_rpm | 25 | Rotational Velocity (rpm)
Frequency | 26 | Frequency
Concentration_gram_liter | 27 | Concentration (gram/liter)
Concentration_kg_liter | 28 | Concentration (kg/liter)
MolarConcentration_mole_m3 | 29 | Molar Concentration (mole/m³)
MolarConcentration_mole_l | 30 | Molar Concentration (mole/l)
VolumetricConcentration_m3_m3 | 31 | Volumetric Concentration (m³/m³)
VolumetricConcentration_l_l | 32 | Volumetric Concentration (l/l)
MassFlow | 33 | Mass Flow
VolumetricFlow_m3_s | 34 | Volumetric Flow (m³/s)
VolumetricFlow_m3_hr | 35 | Volumetric Flow (m³/hr)
VolumetricFlow_gpm | 36 | Volumetric Flow (gpm)
VolumetricFlow_cfm | 37 | Volumetric Flow (cfm)
VolumetricFlow_l_min | 38 | Volumetric Flow (l/min)
RelativeHumidity | 39 | Relative Humidity
Ratio_percent | 40 | Ratio (percent)
Voltage | 41 | Voltage
RmsVoltage | 42 | RMS Voltage
Current | 43 | Current
RmsCurrent | 44 | RMS Current
Power_Watts | 45 | Power (Watts)

See Also


PowerSource Enumeration

[image]

OpenLayers for .NET Documentation
PowerSource Enumeration
See Also Send Feedback
Contains the possible values for the PowerSource property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum PowerSource
Visual Basic
Public Enumeration PowerSource

Members

Member name | Value | Description
Internal | 1 | The device is powered by the internal system power.
External | 2 | The device is powered by an external power source.

See Also


PreTriggerBufferDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
PreTriggerBufferDoneHandler Delegate
See Also Send Feedback
The PreTriggerBufferDoneHandler delegate is called when the event PreTriggerBufferDoneEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void PreTriggerBufferDoneHandler(
    Object sender,
    BufferDoneEventArgs eventArgs
)
Visual Basic
Public Delegate Sub PreTriggerBufferDoneHandler (
    sender As Object,
    eventArgs As BufferDoneEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..BufferDoneEventArgs
The BufferDoneEventArgs object that is associated with the event PreTriggerBufferDoneEvent.

Remarks

The event PreTriggerBufferDone is raised when the internal buffer of an OlBuffer object is filled with pre-trigger data (for an input operation only).

See Also


PulseType Enumeration

[image]

OpenLayers for .NET Documentation
PulseType Enumeration
See Also Send Feedback
Contains the possible values for the PulseType property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum PulseType
Visual Basic
Public Enumeration PulseType

Members

Member name | Value | Description
HighToLow | 600 | The low portion of the total pulse output period is the active portion of the counter/timer clock output signal.
LowToHigh | 601 | The high portion of the total pulse output period is the active portion of the counter/timer pulse output signal.

See Also


QuadratureDecoderSubsystem Class

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem Class
Members See Also Send Feedback
The QuadratureDecoderSubsystem class provides the properties, methods, and events for performing quadrature decoder operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class QuadratureDecoderSubsystem : SubsystemBase
Visual Basic
Public Class QuadratureDecoderSubsystem
    Inherits SubsystemBase

Remarks

Instances of this class are created using the QuadratureDecoderSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..QuadratureDecoderSubsystem

See Also

QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem Members
QuadratureDecoderSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The QuadratureDecoderSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | QuadratureDecoderSubsystem | Returns a QuadratureDecoderSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops a quadrature decoder operation. For this subsystem type, Abort behaves like Stop()()()(). (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadCount | Returns the current count of the quadrature decoder.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a quadrature decoder operation. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops the current quadrature decoder operation. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the quadrature decoder subsystem and element. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | ClockPreScale | Gets and sets the clock prescale value for the quadrature decoder subsystem. The ClockPreScale property allows you to filter the sampling frequency of the onboard base clock by dividing down the base frequency. Values for this property range from 0 and 255, where 0 corresponds to an actual pre-scale value of 1, and 255 corresponds to an actual prescale value of 256.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Overrides SubsystemBase..::..Element.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IndexMode | Gets/sets the index mode (Disabled, Low, or High) for the quadrature decoder subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (QuadratureDecoder). (Overrides SubsystemBase..::..SubsystemType.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | X4Scaling | Gets and sets the quadrature decoder scaling mode (X1 or X4).

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

QuadratureDecoderSubsystem Class


QuadratureDecoderSubsystem Constructor

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem Constructor
QuadratureDecoderSubsystem Class See Also Send Feedback
Returns a QuadratureDecoderSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public QuadratureDecoderSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.Base..::..Device
The Open Layers Device object with which to associate the quadrature decoder subsystem.
element
Type: System..::..Int32
The Element number of the quadrature decoder subsystem.

Remarks

It is recommended that you use the QuadratureDecoderSubsystem(Int32) method rather than this constructor to return a quadrature decoder subsystem.

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem Methods
QuadratureDecoderSubsystem Class See Also Send Feedback

The QuadratureDecoderSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops a quadrature decoder operation. For this subsystem type, Abort behaves like Stop()()()(). (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadCount | Returns the current count of the quadrature decoder.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a quadrature decoder operation. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops the current quadrature decoder operation. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the quadrature decoder subsystem and element. (Overrides Object..::..ToString()()()().)

See Also

QuadratureDecoderSubsystem Class


QuadratureDecoderSubsystem.Abort Method

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..Abort Method
QuadratureDecoderSubsystem Class See Also Send Feedback
Stops a quadrature decoder operation. For this subsystem type, Abort behaves like Stop()()()().

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Abort()
Visual Basic
Public Overrides Sub Abort

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.ReadCount Method

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..ReadCount Method
QuadratureDecoderSubsystem Class See Also Send Feedback
Returns the current count of the quadrature decoder.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public long ReadCount()
Visual Basic
Public Function ReadCount As Long

Return Value

Type: Int64
The current value of the quadrature decoder.

Remarks

You can read the count of the quadrature decoder to determine relative or absolute position and/or rotational speed.

For example, in an X/Y positioning application, you could use one quadrature decoder to determine the position on the X-plane, and another quadrature decoder to determine the position on the Y-plane. You can also reset the value of the decoder to 0 whenever a selected edge (high or low) of the Index signal goes high or low.

To determine the rotation of a quadrature encoder, use the following formula: Rotation degrees = Count/(4*N) x 360 degrees, where N is the number of pulses generated by the quadrature encoder per rotation. For example, if every rotation of the quadrature encoder generated 10 pulses, and the value read from the quadrature decoder is 20, the rotation of the quadrature encoder is 180 degrees (20/40 x 360 degrees).

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.Start Method

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..Start Method
QuadratureDecoderSubsystem Class See Also Send Feedback
Starts a quadrature decoder operation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Start()
Visual Basic
Public Overrides Sub Start

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.Stop Method

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..Stop Method
QuadratureDecoderSubsystem Class See Also Send Feedback
Stops the current quadrature decoder operation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Stop()
Visual Basic
Public Overrides Sub Stop

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..ToString Method
QuadratureDecoderSubsystem Class See Also Send Feedback
Returns a description of the quadrature decoder subsystem and element.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the quadrature decoder subsystem and element.

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem Properties
QuadratureDecoderSubsystem Class See Also Send Feedback

The QuadratureDecoderSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | ClockPreScale | Gets and sets the clock prescale value for the quadrature decoder subsystem. The ClockPreScale property allows you to filter the sampling frequency of the onboard base clock by dividing down the base frequency. Values for this property range from 0 and 255, where 0 corresponds to an actual pre-scale value of 1, and 255 corresponds to an actual prescale value of 256.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Overrides SubsystemBase..::..Element.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IndexMode | Gets/sets the index mode (Disabled, Low, or High) for the quadrature decoder subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (QuadratureDecoder). (Overrides SubsystemBase..::..SubsystemType.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | X4Scaling | Gets and sets the quadrature decoder scaling mode (X1 or X4).

See Also

QuadratureDecoderSubsystem Class


QuadratureDecoderSubsystem.ClockPreScale Property

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..ClockPreScale Property
QuadratureDecoderSubsystem Class See Also Send Feedback
Gets and sets the clock prescale value for the quadrature decoder subsystem. The ClockPreScale property allows you to filter the sampling frequency of the onboard base clock by dividing down the base frequency. Values for this property range from 0 and 255, where 0 corresponds to an actual pre-scale value of 1, and 255 corresponds to an actual prescale value of 256.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short ClockPreScale { get; set; }
Visual Basic
Public Property ClockPreScale As Short
    Get
    Set

Property Value

Type: Int16

Remarks

For quadrature decoder operations, the onboard base clock of the hardware device is used to sample the A and B inputs. Use the BaseClockFrequency to get the base clock frequency that is used by your device. From a software perspective, the software considers the A and B inputs as external clock sources, therefore, you must specify the clock source as External using the Source property.

If you are using a device with a base clock of 36 MHz and specify a pre-scale value of 0, the resulting sampling frequency is 36 MHz (36 MHz/1). Similarly, if you specify a pre-scale value of 255 when using a device with a 48 MHz base clock, the resulting sampling frequency is 18.75 kHz (48 MHz/256).

The filter samples the incoming A and B signals twice, and when it samples a change in the state of any of these signals and the change is present for two samples, the change on the inputs is valid. A minimum of 4 clock pulses is needed to sample each edge of the A and B inputs in one cycle (for a total of 16 clock pulses). In addition, the minimum time between one edge and the next edge is 112 ns. So, if you are using a 36 MHz sample frequency, the A and B inputs can have a maximum frequency of 2.23 MHz, or a period of 448 ns.

In general, if the ClockPreScale value is set too low, the system is more susceptible to noise on the inputs. If the ClockPreScale value is set too high, counts may be missed.

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.Element Property

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..Element Property
QuadratureDecoderSubsystem Class See Also Send Feedback
Returns the element number of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override int Element { get; }
Visual Basic
Public Overrides ReadOnly Property Element As Integer
    Get

Property Value

Type: Int32

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.IndexMode Property

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..IndexMode Property
QuadratureDecoderSubsystem Class See Also Send Feedback
Gets/sets the index mode (Disabled, Low, or High) for the quadrature decoder subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public QuadratureIndexMode IndexMode { get; set; }
Visual Basic
Public Property IndexMode As QuadratureIndexMode
    Get
    Set

Property Value

Type: QuadratureIndexMode

Remarks

If you set this property to Disabled, then the Index input signal has no effect. Note that you must set the IndexMode property to Disabled if you set the X4Scaling property to True.

If you set this property to Low, then the quadrature decoder resets its value to 0 whenever it detects a low edge (falling edge) on the Index input signal.

If you set this property to High, then the quadrature decoder resets its value to 0 whenever it detects the high edge (rising edge) on the Index input signal.

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.SubsystemType Property

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..SubsystemType Property
QuadratureDecoderSubsystem Class See Also Send Feedback
Returns the subsystem type (QuadratureDecoder).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override SubsystemType SubsystemType { get; }
Visual Basic
Public Overrides ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem.X4Scaling Property

[image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem..::..X4Scaling Property
QuadratureDecoderSubsystem Class See Also Send Feedback
Gets and sets the quadrature decoder scaling mode (X1 or X4).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool X4Scaling { get; set; }
Visual Basic
Public Property X4Scaling As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Setting this property to False selects X1 mode; in X1 mode, the decoder generates one clock pulse for every complete cycle of the A and B inputs.

Setting this property to True selects X4 mode; in X4 mode, the decoder generates one clock pulse for each edge of the A and B signals – four edges for each cycle of the A and B inputs.

Note that you must set the IndexMode property to Disabled if you set the X4Scaling property to True.

See Also

QuadratureDecoderSubsystem Class
QuadratureDecoderSubsystem Members


QuadratureDecoderSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
QuadratureDecoderSubsystem Events
QuadratureDecoderSubsystem Class See Also Send Feedback

The QuadratureDecoderSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

QuadratureDecoderSubsystem Class


QuadratureIndexMode Enumeration

[image]

OpenLayers for .NET Documentation
QuadratureIndexMode Enumeration
See Also Send Feedback
Contains the possible values for the IndexMode property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum QuadratureIndexMode
Visual Basic
Public Enumeration QuadratureIndexMode

Members

Member name | Value | Description
Disabled | 1400 | If Disabled, the Index input signal has no effect on the operation of the quadrature decoder.
Low | 1401 | If Low, then the quadrature decoder resets its value to 0 whenever it detects a falling edge on the Index input signal.
High | 1402 | If High, then the quadrature decoder resets its value to 0 whenever it detects the rising edge on the Index input signal.

See Also


QueueDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
QueueDoneHandler Delegate
See Also Send Feedback
The QueueDoneHandler delegate is called when the event QueueDoneEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void QueueDoneHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub QueueDoneHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event QueueDoneEvent.

Remarks

The event QueueDoneEvent is raised when no OlBuffer objects are available on the queue and the operation stops.

See Also


QueueStoppedHandler Delegate

[image]

OpenLayers for .NET Documentation
QueueStoppedHandler Delegate
See Also Send Feedback
The QueueStoppedHandler delegate is called when the event QueueStoppedEvent occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void QueueStoppedHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub QueueStoppedHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.Base..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event QueueStoppedEvent.

Remarks

A QueueStoppedEvent is raised when Stop or Abort is called for a continuous analog I/O operation. The event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.

See Also


Range Class

[image]

OpenLayers for .NET Documentation
Range Class
Members See Also Send Feedback
This class is used by the VoltageRange and SupportedVoltageRanges methods to return the lower and upper limits of the voltage range for an analog subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class Range
Visual Basic
Public Class Range

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..Range

See Also

Range Members


Range Members

[image] [image]

OpenLayers for .NET Documentation
Range Members
Range Class Constructors Methods Properties See Also Send Feedback

The Range type exposes the following members.

Constructors

 | Name | Description
Public method | Range | Initializes a new instance of a Range object with the specified lower and upper limits of the voltage range.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | High | Gets or sets the upper limit of the voltage range.
Public property | Low | Gets or sets the lower limit of the voltage range.

See Also

Range Class


Range Constructor

[image]

OpenLayers for .NET Documentation
Range Constructor
Range Class See Also Send Feedback
Initializes a new instance of a Range object with the specified lower and upper limits of the voltage range.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range(
    double low,
    double high
)
Visual Basic
Public Sub New (
    low As Double,
    high As Double
)

Parameters

low
Type: System..::..Double
Gets or sets the lower limit of the voltage range.
high
Type: System..::..Double
Gets or sets the upper limit of the voltage range.

See Also

Range Class
Range Members


Range Methods

[image] [image]

OpenLayers for .NET Documentation
Range Methods
Range Class See Also Send Feedback

The Range type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Range Class


Range Properties

[image] [image]

OpenLayers for .NET Documentation
Range Properties
Range Class See Also Send Feedback

The Range type exposes the following members.

Properties

 | Name | Description
Public property | High | Gets or sets the upper limit of the voltage range.
Public property | Low | Gets or sets the lower limit of the voltage range.

See Also

Range Class


Range.High Property

[image]

OpenLayers for .NET Documentation
Range..::..High Property
Range Class See Also Send Feedback
Gets or sets the upper limit of the voltage range.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double High { get; set; }
Visual Basic
Public Property High As Double
    Get
    Set

Property Value

Type: Double

See Also

Range Class
Range Members


Range.Low Property

[image]

OpenLayers for .NET Documentation
Range..::..Low Property
Range Class See Also Send Feedback
Gets or sets the lower limit of the voltage range.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Low { get; set; }
Visual Basic
Public Property Low As Double
    Get
    Set

Property Value

Type: Double

See Also

Range Class
Range Members


ReferenceTrigger Class

[image]

OpenLayers for .NET Documentation
ReferenceTrigger Class
Members See Also Send Feedback
The ReferenceTrigger class provides an interface for controlling the reference trigger of a subsystem. For devices that support a reference trigger, pre-trigger data acquisition stops and post-trigger acquisition starts when the reference trigger event occurs. Post-trigger acquisition stops when the number of samples you specify for the post-trigger scan count has been reached.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class ReferenceTrigger
Visual Basic
Public NotInheritable Class ReferenceTrigger

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..ReferenceTrigger

See Also

ReferenceTrigger Members


ReferenceTrigger Members

[image] [image]

OpenLayers for .NET Documentation
ReferenceTrigger Members
ReferenceTrigger Class Methods Properties See Also Send Feedback

The ReferenceTrigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets and sets the threshold value for the reference trigger. By default, the threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings for the reference trigger.
Public property | PostTriggerScanCount | Gets and sets the samples per channel to acquire after the reference trigger occurs.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent reference trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg reference trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg reference trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos reference trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos reference trigger type; otherwise, returns False.
Public property | SupportsPostTriggerScanCount | Returns True if the subsystem supports acquiring a specified number of samples after the reference trigger occurs; otherwise, returns False.
Public property | SupportsSyncBusTrigger | Return True if the subsystem supports a SyncBus reference trigger type; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg reference trigger event.
Public property | TriggerType | Gets and sets the reference trigger type (None, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

ReferenceTrigger Class


ReferenceTrigger Methods

[image] [image]

OpenLayers for .NET Documentation
ReferenceTrigger Methods
ReferenceTrigger Class See Also Send Feedback

The ReferenceTrigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceTrigger Class


ReferenceTrigger Properties

[image] [image]

OpenLayers for .NET Documentation
ReferenceTrigger Properties
ReferenceTrigger Class See Also Send Feedback

The ReferenceTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets and sets the threshold value for the reference trigger. By default, the threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings for the reference trigger.
Public property | PostTriggerScanCount | Gets and sets the samples per channel to acquire after the reference trigger occurs.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent reference trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg reference trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg reference trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos reference trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos reference trigger type; otherwise, returns False.
Public property | SupportsPostTriggerScanCount | Returns True if the subsystem supports acquiring a specified number of samples after the reference trigger occurs; otherwise, returns False.
Public property | SupportsSyncBusTrigger | Return True if the subsystem supports a SyncBus reference trigger type; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg reference trigger event.
Public property | TriggerType | Gets and sets the reference trigger type (None, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

ReferenceTrigger Class


ReferenceTrigger.Level Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..Level Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the threshold value for the reference trigger. By default, the threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings for the reference trigger.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Level { get; set; }
Visual Basic
Public Property Level As Double
    Get
    Set

Property Value

Type: Double

Remarks

This propery is valid only if TriggerType property is ThresholdPos or ThresholdNeg trigger type. The threshold level set by this property is the value after the gain is a applied to the threshold trigger channel. For example, if the voltage range of the subsystem is ±10 V, and the specified gain is 1, specify a threshold voltage level within ±10 V. Likewise, if the voltage range of the subsystem is ±10 V, and the specified gain is 10, specify a threshold voltage level within ±1 V.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.PostTriggerScanCount Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..PostTriggerScanCount Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the samples per channel to acquire after the reference trigger occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PostTriggerScanCount { get; set; }
Visual Basic
Public Property PostTriggerScanCount As Integer
    Get
    Set

Property Value

Type: Int32

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportedThresholdTriggerChannels Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportedThresholdTriggerChannels Property
ReferenceTrigger Class See Also Send Feedback
Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int[] SupportedThresholdTriggerChannels { get; }
Visual Basic
Public ReadOnly Property SupportedThresholdTriggerChannels As Integer()
    Get

Property Value

Type: array<Int32>[]()[][]

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportsDigitalEventTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsDigitalEventTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a DigitalEvent reference trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDigitalEventTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsDigitalEventTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportsNegExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsNegExternalTTLTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a TTLNeg reference trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportsNegThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsNegThresholdTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdNeg reference trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportsPosExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsPosExternalTTLTrigger Property
ReferenceTrigger Class See Also Send Feedback
Return True if the subsystem supports a TTLPos reference trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportsPosThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsPosThresholdTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdPos reference trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportsPostTriggerScanCount Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsPostTriggerScanCount Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports acquiring a specified number of samples after the reference trigger occurs; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPostTriggerScanCount { get; }
Visual Basic
Public ReadOnly Property SupportsPostTriggerScanCount As Boolean
    Get

Property Value

Type: Boolean

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.SupportsSyncBusTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsSyncBusTrigger Property
ReferenceTrigger Class See Also Send Feedback
Return True if the subsystem supports a SyncBus reference trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSyncBusTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsSyncBusTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.ThresholdTriggerChannel Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..ThresholdTriggerChannel Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg reference trigger event.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ThresholdTriggerChannel { get; set; }
Visual Basic
Public Property ThresholdTriggerChannel As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

This propery is valid only if the TriggerType property is ThresholdPos or ThresholdNeg.

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTrigger.TriggerType Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..TriggerType Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the reference trigger type (None, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ReferenceTriggerType TriggerType { get; set; }
Visual Basic
Public Property TriggerType As ReferenceTriggerType
    Get
    Set

Property Value

Type: ReferenceTriggerType

See Also

ReferenceTrigger Class
ReferenceTrigger Members


ReferenceTriggerType Enumeration

[image]

OpenLayers for .NET Documentation
ReferenceTriggerType Enumeration
See Also Send Feedback
Contains the possible values for the TriggerType property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ReferenceTriggerType
Visual Basic
Public Enumeration ReferenceTriggerType

Members

Member name | Value | Description
None | 300 | Triggering is disabled.
TTLPos | 301 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the rising edge of the digital TTL signal.
DigitalEvent | 304 | A trigger is generated when an external digital event occurs.
TTLNeg | 306 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the falling edge of the digital TTL signal.
ThresholdPos | 1200 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A positive analog threshold trigger occurs when the device detects a positive-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.
ThresholdNeg | 1201 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A negative analog threshold trigger occurs when the device detects a negative-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.
SyncBus | 1202 | An external Sync Bus signal attached to the device. For devices that support connecting multiple devices together in a master/slave relationship using Sync Bus (RJ45) connectors, the Sync Bus trigger occurs when the slave device detects a transition on the SyncBus trigger input of the Sync Bus connector.

See Also


RTDType Enumeration

[image]

OpenLayers for .NET Documentation
RTDType Enumeration
See Also Send Feedback
Contains the possible values for the RTDType property in the SupportedChannelInfo class.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum RTDType
Visual Basic
Public Enumeration RTDType

Members

Member name | Value | Description
Pt3750 | 1608 | Temperature Coefficient of Resistance (TCR) value of 0.003750 Ohm / Ohm /° C used in the Callendar-Van Dusen transfer function for Platinum 1000 Ohm RTDs. This value is specified in the Low Cost standard. If this value is set, a value of 1000 is used for the RtdR0 property, a value of 0.00381 is used for the RtdACoefficient property, a value of –0.000000602 is used for the RtdBCoefficient property, and a value of –0.0000000000060 is used for the RtdCCoefficient property. These properties are used in the Callendar-Van Dusen equation.
Pt3850 | 1609 | Temperature Coefficient of Resistance value of 0.003850 Ohm / Ohm /° C used in the Callendar-Van Dusen transfer function for Platinum 100, 500, and 1000 Ohm RTDs. This value is specified in the DIN/IEC 60751 and ASTM-E1137 standards. If this value is set, specify a value of 100, 500, or 1000 for the RtdR0 property. A value of 0.0039083 is used for the RtdACoefficient property, a value of –0.0000005775 is used for the RtdBCoefficient property, and a value of –0.000000000004183 is used for the RtdCCoefficient property. These properties are used in the Callendar-Van Dusen equation.
Pt3911 | 1610 | Temperature Coefficient of Resistance value of 0.003911 Ohm / Ohm /° C used in the Callendar-Van Dusen transfer function for Platinum 100 Ohm RTDs. This value is specified in the US Industrial Standard. If this value is set, a value of 100 is used for the RtdR0 property, a value of 0.0039692 is used for the RtdACoefficient property, a value of –0.00000058495 is used for the RtdBCoefficient property, and a value of –0.000000000004233 is used for the RtdCCoefficient property. These properties are used in the Callendar-Van Dusen equation.
Pt3916 | 1611 | Temperature Coefficient of Resistance value of 0.003916 Ohm / Ohm /° C used in the Callendar-Van Dusen transfer function for Platinum 100 Ohm RTDs. This value is specified in the Japanese JISC 1604-1989 standard. If this value is set, a value of 100 is used for the RtdR0 property, a value of 0.0039739 is used for the RtdACoefficient property, a value of –0.000000587 is used for the RtdBCoefficient property, and a value of –0.0000000000044 is used for the RtdCCoefficient property. These properties are used in the Callendar-Van Dusen equation.
Pt3920 | 1612 | Temperature Coefficient of Resistance value of 0.003920 Ohm / Ohm /° C used in the Callendar-Van Dusen transfer equation to calculate temperature for a Platinum 100 Ohm RTDs. This value is specified in the SAMA RC21-4-1966 standard. If this value is set, a value of 98.129 is used for the RtdR0 property, a value of 0.0039787 is used for the RtdACoefficient property, a value of –0.0000005869 is used for the RtdBCoefficient property, and a value of –0.000000000004167 is used for the RtdCCoefficient property. These properties are used in the Callendar-Van Dusen equation.
Pt3928 | 1613 | Temperature Coefficient of Resistance value of 0.003928 Ohm / Ohm /° C used in the Callendar-Van Dusen transfer equation to calculate temperature for a Platinum 100 Ohm RTD. If this value is set, a value of 100 is used for the RtdR0 property, a value of 0.0039888 is used for the RtdACoefficient property, a value of –0.0000005915 is used for the RtdBCoefficient property, and a value of –0.00000000000385 is used for the RtdCCoefficient property. These properties are used in the Callendar-Van Dusen equation.
Custom | 1614 | A user-defined value for the Temperature Coefficient of Resistance in the Callendar-Van Dusen transfer equation to calculate temperature. If this value is set, you must specify a value for the RtdR0, RtdACoefficient, RtdBCoefficient, and RtdCCoefficient properties, which are used in the Callendar-Van Dusen equation.

See Also


SensorWiringConfiguration Enumeration

[image]

OpenLayers for .NET Documentation
SensorWiringConfiguration Enumeration
See Also Send Feedback
Contains the possible values for the SensorWiringConfiguration property in the SupportedChannelInfo class.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum SensorWiringConfiguration
Visual Basic
Public Enumeration SensorWiringConfiguration

Members

Member name | Value | Description
TwoWire | 0 | The sensor type (typically, an RTD, thermistor, or resistance measurement) uses two wires to connect to the device.
ThreeWire | 1 | The sensor type (typically, an RTD, thermistor, or resistance measurement) uses three wires to connect to the device.
FourWire | 2 | The sensor type (typically, an RTD, thermistor, or resistance measurement) uses four wires to connect to the device.

See Also


SimultaneousStart Class

[image]

OpenLayers for .NET Documentation
SimultaneousStart Class
Members See Also Send Feedback
The SimultaneousStart class provides an interface for simultaneously starting multiple subsystems.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class SimultaneousStart
Visual Basic
Public NotInheritable Class SimultaneousStart

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SimultaneousStart

See Also

SimultaneousStart Members


SimultaneousStart Members

[image] [image]

OpenLayers for .NET Documentation
SimultaneousStart Members
SimultaneousStart Class Methods See Also Send Feedback

The SimultaneousStart type exposes the following members.

Methods

 | Name | Description
Public method | AddSubsystem | Adds a subsystem to the list of subsystems to simultaneously start.
Public method | Clear | Removes all subsystems from the simultaneous start list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubsystemList | Returns an array of subsystems that are currently on the simultaneous start list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStart | Simultaneously prestarts all subsystems on the simultaneous start list.
Public method | RemoveSubsystem | Removes a subsystem from the list of subsystems to simultaneously start.
Public method | Start | Simultaneously starts all subsystems on the simultaneous start list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimultaneousStart Class


SimultaneousStart Methods

[image] [image]

OpenLayers for .NET Documentation
SimultaneousStart Methods
SimultaneousStart Class See Also Send Feedback

The SimultaneousStart type exposes the following members.

Methods

 | Name | Description
Public method | AddSubsystem | Adds a subsystem to the list of subsystems to simultaneously start.
Public method | Clear | Removes all subsystems from the simultaneous start list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubsystemList | Returns an array of subsystems that are currently on the simultaneous start list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStart | Simultaneously prestarts all subsystems on the simultaneous start list.
Public method | RemoveSubsystem | Removes a subsystem from the list of subsystems to simultaneously start.
Public method | Start | Simultaneously starts all subsystems on the simultaneous start list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimultaneousStart Class


SimultaneousStart.AddSubsystem Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..AddSubsystem Method
SimultaneousStart Class See Also Send Feedback
Adds a subsystem to the list of subsystems to simultaneously start.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void AddSubsystem(
    SubsystemBase subsystem
)
Visual Basic
Public Sub AddSubsystem (
    subsystem As SubsystemBase
)

Parameters

subsystem
Type: OpenLayers.Base..::..SubsystemBase
The subsystem to add to the simultaneous start list.

See Also

SimultaneousStart Class
SimultaneousStart Members


SimultaneousStart.Clear Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..Clear Method
SimultaneousStart Class See Also Send Feedback
Removes all subsystems from the simultaneous start list.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

SimultaneousStart Class
SimultaneousStart Members


SimultaneousStart.GetSubsystemList Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..GetSubsystemList Method
SimultaneousStart Class See Also Send Feedback
Returns an array of subsystems that are currently on the simultaneous start list.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase[] GetSubsystemList()
Visual Basic
Public Function GetSubsystemList As SubsystemBase()

Return Value

Type: array< SubsystemBase >[]()[][]
An array of subsystems that are currently on the simultaneous start list.

See Also

SimultaneousStart Class
SimultaneousStart Members


SimultaneousStart.PreStart Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..PreStart Method
SimultaneousStart Class See Also Send Feedback
Simultaneously prestarts all subsystems on the simultaneous start list.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PreStart()
Visual Basic
Public Sub PreStart

See Also

SimultaneousStart Class
SimultaneousStart Members


SimultaneousStart.RemoveSubsystem Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..RemoveSubsystem Method
SimultaneousStart Class See Also Send Feedback
Removes a subsystem from the list of subsystems to simultaneously start.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void RemoveSubsystem(
    SubsystemBase subsystem
)
Visual Basic
Public Sub RemoveSubsystem (
    subsystem As SubsystemBase
)

Parameters

subsystem
Type: OpenLayers.Base..::..SubsystemBase
The subsystem to remove.

See Also

SimultaneousStart Class
SimultaneousStart Members


SimultaneousStart.Start Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..Start Method
SimultaneousStart Class See Also Send Feedback
Simultaneously starts all subsystems on the simultaneous start list.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Start()
Visual Basic
Public Sub Start

See Also

SimultaneousStart Class
SimultaneousStart Members


SingleValuesInfoRaw Structure

[image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Structure
Members See Also Send Feedback
Used with SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]), specifies the analog output channel to update and the raw count value to output on that channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public struct SingleValuesInfoRaw
Visual Basic
Public Structure SingleValuesInfoRaw

See Also

SingleValuesInfoRaw Members


SingleValuesInfoRaw Members

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Members
SingleValuesInfoRaw Structure Methods Fields See Also Send Feedback

The SingleValuesInfoRaw type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | RawValue | The raw count value to output on the specified analog output channel.

See Also

SingleValuesInfoRaw Structure


SingleValuesInfoRaw Fields

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Fields
SingleValuesInfoRaw Structure See Also Send Feedback

The SingleValuesInfoRaw type exposes the following members.

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | RawValue | The raw count value to output on the specified analog output channel.

See Also

SingleValuesInfoRaw Structure


SingleValuesInfoRaw.PhysicalChannel Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw..::..PhysicalChannel Field
SingleValuesInfoRaw Structure See Also Send Feedback
The number of the physical analog output channel to update.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannel
Visual Basic
Public PhysicalChannel As Integer

Field Value

Type: Int32

See Also

SingleValuesInfoRaw Structure
SingleValuesInfoRaw Members


SingleValuesInfoRaw.RawValue Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw..::..RawValue Field
SingleValuesInfoRaw Structure See Also Send Feedback
The raw count value to output on the specified analog output channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int RawValue
Visual Basic
Public RawValue As Integer

Field Value

Type: Int32

See Also

SingleValuesInfoRaw Structure
SingleValuesInfoRaw Members


SingleValuesInfoRaw Methods

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Methods
SingleValuesInfoRaw Structure See Also Send Feedback

The SingleValuesInfoRaw type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SingleValuesInfoRaw Structure


SingleValuesInfoVolts Structure

[image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Structure
Members See Also Send Feedback
Used with SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][]), specifies the analog output channel to update and the voltage value to output on that channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public struct SingleValuesInfoVolts
Visual Basic
Public Structure SingleValuesInfoVolts

See Also

SingleValuesInfoVolts Members


SingleValuesInfoVolts Members

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Members
SingleValuesInfoVolts Structure Methods Fields See Also Send Feedback

The SingleValuesInfoVolts type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | Voltage | The voltage value to output on the specified analog output channel.

See Also

SingleValuesInfoVolts Structure


SingleValuesInfoVolts Fields

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Fields
SingleValuesInfoVolts Structure See Also Send Feedback

The SingleValuesInfoVolts type exposes the following members.

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | Voltage | The voltage value to output on the specified analog output channel.

See Also

SingleValuesInfoVolts Structure


SingleValuesInfoVolts.PhysicalChannel Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts..::..PhysicalChannel Field
SingleValuesInfoVolts Structure See Also Send Feedback
The number of the physical analog output channel to update.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannel
Visual Basic
Public PhysicalChannel As Integer

Field Value

Type: Int32

See Also

SingleValuesInfoVolts Structure
SingleValuesInfoVolts Members


SingleValuesInfoVolts.Voltage Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts..::..Voltage Field
SingleValuesInfoVolts Structure See Also Send Feedback
The voltage value to output on the specified analog output channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float Voltage
Visual Basic
Public Voltage As Single

Field Value

Type: Single

See Also

SingleValuesInfoVolts Structure
SingleValuesInfoVolts Members


SingleValuesInfoVolts Methods

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Methods
SingleValuesInfoVolts Structure See Also Send Feedback

The SingleValuesInfoVolts type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SingleValuesInfoVolts Structure


StrainGageBridgeConfiguration Enumeration

[image]

OpenLayers for .NET Documentation
StrainGageBridgeConfiguration Enumeration
See Also Send Feedback
Contains the possible values for the StrainGageBridgeConfiguration property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum StrainGageBridgeConfiguration
Visual Basic
Public Enumeration StrainGageBridgeConfiguration

Members

Member name | Value | Description
FullBridgeBending | 0 | This configurations uses four active gages to measure bending strain. This configuration rejects axial strain, compensates for temperature and compensates for lead resistance.
FullBridgeBendingPoisson | 1 | This configuration uses four active gages to measure bending strain. This configuration also rejects axial strain, compensates for temperature, compensates for lead resistance, and compensates for the aggregate effect on the principle strain measurement due to the Poisson ratio of the specimen material.
FullBridgeAxialPoisson | 2 | This configuration uses four active gages to measure axial strain. This configuration also compensates for temperature, rejects bending strain, compensates for lead resistance, and compensates for the aggregate effect on the principle strain measurement due to the Poisson ratio of the specimen material.
HalfBridgePoisson | 3 | This configuration uses two active gages to measure either axial or bending strain. This configuration compensates for temperature, and compensates for the aggregate effect on the principle strain measurement due to the Poisson ratio of the specimen material.
HalfBridgeBending | 4 | This configuration uses two active gages to measure bending strain. This configuration rejects axial strain and compensates for temperature.
QuarterBridge | 5 | This configuration uses a single active gage to measure axial or bending strain. You must supply an external resistor that matches the nominal resistance of the bridge to complete the bridge externally.
QuarterBridgeTempCompensation | 6 | This configuration uses one active gage and one dummy gage to measure axial and bending strain while compensating for temperature.

See Also


StrainGageTeds Class

[image]

OpenLayers for .NET Documentation
StrainGageTeds Class
Members See Also Send Feedback
The StrainGageTeds class provides the properties and methods that support TEDS for strain gages.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class StrainGageTeds : TedsBase
Visual Basic
Public Class StrainGageTeds
    Inherits TedsBase

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..TedsBase
OpenLayers.Base..::..StrainGageTeds

See Also

StrainGageTeds Members


StrainGageTeds Members

[image] [image]

OpenLayers for .NET Documentation
StrainGageTeds Members
StrainGageTeds Class Methods Properties See Also Send Feedback

The StrainGageTeds type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadHardwareTeds | Reads data directly from a TEDS-compatible sensor that is associated with the connected channel. (Overrides TedsBase..::..ReadHardwareTeds()()()().)
Public method | ReadVirtualTeds | Reads TEDS data from a virtual TEDS file. (Overrides TedsBase..::..ReadVirtualTeds(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BridgeType | Gets the type of bridge (Full Bridge, Half Bridge, or Quarter Bridge) that was specified in the TEDS data for the channel.
Public property | CalDate | Gets the calibration date that was specified in the TEDS data for the channel.
Public property | CalibrationPeriod | Gets the calibration period that was specified in the TEDS data for the channel.
Public property | CalInitials | Gets the calibration initials that were specified in the TEDS data for the channel.
Public property | ElectricalSignalType | Gets the electrical signal type that was specified in the TEDS data for the channel.
Public property | GageArea | Gets the area of each gage element, in mm², that was specified in the TEDS data for the channel.
Public property | GageFactor | Gets the gage factor, or sensitivity, of the strain gage that was specified in the TEDS data for the channel.
Public property | GageResistance | Gets the initial (unstrained) gage resistance, in ohms, that was specified in the TEDS data for the channel.
Public property | GageType | Gets the type of gage that was specified in the TEDS data for the channel.
Public property | IsTedsConfigured | Returns True if the TEDS data stream is read successfully; otherwise, returns False. (Inherited from TedsBase.)
Public property | ManufacturerId | Gets identifying information about the manufacturer of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | MaxElecticalValue | Gets the maximum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MaximumExcitationVoltage | Gets the maximum excitation voltage, in voltage, that was specified in the TEDS data for the channel.
Public property | MaxPhysicalValue | Gets the positive full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | MeasID | Gets the measurement location ID that was specified in the TEDS data for the channel.
Public property | MinElecticalValue | Gets the minimum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MinPhysicalValue | Gets the negative full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | ModelNumber | Gets the model number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | NominalExcitationVoltage | Gets the nominal excitation voltage, in voltage, that was specified in the TEDS data for the channel.
Public property | PoissonCoefficient | Gets the Poisson coefficient after installation that was specified in the TEDS data for the channel.
Public property | ResponseTime | Gets the response time, in seconds, that was specified in the TEDS data for the channel.
Public property | SerialNumber | Gets the serial number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | TransverseSensitivity | Gets the transverse sensitivity, in percentage, that was specified in the TEDS data for the channel.
Public property | VersionLetter | Gets the version letter of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | VersionNumber | Gets the version number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | YoungModulus | Gets the Young’s modulus, or measure of the stiffness of the material, in MPa, that was specified in the TEDS data for the channel.
Public property | ZeroOffset | Gets the zero offset value after installation, in V/V, that was specified in the TEDS data for the channel.

See Also

StrainGageTeds Class


StrainGageTeds Methods

[image] [image]

OpenLayers for .NET Documentation
StrainGageTeds Methods
StrainGageTeds Class See Also Send Feedback

The StrainGageTeds type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadHardwareTeds | Reads data directly from a TEDS-compatible sensor that is associated with the connected channel. (Overrides TedsBase..::..ReadHardwareTeds()()()().)
Public method | ReadVirtualTeds | Reads TEDS data from a virtual TEDS file. (Overrides TedsBase..::..ReadVirtualTeds(String).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StrainGageTeds Class


StrainGageTeds.ReadHardwareTeds Method

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..ReadHardwareTeds Method
StrainGageTeds Class See Also Send Feedback
Reads data directly from a TEDS-compatible sensor that is associated with the connected channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void ReadHardwareTeds()
Visual Basic
Public Overrides Sub ReadHardwareTeds

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.ReadVirtualTeds Method

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..ReadVirtualTeds Method
StrainGageTeds Class See Also Send Feedback
Reads TEDS data from a virtual TEDS file.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void ReadVirtualTeds(
    string fileName
)
Visual Basic
Public Overrides Sub ReadVirtualTeds (
    fileName As String
)

Parameters

fileName
Type: System..::..String
The name of the file that contains the TEDS data for the strain gage.

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds Properties

[image] [image]

OpenLayers for .NET Documentation
StrainGageTeds Properties
StrainGageTeds Class See Also Send Feedback

The StrainGageTeds type exposes the following members.

Properties

 | Name | Description
Public property | BridgeType | Gets the type of bridge (Full Bridge, Half Bridge, or Quarter Bridge) that was specified in the TEDS data for the channel.
Public property | CalDate | Gets the calibration date that was specified in the TEDS data for the channel.
Public property | CalibrationPeriod | Gets the calibration period that was specified in the TEDS data for the channel.
Public property | CalInitials | Gets the calibration initials that were specified in the TEDS data for the channel.
Public property | ElectricalSignalType | Gets the electrical signal type that was specified in the TEDS data for the channel.
Public property | GageArea | Gets the area of each gage element, in mm², that was specified in the TEDS data for the channel.
Public property | GageFactor | Gets the gage factor, or sensitivity, of the strain gage that was specified in the TEDS data for the channel.
Public property | GageResistance | Gets the initial (unstrained) gage resistance, in ohms, that was specified in the TEDS data for the channel.
Public property | GageType | Gets the type of gage that was specified in the TEDS data for the channel.
Public property | IsTedsConfigured | Returns True if the TEDS data stream is read successfully; otherwise, returns False. (Inherited from TedsBase.)
Public property | ManufacturerId | Gets identifying information about the manufacturer of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | MaxElecticalValue | Gets the maximum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MaximumExcitationVoltage | Gets the maximum excitation voltage, in voltage, that was specified in the TEDS data for the channel.
Public property | MaxPhysicalValue | Gets the positive full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | MeasID | Gets the measurement location ID that was specified in the TEDS data for the channel.
Public property | MinElecticalValue | Gets the minimum electrical output, in V/V, that was specified in the TEDS data for the channel.
Public property | MinPhysicalValue | Gets the negative full-scale value, in strain, that was specified in the TEDS data for the channel.
Public property | ModelNumber | Gets the model number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | NominalExcitationVoltage | Gets the nominal excitation voltage, in voltage, that was specified in the TEDS data for the channel.
Public property | PoissonCoefficient | Gets the Poisson coefficient after installation that was specified in the TEDS data for the channel.
Public property | ResponseTime | Gets the response time, in seconds, that was specified in the TEDS data for the channel.
Public property | SerialNumber | Gets the serial number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | TransverseSensitivity | Gets the transverse sensitivity, in percentage, that was specified in the TEDS data for the channel.
Public property | VersionLetter | Gets the version letter of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | VersionNumber | Gets the version number of the strain gage from the TEDS data for the channel. (Inherited from TedsBase.)
Public property | YoungModulus | Gets the Young’s modulus, or measure of the stiffness of the material, in MPa, that was specified in the TEDS data for the channel.
Public property | ZeroOffset | Gets the zero offset value after installation, in V/V, that was specified in the TEDS data for the channel.

See Also

StrainGageTeds Class


StrainGageTeds.BridgeType Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..BridgeType Property
StrainGageTeds Class See Also Send Feedback
Gets the type of bridge (Full Bridge, Half Bridge, or Quarter Bridge) that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TedsBridgeType BridgeType { get; }
Visual Basic
Public ReadOnly Property BridgeType As TedsBridgeType
    Get

Property Value

Type: TedsBridgeType

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.CalDate Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..CalDate Property
StrainGageTeds Class See Also Send Feedback
Gets the calibration date that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DateTime CalDate { get; }
Visual Basic
Public ReadOnly Property CalDate As DateTime
    Get

Property Value

Type: DateTime

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.CalibrationPeriod Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..CalibrationPeriod Property
StrainGageTeds Class See Also Send Feedback
Gets the calibration period that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint CalibrationPeriod { get; }
Visual Basic
Public ReadOnly Property CalibrationPeriod As UInteger
    Get

Property Value

Type: UInt32

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.CalInitials Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..CalInitials Property
StrainGageTeds Class See Also Send Feedback
Gets the calibration initials that were specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string CalInitials { get; }
Visual Basic
Public ReadOnly Property CalInitials As String
    Get

Property Value

Type: String

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.ElectricalSignalType Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..ElectricalSignalType Property
StrainGageTeds Class See Also Send Feedback
Gets the electrical signal type that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string ElectricalSignalType { get; }
Visual Basic
Public ReadOnly Property ElectricalSignalType As String
    Get

Property Value

Type: String

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.GageArea Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..GageArea Property
StrainGageTeds Class See Also Send Feedback
Gets the area of each gage element, in mm², that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GageArea { get; }
Visual Basic
Public ReadOnly Property GageArea As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.GageFactor Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..GageFactor Property
StrainGageTeds Class See Also Send Feedback
Gets the gage factor, or sensitivity, of the strain gage that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GageFactor { get; }
Visual Basic
Public ReadOnly Property GageFactor As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.GageResistance Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..GageResistance Property
StrainGageTeds Class See Also Send Feedback
Gets the initial (unstrained) gage resistance, in ohms, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GageResistance { get; }
Visual Basic
Public ReadOnly Property GageResistance As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.GageType Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..GageType Property
StrainGageTeds Class See Also Send Feedback
Gets the type of gage that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public GageType GageType { get; }
Visual Basic
Public ReadOnly Property GageType As GageType
    Get

Property Value

Type: GageType

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.MaxElecticalValue Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..MaxElecticalValue Property
StrainGageTeds Class See Also Send Feedback
Gets the maximum electrical output, in V/V, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MaxElecticalValue { get; }
Visual Basic
Public ReadOnly Property MaxElecticalValue As Single
    Get

Property Value

Type: Single

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.MaximumExcitationVoltage Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..MaximumExcitationVoltage Property
StrainGageTeds Class See Also Send Feedback
Gets the maximum excitation voltage, in voltage, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaximumExcitationVoltage { get; }
Visual Basic
Public ReadOnly Property MaximumExcitationVoltage As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.MaxPhysicalValue Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..MaxPhysicalValue Property
StrainGageTeds Class See Also Send Feedback
Gets the positive full-scale value, in strain, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MaxPhysicalValue { get; }
Visual Basic
Public ReadOnly Property MaxPhysicalValue As Single
    Get

Property Value

Type: Single

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.MeasID Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..MeasID Property
StrainGageTeds Class See Also Send Feedback
Gets the measurement location ID that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint MeasID { get; }
Visual Basic
Public ReadOnly Property MeasID As UInteger
    Get

Property Value

Type: UInt32

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.MinElecticalValue Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..MinElecticalValue Property
StrainGageTeds Class See Also Send Feedback
Gets the minimum electrical output, in V/V, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MinElecticalValue { get; }
Visual Basic
Public ReadOnly Property MinElecticalValue As Single
    Get

Property Value

Type: Single

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.MinPhysicalValue Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..MinPhysicalValue Property
StrainGageTeds Class See Also Send Feedback
Gets the negative full-scale value, in strain, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float MinPhysicalValue { get; }
Visual Basic
Public ReadOnly Property MinPhysicalValue As Single
    Get

Property Value

Type: Single

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.NominalExcitationVoltage Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..NominalExcitationVoltage Property
StrainGageTeds Class See Also Send Feedback
Gets the nominal excitation voltage, in voltage, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double NominalExcitationVoltage { get; }
Visual Basic
Public ReadOnly Property NominalExcitationVoltage As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.PoissonCoefficient Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..PoissonCoefficient Property
StrainGageTeds Class See Also Send Feedback
Gets the Poisson coefficient after installation that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double PoissonCoefficient { get; }
Visual Basic
Public ReadOnly Property PoissonCoefficient As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.ResponseTime Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..ResponseTime Property
StrainGageTeds Class See Also Send Feedback
Gets the response time, in seconds, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ResponseTime { get; }
Visual Basic
Public ReadOnly Property ResponseTime As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.TransverseSensitivity Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..TransverseSensitivity Property
StrainGageTeds Class See Also Send Feedback
Gets the transverse sensitivity, in percentage, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double TransverseSensitivity { get; }
Visual Basic
Public ReadOnly Property TransverseSensitivity As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.YoungModulus Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..YoungModulus Property
StrainGageTeds Class See Also Send Feedback
Gets the Young’s modulus, or measure of the stiffness of the material, in MPa, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double YoungModulus { get; }
Visual Basic
Public ReadOnly Property YoungModulus As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


StrainGageTeds.ZeroOffset Property

[image]

OpenLayers for .NET Documentation
StrainGageTeds..::..ZeroOffset Property
StrainGageTeds Class See Also Send Feedback
Gets the zero offset value after installation, in V/V, that was specified in the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ZeroOffset { get; }
Visual Basic
Public ReadOnly Property ZeroOffset As Double
    Get

Property Value

Type: Double

See Also

StrainGageTeds Class
StrainGageTeds Members


SubsystemBase Class

[image]

OpenLayers for .NET Documentation
SubsystemBase Class
Members See Also Send Feedback
The SubsystemBase class is an abstract base class that is accessible from the following derived classes: AnalogSubsystem (and its derived classes AnalogInputSubsystem and AnalogOutputSubsystem), DigitalInputSubsystem, DigitalOutputSubsystem, CounterTimerSubsystem, and QuadratureDecoderSubsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public abstract class SubsystemBase : IDisposable
Visual Basic
Public MustInherit Class SubsystemBase
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..AnalogSubsystem
OpenLayers.Base..::..CounterTimerSubsystem
OpenLayers.Base..::..DigitalInputSubsystem
OpenLayers.Base..::..DigitalOutputSubsystem
OpenLayers.Base..::..QuadratureDecoderSubsystem
OpenLayers.Base..::..TachSubsystem

See Also

SubsystemBase Members


SubsystemBase Members

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Members
SubsystemBase Class Methods Properties Events See Also Send Feedback

The SubsystemBase type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately.
Public method | Config | Configures the subsystem based on the current property settings.
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration.
Public method | Start | Starts an operation on the subsystem.
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem.
Public property | BufferQueue | Provides an interface to a BufferQueue object.
Public property | ChannelList | Provides an interface to a ChannelList object.
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem.
Public property | Clock | Provides an interface to a Clock object.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem.
Public property | Device | Returns the Device object that is associated with the subsystem.
Public property | Element | Returns the element number of the subsystem.
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem.
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False.
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem.
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem.
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object.
Public property | Resolution | Gets and sets the resolution of the subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete).
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs).
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder).
Public property | SupportedChannels | Provides an interface to a SupportedChannels object.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False.
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False.
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False.
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False.
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False.
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False.
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False.
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False.
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False.
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False.
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False.
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize.
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave).
Public property | Trigger | Provides an interface to a Trigger object.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops.
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied.

See Also

SubsystemBase Class


SubsystemBase Methods

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Methods
SubsystemBase Class See Also Send Feedback

The SubsystemBase type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately.
Public method | Config | Configures the subsystem based on the current property settings.
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration.
Public method | Start | Starts an operation on the subsystem.
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubsystemBase Class


SubsystemBase.Abort Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Abort Method
SubsystemBase Class See Also Send Feedback
Stops an operation on the subsystem immediately.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Abort()
Visual Basic
Public Overridable Sub Abort

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Config Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Config Method
SubsystemBase Class See Also Send Feedback
Configures the subsystem based on the current property settings.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Config()
Visual Basic
Public Overridable Sub Config

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Dispose Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Dispose Method
SubsystemBase Class See Also Send Feedback
Releases the subsystem’s connection to the Open Layers device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Reset Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Reset Method
SubsystemBase Class See Also Send Feedback
Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Start Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Start Method
SubsystemBase Class See Also Send Feedback
Starts an operation on the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Start()
Visual Basic
Public Overridable Sub Start

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Stop Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Stop Method
SubsystemBase Class See Also Send Feedback
Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Stop()
Visual Basic
Public Overridable Sub Stop

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase Properties

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Properties
SubsystemBase Class See Also Send Feedback

The SubsystemBase type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem.
Public property | BufferQueue | Provides an interface to a BufferQueue object.
Public property | ChannelList | Provides an interface to a ChannelList object.
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem.
Public property | Clock | Provides an interface to a Clock object.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem.
Public property | Device | Returns the Device object that is associated with the subsystem.
Public property | Element | Returns the element number of the subsystem.
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem.
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False.
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem.
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem.
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object.
Public property | Resolution | Gets and sets the resolution of the subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete).
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs).
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder).
Public property | SupportedChannels | Provides an interface to a SupportedChannels object.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False.
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False.
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False.
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False.
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False.
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False.
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False.
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False.
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False.
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False.
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False.
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize.
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave).
Public property | Trigger | Provides an interface to a Trigger object.

See Also

SubsystemBase Class


SubsystemBase.AsynchronousStop Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..AsynchronousStop Property
SubsystemBase Class See Also Send Feedback
Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool AsynchronousStop { get; set; }
Visual Basic
Public Property AsynchronousStop As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If you set the AsynchronousStop property to True, control returns to your program after Stop()()()() is called. If you set the AsynchronousStop property to False (the default setting), control does not return to your program after Stop is called until the OlBuffer object completes. (It is recommended that you do not wait more than 20 seconds for the stop to complete.) If you try to perform another operation while the stop is in progress, an exception is raised with the error code "SubsystemStopping" and the exception message "The subsystem is in the process of stopping or aborting".

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.BufferQueue Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..BufferQueue Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a BufferQueue object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public BufferQueue BufferQueue { get; }
Visual Basic
Public ReadOnly Property BufferQueue As BufferQueue
    Get

Property Value

Type: BufferQueue

Remarks

For continuous analog I/O operations, use this interface to add OlBuffer objects to the subsystem's buffer queue.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.ChannelList Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ChannelList Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a ChannelList object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelList ChannelList { get; set; }
Visual Basic
Public Property ChannelList As ChannelList
    Get
    Set

Property Value

Type: ChannelList

Remarks

Use this interface to set up a channel list for a continuous analog input or output operation.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.ChannelType Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ChannelType Property
SubsystemBase Class See Also Send Feedback
Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelType ChannelType { get; set; }
Visual Basic
Public Property ChannelType As ChannelType
    Get
    Set

Property Value

Type: ChannelType

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Clock Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Clock Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a Clock object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Clock Clock { get; }
Visual Basic
Public ReadOnly Property Clock As Clock
    Get

Property Value

Type: Clock

Remarks

Use this interface to configure how a subsystem is clocked.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.DataFlow Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..DataFlow Property
SubsystemBase Class See Also Send Feedback
Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DataFlow DataFlow { get; set; }
Visual Basic
Public Property DataFlow As DataFlow
    Get
    Set

Property Value

Type: DataFlow

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Device Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Device Property
SubsystemBase Class See Also Send Feedback
Returns the Device object that is associated with the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Device Device { get; }
Visual Basic
Public ReadOnly Property Device As Device
    Get

Property Value

Type: Device

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Element Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Element Property
SubsystemBase Class See Also Send Feedback
Returns the element number of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual int Element { get; }
Visual Basic
Public Overridable ReadOnly Property Element As Integer
    Get

Property Value

Type: Int32

Remarks

Your device may support multiple instances, called elements, of the same subsystem type. Element numbering is zero-based; that is, the first instance of the subsystem is called element 0, the second instance of the subsystem is called element 1, and so on. For example, if your device has two digital input ports, two subsystems of type DigitalInput are available, differentiated as elements 0 and 1.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Encoding Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Encoding Property
SubsystemBase Class See Also Send Feedback
Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic
Public Property Encoding As Encoding
    Get
    Set

Property Value

Type: Encoding

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.FifoSize Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..FifoSize Property
SubsystemBase Class See Also Send Feedback
Returns the size of the FIFO on the device that is associated with the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int FifoSize { get; }
Visual Basic
Public ReadOnly Property FifoSize As Integer
    Get

Property Value

Type: Int32

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.IsRunning Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..IsRunning Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem is currently running; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool IsRunning { get; }
Visual Basic
Public ReadOnly Property IsRunning As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.MaxDifferentialChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..MaxDifferentialChannels Property
SubsystemBase Class See Also Send Feedback
Returns the total number of Differential channels supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int MaxDifferentialChannels { get; }
Visual Basic
Public ReadOnly Property MaxDifferentialChannels As Integer
    Get

Property Value

Type: Int32

Remarks

Use the ChannelType property to set the channel configuration to Differential.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.MaxSingleEndedChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..MaxSingleEndedChannels Property
SubsystemBase Class See Also Send Feedback
Returns the total number of SingleEnded channels supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int MaxSingleEndedChannels { get; }
Visual Basic
Public ReadOnly Property MaxSingleEndedChannels As Integer
    Get

Property Value

Type: Int32

Remarks

Use the ChannelType property to set the channel configuration to SingleEnded.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.NumberOfChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..NumberOfChannels Property
SubsystemBase Class See Also Send Feedback
Returns the total number of channels that are supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfChannels { get; }
Visual Basic
Public ReadOnly Property NumberOfChannels As Integer
    Get

Property Value

Type: Int32

Remarks

This total number of channels includes both native and non-native channels that are supported for the subsystem. For example, if the analog input subsystem supports the ability to stream both analog and digital input data, the digital input channels will be included with the analog input channels in the total channel count. See also and .

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.Base Namespace
OpenLayers.Base..::..ChannelListEntry
OpenLayers.Base..::..SupportedChannels


SubsystemBase.NumberOfResolutions Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..NumberOfResolutions Property
SubsystemBase Class See Also Send Feedback
Returns the number of resolutions that are supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfResolutions { get; }
Visual Basic
Public ReadOnly Property NumberOfResolutions As Integer
    Get

Property Value

Type: Int32

Remarks

To get an array of available resolutions that are supported by the subsystem, use the SupportedResolutions property. Use the Resolution property to specify the resolution for the subsystem.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.ReferenceTrigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ReferenceTrigger Property
SubsystemBase Class See Also Send Feedback
Provides an interface to ReferenceTrigger object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ReferenceTrigger ReferenceTrigger { get; }
Visual Basic
Public ReadOnly Property ReferenceTrigger As ReferenceTrigger
    Get

Property Value

Type: ReferenceTrigger

Remarks

Use this interface to configure how a subsystem is triggered using stop trigger.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Resolution Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Resolution Property
SubsystemBase Class See Also Send Feedback
Gets and sets the resolution of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual short Resolution { get; set; }
Visual Basic
Public Overridable Property Resolution As Short
    Get
    Set

Property Value

Type: Int16

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.ReturnsFloats Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ReturnsFloats Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool ReturnsFloats { get; }
Visual Basic
Public ReadOnly Property ReturnsFloats As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.State Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..State Property
SubsystemBase Class See Also Send Feedback
Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase..::..States State { get; }
Visual Basic
Public ReadOnly Property State As SubsystemBase..::..States
    Get

Property Value

Type: SubsystemBase..::..States

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.StopOnError Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..StopOnError Property
SubsystemBase Class See Also Send Feedback
Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic
Public Property StopOnError As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If StopOnError is True, the subsystem automatically stops when an overrun or underrun error occurs. If StopOnError is False, the subsystem continues to run when an overrun or underrun error occurs.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SubsystemType Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SubsystemType Property
SubsystemBase Class See Also Send Feedback
Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual SubsystemType SubsystemType { get; }
Visual Basic
Public Overridable ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportedChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportedChannels Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a SupportedChannels object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannels SupportedChannels { get; }
Visual Basic
Public ReadOnly Property SupportedChannels As SupportedChannels
    Get

Property Value

Type: SupportedChannels

Remarks

Use this interface to get information about each channel that is supported by the specified subsystem.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportedResolutions Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportedResolutions Property
SubsystemBase Class See Also Send Feedback
Returns an array of available resolutions that are supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] SupportedResolutions { get; }
Visual Basic
Public ReadOnly Property SupportedResolutions As Double()
    Get

Property Value

Type: array<Double>[]()[][]

Remarks

Use the Resolution property to specify the resolution for the subsystem.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsBinaryEncoding Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsBinaryEncoding Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports Binary data encoding; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsBinaryEncoding { get; }
Visual Basic
Public ReadOnly Property SupportsBinaryEncoding As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Encoding property to set the data encoding to Binary.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsBuffering Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsBuffering Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsBuffering { get; }
Visual Basic
Public ReadOnly Property SupportsBuffering As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the OlBuffer and BufferQueue classes to set up buffering for your operation.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsChannelListInhibit Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsChannelListInhibit Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsChannelListInhibit { get; }
Visual Basic
Public ReadOnly Property SupportsChannelListInhibit As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Inhibit property to set the inhibit state for a ChannelListEntry object.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsContinuous Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsContinuous Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsContinuous { get; }
Visual Basic
Public ReadOnly Property SupportsContinuous As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to Continuous.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsContinuousPrePostTrigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsContinuousPrePostTrigger Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsContinuousPrePostTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsContinuousPrePostTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to ContinuousPrePostTrigger.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsContinuousPreTrigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsContinuousPreTrigger Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsContinuousPreTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsContinuousPreTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to ContinuousPreTrigger.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsCurrentOutput Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsCurrentOutput Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports current outputs; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsCurrentOutput { get; }
Visual Basic
Public ReadOnly Property SupportsCurrentOutput As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsDifferential Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsDifferential Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports Differential channels; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDifferential { get; }
Visual Basic
Public ReadOnly Property SupportsDifferential As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the ChannelType property to set the channel configuration to Differential.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsProgrammableGain Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsProgrammableGain Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsProgrammableGain { get; }
Visual Basic
Public ReadOnly Property SupportsProgrammableGain As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Gain property to set the gain for a ChannelListEntry object.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsSetSingleValues Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSetSingleValues Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSetSingleValues { get; }
Visual Basic
Public ReadOnly Property SupportsSetSingleValues As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsSimultaneousStart Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSimultaneousStart Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSimultaneousStart { get; }
Visual Basic
Public ReadOnly Property SupportsSimultaneousStart As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the SimultaneousStart class to set up and manage the simultaneous start list.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsSingleEnded Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSingleEnded Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports SingleEnded channels; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSingleEnded { get; }
Visual Basic
Public ReadOnly Property SupportsSingleEnded As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the ChannelType property to set the channel configuration to SingleEnded.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsSingleValue Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSingleValue Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSingleValue { get; }
Visual Basic
Public ReadOnly Property SupportsSingleValue As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to SingleValue.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsSoftwareResolution Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSoftwareResolution Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports software-programmable resolution; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSoftwareResolution { get; }
Visual Basic
Public ReadOnly Property SupportsSoftwareResolution As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Resolution property to specify the resolution for the subsystem.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsSynchronization Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSynchronization Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSynchronization { get; }
Visual Basic
Public ReadOnly Property SupportsSynchronization As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsTwosCompEncoding Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsTwosCompEncoding Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsTwosCompEncoding { get; }
Visual Basic
Public ReadOnly Property SupportsTwosCompEncoding As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Encoding property to set the data encoding to TwosComplement.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SupportsWaveformModeOnly Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsWaveformModeOnly Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsWaveformModeOnly { get; }
Visual Basic
Public ReadOnly Property SupportsWaveformModeOnly As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.SynchronizationMode Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SynchronizationMode Property
SubsystemBase Class See Also Send Feedback
For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SynchronizationModes SynchronizationMode { get; set; }
Visual Basic
Public Property SynchronizationMode As SynchronizationModes
    Get
    Set

Property Value

Type: SynchronizationModes

Remarks

If the synchronization mode is None, the subsystem is configured to ignore the synchronization circuit on the device. If the synchronization mode is Master, the synchronization connector on the device is configured to output a synchronization signal. If the synchronization mode is Slave, the synchronization connector on the device is configured to accept a synchronization signal as an input.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.Trigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Trigger Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a Trigger object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Trigger Trigger { get; }
Visual Basic
Public ReadOnly Property Trigger As Trigger
    Get

Property Value

Type: Trigger

Remarks

Use this interface to configure how a subsystem is triggered.

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase Events

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Events
SubsystemBase Class See Also Send Feedback

The SubsystemBase type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops.
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied.

See Also

SubsystemBase Class


SubsystemBase.BufferDoneEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..BufferDoneEvent Event
SubsystemBase Class See Also Send Feedback
For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event BufferDoneHandler BufferDoneEvent
Visual Basic
Public Event BufferDoneEvent As BufferDoneHandler

Value

Type: OpenLayers.Base..::..BufferDoneHandler

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.DeviceRemovedEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..DeviceRemovedEvent Event
SubsystemBase Class See Also Send Feedback
Occurs when a device is removed from your system while your application is running.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event DeviceRemovedHandler DeviceRemovedEvent
Visual Basic
Public Event DeviceRemovedEvent As DeviceRemovedHandler

Value

Type: OpenLayers.Base..::..DeviceRemovedHandler

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.GeneralFailureEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..GeneralFailureEvent Event
SubsystemBase Class See Also Send Feedback
Occurs when a general library failure is encountered.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event GeneralFailureHandler GeneralFailureEvent
Visual Basic
Public Event GeneralFailureEvent As GeneralFailureHandler

Value

Type: OpenLayers.Base..::..GeneralFailureHandler

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.QueueDoneEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..QueueDoneEvent Event
SubsystemBase Class See Also Send Feedback
Occurs when no OlBuffer objects are available on the queue and the operation stops.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event QueueDoneHandler QueueDoneEvent
Visual Basic
Public Event QueueDoneEvent As QueueDoneHandler

Value

Type: OpenLayers.Base..::..QueueDoneHandler

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.QueueStoppedEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..QueueStoppedEvent Event
SubsystemBase Class See Also Send Feedback
For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event QueueStoppedHandler QueueStoppedEvent
Visual Basic
Public Event QueueStoppedEvent As QueueStoppedHandler

Value

Type: OpenLayers.Base..::..QueueStoppedHandler

See Also

SubsystemBase Class
SubsystemBase Members


SubsystemBase.States Enumeration

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..States Enumeration
SubsystemBase Class See Also Send Feedback
Returns the current state of the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum States
Visual Basic
Public Enumeration States

Members

Member name | Value | Description
Initialized | 1000 | The subsystem is initialized, but not configured.
ConfiguredForSingleValue | 1001 | The subsystem is configured for a single-value operation.
ConfiguredForContinuous | 1002 | The subsystem is configured for a continuous operation.
PreStarted | 1003 | The subsystem was prestarted for a continuous operation.
Running | 1004 | The subsystem is running.
Stopping | 1005 | The subsystem is in the process of stopping.
Aborting | 1006 | The subsystem is in the process of aborting.
IoComplete | 1007 | The final analog output sample has been written from the FIFO on the device.

See Also


SubsystemType Enumeration

[image]

OpenLayers for .NET Documentation
SubsystemType Enumeration
See Also Send Feedback
Contains the possible values for the SubsystemType property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum SubsystemType
Visual Basic
Public Enumeration SubsystemType

Members

Member name | Value | Description
AnalogInput | 0 | Analog input subsystem
AnalogOutput | 1 | Analog output subsystem
DigitalInput | 2 | Digital input subsystem
DigitalOutput | 3 | Digital output subsystem
QuadratureDecoder | 4 | Quadrature decoder subsystem
CounterTimer | 5 | Counter/timer subsystem
Tachometer | 6 | Tachometer subsystem

See Also


SupportedChannelInfo Class

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo Class
Members See Also Send Feedback
The SupportedChannelInfo class describes a specific channel of a subsystem. You access a SupportedChannelInfo object using the SupportedChannels class.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class SupportedChannelInfo
Visual Basic
Public Class SupportedChannelInfo

Remarks

When you get a subsystem of a specified type, the software automatically determines the number of available channels for the subsystem and creates a SupportedChannelInfo object for each channel, containing the following information: physical channel number, logical channel number, logical channel word, channel name, sensor gain, and sensor offset.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SupportedChannelInfo

See Also

SupportedChannelInfo Members


SupportedChannelInfo Members

[image] [image]

OpenLayers for .NET Documentation
SupportedChannelInfo Members
SupportedChannelInfo Class Methods Properties See Also Send Feedback

The SupportedChannelInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BridgeConfiguration | Gets and sets the BridgeConfiguration of the full-bridge-based sensor or general-purpose bridge that is connected to the channel.
Public property | BridgeSensorTeds | Provides an interface to a BridgeSensorTeds object.
Public property | CjcChannel | Gets the CJC (cold junction compensation) channel that is associated with this input channel.
Public property | Coupling | Gets and sets the CouplingType to apply to the channel.
Public property | ExcitationCurrentSource | Gets and sets the ExcitationCurrentSource to apply to the channel.
Public property | ExcitationCurrentValue | Gets and sets the value of the excitation current source to apply to the channel.
Public property | InputTerminationEnabled | Specifies whether input termination is enabled (bias return termination resistor is switched in) or disabled (not used) for the analog input channel.
Public property | IOType | Gets the measurement IOType that is supported by the channel.
Public property | LogicalChannelNumber | Returns the zero-based logical channel number that is associated with this channel.
Public property | LogicalChannelWord | For channels with multi-word data (such as a 32-bit counter), returns the zero-based word number that is associated with this channel. For channels without multi-word data, returns -1.
Public property | MultiSensorType | If the IOType property for the channel is MultiSensor, gets and sets the type of measurement that is supported by the channel.
Public property | Name | Gets and sets the name of the associated channel.
Public property | PhysicalChannelNumber | Returns the physical channel number that is associated with this channel.
Public property | RtdACoefficient | Gets and sets the A coefficient that used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.
Public property | RtdBCoefficient | Gets and sets the B coefficient that is used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.
Public property | RtdCCoefficient | Gets and sets the C coefficient that is used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.
Public property | RtdR0 | Gets and sets the nominal resistance of the RTD, in ohms, at 0 deg C. Set the value of this property only if the RTDType property is Custom or Pt3850 (unless you are using a 100 Ohm RTD).
Public property | RTDType | Gets and sets the RTDType for the RTD that is connected to the channel. This property is used in the Callendar-Van Dusen transfer function to convert raw counts to temperature.
Public property | SensorGain | Gets and sets the gain value to apply to the sensor that is connected to this channel.
Public property | SensorOffset | Gets and sets the offset value to apply to the sensor that is connected to this channel.
Public property | SensorWiringConfiguration | Gets and sets the SensorWiringConfiguration for the channel. Set the value of this property when the IOType or MultiSensorType property is Rtd, Resistance, or Thermistor.
Public property | StrainGageBridgeConfiguration | Gets and sets the StrainGageBridgeConfiguration of the strain gage that is connected to the channel.
Public property | StrainGageGageFactor | Gets and sets the gage factor, or sensitivity, of the strain gage.
Public property | StrainGageLeadWireResistance | Gets and sets the lead wire resistance of the strain gage or bridge, in ohms.
Public property | StrainGageNominalResistance | Gets and sets the resistance, in ohms, of the strain gage or bridge while it is not under strain/load.
Public property | StrainGageOffsetNullingValueInVolts | Gets and sets the value of the bridge output (in volts) in the unstrained/unloaded condition. Internally, this value is subtracted from any measurements before the voltage is converted to strain.
Public property | StrainGagePoissonRatio | Gets and sets the Poisson ratio for the strain gage.
Public property | StrainGageShuntCalibrationResistorEnabled | Specifies whether the internal shunt calibration resistor is enabled (switched in) or disabled (not used).
Public property | StrainGageShuntCalibrationValue | Gets and sets the shunt calibration value, in microstrain, for the bridge. Internally, the software multiplies the channel measurement with this value to adjust the gain of the device.
Public property | StrainGageTeds | Provides an interface to a StrainGageTeds object.
Public property | Subsystem | Returns the subsystem object (AnalogInputSubsystem, AnalogOutputSubsystem, DigitalInputSubsystem, DigitalOutputSubsystem, CounterTimerSubsystem, TachSubsystem, or QuadratureDecoderSubsystem) that is associated with this channel.
Public property | SubsystemType | Returns the type of subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that is associated with this channel.
Public property | SupportedMultiSensorTypes | For channels that return an IOType of MultiSensor, returns an array containing the available sensor types (of type IOType) that the channel supports.
Public property | SupportsInputTermination | Specifies whether input termination is supported for the analog input channel.
Public property | ThermistorACoefficient | Gets and sets the A coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
Public property | ThermistorBCoefficient | Gets and sets the B coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
Public property | ThermistorCCoefficient | Gets and sets the C coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
Public property | ThermocoupleType | Gets and sets the ThermocoupleType that is connected to this channel.
Public property | TransducerCapacity | Gets and sets the full-scale range of the bridge-based sensor or transducer, such as a load cell, in its native engineering units.
Public property | TransducerRatedOutputInMv | Gets and sets the rated output of a bridge-based sensor or transducer, such as a load cell, in terms of mV/V excitation.

See Also

SupportedChannelInfo Class


SupportedChannelInfo Methods

[image] [image]

OpenLayers for .NET Documentation
SupportedChannelInfo Methods
SupportedChannelInfo Class See Also Send Feedback

The SupportedChannelInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupportedChannelInfo Class


SupportedChannelInfo Properties

[image] [image]

OpenLayers for .NET Documentation
SupportedChannelInfo Properties
SupportedChannelInfo Class See Also Send Feedback

The SupportedChannelInfo type exposes the following members.

Properties

 | Name | Description
Public property | BridgeConfiguration | Gets and sets the BridgeConfiguration of the full-bridge-based sensor or general-purpose bridge that is connected to the channel.
Public property | BridgeSensorTeds | Provides an interface to a BridgeSensorTeds object.
Public property | CjcChannel | Gets the CJC (cold junction compensation) channel that is associated with this input channel.
Public property | Coupling | Gets and sets the CouplingType to apply to the channel.
Public property | ExcitationCurrentSource | Gets and sets the ExcitationCurrentSource to apply to the channel.
Public property | ExcitationCurrentValue | Gets and sets the value of the excitation current source to apply to the channel.
Public property | InputTerminationEnabled | Specifies whether input termination is enabled (bias return termination resistor is switched in) or disabled (not used) for the analog input channel.
Public property | IOType | Gets the measurement IOType that is supported by the channel.
Public property | LogicalChannelNumber | Returns the zero-based logical channel number that is associated with this channel.
Public property | LogicalChannelWord | For channels with multi-word data (such as a 32-bit counter), returns the zero-based word number that is associated with this channel. For channels without multi-word data, returns -1.
Public property | MultiSensorType | If the IOType property for the channel is MultiSensor, gets and sets the type of measurement that is supported by the channel.
Public property | Name | Gets and sets the name of the associated channel.
Public property | PhysicalChannelNumber | Returns the physical channel number that is associated with this channel.
Public property | RtdACoefficient | Gets and sets the A coefficient that used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.
Public property | RtdBCoefficient | Gets and sets the B coefficient that is used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.
Public property | RtdCCoefficient | Gets and sets the C coefficient that is used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.
Public property | RtdR0 | Gets and sets the nominal resistance of the RTD, in ohms, at 0 deg C. Set the value of this property only if the RTDType property is Custom or Pt3850 (unless you are using a 100 Ohm RTD).
Public property | RTDType | Gets and sets the RTDType for the RTD that is connected to the channel. This property is used in the Callendar-Van Dusen transfer function to convert raw counts to temperature.
Public property | SensorGain | Gets and sets the gain value to apply to the sensor that is connected to this channel.
Public property | SensorOffset | Gets and sets the offset value to apply to the sensor that is connected to this channel.
Public property | SensorWiringConfiguration | Gets and sets the SensorWiringConfiguration for the channel. Set the value of this property when the IOType or MultiSensorType property is Rtd, Resistance, or Thermistor.
Public property | StrainGageBridgeConfiguration | Gets and sets the StrainGageBridgeConfiguration of the strain gage that is connected to the channel.
Public property | StrainGageGageFactor | Gets and sets the gage factor, or sensitivity, of the strain gage.
Public property | StrainGageLeadWireResistance | Gets and sets the lead wire resistance of the strain gage or bridge, in ohms.
Public property | StrainGageNominalResistance | Gets and sets the resistance, in ohms, of the strain gage or bridge while it is not under strain/load.
Public property | StrainGageOffsetNullingValueInVolts | Gets and sets the value of the bridge output (in volts) in the unstrained/unloaded condition. Internally, this value is subtracted from any measurements before the voltage is converted to strain.
Public property | StrainGagePoissonRatio | Gets and sets the Poisson ratio for the strain gage.
Public property | StrainGageShuntCalibrationResistorEnabled | Specifies whether the internal shunt calibration resistor is enabled (switched in) or disabled (not used).
Public property | StrainGageShuntCalibrationValue | Gets and sets the shunt calibration value, in microstrain, for the bridge. Internally, the software multiplies the channel measurement with this value to adjust the gain of the device.
Public property | StrainGageTeds | Provides an interface to a StrainGageTeds object.
Public property | Subsystem | Returns the subsystem object (AnalogInputSubsystem, AnalogOutputSubsystem, DigitalInputSubsystem, DigitalOutputSubsystem, CounterTimerSubsystem, TachSubsystem, or QuadratureDecoderSubsystem) that is associated with this channel.
Public property | SubsystemType | Returns the type of subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that is associated with this channel.
Public property | SupportedMultiSensorTypes | For channels that return an IOType of MultiSensor, returns an array containing the available sensor types (of type IOType) that the channel supports.
Public property | SupportsInputTermination | Specifies whether input termination is supported for the analog input channel.
Public property | ThermistorACoefficient | Gets and sets the A coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
Public property | ThermistorBCoefficient | Gets and sets the B coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
Public property | ThermistorCCoefficient | Gets and sets the C coefficient that is used in the Steinhart-Hart transfer function for the thermistor.
Public property | ThermocoupleType | Gets and sets the ThermocoupleType that is connected to this channel.
Public property | TransducerCapacity | Gets and sets the full-scale range of the bridge-based sensor or transducer, such as a load cell, in its native engineering units.
Public property | TransducerRatedOutputInMv | Gets and sets the rated output of a bridge-based sensor or transducer, such as a load cell, in terms of mV/V excitation.

See Also

SupportedChannelInfo Class


SupportedChannelInfo.BridgeConfiguration Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..BridgeConfiguration Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the BridgeConfiguration of the full-bridge-based sensor or general-purpose bridge that is connected to the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public BridgeConfiguration BridgeConfiguration { get; set; }
Visual Basic
Public Property BridgeConfiguration As BridgeConfiguration
    Get
    Set

Property Value

Type: BridgeConfiguration

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.BridgeSensorTeds Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..BridgeSensorTeds Property
SupportedChannelInfo Class See Also Send Feedback
Provides an interface to a BridgeSensorTeds object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public BridgeSensorTeds BridgeSensorTeds { get; }
Visual Basic
Public ReadOnly Property BridgeSensorTeds As BridgeSensorTeds
    Get

Property Value

Type: BridgeSensorTeds

Remarks

Use this interface to read TEDS data directly from the bridge-based sensor hardware, such as a load cell, or from a data file for a bridge-based sensor (virtual TEDS).

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.CjcChannel Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..CjcChannel Property
SupportedChannelInfo Class See Also Send Feedback
Gets the CJC (cold junction compensation) channel that is associated with this input channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int CjcChannel { get; }
Visual Basic
Public ReadOnly Property CjcChannel As Integer
    Get

Property Value

Type: Int32

Remarks

This property applies only to devices that support a channel (not an internal source) as the CJC source.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.Coupling Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..Coupling Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the CouplingType to apply to the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public CouplingType Coupling { get; set; }
Visual Basic
Public Property Coupling As CouplingType
    Get
    Set

Property Value

Type: CouplingType

Remarks

By default, DC coupling is selected for all channels.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.ExcitationCurrentSource Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ExcitationCurrentSource Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the ExcitationCurrentSource to apply to the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ExcitationCurrentSource ExcitationCurrentSource { get; set; }
Visual Basic
Public Property ExcitationCurrentSource As ExcitationCurrentSource
    Get
    Set

Property Value

Type: ExcitationCurrentSource

Remarks

By default, the excitation current source is disabled for all channels.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.ExcitationCurrentValue Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ExcitationCurrentValue Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the value of the excitation current source to apply to the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ExcitationCurrentValue { get; set; }
Visual Basic
Public Property ExcitationCurrentValue As Double
    Get
    Set

Property Value

Type: Double

Remarks

This value is applicable only when the excitation current source is internal.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.InputTerminationEnabled Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..InputTerminationEnabled Property
SupportedChannelInfo Class See Also Send Feedback
Specifies whether input termination is enabled (bias return termination resistor is switched in) or disabled (not used) for the analog input channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool InputTerminationEnabled { get; set; }
Visual Basic
Public Property InputTerminationEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

This property is used only if the SupportsInputTermination property is True. Refer to the hardware documentation for your device to determine when the bias return termination resistor should be enabled and disabled. Typically, the bias return termination resistor should be enabled for floating and grounded voltage and current sources, and disabled for voltage and current sources that have a grounded reference.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.IOType Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..IOType Property
SupportedChannelInfo Class See Also Send Feedback
Gets the measurement IOType that is supported by the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public IOType IOType { get; }
Visual Basic
Public ReadOnly Property IOType As IOType
    Get

Property Value

Type: IOType

Remarks

Some devices, such as the DT9829, support multiple sensor inputs for each channel and return a value of MultiSensor for the IOType property. If the channel has an IOType of MultiSensor, set the sensor type for the channel using the MultiSensorType property. Most devices support only one IOType for each channel; setting the MultiSensorType property is not applicable in this case.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.LogicalChannelNumber Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..LogicalChannelNumber Property
SupportedChannelInfo Class See Also Send Feedback
Returns the zero-based logical channel number that is associated with this channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int LogicalChannelNumber { get; }
Visual Basic
Public ReadOnly Property LogicalChannelNumber As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.LogicalChannelWord Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..LogicalChannelWord Property
SupportedChannelInfo Class See Also Send Feedback
For channels with multi-word data (such as a 32-bit counter), returns the zero-based word number that is associated with this channel. For channels without multi-word data, returns -1.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int LogicalChannelWord { get; }
Visual Basic
Public ReadOnly Property LogicalChannelWord As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.MultiSensorType Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..MultiSensorType Property
SupportedChannelInfo Class See Also Send Feedback
If the IOType property for the channel is MultiSensor, gets and sets the type of measurement that is supported by the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public IOType MultiSensorType { get; set; }
Visual Basic
Public Property MultiSensorType As IOType
    Get
    Set

Property Value

Type: IOType

Remarks

Some devices, such as the DT9829, support multiple sensor inputs for each channel and return a value of MultiSensor for the IOType property. If the channel has an IOType of MultiSensor, set the sensor type for the channel using the MultiSensor property. Most devices support only one IOType for each channel; setting the MultiSensorType property is not applicable in this case.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.Name Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..Name Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the name of the associated channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

Remarks

Each SupportedChannelInfo object in a SupportedChannels collection object must have a unique name. By default, the channels have the following names, which you can modify, if you wish: For analog input channels, the channels are named Ain0, Ain1, and so on. For analog output channels, the channels are named Aout0, Aout1, and so on. For digital input channels, the channels are named Din0, Din1, and so on. For counter/timer channels, the channels are named CT0 Word 0, CT0 Word 1, CT1 Word 0, CT1 Word 1, and so on. For quadrature decoder channels, the channels are named Quad0 Word 0, Quad0 Word 1, Quad1 Word 0, Quad1 Word 1, and so on.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.PhysicalChannelNumber Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..PhysicalChannelNumber Property
SupportedChannelInfo Class See Also Send Feedback
Returns the physical channel number that is associated with this channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannelNumber { get; }
Visual Basic
Public ReadOnly Property PhysicalChannelNumber As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.RtdACoefficient Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..RtdACoefficient Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the A coefficient that used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RtdACoefficient { get; set; }
Visual Basic
Public Property RtdACoefficient As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Callendar-Van Dusen transfer function converts raw counts to temperature for RTD measurements. If the RTDType is Pt3750, a value of 0.00381 is used for the RtdACoefficient property. If the RTDType is Pt3850, a value of 0.0039083 is used for the RtdACoefficient property. If the RTDType is Pt3911, a value of 0.0039692 is used for the RtdACoefficient property. If the RTDType is Pt3916, a value of 0.0039739 is used for the RtdACoefficient property. If the RTDType is Pt3920, a value of 0.0039787 is used for the RtdACoefficient property. If the RTDType is Pt3928, a value of 0.0039888 is used for the RtdACoefficient property.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.RtdBCoefficient Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..RtdBCoefficient Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the B coefficient that is used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RtdBCoefficient { get; set; }
Visual Basic
Public Property RtdBCoefficient As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Callendar-Van Dusen transfer function converts raw counts to temperature for RTD measurements. If the RTDType is Pt3750, a value of –0.000000602 is used for the RtdBCoefficient property. If the RTDType is Pt3850, a value of –0.0000005775 is used for the RtdBCoefficient property. If the RTDType is Pt3911, a value of –0.00000058495 is used for the RtdBCoefficient property. If the RTDType is Pt3916, a value of –0.000000587 is used for the RtdBCoefficient property. If the RTDType is Pt3920, a value of –0.0000005869 is used for the RtdBCoefficient property. If the RTDType is Pt3928, a value of –0.0000005915 is used for the RtdBCoefficient property.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.RtdCCoefficient Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..RtdCCoefficient Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the C coefficient that is used in the Callendar-Van Dusen transfer function for the RTD. Set the value of this property only if the RTDType property is Custom.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RtdCCoefficient { get; set; }
Visual Basic
Public Property RtdCCoefficient As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Callendar-Van Dusen transfer function converts raw counts to temperature for RTD measurements. If the RTDType is Pt3750, a value of –0.0000000000060 is used for the RtdCCoefficient property. If the RTDType is Pt3850, a value of –0.000000000004183 is used for the RtdCCoefficient property. If the RTDType is Pt3911, a value of –0.000000000004233 is used for the RtdCCoefficient property. If the RTDType is Pt3916, a value of –0.0000000000044 is used for the RtdCCoefficient property. If the RTDType is Pt3920, a value of –0.000000000004167 is used for the RtdCCoefficient property. If the RTDType is Pt3928, a value of –0.00000000000385 is used for the RtdCCoefficient property.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.RtdR0 Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..RtdR0 Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the nominal resistance of the RTD, in ohms, at 0 deg C. Set the value of this property only if the RTDType property is Custom or Pt3850 (unless you are using a 100 Ohm RTD).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RtdR0 { get; set; }
Visual Basic
Public Property RtdR0 As Double
    Get
    Set

Property Value

Type: Double

Remarks

This property is used in the Callendar-Van Dusen transfer function to convert raw counts to temperature for RTD measurements. If the RTDType is Pt3850 or Custom, specify a value of 100 (the default value), 500, or 1000 for the RtdR0 property. If the RTDType is Pt3750, a value of 1000 is used for the RtdR0 property. If the RTDType is Pt3911, a value of 100 is used for the RtdR0 property. If the RTDType is Pt3916, a value of 100 is used for the RtdR0 property. If the RTDType is Pt3920, a value of 98.129 is used for the RtdR0 property. If the RTDType is Pt3928, a value of 100 is used for the RtdR0 property.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.RTDType Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..RTDType Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the RTDType for the RTD that is connected to the channel. This property is used in the Callendar-Van Dusen transfer function to convert raw counts to temperature.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public RTDType RTDType { get; set; }
Visual Basic
Public Property RTDType As RTDType
    Get
    Set

Property Value

Type: RTDType

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.SensorGain Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SensorGain Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the gain value to apply to the sensor that is connected to this channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double SensorGain { get; set; }
Visual Basic
Public Property SensorGain As Double
    Get
    Set

Property Value

Type: Double

Remarks

By default, the sensor gain is 1. The sensor gain and offset are used to scale a sample from raw counts to a value in the engineering units of the sensor. The scaling occurs in two steps. First, the raw count value is converted to prescaled voltage using the gain applied to the input signal. Then, the prescaled voltage is scaled using the following equation: y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.SensorOffset Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SensorOffset Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the offset value to apply to the sensor that is connected to this channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double SensorOffset { get; set; }
Visual Basic
Public Property SensorOffset As Double
    Get
    Set

Property Value

Type: Double

Remarks

By default, the sensor offset is 0. The sensor gain and offset are used to scale a sample from raw counts to a value in the engineering units of the sensor. The scaling occurs in two steps. First, the raw count value is converted to prescaled voltage using the gain applied to the input signal. Then, the prescaled voltage is scaled using the following equation: y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.SensorWiringConfiguration Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SensorWiringConfiguration Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the SensorWiringConfiguration for the channel. Set the value of this property when the IOType or MultiSensorType property is Rtd, Resistance, or Thermistor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SensorWiringConfiguration SensorWiringConfiguration { get; set; }
Visual Basic
Public Property SensorWiringConfiguration As SensorWiringConfiguration
    Get
    Set

Property Value

Type: SensorWiringConfiguration

Remarks

Ensure that the value of this property matches the wiring configuration for your channel.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageBridgeConfiguration Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageBridgeConfiguration Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the StrainGageBridgeConfiguration of the strain gage that is connected to the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public StrainGageBridgeConfiguration StrainGageBridgeConfiguration { get; set; }
Visual Basic
Public Property StrainGageBridgeConfiguration As StrainGageBridgeConfiguration
    Get
    Set

Property Value

Type: StrainGageBridgeConfiguration

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageGageFactor Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageGageFactor Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the gage factor, or sensitivity, of the strain gage.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double StrainGageGageFactor { get; set; }
Visual Basic
Public Property StrainGageGageFactor As Double
    Get
    Set

Property Value

Type: Double

Remarks

This value is supplied by the manufacturer of the stain gage. Refer to the documentation for your strain gage for more information.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageLeadWireResistance Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageLeadWireResistance Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the lead wire resistance of the strain gage or bridge, in ohms.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double StrainGageLeadWireResistance { get; set; }
Visual Basic
Public Property StrainGageLeadWireResistance As Double
    Get
    Set

Property Value

Type: Double

Remarks

If remote sensing is used, specify 0 for this property.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageNominalResistance Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageNominalResistance Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the resistance, in ohms, of the strain gage or bridge while it is not under strain/load.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double StrainGageNominalResistance { get; set; }
Visual Basic
Public Property StrainGageNominalResistance As Double
    Get
    Set

Property Value

Type: Double

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageOffsetNullingValueInVolts Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageOffsetNullingValueInVolts Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the value of the bridge output (in volts) in the unstrained/unloaded condition. Internally, this value is subtracted from any measurements before the voltage is converted to strain.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double StrainGageOffsetNullingValueInVolts { get; set; }
Visual Basic
Public Property StrainGageOffsetNullingValueInVolts As Double
    Get
    Set

Property Value

Type: Double

Remarks

A balanced bridge under ideal conditions with zero strain applied produces zero volts. In practice, however, the output of a bridge in an unstrained condition is offset from zero slightly due to imperfect matching of bridge resistances. To perform offset nulling, read the value of the bridge in an unstrained condition using the AnalogInputSubsystem.GetSingleValueAsVolts method, and then specify the value that you read using this property. All subsequent data is then offset by this reference value.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGagePoissonRatio Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGagePoissonRatio Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the Poisson ratio for the strain gage.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double StrainGagePoissonRatio { get; set; }
Visual Basic
Public Property StrainGagePoissonRatio As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Poisson ratio is a material-dependent constant that is the ratio of transverse (perpendicular) contraction to axial strain. Specify the Poisson ratio when the analog input channel is configured for one of the following strain gage configurations: FullBridgeBendingPoisson, FullBridgeAxialPoisson, or HalfBridgePoisson.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageShuntCalibrationResistorEnabled Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageShuntCalibrationResistorEnabled Property
SupportedChannelInfo Class See Also Send Feedback
Specifies whether the internal shunt calibration resistor is enabled (switched in) or disabled (not used).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool StrainGageShuntCalibrationResistorEnabled { get; set; }
Visual Basic
Public Property StrainGageShuntCalibrationResistorEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If you want to use the internal shunt calibration resistor provided by the device, ensure that the internal RSHUNT+ and RSHUNT– lines are connected across the gage and that no strain is applied to the specimen, and then enable the resistor by setting this property to True. (Be sure to set this value back to False when the shunt calibration procedure is complete.)

Once the shunt resistor is enabled, read the value of the strain gage or bridge using the AnalogInputSubsystem.GetSingleValueAsStrain method. Then, divide the expected value of the strain gage or bridge by the actual value that you read, and specify the result, in microstrain, using the StrainGageShuntCalibrationValue property.

Refer to the user's manual for your device for more information on shunt calibration.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageShuntCalibrationValue Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageShuntCalibrationValue Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the shunt calibration value, in microstrain, for the bridge. Internally, the software multiplies the channel measurement with this value to adjust the gain of the device.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double StrainGageShuntCalibrationValue { get; set; }
Visual Basic
Public Property StrainGageShuntCalibrationValue As Double
    Get
    Set

Property Value

Type: Double

Remarks

For an analog input channel that supports a strain gage input and shunt calibration, you can use shunt calibration to correct span errors in the measurement path. You can also use shunt calibration to verify the integrity of the setup by turning on the shunt resistor before you acquire data.

If you want to use the internal shunt calibration resistor provided by the device, ensure that the internal RSHUNT+ and RSHUNT– lines are connected across the gage and that no strain is applied to the specimen, and then enable the resistor by setting the StrainGageShuntCalibrationResistorEnabled property to True. (Be sure to set this value back to False when the shunt calibration procedure is complete.)

Once the shunt resistor is enabled, read the value of the bridge using the AnalogInputSubsystem.GetSingleValueAsStrain method. Then, divide the expected value of the bridge by the actual value that you read, and specify the result, in microstrain, using this property.

Refer to the user's manual for your device for more information on shunt calibration.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.StrainGageTeds Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..StrainGageTeds Property
SupportedChannelInfo Class See Also Send Feedback
Provides an interface to a StrainGageTeds object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public StrainGageTeds StrainGageTeds { get; }
Visual Basic
Public ReadOnly Property StrainGageTeds As StrainGageTeds
    Get

Property Value

Type: StrainGageTeds

Remarks

Use this interface to read TEDS data directly from the strain gage hardware or from a data file for a strain gage (virtual TEDS).

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.Subsystem Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..Subsystem Property
SupportedChannelInfo Class See Also Send Feedback
Returns the subsystem object (AnalogInputSubsystem, AnalogOutputSubsystem, DigitalInputSubsystem, DigitalOutputSubsystem, CounterTimerSubsystem, TachSubsystem, or QuadratureDecoderSubsystem) that is associated with this channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase Subsystem { get; }
Visual Basic
Public ReadOnly Property Subsystem As SubsystemBase
    Get

Property Value

Type: SubsystemBase

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.SubsystemType Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SubsystemType Property
SupportedChannelInfo Class See Also Send Feedback
Returns the type of subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that is associated with this channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemType SubsystemType { get; }
Visual Basic
Public ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.SupportedMultiSensorTypes Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SupportedMultiSensorTypes Property
SupportedChannelInfo Class See Also Send Feedback
For channels that return an IOType of MultiSensor, returns an array containing the available sensor types (of type IOType) that the channel supports.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public IOType[] SupportedMultiSensorTypes { get; }
Visual Basic
Public ReadOnly Property SupportedMultiSensorTypes As IOType()
    Get

Property Value

Type: array< IOType >[]()[][]

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.SupportsInputTermination Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SupportsInputTermination Property
SupportedChannelInfo Class See Also Send Feedback
Specifies whether input termination is supported for the analog input channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInputTermination { get; set; }
Visual Basic
Public Property SupportsInputTermination As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If input termination is supported for the channel, you can enable or disable the bias return termination resistor using the InputTerminationEnabled property.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.ThermistorACoefficient Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ThermistorACoefficient Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the A coefficient that is used in the Steinhart-Hart transfer function for the thermistor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ThermistorACoefficient { get; set; }
Visual Basic
Public Property ThermistorACoefficient As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Steinhart-Hart transfer function converts raw counts to temperature for thermistor measurements.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.ThermistorBCoefficient Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ThermistorBCoefficient Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the B coefficient that is used in the Steinhart-Hart transfer function for the thermistor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ThermistorBCoefficient { get; set; }
Visual Basic
Public Property ThermistorBCoefficient As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Steinhart-Hart transfer function converts raw counts to temperature for thermistor measurements.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.ThermistorCCoefficient Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ThermistorCCoefficient Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the C coefficient that is used in the Steinhart-Hart transfer function for the thermistor.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ThermistorCCoefficient { get; set; }
Visual Basic
Public Property ThermistorCCoefficient As Double
    Get
    Set

Property Value

Type: Double

Remarks

The Steinhart-Hart transfer function converts raw counts to temperature for thermistor measurements.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.ThermocoupleType Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ThermocoupleType Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the ThermocoupleType that is connected to this channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ThermocoupleType ThermocoupleType { get; set; }
Visual Basic
Public Property ThermocoupleType As ThermocoupleType
    Get
    Set

Property Value

Type: ThermocoupleType

Remarks

By default, a J thermocouple type is used. The thermocouple type is used to convert a sample from raw counts to a temperature value in Celsius, Fahrenheit, or Kelvin. The software supplies the appropriate linearization algorithm based on the specified thermocouple type. To get the range for a specified thermocouple type, use the GetThermocoupleRange(ThermocoupleType, Double%, Double%, TemperatureUnit) method.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.TransducerCapacity Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..TransducerCapacity Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the full-scale range of the bridge-based sensor or transducer, such as a load cell, in its native engineering units.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double TransducerCapacity { get; set; }
Visual Basic
Public Property TransducerCapacity As Double
    Get
    Set

Property Value

Type: Double

Remarks

This value is supplied by the manufacturer of the bridge-based sensor or transducer. The bridge-based sensor or transducer is based on the full-bridge configuration.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannelInfo.TransducerRatedOutputInMv Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..TransducerRatedOutputInMv Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the rated output of a bridge-based sensor or transducer, such as a load cell, in terms of mV/V excitation.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double TransducerRatedOutputInMv { get; set; }
Visual Basic
Public Property TransducerRatedOutputInMv As Double
    Get
    Set

Property Value

Type: Double

Remarks

This value is supplied by the manufacturer of the bridge-based sensor or transducer. The bridge-based sensor or transducer is based on the full-bridge configuration.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members


SupportedChannels Class

[image]

OpenLayers for .NET Documentation
SupportedChannels Class
Members Example See Also Send Feedback
The SupportedChannels class describes, through a collection of SupportedChannelInfo objects, the channels available for a particular subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class SupportedChannels
Visual Basic
Public Class SupportedChannels

Remarks

It is often the case that a subsystem of one type is capable of including data in its data stream from a different subsystem type. For example, an analog input subsystem, which has its own native analog input channels, may also stream data from non-native channels, such as a digital input port or counter/timer channel. Typically, these non-native channels are described in a channel list with numbers beyond the range of its native channels. The Open Layers for .NET Class Library allows you to deal with non-native channels more easily by describing channels in terms of subsystem type and logical channel numbers or channel names.

Examples

Copy image Copy
// rename channel 0
ainSS.SupportedChannels[0].Name = "Pressure Sensor";

// add all available channels to the channel select list
int numChannels = ainSS.SupportedChannels.Count;
for (int i=0; i != numChannels-1; ++i)
{
    // get the channel using the physical channel number
    SupportedChannelInfo curChannel = ainSS.SupportedChannels[i];
    lbAin.Items.Add (curChannel.Name);
}

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SupportedChannels

See Also

SupportedChannels Members


SupportedChannels Members

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels Members
SupportedChannels Class Methods Properties See Also Send Feedback

The SupportedChannels type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChannelInfo(Int32) | Returns the SupportedChannelInfo object for the specified physical channel number.
Public method | GetChannelInfo(String) | Returns the SupportedChannelInfo object for the specified channel name.
Public method | GetChannelInfo(SubsystemType, Int32) | Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.
Public method | GetChannelInfo(SubsystemType, Int32, Int32) | Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Returns the number of SupportedChannelInfo objects in the SupportedChannels collection.
Public property | Item | Returns the SupportedChannelInfo object at the specified index ([index]) of the SupportedChannels object.

See Also

SupportedChannels Class


SupportedChannels Methods

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels Methods
SupportedChannels Class See Also Send Feedback

The SupportedChannels type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChannelInfo(Int32) | Returns the SupportedChannelInfo object for the specified physical channel number.
Public method | GetChannelInfo(String) | Returns the SupportedChannelInfo object for the specified channel name.
Public method | GetChannelInfo(SubsystemType, Int32) | Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.
Public method | GetChannelInfo(SubsystemType, Int32, Int32) | Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupportedChannels Class


SupportedChannels.GetChannelInfo Method

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method
SupportedChannels Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChannelInfo(Int32) | Returns the SupportedChannelInfo object for the specified physical channel number.
Public method | GetChannelInfo(String) | Returns the SupportedChannelInfo object for the specified channel name.
Public method | GetChannelInfo(SubsystemType, Int32) | Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.
Public method | GetChannelInfo(SubsystemType, Int32, Int32) | Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.

See Also

SupportedChannels Class
SupportedChannels Members


SupportedChannels.GetChannelInfo Method (Int32)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (Int32)
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object for the specified physical channel number.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    int physicalChannel
)
Visual Basic
Public Function GetChannelInfo (
    physicalChannel As Integer
) As SupportedChannelInfo

Parameters

physicalChannel
Type: System..::..Int32
Physical channel number of the subsystem.

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the specified channel.

Remarks

If the channel has multiple logical channel words, this method returns the SupportedChannelInfo object for logical channel word 0.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload


SupportedChannels.GetChannelInfo Method (String)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (String)
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object for the specified channel name.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    string name
)
Visual Basic
Public Function GetChannelInfo (
    name As String
) As SupportedChannelInfo

Parameters

name
Type: System..::..String
Channel name

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the specified channel.

Remarks

If the channel has multiple logical channel words, this method returns the SupportedChannelInfo object for logical channel word 0.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload


SupportedChannels.GetChannelInfo Method (SubsystemType, Int32)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (SubsystemType, Int32)
SupportedChannels Class See Also Send Feedback
Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    SubsystemType ssType,
    int subsystemChannel
)
Visual Basic
Public Function GetChannelInfo (
    ssType As SubsystemType,
    subsystemChannel As Integer
) As SupportedChannelInfo

Parameters

ssType
Type: OpenLayers.Base..::..SubsystemType
Subsystem type.
subsystemChannel
Type: System..::..Int32
Logical channel number for the subsystem type.

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the specified channel.

Remarks

If the channel has multiple logical channel words, this method returns the SupportedChannelInfo object for logical channel word 0.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload


SupportedChannels.GetChannelInfo Method (SubsystemType, Int32, Int32)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (SubsystemType, Int32, Int32)
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    SubsystemType ssType,
    int subsystemChannel,
    int channelWord
)
Visual Basic
Public Function GetChannelInfo (
    ssType As SubsystemType,
    subsystemChannel As Integer,
    channelWord As Integer
) As SupportedChannelInfo

Parameters

ssType
Type: OpenLayers.Base..::..SubsystemType
Subsystem type.
subsystemChannel
Type: System..::..Int32
Logical channel number for the subsystem type.
channelWord
Type: System..::..Int32
Logical channel word for the specified logical channel number.

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the logical channel word.

Remarks

For channels like 32-bit counter/timers that return multi-word data, the logical channel word, which is zero-based, maps the physical channel to the data word that it returns. For example, a logical channel word of 0 indicates that this channel returns the first 16-bits of data. A logical channel word of 1 indicates that this channel returns the second 16-bits of data. For channels that do not return multi-word data, the value of the logical channel word is -1.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload


SupportedChannels Properties

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels Properties
SupportedChannels Class See Also Send Feedback

The SupportedChannels type exposes the following members.

Properties

 | Name | Description
Public property | Count | Returns the number of SupportedChannelInfo objects in the SupportedChannels collection.
Public property | Item | Returns the SupportedChannelInfo object at the specified index ([index]) of the SupportedChannels object.

See Also

SupportedChannels Class


SupportedChannels.Count Property

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..Count Property
SupportedChannels Class See Also Send Feedback
Returns the number of SupportedChannelInfo objects in the SupportedChannels collection.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannels Class
SupportedChannels Members


SupportedChannels.Item Property

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..Item Property
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object at the specified index ([index]) of the SupportedChannels object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As SupportedChannelInfo
    Get

Parameters

index
Type: System..::..Int32

Property Value

Type: SupportedChannelInfo

See Also

SupportedChannels Class
SupportedChannels Members


SynchronizationModes Enumeration

[image]

OpenLayers for .NET Documentation
SynchronizationModes Enumeration
See Also Send Feedback
Contains the possible values for the SynchronizationMode property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum SynchronizationModes
Visual Basic
Public Enumeration SynchronizationModes

Members

Member name | Value | Description
None | 0 | No synchronization. The subsystem is configured to ignore the synchronization circuit.
Master | 1 | Device is the master. The synchronization connector on the device is configured to output a synchronization signal.
Slave | 2 | Device is a slave. The synchronization connector on the device is configured to accept a synchronization signal as an input.

See Also


TachSubsystem Class

[image]

OpenLayers for .NET Documentation
TachSubsystem Class
Members See Also Send Feedback
The TachSubsystem class provides the properties, methods, and events for performing tachometer operations.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class TachSubsystem : SubsystemBase
Visual Basic
Public Class TachSubsystem
    Inherits SubsystemBase

Remarks

Instances of this class are created using the TachSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..SubsystemBase
OpenLayers.Base..::..TachSubsystem

See Also

TachSubsystem Members


TachSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
TachSubsystem Members
TachSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The TachSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | TachSubsystem | Returns a TachSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a description of the tachometer subsystem and element. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | Count | Returns the current count between two consecutive edges (rising to rising or falling to falling) of the tachometer signal.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | EdgeType | Gets and sets the edge type (Falling or Rising) for the tachometer subsystem.
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | StaleDataFlagEnabled | Gets and sets the flag indicating whether or not the value of the tachometer is new. If StaleDataFlagEnabled is True, the most significant bit (MSB) of the value is set to 0 to indicate new data; reading the value before the measurement is complete returns an MSB of 1. If the StaleDataFlagEnabled is False, the MSB is always set to 0.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (Tachometer). (Overrides SubsystemBase..::..SubsystemType.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsFallingEdge | Returns True if the subsystem supports Falling falling edges of the tachometer signal; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsRisingEdge | Returns True if the subsystem supports Rising rising edges of the tachometer signal; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsStaleDataFlag | Returns True if the subsystem supports stale data flag
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

TachSubsystem Class


TachSubsystem Constructor

[image]

OpenLayers for .NET Documentation
TachSubsystem Constructor
TachSubsystem Class See Also Send Feedback
Returns a TachSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TachSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.Base..::..Device
The Open Layers Device object with which to associate the tachometer subsystem.
element
Type: System..::..Int32
The Element number of the tachometer subsystem.

Remarks

It is recommended that you use the TachSubsystem(Int32) method rather than this constructor to return a tachometer subsystem.

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
TachSubsystem Methods
TachSubsystem Class See Also Send Feedback

The TachSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from SubsystemBase.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a description of the tachometer subsystem and element. (Overrides Object..::..ToString()()()().)

See Also

TachSubsystem Class


TachSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..ToString Method
TachSubsystem Class See Also Send Feedback
Returns a description of the tachometer subsystem and element.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the tachometer subsystem and element.

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
TachSubsystem Properties
TachSubsystem Class See Also Send Feedback

The TachSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | Count | Returns the current count between two consecutive edges (rising to rising or falling to falling) of the tachometer signal.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | EdgeType | Gets and sets the edge type (Falling or Rising) for the tachometer subsystem.
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Gets and sets the resolution of the subsystem. (Inherited from SubsystemBase.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | StaleDataFlagEnabled | Gets and sets the flag indicating whether or not the value of the tachometer is new. If StaleDataFlagEnabled is True, the most significant bit (MSB) of the value is set to 0 to indicate new data; reading the value before the measurement is complete returns an MSB of 1. If the StaleDataFlagEnabled is False, the MSB is always set to 0.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (Tachometer). (Overrides SubsystemBase..::..SubsystemType.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsFallingEdge | Returns True if the subsystem supports Falling falling edges of the tachometer signal; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsRisingEdge | Returns True if the subsystem supports Rising rising edges of the tachometer signal; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsStaleDataFlag | Returns True if the subsystem supports stale data flag
Public property | SupportsSynchronization | Returns True if the subsystem supports synchronization with other devices (using SynchronizationMode); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronizationMode | For subsystems that allow you to synchronize operations on multiple devices using a synchronization connector, gets and sets the synchronization mode (None, Master, or Slave). (Inherited from SubsystemBase.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)

See Also

TachSubsystem Class


TachSubsystem.Count Property

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..Count Property
TachSubsystem Class See Also Send Feedback
Returns the current count between two consecutive edges (rising to rising or falling to falling) of the tachometer signal.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public long Count { get; }
Visual Basic
Public ReadOnly Property Count As Long
    Get

Return Value

Type: Int64
The current value of the tachometer.

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem.EdgeType Property

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..EdgeType Property
TachSubsystem Class See Also Send Feedback
Gets and sets the edge type (Falling or Rising) for the tachometer subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public EdgeType EdgeType { get; set; }
Visual Basic
Public Property EdgeType As EdgeType
    Get
    Set

Property Value

Type: EdgeType

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem.StaleDataFlagEnabled Property

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..StaleDataFlagEnabled Property
TachSubsystem Class See Also Send Feedback
Gets and sets the flag indicating whether or not the value of the tachometer is new. If StaleDataFlagEnabled is True, the most significant bit (MSB) of the value is set to 0 to indicate new data; reading the value before the measurement is complete returns an MSB of 1. If the StaleDataFlagEnabled is False, the MSB is always set to 0.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool StaleDataFlagEnabled { get; set; }
Visual Basic
Public Property StaleDataFlagEnabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem.SubsystemType Property

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..SubsystemType Property
TachSubsystem Class See Also Send Feedback
Returns the subsystem type (Tachometer).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override SubsystemType SubsystemType { get; }
Visual Basic
Public Overrides ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem.SupportsFallingEdge Property

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..SupportsFallingEdge Property
TachSubsystem Class See Also Send Feedback
Returns True if the subsystem supports Falling falling edges of the tachometer signal; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsFallingEdge { get; }
Visual Basic
Public ReadOnly Property SupportsFallingEdge As Boolean
    Get

Property Value

Type: Boolean

Remarks

Sets the edge type of the tachometer signal using the EdgeType property.

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem.SupportsRisingEdge Property

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..SupportsRisingEdge Property
TachSubsystem Class See Also Send Feedback
Returns True if the subsystem supports Rising rising edges of the tachometer signal; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsRisingEdge { get; }
Visual Basic
Public ReadOnly Property SupportsRisingEdge As Boolean
    Get

Property Value

Type: Boolean

Remarks

Sets the edge type of the tachometer signal using the EdgeType property.

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem.SupportsStaleDataFlag Property

[image]

OpenLayers for .NET Documentation
TachSubsystem..::..SupportsStaleDataFlag Property
TachSubsystem Class See Also Send Feedback
Returns True if the subsystem supports stale data flag

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsStaleDataFlag { get; }
Visual Basic
Public ReadOnly Property SupportsStaleDataFlag As Boolean
    Get

Property Value

Type: Boolean

See Also

TachSubsystem Class
TachSubsystem Members


TachSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
TachSubsystem Events
TachSubsystem Class See Also Send Feedback

The TachSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

TachSubsystem Class


TedsBase Class

[image]

OpenLayers for .NET Documentation
TedsBase Class
Members See Also Send Feedback
The TedsBase class is an abstract base class that is accessible from the following derived classes: StrainGageTeds and BridgeSensorTeds.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public abstract class TedsBase
Visual Basic
Public MustInherit Class TedsBase

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..TedsBase
OpenLayers.Base..::..BridgeSensorTeds
OpenLayers.Base..::..StrainGageTeds

See Also

TedsBase Members


TedsBase Members

[image] [image]

OpenLayers for .NET Documentation
TedsBase Members
TedsBase Class Methods Properties See Also Send Feedback

The TedsBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadHardwareTeds | Reads data directly from a TEDS-compatible sensor that is associated with the connected channel.
Public method | ReadVirtualTeds | Reads TEDS data from a virtual TEDS file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsTedsConfigured | Returns True if the TEDS data stream is read successfully; otherwise, returns False.
Public property | ManufacturerId | Gets identifying information about the manufacturer of the strain gage from the TEDS data for the channel.
Public property | ModelNumber | Gets the model number of the strain gage from the TEDS data for the channel.
Public property | SerialNumber | Gets the serial number of the strain gage from the TEDS data for the channel.
Public property | VersionLetter | Gets the version letter of the strain gage from the TEDS data for the channel.
Public property | VersionNumber | Gets the version number of the strain gage from the TEDS data for the channel.

See Also

TedsBase Class


TedsBase Methods

[image] [image]

OpenLayers for .NET Documentation
TedsBase Methods
TedsBase Class See Also Send Feedback

The TedsBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ReadHardwareTeds | Reads data directly from a TEDS-compatible sensor that is associated with the connected channel.
Public method | ReadVirtualTeds | Reads TEDS data from a virtual TEDS file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TedsBase Class


TedsBase.ReadHardwareTeds Method

[image]

OpenLayers for .NET Documentation
TedsBase..::..ReadHardwareTeds Method
TedsBase Class See Also Send Feedback
Reads data directly from a TEDS-compatible sensor that is associated with the connected channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void ReadHardwareTeds()
Visual Basic
Public Overridable Sub ReadHardwareTeds

See Also

TedsBase Class
TedsBase Members


TedsBase.ReadVirtualTeds Method

[image]

OpenLayers for .NET Documentation
TedsBase..::..ReadVirtualTeds Method
TedsBase Class See Also Send Feedback
Reads TEDS data from a virtual TEDS file.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void ReadVirtualTeds(
    string fileName
)
Visual Basic
Public Overridable Sub ReadVirtualTeds (
    fileName As String
)

Parameters

fileName
Type: System..::..String
The name of the file that contains the TEDS data.

See Also

TedsBase Class
TedsBase Members


TedsBase Properties

[image] [image]

OpenLayers for .NET Documentation
TedsBase Properties
TedsBase Class See Also Send Feedback

The TedsBase type exposes the following members.

Properties

 | Name | Description
Public property | IsTedsConfigured | Returns True if the TEDS data stream is read successfully; otherwise, returns False.
Public property | ManufacturerId | Gets identifying information about the manufacturer of the strain gage from the TEDS data for the channel.
Public property | ModelNumber | Gets the model number of the strain gage from the TEDS data for the channel.
Public property | SerialNumber | Gets the serial number of the strain gage from the TEDS data for the channel.
Public property | VersionLetter | Gets the version letter of the strain gage from the TEDS data for the channel.
Public property | VersionNumber | Gets the version number of the strain gage from the TEDS data for the channel.

See Also

TedsBase Class


TedsBase.IsTedsConfigured Property

[image]

OpenLayers for .NET Documentation
TedsBase..::..IsTedsConfigured Property
TedsBase Class See Also Send Feedback
Returns True if the TEDS data stream is read successfully; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool IsTedsConfigured { get; }
Visual Basic
Public ReadOnly Property IsTedsConfigured As Boolean
    Get

Property Value

Type: Boolean

See Also

TedsBase Class
TedsBase Members


TedsBase.ManufacturerId Property

[image]

OpenLayers for .NET Documentation
TedsBase..::..ManufacturerId Property
TedsBase Class See Also Send Feedback
Gets identifying information about the manufacturer of the strain gage from the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ManufacturerId { get; }
Visual Basic
Public ReadOnly Property ManufacturerId As Integer
    Get

Property Value

Type: Int32

See Also

TedsBase Class
TedsBase Members


TedsBase.ModelNumber Property

[image]

OpenLayers for .NET Documentation
TedsBase..::..ModelNumber Property
TedsBase Class See Also Send Feedback
Gets the model number of the strain gage from the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ModelNumber { get; }
Visual Basic
Public ReadOnly Property ModelNumber As Integer
    Get

Property Value

Type: Int32

See Also

TedsBase Class
TedsBase Members


TedsBase.SerialNumber Property

[image]

OpenLayers for .NET Documentation
TedsBase..::..SerialNumber Property
TedsBase Class See Also Send Feedback
Gets the serial number of the strain gage from the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint SerialNumber { get; }
Visual Basic
Public ReadOnly Property SerialNumber As UInteger
    Get

Property Value

Type: UInt32

See Also

TedsBase Class
TedsBase Members


TedsBase.VersionLetter Property

[image]

OpenLayers for .NET Documentation
TedsBase..::..VersionLetter Property
TedsBase Class See Also Send Feedback
Gets the version letter of the strain gage from the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public char VersionLetter { get; }
Visual Basic
Public ReadOnly Property VersionLetter As Char
    Get

Property Value

Type: Char

See Also

TedsBase Class
TedsBase Members


TedsBase.VersionNumber Property

[image]

OpenLayers for .NET Documentation
TedsBase..::..VersionNumber Property
TedsBase Class See Also Send Feedback
Gets the version number of the strain gage from the TEDS data for the channel.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int VersionNumber { get; }
Visual Basic
Public ReadOnly Property VersionNumber As Integer
    Get

Property Value

Type: Int32

See Also

TedsBase Class
TedsBase Members


TedsBridgeType Enumeration

[image]

OpenLayers for .NET Documentation
TedsBridgeType Enumeration
See Also Send Feedback
Bridge types as defined by TEDS.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum TedsBridgeType
Visual Basic
Public Enumeration TedsBridgeType

Members

Member name | Value | Description
Quarter | 0 | Quarter Bridge
Half | 1 | Half Bridge
Full | 2 | Full Bridge

See Also


TedsTemplateId Enumeration

[image]

OpenLayers for .NET Documentation
TedsTemplateId Enumeration
See Also Send Feedback
An identification number at the beginning of each template that identifies the template.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum TedsTemplateId
Visual Basic
Public Enumeration TedsTemplateId

Members

Member name | Value | Description
NotDefined | -1 | No TEDS template associated with the channel.
BridgeSensors | 33 | ID of a TEDs template for a bridge-based sensor.
StrainGage | 35 | ID of a TEDS template for a strain gage.

See Also


TemperatureFilterType Enumeration

[image]

OpenLayers for .NET Documentation
TemperatureFilterType Enumeration
See Also Send Feedback
Obsolete enumeration. This enum have been deprecated and may not be supported in future versions of library. Use DataFilterType enum and DataFilterType property.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum TemperatureFilterType
Visual Basic
Public Enumeration TemperatureFilterType

Members

Member name Value Description
Raw 1700 No filter. Provides fast response times, but the data may be difficult to interpret. Use when you want to filter the data yourself.

The Raw filter type returns the data exactly as it comes out of the Delta-Sigma A/D converters. Note that Delta-Sigma converters provide substantial digital filtering above the Nyquist frequency.

Generally, the only time it is desirable to use the Raw filter is if you are using fast responding thermocouples/RTDs, sampling them at higher speeds (> 1 Hz), and need as much response speed as possible.

MovingAverage 1701 Provides a compromise of filter functionality and response time. This filter can be used in any application.

This low-pass filter takes the previous 16 samples, adds them together, and divides by 16.

See Also


TemperatureUnit Enumeration

[image]

OpenLayers for .NET Documentation
TemperatureUnit Enumeration
See Also Send Feedback
Contains the possible values for the tempUnit parameter that is used by the GetDataAsTemperatureByte(ChannelListEntry, TemperatureUnit, Int32) and GetDataAsTemperatureDouble(ChannelListEntry, TemperatureUnit) methods.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum TemperatureUnit
Visual Basic
Public Enumeration TemperatureUnit

Members

Member name | Value | Description
Celsius | 0 | Celsius
Fahrenheit | 1 | Fahrenheit
Kelvin | 2 | Kelvin

See Also


ThermocoupleType Enumeration

[image]

OpenLayers for .NET Documentation
ThermocoupleType Enumeration
See Also Send Feedback
Contains the possible values for the ThermocoupleType property in the SupportedChannelInfo class.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ThermocoupleType
Visual Basic
Public Enumeration ThermocoupleType

Members

Member name | Value | Description
None | 1500 | None, return voltage for this channel
J | 1501 | Type J
K | 1502 | Type K
B | 1503 | Type B
E | 1504 | Type E
N | 1505 | Type N
R | 1506 | Type R
S | 1507 | Type S
T | 1508 | Type T

See Also


Trigger Class

[image]

OpenLayers for .NET Documentation
Trigger Class
Members See Also Send Feedback
The Trigger class provides an interface for controlling how a subsystem is triggered. For devices that support a start trigger and a reference trigger, the Trigger class is used to set up the start trigger, which starts pre-trigger data acquisition. Use the ReferenceTrigger class to control the reference trigger.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class Trigger
Visual Basic
Public NotInheritable Class Trigger

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..Trigger

See Also

Trigger Members


Trigger Members

[image] [image]

OpenLayers for .NET Documentation
Trigger Members
Trigger Class Methods Properties See Also Send Feedback

The Trigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets and sets the trigger threshold value. By default, the trigger threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings.
Public property | PreTriggerSource | Gets and sets the pre-trigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem when using ContinuousPreTrigger or ContinuousPrePostTrigger mode.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos trigger type; otherwise, returns False.
Public property | SupportsSoftwareTrigger | Returns True if the subsystem supports a Software trigger type; otherwise, returns False.
Public property | SupportsSvNegExternalTTLTrigger | Return True if the subsystem supports a TTLNeg trigger type for a single-value operation; otherwise, returns False.
Public property | SupportsSvPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type for a single-value operation; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg trigger event.
Public property | TriggerType | Gets and sets the trigger type (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

Trigger Class


Trigger Methods

[image] [image]

OpenLayers for .NET Documentation
Trigger Methods
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Trigger Class


Trigger Properties

[image] [image]

OpenLayers for .NET Documentation
Trigger Properties
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets and sets the trigger threshold value. By default, the trigger threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings.
Public property | PreTriggerSource | Gets and sets the pre-trigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem when using ContinuousPreTrigger or ContinuousPrePostTrigger mode.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos trigger type; otherwise, returns False.
Public property | SupportsSoftwareTrigger | Returns True if the subsystem supports a Software trigger type; otherwise, returns False.
Public property | SupportsSvNegExternalTTLTrigger | Return True if the subsystem supports a TTLNeg trigger type for a single-value operation; otherwise, returns False.
Public property | SupportsSvPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type for a single-value operation; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg trigger event.
Public property | TriggerType | Gets and sets the trigger type (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

Trigger Class


Trigger.Level Property

[image]

OpenLayers for .NET Documentation
Trigger..::..Level Property
Trigger Class See Also Send Feedback
Gets and sets the trigger threshold value. By default, the trigger threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Level { get; set; }
Visual Basic
Public Property Level As Double
    Get
    Set

Property Value

Type: Double

Remarks

This propery is valid only if TriggerType property is ThresholdPos or ThresholdNeg trigger type. The threshold level set by this property is the value after the gain is a applied to the threshold trigger channel. For example, if the voltage range of the subsystem is ±10 V, and the specified gain is 1, specify a threshold voltage level within ±10 V. Likewise, if the voltage range of the subsystem is ±10 V, and the specified gain is 10, specify a threshold voltage level within ±1 V.

See Also

Trigger Class
Trigger Members


Trigger.PreTriggerSource Property

[image]

OpenLayers for .NET Documentation
Trigger..::..PreTriggerSource Property
Trigger Class See Also Send Feedback
Gets and sets the pre-trigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem when using ContinuousPreTrigger or ContinuousPrePostTrigger mode.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TriggerType PreTriggerSource { get; set; }
Visual Basic
Public Property PreTriggerSource As TriggerType
    Get
    Set

Property Value

Type: TriggerType

See Also

Trigger Class
Trigger Members


Trigger.SupportedThresholdTriggerChannels Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportedThresholdTriggerChannels Property
Trigger Class See Also Send Feedback
Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int[] SupportedThresholdTriggerChannels { get; }
Visual Basic
Public ReadOnly Property SupportedThresholdTriggerChannels As Integer()
    Get

Property Value

Type: array<Int32>[]()[][]

See Also

Trigger Class
Trigger Members


Trigger.SupportsDigitalEventTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsDigitalEventTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a DigitalEvent trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDigitalEventTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsDigitalEventTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.SupportsNegExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsNegExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a TTLNeg trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.SupportsNegThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsNegThresholdTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdNeg trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.SupportsPosExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsPosExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Return True if the subsystem supports a TTLPos trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.SupportsPosThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsPosThresholdTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdPos trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.SupportsSoftwareTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsSoftwareTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a Software trigger type; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSoftwareTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsSoftwareTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.SupportsSvNegExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsSvNegExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Return True if the subsystem supports a TTLNeg trigger type for a single-value operation; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSvNegExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsSvNegExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.SupportsSvPosExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsSvPosExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Return True if the subsystem supports a TTLPos trigger type for a single-value operation; otherwise, returns False.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSvPosExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsSvPosExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members


Trigger.ThresholdTriggerChannel Property

[image]

OpenLayers for .NET Documentation
Trigger..::..ThresholdTriggerChannel Property
Trigger Class See Also Send Feedback
Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg trigger event.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ThresholdTriggerChannel { get; set; }
Visual Basic
Public Property ThresholdTriggerChannel As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

This propery is valid only if the TriggerType property is ThresholdPos or ThresholdNeg.

See Also

Trigger Class
Trigger Members


Trigger.TriggerType Property

[image]

OpenLayers for .NET Documentation
Trigger..::..TriggerType Property
Trigger Class See Also Send Feedback
Gets and sets the trigger type (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TriggerType TriggerType { get; set; }
Visual Basic
Public Property TriggerType As TriggerType
    Get
    Set

Property Value

Type: TriggerType

See Also

Trigger Class
Trigger Members


TriggeredScan Class

[image]

OpenLayers for .NET Documentation
TriggeredScan Class
Members See Also Send Feedback
The TriggeredScan class provides support for scanning the entries in a ChannelList a specified number of times when the device detects a specified retrigger.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class TriggeredScan
Visual Basic
Public NotInheritable Class TriggeredScan

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..TriggeredScan

See Also

TriggeredScan Members


TriggeredScan Members

[image] [image]

OpenLayers for .NET Documentation
TriggeredScan Members
TriggeredScan Class Methods Properties See Also Send Feedback

The TriggeredScan type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets and sets whether triggered scan mode is enabled for the subsystem. A value of True indicates that triggered scan mode is enabled, and a value of False indicates that triggered scan mode is disabled.
Public property | MaxMultiScanCount | Returns the maximum number of scans per retrigger that are supported by the subsystem.
Public property | MaxRetriggerFreq | Returns the maximum retrigger frequency that is supported by the subsystem.
Public property | MinRetriggerFreq | Returns the minimum retrigger frequency that is supported by the subsystem.
Public property | MultiScanCount | Gets and sets the maximum number of scans per retrigger that are supported by the subsystem.
Public property | RetriggerFrequency | Gets and sets the frequency of the internal (Software) retrigger source.
Public property | RetriggerSource | Gets and sets the retrigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

TriggeredScan Class


TriggeredScan Methods

[image] [image]

OpenLayers for .NET Documentation
TriggeredScan Methods
TriggeredScan Class See Also Send Feedback

The TriggeredScan type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriggeredScan Class


TriggeredScan Properties

[image] [image]

OpenLayers for .NET Documentation
TriggeredScan Properties
TriggeredScan Class See Also Send Feedback

The TriggeredScan type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets and sets whether triggered scan mode is enabled for the subsystem. A value of True indicates that triggered scan mode is enabled, and a value of False indicates that triggered scan mode is disabled.
Public property | MaxMultiScanCount | Returns the maximum number of scans per retrigger that are supported by the subsystem.
Public property | MaxRetriggerFreq | Returns the maximum retrigger frequency that is supported by the subsystem.
Public property | MinRetriggerFreq | Returns the minimum retrigger frequency that is supported by the subsystem.
Public property | MultiScanCount | Gets and sets the maximum number of scans per retrigger that are supported by the subsystem.
Public property | RetriggerFrequency | Gets and sets the frequency of the internal (Software) retrigger source.
Public property | RetriggerSource | Gets and sets the retrigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

TriggeredScan Class


TriggeredScan.Enabled Property

[image]

OpenLayers for .NET Documentation
TriggeredScan..::..Enabled Property
TriggeredScan Class See Also Send Feedback
Gets and sets whether triggered scan mode is enabled for the subsystem. A value of True indicates that triggered scan mode is enabled, and a value of False indicates that triggered scan mode is disabled.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

Property Value

Type: Boolean

See Also

TriggeredScan Class
TriggeredScan Members


TriggeredScan.MaxMultiScanCount Property

[image]

OpenLayers for .NET Documentation
TriggeredScan..::..MaxMultiScanCount Property
TriggeredScan Class See Also Send Feedback
Returns the maximum number of scans per retrigger that are supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short MaxMultiScanCount { get; }
Visual Basic
Public ReadOnly Property MaxMultiScanCount As Short
    Get

Property Value

Type: Int16

Remarks

Set the number of scans per retrigger using the MultiScanCount property.

See Also

TriggeredScan Class
TriggeredScan Members


TriggeredScan.MaxRetriggerFreq Property

[image]

OpenLayers for .NET Documentation
TriggeredScan..::..MaxRetriggerFreq Property
TriggeredScan Class See Also Send Feedback
Returns the maximum retrigger frequency that is supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaxRetriggerFreq { get; }
Visual Basic
Public ReadOnly Property MaxRetriggerFreq As Double
    Get

Property Value

Type: Double

Remarks

Set the retrigger frequency of the internal (Software) retrigger using the RetriggerFrequency property.

See Also

TriggeredScan Class
TriggeredScan Members


TriggeredScan.MinRetriggerFreq Property

[image]

OpenLayers for .NET Documentation
TriggeredScan..::..MinRetriggerFreq Property
TriggeredScan Class See Also Send Feedback
Returns the minimum retrigger frequency that is supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MinRetriggerFreq { get; }
Visual Basic
Public ReadOnly Property MinRetriggerFreq As Double
    Get

Property Value

Type: Double

Remarks

Set the retrigger frequency of the internal (Software) retrigger using the RetriggerFrequency property.

See Also

TriggeredScan Class
TriggeredScan Members


TriggeredScan.MultiScanCount Property

[image]

OpenLayers for .NET Documentation
TriggeredScan..::..MultiScanCount Property
TriggeredScan Class See Also Send Feedback
Gets and sets the maximum number of scans per retrigger that are supported by the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short MultiScanCount { get; set; }
Visual Basic
Public Property MultiScanCount As Short
    Get
    Set

Property Value

Type: Int16

Remarks

When it detects an initial trigger (pre-trigger source or post-trigger source), the device scans the ChannelList a specified number of times (determined by the MultiScanCount property), then stops. When the retrigger occurs, the process repeats.

See Also

TriggeredScan Class
TriggeredScan Members


TriggeredScan.RetriggerFrequency Property

[image]

OpenLayers for .NET Documentation
TriggeredScan..::..RetriggerFrequency Property
TriggeredScan Class See Also Send Feedback
Gets and sets the frequency of the internal (Software) retrigger source.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RetriggerFrequency { get; set; }
Visual Basic
Public Property RetriggerFrequency As Double
    Get
    Set

Property Value

Type: Double

Remarks

When the retrigger source is Software, use this method to specify the period between retriggers. When it detects an initial trigger (pre-trigger source or post-trigger source), the device scans the ChannelList a specified number of times (determined by the MultiScanCount property), then stops. When the software retrigger occurs (determined by the RetriggerFrequency property), the process repeats.

Determine the frequency of the software retrigger as follows:

Minimum Retrigger Period = (# of CGL entries x # of CGLs per trigger)/ A/D sample clock frequency + 2 us

Maximum Retrigger Frequency = 1/Minimum Retrigger Period

For example, if you have 512 ChannelListEntry objects in the ChannelList, are scanning the channel list 256 times every trigger or retrigger, and are using an A/D sample clock with a frequency of 1 MHz, set the maximum retrigger frequency to 7.62 Hz, since 7.62 Hz = 1/((512 * 256)/1 MHz + 2 us)

See Also

TriggeredScan Class
TriggeredScan Members


TriggeredScan.RetriggerSource Property

[image]

OpenLayers for .NET Documentation
TriggeredScan..::..RetriggerSource Property
TriggeredScan Class See Also Send Feedback
Gets and sets the retrigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TriggerType RetriggerSource { get; set; }
Visual Basic
Public Property RetriggerSource As TriggerType
    Get
    Set

Property Value

Type: TriggerType

Remarks

When it detects an initial trigger (pre-trigger source or post-trigger source), the device scans the ChannelList a specified number of times (determined by the MultiScanCount property), then stops. When the retrigger occurs, the process repeats. If the RetriggerSource is Software, specify the frequency of the retrigger using the RetriggerFrequency property. If the RetriggerSource is any of the external trigger sources, the ChannelList is retriggered whenever the external retrigger event occurs.

See Also

TriggeredScan Class
TriggeredScan Members


TriggerType Enumeration

[image]

OpenLayers for .NET Documentation
TriggerType Enumeration
See Also Send Feedback
Contains the possible values for the TriggerType, PreTriggerSource, and RetriggerSource properties.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum TriggerType
Visual Basic
Public Enumeration TriggerType

Members

Member name | Value | Description
Software | 300 | Software (internal) trigger. The trigger occurs when the Start()()()() method is executed.
TTLPos | 301 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the rising edge of the digital TTL signal.
DigitalEvent | 304 | A trigger is generated when an external digital event occurs.
TTLNeg | 306 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the falling edge of the digital TTL signal.
ThresholdPos | 1200 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A positive analog threshold trigger occurs when the device detects a positive-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.
ThresholdNeg | 1201 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A negative analog threshold trigger occurs when the device detects a negative-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.

See Also


Utility Class

[image]

OpenLayers for .NET Documentation
Utility Class
Members See Also Send Feedback
The Utility class provides service-related properties and methods, allowing you to get information about assemblies and to convert data from raw counts to voltage and from voltage to raw counts.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class Utility
Visual Basic
Public Class Utility

Inheritance Hierarchy

System..::..Object
OpenLayers.Base..::..Utility

See Also

Utility Members


Utility Members

[image] [image]

OpenLayers for .NET Documentation
Utility Members
Utility Class Methods Properties See Also Send Feedback

The Utility type exposes the following members.

Methods

 | Name | Description
 | ComputeDeltaRosette | For a delta rosette, calculates the minimum and maximum principal strain values and their associated angles (in degrees).
 | ComputeRectangularRosette | For a rectangular rosette, calculates the minimum and maximum principal strain values and their associated angles (in degrees).
 | ConvertTemperatureToVolts | For a given ThermocoupleType and temperature value, converts the temperature value into voltage.
 | ConvertVoltsToTemperature | For a given ThermocoupleType and voltage value, converts the voltage value into temperature.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetThermocoupleRange | Returns the temperature range for a given ThermocoupleType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RawValueToVolts | Converts a data value from a raw count to voltage.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | VoltsToRawValue | Converts a voltage value into a raw count.

Properties

Name | Description
AssemblyVersion | Returns the major, minor, revision, and build numbers of the assembly.

See Also

Utility Class


Utility Methods

[image] [image]

OpenLayers for .NET Documentation
Utility Methods
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Methods

 | Name | Description
 | ComputeDeltaRosette | For a delta rosette, calculates the minimum and maximum principal strain values and their associated angles (in degrees).
 | ComputeRectangularRosette | For a rectangular rosette, calculates the minimum and maximum principal strain values and their associated angles (in degrees).
 | ConvertTemperatureToVolts | For a given ThermocoupleType and temperature value, converts the temperature value into voltage.
 | ConvertVoltsToTemperature | For a given ThermocoupleType and voltage value, converts the voltage value into temperature.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetThermocoupleRange | Returns the temperature range for a given ThermocoupleType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RawValueToVolts | Converts a data value from a raw count to voltage.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | VoltsToRawValue | Converts a voltage value into a raw count.

See Also

Utility Class


Utility.ComputeDeltaRosette Method

[image]

OpenLayers for .NET Documentation
Utility..::..ComputeDeltaRosette Method
Utility Class See Also Send Feedback
For a delta rosette, calculates the minimum and maximum principal strain values and their associated angles (in degrees).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static void ComputeDeltaRosette(
    double[] strain1,
    double[] strain2,
    double[] strain3,
    out double[] minPrincipalStrain,
    out double[] maxPrinicipalStrain,
    out double[] minPrinicipalStrainAngle,
    out double[] maxPrinicipalStrainAngle
)
Visual Basic
Public Shared Sub ComputeDeltaRosette (
    strain1 As Double(),
    strain2 As Double(),
    strain3 As Double(),
    <OutAttribute> ByRef minPrincipalStrain As Double(),
    <OutAttribute> ByRef maxPrinicipalStrain As Double(),
    <OutAttribute> ByRef minPrinicipalStrainAngle As Double(),
    <OutAttribute> ByRef maxPrinicipalStrainAngle As Double()
)

Parameters

strain1
Type: array<System..::..Double>[]()[][]
Data from strain gage 1.
strain2
Type: array<System..::..Double>[]()[][]
Data from strain gage 2. The axis for strain gage 2 must be 60 degrees away from that of strain gage 1.
strain3
Type: array<System..::..Double>[]()[][]
Data from strain gage 3. The axis for strain gage 3 must be 120 degrees away from that of strain gage 1.
minPrincipalStrain
Type: array<System..::..Double>[]()[][]%
The minimum strain value of the principal strain.
maxPrinicipalStrain
Type: array<System..::..Double>[]()[][]%
The maximum strain value of the principal strain.
minPrinicipalStrainAngle
Type: array<System..::..Double>[]()[][]%
The direction of the minimum principal axes relative to the direction of strain gage 1 (in degrees).
maxPrinicipalStrainAngle
Type: array<System..::..Double>[]()[][]%
The direction of the maximum principal axes relative to the direction of strain gage 1 (in degrees).

See Also

Utility Class
Utility Members


Utility.ComputeRectangularRosette Method

[image]

OpenLayers for .NET Documentation
Utility..::..ComputeRectangularRosette Method
Utility Class See Also Send Feedback
For a rectangular rosette, calculates the minimum and maximum principal strain values and their associated angles (in degrees).

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static void ComputeRectangularRosette(
    double[] strain1,
    double[] strain2,
    double[] strain3,
    out double[] minPrincipalStrain,
    out double[] maxPrinicipalStrain,
    out double[] minPrinicipalStrainAngle,
    out double[] maxPrinicipalStrainAngle
)
Visual Basic
Public Shared Sub ComputeRectangularRosette (
    strain1 As Double(),
    strain2 As Double(),
    strain3 As Double(),
    <OutAttribute> ByRef minPrincipalStrain As Double(),
    <OutAttribute> ByRef maxPrinicipalStrain As Double(),
    <OutAttribute> ByRef minPrinicipalStrainAngle As Double(),
    <OutAttribute> ByRef maxPrinicipalStrainAngle As Double()
)

Parameters

strain1
Type: array<System..::..Double>[]()[][]
Data from strain gage 1.
strain2
Type: array<System..::..Double>[]()[][]
Data from strain gage 2. The axis for strain gage 2 must be 45 degrees away from that of strain gage 1.
strain3
Type: array<System..::..Double>[]()[][]
Data from strain gage 3. The axis for strain gage 3 must be 90 degrees away from that of strain gage 1.
minPrincipalStrain
Type: array<System..::..Double>[]()[][]%
The minimum strain value of the principal strain.
maxPrinicipalStrain
Type: array<System..::..Double>[]()[][]%
The maximum strain value of the principal strain.
minPrinicipalStrainAngle
Type: array<System..::..Double>[]()[][]%
The direction of the minimum principal axes relative to the direction of strain gage 1 (in degrees).
maxPrinicipalStrainAngle
Type: array<System..::..Double>[]()[][]%
The direction of the maximum principal axes relative to the direction of strain gage 1 (in degrees).

See Also

Utility Class
Utility Members


Utility.ConvertTemperatureToVolts Method

[image]

OpenLayers for .NET Documentation
Utility..::..ConvertTemperatureToVolts Method
Utility Class See Also Send Feedback
For a given ThermocoupleType and temperature value, converts the temperature value into voltage.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static double ConvertTemperatureToVolts(
    ThermocoupleType thermocoupleType,
    TemperatureUnit tempUnit,
    double temperature
)
Visual Basic
Public Shared Function ConvertTemperatureToVolts (
    thermocoupleType As ThermocoupleType,
    tempUnit As TemperatureUnit,
    temperature As Double
) As Double

Parameters

thermocoupleType
Type: OpenLayers.Base..::..ThermocoupleType
The ThermocoupleType that is associated with the temperature value.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The units (Celsius, Fahrenheit, or Kelvin) for the specified temperature value.
temperature
Type: System..::..Double
The temperature value to convert.

Return Value

Type: Double
The voltage value that is associated with the specified temperature value.

See Also

Utility Class
Utility Members


Utility.ConvertVoltsToTemperature Method

[image]

OpenLayers for .NET Documentation
Utility..::..ConvertVoltsToTemperature Method
Utility Class See Also Send Feedback
For a given ThermocoupleType and voltage value, converts the voltage value into temperature.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static double ConvertVoltsToTemperature(
    ThermocoupleType thermocoupleType,
    TemperatureUnit tempUnit,
    double voltage
)
Visual Basic
Public Shared Function ConvertVoltsToTemperature (
    thermocoupleType As ThermocoupleType,
    tempUnit As TemperatureUnit,
    voltage As Double
) As Double

Parameters

thermocoupleType
Type: OpenLayers.Base..::..ThermocoupleType
The ThermocoupleType that is associated with the voltage value.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The units (Celsius, Fahrenheit, or Kelvin) to use with the converted temperature value.
voltage
Type: System..::..Double
The voltage value to convert.

Return Value

Type: Double
The temperature value that is associated with the specified voltage value.

See Also

Utility Class
Utility Members


Utility.GetThermocoupleRange Method

[image]

OpenLayers for .NET Documentation
Utility..::..GetThermocoupleRange Method
Utility Class See Also Send Feedback
Returns the temperature range for a given ThermocoupleType.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static void GetThermocoupleRange(
    ThermocoupleType type,
    ref double minValue,
    ref double maxValue,
    TemperatureUnit tempUnit
)
Visual Basic
Public Shared Sub GetThermocoupleRange (
    type As ThermocoupleType,
    ByRef minValue As Double,
    ByRef maxValue As Double,
    tempUnit As TemperatureUnit
)

Parameters

type
Type: OpenLayers.Base..::..ThermocoupleType
The ThermocoupleType whose temperature range you want to get.
minValue
Type: System..::..Double%
The lower limit of the temperature range for the specified thermocouple type.
maxValue
Type: System..::..Double%
The upper limit of the temperature range for the specified thermocouple type.
tempUnit
Type: OpenLayers.Base..::..TemperatureUnit
The units (Celsius, Fahrenheit, or Kelvin) for the temperature values.

See Also

Utility Class
Utility Members


Utility.RawValueToVolts Method

[image]

OpenLayers for .NET Documentation
Utility..::..RawValueToVolts Method
Utility Class See Also Send Feedback
Converts a data value from a raw count to voltage.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static double RawValueToVolts(
    int code,
    Encoding encoding,
    double minVoltage,
    double maxVoltage,
    int resolution
)
Visual Basic
Public Shared Function RawValueToVolts (
    code As Integer,
    encoding As Encoding,
    minVoltage As Double,
    maxVoltage As Double,
    resolution As Integer
) As Double

Parameters

code
Type: System..::..Int32
Raw data count to convert.
encoding
Type: OpenLayers.Base..::..Encoding
The data encoding (Binary or TwosComplement) of the raw count.
minVoltage
Type: System..::..Double
The lower limit of the voltage range.
maxVoltage
Type: System..::..Double
The upper limit of the voltage range.
resolution
Type: System..::..Int32
The resolution of the raw count.

Return Value

Type: Double
The voltage value that is associated with the raw count.

See Also

Utility Class
Utility Members


Utility.VoltsToRawValue Method

[image]

OpenLayers for .NET Documentation
Utility..::..VoltsToRawValue Method
Utility Class See Also Send Feedback
Converts a voltage value into a raw count.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static int VoltsToRawValue(
    double voltage,
    Encoding encoding,
    double minVoltage,
    double maxVoltage,
    int resolution
)
Visual Basic
Public Shared Function VoltsToRawValue (
    voltage As Double,
    encoding As Encoding,
    minVoltage As Double,
    maxVoltage As Double,
    resolution As Integer
) As Integer

Parameters

voltage
Type: System..::..Double
The voltage value to convert.
encoding
Type: OpenLayers.Base..::..Encoding
The data encoding (Binary or TwosComplement) for the raw count.
minVoltage
Type: System..::..Double
The lower limit of the voltage range.
maxVoltage
Type: System..::..Double
The upper limit of the voltage range.
resolution
Type: System..::..Int32
The resolution of the raw count.

Return Value

Type: Int32
The raw count that is associated with the voltage.

See Also

Utility Class
Utility Members


Utility Properties

[image] [image]

OpenLayers for .NET Documentation
Utility Properties
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Properties

Name | Description
AssemblyVersion | Returns the major, minor, revision, and build numbers of the assembly.

See Also

Utility Class


Utility.AssemblyVersion Property

[image]

OpenLayers for .NET Documentation
Utility..::..AssemblyVersion Property
Utility Class See Also Send Feedback
Returns the major, minor, revision, and build numbers of the assembly.

Namespace: OpenLayers.Base
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static Version AssemblyVersion { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyVersion As Version
    Get

Property Value

Type: Version

See Also

Utility Class
Utility Members


OpenLayers.Controls Namespace

[image]

OpenLayers for .NET Documentation
OpenLayers.Controls Namespace
Send Feedback
A Windows control library that contains graphical user controls, which are used on Windows forms.

Classes

 | Class | Description
Public class | Display | The DT-Display control provides properties and methods for plotting data to a display.

Enumerations

 | Enumeration | Description
Public enumeration | BandMode | Contains the possible band modes.


BandMode Enumeration

[image]

OpenLayers for .NET Documentation
BandMode Enumeration
See Also Send Feedback
Contains the possible band modes.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public enum BandMode
Visual Basic
Public Enumeration BandMode

Members

Member name | Value | Description
MultiBand | 0 | Each signal is displayed independently in a separate band with its own y-axis.
SingleBand | 1 | Each signal is displayed in a single band (signals are overlaid). Each signal has its own y-axis.

Remarks

The BandMode property determines how the data for each channel is displayed on the screen.

See Also

OpenLayers.Controls Namespace


Display Class

[image]

OpenLayers for .NET Documentation
Display Class
Members See Also Send Feedback
The DT-Display control provides properties and methods for plotting data to a display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
[SerializableAttribute]
public class Display : UserControl, ISupportInitialize
Visual Basic
<SerializableAttribute>
Public Class Display
    Inherits UserControl
    Implements ISupportInitialize

Remarks

Use the Signals property to add signals to the display. Use the SignalBufferLength property to set the length of the data array for each signal.

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..UserControl
OpenLayers.Controls..::..Display

See Also

Display Members
OpenLayers.Controls Namespace


Display Members

[image] [image]

OpenLayers for .NET Documentation
Display Members
Display Class Constructors Methods Properties Events See Also Send Feedback

The Display type exposes the following members.

Constructors

 | Name | Description
Public method | Display | Creates a display.

Methods

 | Name | Description
Public method | BeginInit | Starts the initialization process of the display.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CaptureScale | Sets the scale of the y-axis to the minimum and maximum values of the first signal in the MemorySignalList collection.
Public method | ChartBeginInit | Starts the initialization process of the control.
Public method | ChartEndInit | Ends the initialization process of the control.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableRendering | Does not allow drawing to the display.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EnableRendering | Allows drawing to the display.
Public method | EndInit | Ends the initialization process of the display.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetCurveColor | Returns the color in which to plot a specified signal.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | Print | Prints the currently displayed view to the default printer.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCurveColor | Sets the color in which to plot a specified signal.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SignalListUpdate | Reinitializes the control when the content or count of the MemorySignalList has changed.
Public method | SignalUpdate | Refreshes the display with new signal data.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Gets or sets the autoscale mode. If set to True, the scale of the y-axis is continually adjusted to the minimum and maximum values of the actual input signal(s). If set to False (the default value), the scale of the y-axis is set to the default range.
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | AxesColor | Gets or sets the color of the x- and y-axes.
Public property | BackColor | Gets or sets the background color when BackgroundStyle is set to Color, or the starting color of the background gradient when BackgroundStyle is set to Gradient. (Overrides Control..::..BackColor.)
Public property | BackGradientAngle | Gets or sets the angle of the color gradient for the background when BackgroundStyle is set to Gradient.
Public property | BackGradientColor | Gets or sets the ending color for the background gradient when BackgroundStyle is set to Gradient.
Public property | BackgroundImage | Gets or sets the image to draw to the background when BackgroundStyle is set to Image. (Overrides Control..::..BackgroundImage.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BackgroundStyle | Gets or sets the style (Color, Gradient, or Image) of the background.
Public property | BandMode | Gets or sets the display mode (SingleBand or MultiBand) for the selected channels.
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | Footer | Gets or sets the text for the footer that appears in the center, bottom of the display.
Public property | FooterFont | Gets or sets the font that is used to format the text in the footer, which appears in the center, bottom of the display.
Public property | ForeColor | Gets or sets the color for the title and footer text of the display. (Overrides Control..::..ForeColor.)
Public property | GridColor | Gets or sets the color of all the gridlines on the display.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SignalBufferLength | Gets or sets the length, in samples, of the data array (buffer) for each signal to be plotted.
Public property | Signals | Accesses a list of signals in the MemorySignalList collection.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Title | Gets or sets the text for the title that appears in the center, top of the display.
Public property | TitleFont | Gets or sets the font that is used to format the text of the title, which appears in the center, top of the display.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | XDataCurrentRangeMax | Gets or sets the upper limit of the x-axis range that is visible.
Public property | XDataCurrentRangeMin | Gets or sets the lower limit on the x-axis range that is visible.
Public property | XDataName | Gets or sets the name for the x-axis.
Public property | XDataRangeMax | Gets or sets the maximum value that can be displayed on the x-axis.
Public property | XDataRangeMin | Gets or sets the minimum value that can be displayed on the x-axis.
Public property | XDataUnit | Gets or sets the units for the x-axis.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Display Class
OpenLayers.Controls Namespace


Display Constructor

[image]

OpenLayers for .NET Documentation
Display Constructor
Display Class See Also Send Feedback
Creates a display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Display()
Visual Basic
Public Sub New

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display Methods

[image] [image]

OpenLayers for .NET Documentation
Display Methods
Display Class See Also Send Feedback

The Display type exposes the following members.

Methods

 | Name | Description
Public method | BeginInit | Starts the initialization process of the display.
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Public method | CaptureScale | Sets the scale of the y-axis to the minimum and maximum values of the first signal in the MemorySignalList collection.
Public method | ChartBeginInit | Starts the initialization process of the control.
Public method | ChartEndInit | Ends the initialization process of the control.
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisableRendering | Does not allow drawing to the display.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EnableRendering | Allows drawing to the display.
Public method | EndInit | Ends the initialization process of the display.
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetCurveColor | Returns the color in which to plot a specified signal.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | Print | Prints the currently displayed view to the default printer.
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetCurveColor | Sets the color in which to plot a specified signal.
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | SignalListUpdate | Reinitializes the control when the content or count of the MemorySignalList has changed.
Public method | SignalUpdate | Refreshes the display with new signal data.
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from UserControl.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)

See Also

Display Class
OpenLayers.Controls Namespace


Display.BeginInit Method

[image]

OpenLayers for .NET Documentation
Display..::..BeginInit Method
Display Class See Also Send Feedback
Starts the initialization process of the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void BeginInit()
Visual Basic
Public Sub BeginInit

Implements

ISupportInitialize..::..BeginInit()()()()

Remarks

This method is called automatically when you drag the control onto your form.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.CaptureScale Method

[image]

OpenLayers for .NET Documentation
Display..::..CaptureScale Method
Display Class See Also Send Feedback
Sets the scale of the y-axis to the minimum and maximum values of the first signal in the MemorySignalList collection.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void CaptureScale()
Visual Basic
Public Sub CaptureScale

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.ChartBeginInit Method

[image]

OpenLayers for .NET Documentation
Display..::..ChartBeginInit Method
Display Class See Also Send Feedback
Starts the initialization process of the control.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void ChartBeginInit()
Visual Basic
Public Sub ChartBeginInit

Remarks

This method is called automatically when you drag the control onto your form.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.ChartEndInit Method

[image]

OpenLayers for .NET Documentation
Display..::..ChartEndInit Method
Display Class See Also Send Feedback
Ends the initialization process of the control.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void ChartEndInit()
Visual Basic
Public Sub ChartEndInit

Remarks

This method is called automatically when you drag the control onto your form.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.DisableRendering Method

[image]

OpenLayers for .NET Documentation
Display..::..DisableRendering Method
Display Class See Also Send Feedback
Does not allow drawing to the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public int DisableRendering()
Visual Basic
Public Function DisableRendering As Integer

Return Value

Type: Int32
The current value of the internal counter.

Remarks

Typically, you disable rendering when you are creating or modifying signal data. DisableRendering increments an internal counter. When the internal counter is zero, the graphic is drawn to the display.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.EnableRendering Method

[image]

OpenLayers for .NET Documentation
Display..::..EnableRendering Method
Display Class See Also Send Feedback
Allows drawing to the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public int EnableRendering()
Visual Basic
Public Function EnableRendering As Integer

Return Value

Type: Int32
The current value of the internal counter.

Remarks

EnableRendering decrements an internal counter. When the internal counter is zero, the graphic is drawn to the screen.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.EndInit Method

[image]

OpenLayers for .NET Documentation
Display..::..EndInit Method
Display Class See Also Send Feedback
Ends the initialization process of the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void EndInit()
Visual Basic
Public Sub EndInit

Implements

ISupportInitialize..::..EndInit()()()()

Remarks

This method is called automatically when drag the Display control onto your form.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.GetCurveColor Method

[image]

OpenLayers for .NET Documentation
Display..::..GetCurveColor Method
Display Class See Also Send Feedback
Returns the color in which to plot a specified signal.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Color GetCurveColor(
    int index
)
Visual Basic
Public Function GetCurveColor (
    index As Integer
) As Color

Parameters

index
Type: System..::..Int32
The index of the signal in the MemorySignalList collection whose color will be returned.

Return Value

Type: Color
The current color of the specified signal.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.Print Method

[image]

OpenLayers for .NET Documentation
Display..::..Print Method
Display Class See Also Send Feedback
Prints the currently displayed view to the default printer.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void Print()
Visual Basic
Public Sub Print

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.SetCurveColor Method

[image]

OpenLayers for .NET Documentation
Display..::..SetCurveColor Method
Display Class See Also Send Feedback
Sets the color in which to plot a specified signal.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void SetCurveColor(
    int index,
    Color curveColor
)
Visual Basic
Public Sub SetCurveColor (
    index As Integer,
    curveColor As Color
)

Parameters

index
Type: System..::..Int32
The index of the signal in the MemorySignalList collection whose color will be changed.
curveColor
Type: System.Drawing..::..Color
The color to apply to the specified signal.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.SignalListUpdate Method

[image]

OpenLayers for .NET Documentation
Display..::..SignalListUpdate Method
Display Class See Also Send Feedback
Reinitializes the control when the content or count of the MemorySignalList has changed.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void SignalListUpdate()
Visual Basic
Public Sub SignalListUpdate

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.SignalUpdate Method

[image]

OpenLayers for .NET Documentation
Display..::..SignalUpdate Method
Display Class See Also Send Feedback
Refreshes the display with new signal data.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void SignalUpdate()
Visual Basic
Public Sub SignalUpdate

Remarks

Use this method when you want to update the display with new signals or new signal data.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display Properties

[image] [image]

OpenLayers for .NET Documentation
Display Properties
Display Class See Also Send Feedback

The Display type exposes the following members.

Properties

 | Name | Description
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Gets or sets the autoscale mode. If set to True, the scale of the y-axis is continually adjusted to the minimum and maximum values of the actual input signal(s). If set to False (the default value), the scale of the y-axis is set to the default range.
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from UserControl.)
Public property | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
Public property | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
Public property | AxesColor | Gets or sets the color of the x- and y-axes.
Public property | BackColor | Gets or sets the background color when BackgroundStyle is set to Color, or the starting color of the background gradient when BackgroundStyle is set to Gradient. (Overrides Control..::..BackColor.)
Public property | BackGradientAngle | Gets or sets the angle of the color gradient for the background when BackgroundStyle is set to Gradient.
Public property | BackGradientColor | Gets or sets the ending color for the background gradient when BackgroundStyle is set to Gradient.
Public property | BackgroundImage | Gets or sets the image to draw to the background when BackgroundStyle is set to Image. (Overrides Control..::..BackgroundImage.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BackgroundStyle | Gets or sets the style (Color, Gradient, or Image) of the background.
Public property | BandMode | Gets or sets the display mode (SingleBand or MultiBand) for the selected channels.
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Public property | Footer | Gets or sets the text for the footer that appears in the center, bottom of the display.
Public property | FooterFont | Gets or sets the font that is used to format the text in the footer, which appears in the center, bottom of the display.
Public property | ForeColor | Gets or sets the color for the title and footer text of the display. (Overrides Control..::..ForeColor.)
Public property | GridColor | Gets or sets the color of all the gridlines on the display.
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Control.)
Public property | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | SignalBufferLength | Gets or sets the length, in samples, of the data array (buffer) for each signal to be plotted.
Public property | Signals | Accesses a list of signals in the MemorySignalList collection.
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the height and width of the control. (Inherited from Control.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from UserControl.)
Public property | Title | Gets or sets the text for the title that appears in the center, top of the display.
Public property | TitleFont | Gets or sets the font that is used to format the text of the title, which appears in the center, top of the display.
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Public property | XDataCurrentRangeMax | Gets or sets the upper limit of the x-axis range that is visible.
Public property | XDataCurrentRangeMin | Gets or sets the lower limit on the x-axis range that is visible.
Public property | XDataName | Gets or sets the name for the x-axis.
Public property | XDataRangeMax | Gets or sets the maximum value that can be displayed on the x-axis.
Public property | XDataRangeMin | Gets or sets the minimum value that can be displayed on the x-axis.
Public property | XDataUnit | Gets or sets the units for the x-axis.

See Also

Display Class
OpenLayers.Controls Namespace


Display.AutoScale Property

[image]

OpenLayers for .NET Documentation
Display..::..AutoScale Property
Display Class See Also Send Feedback
Gets or sets the autoscale mode. If set to True, the scale of the y-axis is continually adjusted to the minimum and maximum values of the actual input signal(s). If set to False (the default value), the scale of the y-axis is set to the default range.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoScale { get; set; }
Visual Basic
Public Property AutoScale As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If you are zooming in on data during run-time, autoscale mode is automatically set to False. When the zoom is undone, the autoscale mode is automatically set to its previous value.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.AxesColor Property

[image]

OpenLayers for .NET Documentation
Display..::..AxesColor Property
Display Class See Also Send Feedback
Gets or sets the color of the x- and y-axes.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Color AxesColor { get; set; }
Visual Basic
Public Property AxesColor As Color
    Get
    Set

Property Value

Type: Color

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.BackColor Property

[image]

OpenLayers for .NET Documentation
Display..::..BackColor Property
Display Class See Also Send Feedback
Gets or sets the background color when BackgroundStyle is set to Color, or the starting color of the background gradient when BackgroundStyle is set to Gradient.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public override Color BackColor { get; set; }
Visual Basic
Public Overrides Property BackColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

When BackgroundStyle is set to Color (the default value), the entire background is filled with the color specified by BackColor. When BackgroundStyle is set to Gradient, the background is filled with a color gradient that starts with the color specified by BackColor and ends with the color specified by BackGradientColor.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..BackgroundStyle
Display..::..BackGradientColor


Display.BackGradientAngle Property

[image]

OpenLayers for .NET Documentation
Display..::..BackGradientAngle Property
Display Class See Also Send Feedback
Gets or sets the angle of the color gradient for the background when BackgroundStyle is set to Gradient.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public float BackGradientAngle { get; set; }
Visual Basic
Public Property BackGradientAngle As Single
    Get
    Set

Property Value

Type: Single

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..BackgroundStyle
Display..::..BackColor
Display..::..BackGradientColor


Display.BackGradientColor Property

[image]

OpenLayers for .NET Documentation
Display..::..BackGradientColor Property
Display Class See Also Send Feedback
Gets or sets the ending color for the background gradient when BackgroundStyle is set to Gradient.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Color BackGradientColor { get; set; }
Visual Basic
Public Property BackGradientColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

When BackgroundStyle is set to Gradient, the background is filled with a color gradient that starts with the color specified by BackColor and ends with the color specified by BackGradientColor.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..BackgroundStyle
Display..::..BackColor
Display..::..BackGradientAngle


Display.BackgroundImage Property

[image]

OpenLayers for .NET Documentation
Display..::..BackgroundImage Property
Display Class See Also Send Feedback
Gets or sets the image to draw to the background when BackgroundStyle is set to Image.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public override Image BackgroundImage { get; set; }
Visual Basic
Public Overrides Property BackgroundImage As Image
    Get
    Set

Property Value

Type: Image

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..BackgroundStyle


Display.BackgroundStyle Property

[image]

OpenLayers for .NET Documentation
Display..::..BackgroundStyle Property
Display Class See Also Send Feedback
Gets or sets the style (Color, Gradient, or Image) of the background.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public BackgroundStyle BackgroundStyle { get; set; }
Visual Basic
Public Property BackgroundStyle As BackgroundStyle
    Get
    Set

Property Value

Type: BackgroundStyle

Remarks

When BackgroundStyle is set to Color (the default value), the background shows the color specified by BackColor. When BackgroundStyle is set to Gradient, the background shows a color gradient starting with the color specified by BackColor and ending with the color specified by BackGradientColor, at the angle specified by BackGradientAngle. When BackgroundStyle is set to Image, the image specified by BackgroundImage is drawn to the background.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..BackColor
Display..::..BackGradientColor
Display..::..BackGradientAngle
Display..::..BackgroundImage


Display.BandMode Property

[image]

OpenLayers for .NET Documentation
Display..::..BandMode Property
Display Class See Also Send Feedback
Gets or sets the display mode (SingleBand or MultiBand) for the selected channels.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public BandMode BandMode { get; set; }
Visual Basic
Public Property BandMode As BandMode
    Get
    Set

Property Value

Type: BandMode

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..BandMode


Display.Footer Property

[image]

OpenLayers for .NET Documentation
Display..::..Footer Property
Display Class See Also Send Feedback
Gets or sets the text for the footer that appears in the center, bottom of the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public string Footer { get; set; }
Visual Basic
Public Property Footer As String
    Get
    Set

Property Value

Type: String

Remarks

By default, no footer text is specified.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..FooterFont


Display.FooterFont Property

[image]

OpenLayers for .NET Documentation
Display..::..FooterFont Property
Display Class See Also Send Feedback
Gets or sets the font that is used to format the text in the footer, which appears in the center, bottom of the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Font FooterFont { get; set; }
Visual Basic
Public Property FooterFont As Font
    Get
    Set

Property Value

Type: Font

Remarks

By default, the font is Arial, 8 pt.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..Footer


Display.ForeColor Property

[image]

OpenLayers for .NET Documentation
Display..::..ForeColor Property
Display Class See Also Send Feedback
Gets or sets the color for the title and footer text of the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public override Color ForeColor { get; set; }
Visual Basic
Public Overrides Property ForeColor As Color
    Get
    Set

Property Value

Type: Color

Remarks

See TitleFontfor further information on formatting the title text and see FooterFont for further information on formatting the footer text.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.GridColor Property

[image]

OpenLayers for .NET Documentation
Display..::..GridColor Property
Display Class See Also Send Feedback
Gets or sets the color of all the gridlines on the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Color GridColor { get; set; }
Visual Basic
Public Property GridColor As Color
    Get
    Set

Property Value

Type: Color

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.SignalBufferLength Property

[image]

OpenLayers for .NET Documentation
Display..::..SignalBufferLength Property
Display Class See Also Send Feedback
Gets or sets the length, in samples, of the data array (buffer) for each signal to be plotted.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public long SignalBufferLength { get; set; }
Visual Basic
Public Property SignalBufferLength As Long
    Get
    Set

Property Value

Type: Int64

Remarks

The data array of each signal must be the same length. Changing SignalBufferLength updates the length of the data array for each signal. By default, the value of the SignalBufferLength property is 0.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.Signals Property

[image]

OpenLayers for .NET Documentation
Display..::..Signals Property
Display Class See Also Send Feedback
Accesses a list of signals in the MemorySignalList collection.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public MemorySignalList Signals { get; }
Visual Basic
Public ReadOnly Property Signals As MemorySignalList
    Get

Property Value

Type: MemorySignalList

Remarks

You can index the MemorySignalList collection to access the data arrays for each signal. For example, Signal[0].Data[15] accesses the data value at index 15 of the data array for the first signal in the MemorySignalList collection. Call SignalUpdate() to refresh the display after the data for a signal is changed. Refer to MemorySignalList for information on adding, inserting, and removing MemorySignal objects. Refer to Data for more information on assigning data to a signal.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.Title Property

[image]

OpenLayers for .NET Documentation
Display..::..Title Property
Display Class See Also Send Feedback
Gets or sets the text for the title that appears in the center, top of the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set

Property Value

Type: String

Remarks

By default, the value of this property is Chart.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..TitleFont


Display.TitleFont Property

[image]

OpenLayers for .NET Documentation
Display..::..TitleFont Property
Display Class See Also Send Feedback
Gets or sets the font that is used to format the text of the title, which appears in the center, top of the display.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Font TitleFont { get; set; }
Visual Basic
Public Property TitleFont As Font
    Get
    Set

Property Value

Type: Font

Remarks

By default, the font is Arial, 10 pt, Bold, Underline.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace
Display..::..Title


Display.XDataCurrentRangeMax Property

[image]

OpenLayers for .NET Documentation
Display..::..XDataCurrentRangeMax Property
Display Class See Also Send Feedback
Gets or sets the upper limit of the x-axis range that is visible.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double XDataCurrentRangeMax { get; set; }
Visual Basic
Public Property XDataCurrentRangeMax As Double
    Get
    Set

Property Value

Type: Double

Remarks

The XDataRangeMin and XDataRangeMax properties specify the maximum range that can be displayed on the x-axis. By setting the XDataCurrentRangeMin and XDataCurrentRangeMax properties, you define a subset of this range that will be displayed on the x-axis; this is called the current visible range. In general, the value of XDataCurrentRangeMax should be less than or equal to the value of the XDataRangeMax property. By default, the value of XDataCurrentRangeMax is 1000.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.XDataCurrentRangeMin Property

[image]

OpenLayers for .NET Documentation
Display..::..XDataCurrentRangeMin Property
Display Class See Also Send Feedback
Gets or sets the lower limit on the x-axis range that is visible.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double XDataCurrentRangeMin { get; set; }
Visual Basic
Public Property XDataCurrentRangeMin As Double
    Get
    Set

Property Value

Type: Double

Remarks

The XDataRangeMin and XDataRangeMax properties specify the maximum range that can be displayed on the x-axis. By setting the XDataCurrentRangeMin and XDataCurrentRangeMax properties, you define a subset of this range that will be displayed on the x-axis; this is called the current visible range. In general, the value of XDataCurrentRangeMin should be greater than or equal to the value of the XDataRangeMin property. By default, the value of XDataCurrentRangeMin is 0.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.XDataName Property

[image]

OpenLayers for .NET Documentation
Display..::..XDataName Property
Display Class See Also Send Feedback
Gets or sets the name for the x-axis.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public string XDataName { get; set; }
Visual Basic
Public Property XDataName As String
    Get
    Set

Property Value

Type: String

Remarks

By default, the value of this property is Time.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.XDataRangeMax Property

[image]

OpenLayers for .NET Documentation
Display..::..XDataRangeMax Property
Display Class See Also Send Feedback
Gets or sets the maximum value that can be displayed on the x-axis.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double XDataRangeMax { get; set; }
Visual Basic
Public Property XDataRangeMax As Double
    Get
    Set

Property Value

Type: Double

Remarks

The XDataRangeMin and XDataRangeMax properties specify the entire range that can be displayed on the x-axis. By setting the XDataCurrentRangeMin and XDataCurrentRangeMax properties, you can define a subset of this range that will be displayed on the x-axis; this is called the current visible range. By default, the value of XDataRangeMax is 1000.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.XDataRangeMin Property

[image]

OpenLayers for .NET Documentation
Display..::..XDataRangeMin Property
Display Class See Also Send Feedback
Gets or sets the minimum value that can be displayed on the x-axis.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double XDataRangeMin { get; set; }
Visual Basic
Public Property XDataRangeMin As Double
    Get
    Set

Property Value

Type: Double

Remarks

The XDataRangeMin and XDataRangeMax properties specify the entire range that can be displayed on the x-axis. By setting the XDataCurrentRangeMin and XDataCurrentRangeMax properties, you can define a subset of this range that will be displayed on the x-axis; this is called the current visible range. By default, the value of XDataRangeMin is 0.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display.XDataUnit Property

[image]

OpenLayers for .NET Documentation
Display..::..XDataUnit Property
Display Class See Also Send Feedback
Gets or sets the units for the x-axis.

Namespace: OpenLayers.Controls
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public string XDataUnit { get; set; }
Visual Basic
Public Property XDataUnit As String
    Get
    Set

Property Value

Type: String

Remarks

By default, the value of this property is sec.

See Also

Display Class
Display Members
OpenLayers.Controls Namespace


Display Events

[image] [image]

OpenLayers for .NET Documentation
Display Events
Display Class See Also Send Feedback

The Display type exposes the following members.

Events

 | Name | Description
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
Public event | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
Public event | TextChanged | (Inherited from UserControl.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

Display Class
OpenLayers.Controls Namespace


OpenLayers.DeviceCollection Namespace

[image]

OpenLayers for .NET Documentation
OpenLayers.DeviceCollection Namespace
Send Feedback
Provides a programming interface for Open Layers-compatible device collections.

Classes

 | Class | Description
Public class | AnalogInputSubsystem | The AnalogInputSubsystem class provides the properties, methods, and events for performing analog input operations for a device collection.
Public class | AnalogOutputSubsystem | The AnalogOutputSubsystem class provides the properties, methods, and events for performing analog output operations.
Public class | AnalogSubsystem | The AnalogSubsystem class is an abstract base class and is accessible only by using the following derived classes: AnalogInputSubsystem and/or AnalogOutputSubsystem.
Public class | BufferDoneEventArgs | A BufferDoneEventArgs object is passed to one of the following delegates when the associated event occurs: BufferDoneHandler delegate when the event BufferDoneEvent occurs or PreTriggerBufferDoneHandler delegate when the event PreTriggerBufferDoneEvent occurs. BufferDoneEventArgs contains the data that is associated with the event, including the subsystem that raised the event, the time stamp of when the event occurred, and the completed OlBuffer object.
Public class | BufferQueue | The BufferQueue class provides an interface for queuing OlBuffer objects to a device's subsystem for continuous I/O operations.
Public class | ChannelList | A ChannelList specifies a collection of ChannelListEntry objects for use in a continuous I/O operation. Each ChannelListEntry object encapsulates a physical channel connection for a specific subsystem.
Public class | ChannelListEntry | A ChannelListEntry object encapsulates a physical channel connection that is associated with a specific subsystem. A ChannelList object is a collection of ChannelListEntry objects.
Public class | Clock | The Clock class provides an interface for controlling the clock of a subsystem.
Public class | Device | A Device object encapsulates an Open Layers device collection and manages and distributes subsystems for the individual devices contained within the device collection.
Public class | DeviceMgr | The DeviceMgr is a singleton class that is responsible for managing Open Layers devices in the system and for assigning Device objects.
Public class | DriverRunTimeErrorEventArgs | A DriverRunTimeErrorEventArgs object is passed to the DriverRunTimeErrorEventHandler delegate when when the event DriverRunTimeErrorEvent occurs. DriverRunTimeErrorEventArgs contains the error/warning that is generated by the device driver, an error message that describes the error/warning, the subsystem that raised the event, and the time stamp of when the event occurred.
Public class | GeneralEventArgs | GeneralEventArgs is the base class for all event data. GeneralEventArgs contains the data that is passed to all events, including the subsystem that raised the event, and the time stamp of when the event occurred.
Public class | IOCompleteEventArgs | An IOCompleteEventArgs object is passed to the IOCompleteHandler delegate when the event IOCompleteEvent occurs. IOCompleteEventArgs contains the data associated with the event IOCompleteEvent. For analog input operations, this includes the total number of samples per channel that were acquired from the time acquisition was started to the last post-trigger sample, and the subsystem that raised the event. For analog output operations, this is the subsystem that raised the event.
Public class | OlBuffer | The OlBuffer class encapsulates a data buffer that is used in a continuous I/O operation.
Public class | OlError | An OlError object encapsulates an Open Layers error code.
Public class | OlException | The OlException class provides properites for handling Open Layers errors that can be generated in the OpenLayers.DeviceCollection namespace.
Public class | Range | This class is used by the VoltageRange and SupportedVoltageRanges methods to return the lower and upper limits of the voltage range for an analog subsystem.
Public class | ReferenceTrigger | The ReferenceTrigger class provides an interface for controlling the reference trigger of a subsystem. For devices that support a reference trigger, pre-trigger data acquisition stops and post-trigger acquisition starts when the reference trigger event occurs. Post-trigger acquisition stops when the number of samples you specify for the post-trigger scan count has been reached.
Public class | SimultaneousStart | The SimultaneousStart class provides an interface for simultaneously starting multiple subsystems.
Public class | SubsystemBase | The SubsystemBase class is an abstract base class that is accessible from the following derived classes: AnalogSubsystem (and its derived classes AnalogInputSubsystem and AnalogOutputSubsystem),
Public class | SupportedChannelInfo | The SupportedChannelInfo class describes a specific channel of a subsystem. You access a SupportedChannelInfo object using the SupportedChannels class.
Public class | SupportedChannels | The SupportedChannels class describes, through a collection of SupportedChannelInfo objects, the channels available for a particular subsystem.
Public class | Trigger | The Trigger class provides an interface for controlling how a subsystem is triggered. For devices that support a start trigger and a reference trigger, the Trigger class is used to set up the start trigger, which starts pre-trigger data acquisition. Use the ReferenceTrigger class to control the reference trigger.

Structures

 | Structure | Description
Public structure | HardwareInfo | This structure is used by the GetHardwareInfo()()()() method to return information about a Open Layers-compliant device collection.
Public structure | SingleValuesInfoRaw | Used with SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]), specifies the analog output channel to update and the raw count value to output on that channel.
Public structure | SingleValuesInfoVolts | Used with SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][]), specifies the analog output channel to update and the voltage value to output on that channel.

Delegates

 | Delegate | Description
Public delegate | BufferDoneHandler | The BufferDoneHandler delegate is called when the event BufferDoneEvent occurs.
Public delegate | DeviceRemovedHandler | The DeviceRemovedHandler delegate is called when the event DeviceRemovedEvent occurs.
Public delegate | DriverRunTimeErrorEventHandler | The DriverRunTimeErrorEventHandler delegate is called when the DriverRunTimeErrorEvent occurs.
Public delegate | GeneralFailureHandler | The GeneralFailureHandler delegate is called when the event GeneralFailureEvent occurs.
Public delegate | IOCompleteHandler | The IOCompleteHandler delegate is called when the event IOCompleteEvent occurs.
Public delegate | PreTriggerBufferDoneHandler | The PreTriggerBufferDoneHandler delegate is called when the event PreTriggerBufferDoneEvent occurs.
Public delegate | QueueDoneHandler | The QueueDoneHandler delegate is called when the event QueueDoneEvent occurs.
Public delegate | QueueStoppedHandler | The QueueStoppedHandler delegate is called when the event QueueStoppedEvent occurs.

Enumerations

 | Enumeration | Description
Public enumeration | ChannelDataType | Contains the possible values for the ChannelDataType parameter that is used by the RawDataFormat property.
Public enumeration | ChannelType | Contains the possible values for the ChannelType property.
Public enumeration | ClockSource | Contains the possible values for the Source property.
Public enumeration | CouplingType | Contains the possible values for the Coupling property.
Public enumeration | DataFlow | Contains the possible values for the DataFlow property.
Public enumeration | Encoding | Contains the possible values for the SubsystemBase.Encoding and OlBuffer.Encoding properties, and for the Encoding parameter of the VoltsToRawValue(Double, Encoding, Double, Double, Int32) and RawValueToVolts(Int32, Encoding, Double, Double, Int32) methods.
Public enumeration | ErrorCode | Open Layers error codes that are accessible using an OlException object.
Public enumeration | ExcitationCurrentSource | Contains the possible values for the ExcitationCurrentSource property.
Public enumeration | IOType | Contains the possible values for the IOType.
Public enumeration | OlBuffer..::..BufferState | Contains the possible values for the state of an OlBuffer object.
Public enumeration | ReferenceTriggerType | Contains the possible values for the TriggerType property.
Public enumeration | SubsystemBase..::..States | Returns the current state of the subsystem.
Public enumeration | SubsystemType | Contains the possible values for the SubsystemType property.
Public enumeration | TriggerType | Contains the possible values for the TriggerType, PreTriggerSource, and RetriggerSource properties.


AnalogInputSubsystem Class

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Class
Members See Also Send Feedback
The AnalogInputSubsystem class provides the properties, methods, and events for performing analog input operations for a device collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class AnalogInputSubsystem : AnalogSubsystem
Visual Basic
Public Class AnalogInputSubsystem
    Inherits AnalogSubsystem

Remarks

Instances of this class are created using the AnalogInputSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..SubsystemBase
OpenLayers.DeviceCollection..::..AnalogSubsystem
OpenLayers.DeviceCollection..::..AnalogInputSubsystem

See Also

AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Members
AnalogInputSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | AnalogInputSubsystem | Returns an AnalogInputSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the subsystem immediately without waiting for the current buffer to be filled. (Overrides SubsystemBase..::..Abort()()()().)
Public method | AutoCalibrate | Calibrates the subsystem through software, performing an auto-zero function.
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from AnalogSubsystem.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOneBuffer | Using continuous acquisition, acquires a buffer of data NumberOfSample long from the specified channel. This method uses the current clock frequency, trigger, etc., for the acquisition. This method is synchronous and returns only after the requested data has been acquired or a calculated timeout value has been exceeded.
Public method | GetSingleValueAsRaw | Acquires a single value from an analog input channel and returns it in raw counts.
Public method | GetSingleValueAsSensor | Acquires a single value from an analog input channel and returns it in the engineering units of the specified sensor.
Public method | GetSingleValueAsVolts | Acquires a single value from an analog input channel and returns the data in voltage.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous operation on the analog input subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog input subsystem after the current buffer has been filled. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog input subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedExcitationCurrentValues | Returns an array containing the available values for the internal excitation current source.
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsACCoupling | Returns True if the subsystem supports AC coupling, where the DC offset is removed; otherwise, returns False.
Public property | SupportsAutoCalibrate | Returns True if the subsystem supports auto-calibration; otherwise, returns False.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDCCoupling | Returns True if the subsystem supports DC coupling, where the DC offset is included; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsExternalExcitationCurrentSrc | Returns True if the subsystem supports an external excitation current source; otherwise, returns False.
Public property | SupportsIepe | Returns True if the subsystem supports IEPE (accelerometer) inputs; otherwise, returns False.
Public property | SupportsInternalExcitationCurrentSrc | Returns True if the subsystem supports an internal excitation current source; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | PreTriggerBufferDoneEvent | Occurs when the OlBuffer object is filled with pre-trigger data (for an analog input operation only).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogInputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem Constructor

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Constructor
AnalogInputSubsystem Class See Also Send Feedback
Returns an AnalogInputSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogInputSubsystem(
    Device devCollection,
    int element
)
Visual Basic
Public Sub New (
    devCollection As Device,
    element As Integer
)

Parameters

devCollection
Type: OpenLayers.DeviceCollection..::..Device
The Open Layers Device object with which to associate the analog input subsystem.
element
Type: System..::..Int32
The Element number of the analog input subsystem.

Remarks

It is recommended that you use the AnalogInputSubsystem(Int32) method rather than this constructor to return an analog input subsystem.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Methods
AnalogInputSubsystem Class See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the subsystem immediately without waiting for the current buffer to be filled. (Overrides SubsystemBase..::..Abort()()()().)
Public method | AutoCalibrate | Calibrates the subsystem through software, performing an auto-zero function.
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from AnalogSubsystem.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOneBuffer | Using continuous acquisition, acquires a buffer of data NumberOfSample long from the specified channel. This method uses the current clock frequency, trigger, etc., for the acquisition. This method is synchronous and returns only after the requested data has been acquired or a calculated timeout value has been exceeded.
Public method | GetSingleValueAsRaw | Acquires a single value from an analog input channel and returns it in raw counts.
Public method | GetSingleValueAsSensor | Acquires a single value from an analog input channel and returns it in the engineering units of the specified sensor.
Public method | GetSingleValueAsVolts | Acquires a single value from an analog input channel and returns the data in voltage.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts a continuous operation on the analog input subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog input subsystem after the current buffer has been filled. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog input subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

See Also

AnalogInputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.Abort Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..Abort Method
AnalogInputSubsystem Class See Also Send Feedback
Stops a continuous operation on the subsystem immediately without waiting for the current buffer to be filled.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Abort()
Visual Basic
Public Overrides Sub Abort

Remarks

This method overrides the Abort method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.AutoCalibrate Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..AutoCalibrate Method
AnalogInputSubsystem Class See Also Send Feedback
Calibrates the subsystem through software, performing an auto-zero function.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void AutoCalibrate()
Visual Basic
Public Sub AutoCalibrate

Remarks

To determine if the specified subsystem supports this capability, use the SupportsAutoCalibrate property. If this property returns a value of True, the subsystem can be calibrated through software. Ensure that the subsystem is not running when you call this method, or an error is returned.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.GetOneBuffer Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetOneBuffer Method
AnalogInputSubsystem Class See Also Send Feedback
Using continuous acquisition, acquires a buffer of data NumberOfSample long from the specified channel. This method uses the current clock frequency, trigger, etc., for the acquisition. This method is synchronous and returns only after the requested data has been acquired or a calculated timeout value has been exceeded.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer GetOneBuffer(
    SupportedChannelInfo ChannelInfo,
    int NumberOfSamples,
    int TimeoutMSecs
)
Visual Basic
Public Function GetOneBuffer (
    ChannelInfo As SupportedChannelInfo,
    NumberOfSamples As Integer,
    TimeoutMSecs As Integer
) As OlBuffer

Parameters

ChannelInfo
Type: OpenLayers.DeviceCollection..::..SupportedChannelInfo
ChannelListEntry object, which represents the channel from which to acquire data.
NumberOfSamples
Type: System..::..Int32
Number of samples to acquire
TimeoutMSecs
Type: System..::..Int32
Timeout value, in milliseconds, to wait for buffer completion. A value of -1 means the timeout is infinite.

Return Value

Type: OlBuffer
An OlBuffer object with the specified number of samples.

Remarks

This method allocates a buffer and starts the continuous analog input operation automatically using the current configuration of the analog input subsystem. This method is synchronous and returns only after the requested data has been acquired or the specified timeout value, in milliseconds, has been exceeded. No BufferDoneEvents occur. If the buffer is not filled before the specified timeout value is exceeded, AnalogInputSubsystem.Abort is called and a TimeoutException is raised. If a GeneralFailureEvent or DriverRuntimeErrorEvent occurs during acquisition, an OlException with the appropriate error code is raised. Once the buffer is returned, you can copy the data from the buffer into an array using the OlBuffer methods.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.GetSingleValueAsRaw Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsRaw Method
AnalogInputSubsystem Class Example See Also Send Feedback
Acquires a single value from an analog input channel and returns it in raw counts.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int GetSingleValueAsRaw(
    int physicalChannel,
    double gain
)
Visual Basic
Public Function GetSingleValueAsRaw (
    physicalChannel As Integer,
    gain As Double
) As Integer

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.
gain
Type: System..::..Double
Gain to apply to the input signal.

Return Value

Type: Int32
The analog input value in raw counts.

Examples

This example shows a typical use of GetSingleValueAsRaw.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object for element 0.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
ainSS.Config ();
// Acquire a single value from analog input channel 0, apply a gain
// of 1 to the input, and return the data in raw counts.
int rawCount = ainSS.GetSingleValueAsRaw (0,1.0);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
ainSS.Config()
' Acquire a single value from analog input channel 0, apply a gain of 1
' to the input, and return the data in raw counts.
Dim rawValue As Integer = ainSS.GetSingleValueAsRaw(0, 1)

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.GetSingleValueAsSensor Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsSensor Method
AnalogInputSubsystem Class Example See Also Send Feedback
Acquires a single value from an analog input channel and returns it in the engineering units of the specified sensor.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsSensor(
    int physicalChannel,
    double gain,
    double sensorGain,
    double sensorOffset
)
Visual Basic
Public Function GetSingleValueAsSensor (
    physicalChannel As Integer,
    gain As Double,
    sensorGain As Double,
    sensorOffset As Double
) As Double

Parameters

physicalChannel
Type: System..::..Int32
Physical analog input channel to sample.
gain
Type: System..::..Double
Gain to apply to the input signal to get the prescaled voltage value.
sensorGain
Type: System..::..Double
Sensor gain value to apply to the prescaled voltage value. The default value is 1.
sensorOffset
Type: System..::..Double
Sensor offset value to apply to the prescaled voltage value. The default value is 0.

Return Value

Type: Double
The scaled value in the engineering units of the sensor.

Remarks

The sensor gain and offset are used to scale a sample from raw counts to a sensor format. The scaling occurs in two steps. First, the raw count value is acquired and converted to prescaled voltage using the gain applied to the channel. Then, the sensor gain and sensor offset parameters are applied to the prescaled voltage value using the linear equation y = mx + b, where y is the sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

Examples

This example shows a typical use of GetSingleValueAsSensor.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object for element 0.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
ainSS.Config ();
// Acquire a single value from analog input channel 0, apply a gain of 1
// to the input, and return the data in the engineering units of the
// sensor using a sensor gain of 100 and an offset of 2.
double sensorValue = ainSS.GetSingleValueAsSensor (0,1.0,100,2);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
ainSS.Config()
' Acquire a single value from analog input channel 0, apply a gain of 1
' to the input, and return the data in the engineering units of the
' sensor using a sensor gain of 100 and an offset of 2.
Dim sensorValue As Double = ainSS.GetSingleValueAsSensor(0, 1.0, 100, 2)

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.GetSingleValueAsVolts Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..GetSingleValueAsVolts Method
AnalogInputSubsystem Class Example See Also Send Feedback
Acquires a single value from an analog input channel and returns the data in voltage.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double GetSingleValueAsVolts(
    int physicalChannel,
    double gain
)
Visual Basic
Public Function GetSingleValueAsVolts (
    physicalChannel As Integer,
    gain As Double
) As Double

Parameters

physicalChannel
Type: System..::..Int32
The physical analog input channel to sample.
gain
Type: System..::..Double
The gain to apply to the input signal.

Return Value

Type: Double
The acquired value in voltage.

Examples

This example shows a typical use of GetSingleValueAsVolts.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object for element 0.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
ainSS.Config ();
// Acquire a value from analog input channel 0 using a gain of 1, and
// return the data in voltage.
double valueInVolts = ainSS.GetSingleValueAsVolts (0,1.0);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Set the data flow mode to SingleValue
ainSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
ainSS.Config()
' Acquire a value from analog input channel 0 using a gain of 1, and
' return the data in voltage.
Dim voltageValue As Double = ainSS.GetSingleValueAsVolts(0, 1)

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.Start Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..Start Method
AnalogInputSubsystem Class See Also Send Feedback
Starts a continuous operation on the analog input subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Start()
Visual Basic
Public Overrides Sub Start

Remarks

This method overrides the Start method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.Stop Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..Stop Method
AnalogInputSubsystem Class See Also Send Feedback
Stops a continuous operation on the analog input subsystem after the current buffer has been filled.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Stop()
Visual Basic
Public Overrides Sub Stop

Remarks

This method overrides the Stop method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..ToString Method
AnalogInputSubsystem Class See Also Send Feedback
Returns a description of the analog input subsystem and element.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the analog input subsystem and element.

Remarks

This method overrides the ToString method in the base class.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Properties
AnalogInputSubsystem Class See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedExcitationCurrentValues | Returns an array containing the available values for the internal excitation current source.
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsACCoupling | Returns True if the subsystem supports AC coupling, where the DC offset is removed; otherwise, returns False.
Public property | SupportsAutoCalibrate | Returns True if the subsystem supports auto-calibration; otherwise, returns False.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDCCoupling | Returns True if the subsystem supports DC coupling, where the DC offset is included; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsExternalExcitationCurrentSrc | Returns True if the subsystem supports an external excitation current source; otherwise, returns False.
Public property | SupportsIepe | Returns True if the subsystem supports IEPE (accelerometer) inputs; otherwise, returns False.
Public property | SupportsInternalExcitationCurrentSrc | Returns True if the subsystem supports an internal excitation current source; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)

See Also

AnalogInputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.SupportedExcitationCurrentValues Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportedExcitationCurrentValues Property
AnalogInputSubsystem Class See Also Send Feedback
Returns an array containing the available values for the internal excitation current source.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] SupportedExcitationCurrentValues { get; }
Visual Basic
Public ReadOnly Property SupportedExcitationCurrentValues As Double()
    Get

Property Value

Type: array<Double>[]()[][]

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.SupportsACCoupling Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsACCoupling Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports AC coupling, where the DC offset is removed; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsACCoupling { get; }
Visual Basic
Public ReadOnly Property SupportsACCoupling As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.SupportsAutoCalibrate Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsAutoCalibrate Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports auto-calibration; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsAutoCalibrate { get; }
Visual Basic
Public ReadOnly Property SupportsAutoCalibrate As Boolean
    Get

Property Value

Type: Boolean

Remarks

During auto-calibration, the specified subsystem performs an auto-zero function.

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.SupportsDCCoupling Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsDCCoupling Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports DC coupling, where the DC offset is included; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDCCoupling { get; }
Visual Basic
Public ReadOnly Property SupportsDCCoupling As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.SupportsExternalExcitationCurrentSrc Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsExternalExcitationCurrentSrc Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports an external excitation current source; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsExternalExcitationCurrentSrc { get; }
Visual Basic
Public ReadOnly Property SupportsExternalExcitationCurrentSrc As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.SupportsIepe Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsIepe Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports IEPE (accelerometer) inputs; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsIepe { get; }
Visual Basic
Public ReadOnly Property SupportsIepe As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.SupportsInternalExcitationCurrentSrc Property

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..SupportsInternalExcitationCurrentSrc Property
AnalogInputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports an internal excitation current source; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInternalExcitationCurrentSrc { get; }
Visual Basic
Public ReadOnly Property SupportsInternalExcitationCurrentSrc As Boolean
    Get

Property Value

Type: Boolean

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
AnalogInputSubsystem Events
AnalogInputSubsystem Class See Also Send Feedback

The AnalogInputSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | PreTriggerBufferDoneEvent | Occurs when the OlBuffer object is filled with pre-trigger data (for an analog input operation only).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogInputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogInputSubsystem.PreTriggerBufferDoneEvent Event

[image]

OpenLayers for .NET Documentation
AnalogInputSubsystem..::..PreTriggerBufferDoneEvent Event
AnalogInputSubsystem Class See Also Send Feedback
Occurs when the OlBuffer object is filled with pre-trigger data (for an analog input operation only).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event PreTriggerBufferDoneHandler PreTriggerBufferDoneEvent
Visual Basic
Public Event PreTriggerBufferDoneEvent As PreTriggerBufferDoneHandler

Value

Type: OpenLayers.DeviceCollection..::..PreTriggerBufferDoneHandler

See Also

AnalogInputSubsystem Class
AnalogInputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem Class

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Class
Members See Also Send Feedback
The AnalogOutputSubsystem class provides the properties, methods, and events for performing analog output operations.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class AnalogOutputSubsystem : AnalogSubsystem
Visual Basic
Public Class AnalogOutputSubsystem
    Inherits AnalogSubsystem

Remarks

Instances of this class are created using the AnalogOutputSubsystem(Int32) method.

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..SubsystemBase
OpenLayers.DeviceCollection..::..AnalogSubsystem
OpenLayers.DeviceCollection..::..AnalogOutputSubsystem

See Also

AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Members
AnalogOutputSubsystem Class Constructors Methods Properties Events See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Constructors

 | Name | Description
Public method | AnalogOutputSubsystem | Returns an AnalogOutputSubsystem object for a specified subsystem element and Device object.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the analog output subsystem immediately without waiting for all the data in the current buffer to be output. (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from AnalogSubsystem.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Mute | Attenuates the output voltage of the subsystem to 0 V over a hardware-dependent number of samples.
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | SetSingleValueAsRaw | Writes a single value, as a raw count, to an analog output channel.
Public method | SetSingleValueAsVolts | Writes a single value, as a voltage, to an analog output channel.
Public method | SetSingleValuesAsRaw | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single raw count on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | SetSingleValuesAsVolts | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single voltage value on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | Start | Starts a continuous operation on the analog output subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog output subsystem after all the data in the current buffer has been output. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog output subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | UnMute | If the subsystem is muted, returns the output voltage of the subsystem to its current level over a hardware-dependent number of samples.
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsMute | Returns True if the subsystem supports the ability to mute and/or unmute the output voltage.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SupportsWrapSingle | Returns True if the subsystem supports reusing a single buffer for continuous operations; otherwise, returns False.
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | WrapSingleBuffer | Gets and sets the wrap mode. If WrapSingleBuffer is True, the device driver continuously reuses the first buffer queued to the subsystem. If WrapSingleBuffer is False, the device driver uses all the buffers queued to the subsystem (this is the default mode).

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogOutputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem Constructor

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Constructor
AnalogOutputSubsystem Class See Also Send Feedback
Returns an AnalogOutputSubsystem object for a specified subsystem element and Device object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogOutputSubsystem(
    Device device,
    int element
)
Visual Basic
Public Sub New (
    device As Device,
    element As Integer
)

Parameters

device
Type: OpenLayers.DeviceCollection..::..Device
The Open Layers Device object with which to associate the analog output subsystem.
element
Type: System..::..Int32
The Element number of the analog output subsystem.

Remarks

It is recommended that you use the AnalogOutputSubsystem(Int32) method rather than this constructor to return an analog output subsystem.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Methods
AnalogOutputSubsystem Class See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops a continuous operation on the analog output subsystem immediately without waiting for all the data in the current buffer to be output. (Overrides SubsystemBase..::..Abort()()()().)
Public method | Config | Configures the subsystem based on the current property settings. (Inherited from AnalogSubsystem.)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Mute | Attenuates the output voltage of the subsystem to 0 V over a hardware-dependent number of samples.
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value. (Inherited from AnalogSubsystem.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | SetSingleValueAsRaw | Writes a single value, as a raw count, to an analog output channel.
Public method | SetSingleValueAsVolts | Writes a single value, as a voltage, to an analog output channel.
Public method | SetSingleValuesAsRaw | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single raw count on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | SetSingleValuesAsVolts | For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single voltage value on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.
Public method | Start | Starts a continuous operation on the analog output subsystem. (Overrides SubsystemBase..::..Start()()()().)
Public method | Stop | Stops a continuous operation on the analog output subsystem after all the data in the current buffer has been output. (Overrides SubsystemBase..::..Stop()()()().)
Public method | ToString | Returns a description of the analog output subsystem and element. (Overrides Object..::..ToString()()()().)
Public method | UnMute | If the subsystem is muted, returns the output voltage of the subsystem to its current level over a hardware-dependent number of samples.
Public method | VoltsToRawValue | Converts a voltage value into a raw count. (Inherited from AnalogSubsystem.)

See Also

AnalogOutputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.Abort Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Abort Method
AnalogOutputSubsystem Class See Also Send Feedback
Stops a continuous operation on the analog output subsystem immediately without waiting for all the data in the current buffer to be output.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Abort()
Visual Basic
Public Overrides Sub Abort

Remarks

This method overrides the Abort method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.Mute Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Mute Method
AnalogOutputSubsystem Class See Also Send Feedback
Attenuates the output voltage of the subsystem to 0 V over a hardware-dependent number of samples.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Mute()
Visual Basic
Public Sub Mute

Remarks

Refer to the user's manual for your device to determine if the subsystem supports the ability to mute and unmute the output, and to determine the number of samples required for the muting process.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.SetSingleValueAsRaw Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValueAsRaw Method
AnalogOutputSubsystem Class Example See Also Send Feedback
Writes a single value, as a raw count, to an analog output channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValueAsRaw(
    int channel,
    int inRawValue
)
Visual Basic
Public Sub SetSingleValueAsRaw (
    channel As Integer,
    inRawValue As Integer
)

Parameters

channel
Type: System..::..Int32
The physical analog output channel to update.
inRawValue
Type: System..::..Int32
The raw count, as an integer, to output.

Examples

This example shows a typical use of SetSingleValueAsRaw.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem (0);
//Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
aoutSS.Config ();
// Send a raw count value of 256 to DAC0
aoutSS.SetSingleValueAsRaw(0, 256);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem(0)
' Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
aoutSS.Config()
' Send a raw count of 256 to DAC0
aoutSS.SetSingleValueAsRaw(0, 256)

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.SetSingleValueAsVolts Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValueAsVolts Method
AnalogOutputSubsystem Class Example See Also Send Feedback
Writes a single value, as a voltage, to an analog output channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValueAsVolts(
    int channel,
    double inValue
)
Visual Basic
Public Sub SetSingleValueAsVolts (
    channel As Integer,
    inValue As Double
)

Parameters

channel
Type: System..::..Int32
The physical analog output channel to update.
inValue
Type: System..::..Double
The voltage value, as a double, to output.

Examples

This example shows a typical use of SetSingleValueAsVolts.
C# Copy image Copy
// Get the DeviceMgr and Device objects.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem (0);
//Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue;
//Configure the subsystem for a single-value operation
aoutSS.Config ();
// Send a value of 5 V to DAC0
aoutSS.SetSingleValueAsVolts(0, 5);
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
' Allocate the first element of the analog output subsystem
aoutSS = device.AnalogOutputSubsystem(0)
' Set the data flow mode to SingleValue
aoutSS.DataFlow = DataFlow.SingleValue
' Configure the subsystem for a single-value operation
aoutSS.Config()
' Send a value of 5 V to DAC0
aoutSS.SetSingleValueAsVolts(0, 5)

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.SetSingleValuesAsRaw Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValuesAsRaw Method
AnalogOutputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single raw count on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValuesAsRaw(
    SingleValuesInfoRaw[] singleValuesInfo
)
Visual Basic
Public Sub SetSingleValuesAsRaw (
    singleValuesInfo As SingleValuesInfoRaw()
)

Parameters

singleValuesInfo
Type: array< OpenLayers.DeviceCollection..::..SingleValuesInfoRaw >[]()[][]
An array of SingleValuesInfoRaw structures, which specify the analog output channels to update and the raw count value to output on each channel.

Remarks

The resulting output will not be synchronized. If synchronization is required, use OlBuffer and Start()()()() to generate the required output.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.SetSingleValuesAsVolts Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SetSingleValuesAsVolts Method
AnalogOutputSubsystem Class See Also Send Feedback
For subsystems that support simultaneous operations (SupportsSingleValue is True), outputs a single voltage value on each analog output channel that is specified in the singleValuesInfo array. If an analog output channel is not specified in this array, the value of the output channel will not change; the output channel maintains the last value that was written to it.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void SetSingleValuesAsVolts(
    SingleValuesInfoVolts[] singleValuesInfo
)
Visual Basic
Public Sub SetSingleValuesAsVolts (
    singleValuesInfo As SingleValuesInfoVolts()
)

Parameters

singleValuesInfo
Type: array< OpenLayers.DeviceCollection..::..SingleValuesInfoVolts >[]()[][]
An array of SingleValuesInfoVolts structures, which specify the analog output channels to update and the voltage value to output on each channel.

Remarks

The resulting output will not be synchronized. If synchronization is required, use OlBuffer and Start()()()() to generate the required output.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.Start Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Start Method
AnalogOutputSubsystem Class See Also Send Feedback
Starts a continuous operation on the analog output subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Start()
Visual Basic
Public Overrides Sub Start

Remarks

This method overrides the Start method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.Stop Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..Stop Method
AnalogOutputSubsystem Class See Also Send Feedback
Stops a continuous operation on the analog output subsystem after all the data in the current buffer has been output.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Stop()
Visual Basic
Public Overrides Sub Stop

Remarks

This method overrides the Stop method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.ToString Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..ToString Method
AnalogOutputSubsystem Class See Also Send Feedback
Returns a description of the analog output subsystem and element.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

Type: String
A string that describes the analog output subsystem and element.

Remarks

This method overrides the ToString method in the base class.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.UnMute Method

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..UnMute Method
AnalogOutputSubsystem Class See Also Send Feedback
If the subsystem is muted, returns the output voltage of the subsystem to its current level over a hardware-dependent number of samples.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void UnMute()
Visual Basic
Public Sub UnMute

Remarks

Refer to the user's manual for your device to determine if the subsystem supports the ability to mute and unmute the output, and to determine the number of samples required for the muting process.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Properties
AnalogOutputSubsystem Class See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true. (Inherited from AnalogSubsystem.)
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsMute | Returns True if the subsystem supports the ability to mute and/or unmute the output voltage.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SupportsWrapSingle | Returns True if the subsystem supports reusing a single buffer for continuous operations; otherwise, returns False.
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread. (Inherited from AnalogSubsystem.)
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem. (Inherited from AnalogSubsystem.)
Public property | WrapSingleBuffer | Gets and sets the wrap mode. If WrapSingleBuffer is True, the device driver continuously reuses the first buffer queued to the subsystem. If WrapSingleBuffer is False, the device driver uses all the buffers queued to the subsystem (this is the default mode).

See Also

AnalogOutputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.SupportsMute Property

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SupportsMute Property
AnalogOutputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports the ability to mute and/or unmute the output voltage.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsMute { get; }
Visual Basic
Public ReadOnly Property SupportsMute As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Mute()()()() method to attenuate the output voltage to 0 V. If the output voltage is muted, use the UnMute()()()() method to return the output voltage to its current level.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.SupportsWrapSingle Property

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..SupportsWrapSingle Property
AnalogOutputSubsystem Class See Also Send Feedback
Returns True if the subsystem supports reusing a single buffer for continuous operations; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsWrapSingle { get; }
Visual Basic
Public ReadOnly Property SupportsWrapSingle As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the WrapSingleBuffer property to use a single buffer for the continuous operation.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem.WrapSingleBuffer Property

[image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem..::..WrapSingleBuffer Property
AnalogOutputSubsystem Class See Also Send Feedback
Gets and sets the wrap mode. If WrapSingleBuffer is True, the device driver continuously reuses the first buffer queued to the subsystem. If WrapSingleBuffer is False, the device driver uses all the buffers queued to the subsystem (this is the default mode).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool WrapSingleBuffer { get; set; }
Visual Basic
Public Property WrapSingleBuffer As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

Set this property to True for waveform generation operations on the AnalogOutputSubsystem.

See Also

AnalogOutputSubsystem Class
AnalogOutputSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogOutputSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
AnalogOutputSubsystem Events
AnalogOutputSubsystem Class See Also Send Feedback

The AnalogOutputSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information. (Inherited from AnalogSubsystem.)
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur). (Inherited from AnalogSubsystem.)
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogOutputSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogSubsystem Class

[image]

OpenLayers for .NET Documentation
AnalogSubsystem Class
Members See Also Send Feedback
The AnalogSubsystem class is an abstract base class and is accessible only by using the following derived classes: AnalogInputSubsystem and/or AnalogOutputSubsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public abstract class AnalogSubsystem : SubsystemBase
Visual Basic
Public MustInherit Class AnalogSubsystem
    Inherits SubsystemBase

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..SubsystemBase
OpenLayers.DeviceCollection..::..AnalogSubsystem
OpenLayers.DeviceCollection..::..AnalogInputSubsystem
OpenLayers.DeviceCollection..::..AnalogOutputSubsystem

See Also

AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem Members

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Members
AnalogSubsystem Class Methods Properties Events See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Overrides SubsystemBase..::..Config()()()().)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value.
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VoltsToRawValue | Converts a voltage value into a raw count.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem.
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread.
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogSubsystem Methods

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Methods
AnalogSubsystem Class See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately. (Inherited from SubsystemBase.)
Public method | Config | Configures the subsystem based on the current property settings. (Overrides SubsystemBase..::..Config()()()().)
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device. (Inherited from SubsystemBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value.
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value.
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration. (Inherited from SubsystemBase.)
Public method | Start | Starts an operation on the subsystem. (Inherited from SubsystemBase.)
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations. (Inherited from SubsystemBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VoltsToRawValue | Converts a voltage value into a raw count.

See Also

AnalogSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.Config Method

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..Config Method
AnalogSubsystem Class See Also Send Feedback
Configures the subsystem based on the current property settings.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override void Config()
Visual Basic
Public Overrides Sub Config

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.RawValueToSensor Method

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToSensor Method
AnalogSubsystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RawValueToSensor(Int32, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.
Public method | RawValueToSensor(UInt16, Double, Double, Double) | Converts a raw count to a sensor value in engineering units.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.RawValueToSensor Method (Int32, Double, Double, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToSensor Method (Int32, Double, Double, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count to a sensor value in engineering units.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToSensor(
    int code,
    double gain,
    double sensorGain,
    double sensorOffset
)
Visual Basic
Public Function RawValueToSensor (
    code As Integer,
    gain As Double,
    sensorGain As Double,
    sensorOffset As Double
) As Double

Parameters

code
Type: System..::..Int32
The raw count to convert.
gain
Type: System..::..Double
The gain of the input signal, which is used to convert the raw count to a prescaled voltage value.
sensorGain
Type: System..::..Double
The sensor gain that is applied to the prescaled voltage value.
sensorOffset
Type: System..::..Double
The sensor offset that is applied to the prescaled voltage value.

Return Value

Type: Double
The sensor value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution greater than 16 bits. The scaling occurs in two steps. First, the raw count is converted to a prescaled voltage by applying the gain for the input signal. Then, the prescaled voltage value is scaled using the equation y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToSensor Overload
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.RawValueToSensor Method (UInt16, Double, Double, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToSensor Method (UInt16, Double, Double, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count to a sensor value in engineering units.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToSensor(
    ushort code,
    double gain,
    double sensorGain,
    double sensorOffset
)
Visual Basic
Public Function RawValueToSensor (
    code As UShort,
    gain As Double,
    sensorGain As Double,
    sensorOffset As Double
) As Double

Parameters

code
Type: System..::..UInt16
The raw count to convert.
gain
Type: System..::..Double
The gain of the input signal, which is used to convert the raw count to a prescaled voltage value.
sensorGain
Type: System..::..Double
The sensor gain that is applied to the prescaled voltage value.
sensorOffset
Type: System..::..Double
The sensor offset that is applied to the prescaled voltage value.

Return Value

Type: Double
The sensor value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution of 16 bits or less. The scaling occurs in two steps. First, the raw count is converted to a prescaled voltage by applying the gain for the input signal. Then, the prescaled voltage value is scaled using the equation y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToSensor Overload
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.RawValueToVolts Method

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToVolts Method
AnalogSubsystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RawValueToVolts(Int32, Double) | Converts a raw count into a voltage value.
Public method | RawValueToVolts(UInt16, Double) | Converts a raw count into a voltage value.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.RawValueToVolts Method (Int32, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToVolts Method (Int32, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count into a voltage value.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToVolts(
    int code,
    double gain
)
Visual Basic
Public Function RawValueToVolts (
    code As Integer,
    gain As Double
) As Double

Parameters

code
Type: System..::..Int32
The raw count to convert.
gain
Type: System..::..Double
The gain to apply to the value. The gain is typically applied to the input signal at acquisition time.

Return Value

Type: Double
The voltage value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution of greater than 16 bits.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToVolts Overload
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.RawValueToVolts Method (UInt16, Double)

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..RawValueToVolts Method (UInt16, Double)
AnalogSubsystem Class See Also Send Feedback
Converts a raw count into a voltage value.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double RawValueToVolts(
    ushort code,
    double gain
)
Visual Basic
Public Function RawValueToVolts (
    code As UShort,
    gain As Double
) As Double

Parameters

code
Type: System..::..UInt16
The raw count to convert.
gain
Type: System..::..Double
The gain to apply to the value. The gain is typically applied to the input signal at acquisition time.

Return Value

Type: Double
The voltage value that is associated with the raw count.

Remarks

Use this method when the subsystem has a resolution of 16 bits or less.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
RawValueToVolts Overload
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.VoltsToRawValue Method

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..VoltsToRawValue Method
AnalogSubsystem Class See Also Send Feedback
Converts a voltage value into a raw count.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int VoltsToRawValue(
    double volts,
    double gain
)
Visual Basic
Public Function VoltsToRawValue (
    volts As Double,
    gain As Double
) As Integer

Parameters

volts
Type: System..::..Double
The voltage value to convert.
gain
Type: System..::..Double
The gain that was applied to input signal to produce the voltage.

Return Value

Type: Int32
The raw count that is associated with the voltage value.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem Properties

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Properties
AnalogSubsystem Class See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem. (Inherited from SubsystemBase.)
Public property | BufferQueue | Provides an interface to a BufferQueue object. (Inherited from SubsystemBase.)
Public property | ChannelList | Provides an interface to a ChannelList object. (Inherited from SubsystemBase.)
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem. (Inherited from SubsystemBase.)
Public property | Clock | Provides an interface to a Clock object. (Inherited from SubsystemBase.)
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem. (Inherited from SubsystemBase.)
Public property | Device | Returns the Device object that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | Element | Returns the element number of the subsystem. (Inherited from SubsystemBase.)
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem. (Inherited from SubsystemBase.)
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem. (Inherited from SubsystemBase.)
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfRanges | Returns the number of available voltage ranges for the analog subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | NumberOfSupportedGains | Returns the number of available gains for the analog subsystem.
Public property | QueuedBufferDones | Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object. (Inherited from SubsystemBase.)
Public property | Resolution | Returns the resolution of the analog subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values. (Inherited from SubsystemBase.)
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete). (Inherited from SubsystemBase.)
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs). (Inherited from SubsystemBase.)
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput). (Inherited from SubsystemBase.)
Public property | SupportedChannels | Provides an interface to a SupportedChannels object. (Inherited from SubsystemBase.)
Public property | SupportedGains | Returns an array of available gains for the analog subsystem.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem. (Inherited from SubsystemBase.)
Public property | SupportedVoltageRanges | Returns an array of supported voltage ranges for the analog subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False. (Inherited from SubsystemBase.)
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize. (Inherited from SubsystemBase.)
Public property | SynchronousBufferDone | Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread.
Public property | Trigger | Provides an interface to a Trigger object. (Inherited from SubsystemBase.)
Public property | VoltageRange | Gets or sets the current voltage range for the analog subsystem.

See Also

AnalogSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.NumberOfRanges Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..NumberOfRanges Property
AnalogSubsystem Class See Also Send Feedback
Returns the number of available voltage ranges for the analog subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfRanges { get; }
Visual Basic
Public ReadOnly Property NumberOfRanges As Integer
    Get

Property Value

Type: Int32

Remarks

Use the VoltageRange property to set the range.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.NumberOfSupportedGains Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..NumberOfSupportedGains Property
AnalogSubsystem Class See Also Send Feedback
Returns the number of available gains for the analog subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfSupportedGains { get; }
Visual Basic
Public ReadOnly Property NumberOfSupportedGains As Integer
    Get

Property Value

Type: Int32

Remarks

To get an array of supported gain values for the subsystem, use the SupportedGains property. Use the Gain property to set the gain for a ChannelListEntry object.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.QueuedBufferDones Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..QueuedBufferDones Property
AnalogSubsystem Class See Also Send Feedback
Returns the number of Buffer Done Events queued to be sent when SynchronousBufferDone is true.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int QueuedBufferDones { get; }
Visual Basic
Public ReadOnly Property QueuedBufferDones As Integer
    Get

Property Value

Type: Int32

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.Resolution Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..Resolution Property
AnalogSubsystem Class See Also Send Feedback
Returns the resolution of the analog subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As Short
    Get

Property Value

Type: Int16

Remarks

The resolution is fixed for analog input and analog output subsystem; therefore, the Resolution property cannot be set for an analog input or output subsystem.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.SupportedGains Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..SupportedGains Property
AnalogSubsystem Class See Also Send Feedback
Returns an array of available gains for the analog subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] SupportedGains { get; }
Visual Basic
Public ReadOnly Property SupportedGains As Double()
    Get

Property Value

Type: array<Double>[]()[][]

Remarks

Use the Gain property to set the gain for a ChannelListEntry object.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.SupportedVoltageRanges Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..SupportedVoltageRanges Property
AnalogSubsystem Class See Also Send Feedback
Returns an array of supported voltage ranges for the analog subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range[] SupportedVoltageRanges { get; }
Visual Basic
Public ReadOnly Property SupportedVoltageRanges As Range()
    Get

Property Value

Type: array< Range >[]()[][]

Remarks

Use the VoltageRange property to set the range.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.SynchronousBufferDone Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..SynchronousBufferDone Property
AnalogSubsystem Class See Also Send Feedback
Gets or sets the way Buffer Done events are executed (asynchronously or synchronously). If False, each Buffer Done event is executed asynchronously in its own thread. If True, all Buffer Done events are executed synchronously from a single worker thread.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SynchronousBufferDone { get; set; }
Visual Basic
Public Property SynchronousBufferDone As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If your program is running under a heavy CPU load and this property is False, .NET may call your Buffer Done delegates out of order under certain circumstances. To avoid this problem, it is recommended that you set this property to True.

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.VoltageRange Property

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..VoltageRange Property
AnalogSubsystem Class Example See Also Send Feedback
Gets or sets the current voltage range for the analog subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range VoltageRange { get; set; }
Visual Basic
Public Property VoltageRange As Range
    Get
    Set

Property Value

Type: Range

Examples

This example sets the voltage range of the analog input subsystem to the first range in the list of supported voltage ranges.
C# Copy image Copy
ainSS.VoltageRange = ainSS.SupportedVoltageRanges[0];
Visual Basic Copy image Copy
ainSS.VoltageRange = ainSS.SupportedVoltageRanges(0)

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem Events

[image] [image]

OpenLayers for .NET Documentation
AnalogSubsystem Events
AnalogSubsystem Class See Also Send Feedback

The AnalogSubsystem type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs. (Inherited from SubsystemBase.)
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running. (Inherited from SubsystemBase.)
Public event | DriverRunTimeErrorEvent | Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered. (Inherited from SubsystemBase.)
Public event | IOCompleteEvent | Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur).
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops. (Inherited from SubsystemBase.)
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied. (Inherited from SubsystemBase.)

See Also

AnalogSubsystem Class
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.DriverRunTimeErrorEvent Event

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..DriverRunTimeErrorEvent Event
AnalogSubsystem Class See Also Send Feedback
Occurs when the device driver detects one of the following error conditions during runtime: FifoOverflow, FifoUnderflow, DeviceOverClocked, TriggerError, or DeviceError. See OlError for more information.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event DriverRunTimeErrorEventHandler DriverRunTimeErrorEvent
Visual Basic
Public Event DriverRunTimeErrorEvent As DriverRunTimeErrorEventHandler

Value

Type: OpenLayers.DeviceCollection..::..DriverRunTimeErrorEventHandler

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


AnalogSubsystem.IOCompleteEvent Event

[image]

OpenLayers for .NET Documentation
AnalogSubsystem..::..IOCompleteEvent Event
AnalogSubsystem Class See Also Send Feedback
Occurs when the last data point has been output from an analog output channel, or when the last sample has been copied to an analog input buffer on devices that support TTL and analog threshold stop trigger. In some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after BufferDoneEvent and QueueDoneEvents occur).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event IOCompleteHandler IOCompleteEvent
Visual Basic
Public Event IOCompleteEvent As IOCompleteHandler

Value

Type: OpenLayers.DeviceCollection..::..IOCompleteHandler

See Also

AnalogSubsystem Class
AnalogSubsystem Members
OpenLayers.DeviceCollection Namespace


BufferDoneEventArgs Class

[image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Class
Members See Also Send Feedback
A BufferDoneEventArgs object is passed to one of the following delegates when the associated event occurs: BufferDoneHandler delegate when the event BufferDoneEvent occurs or PreTriggerBufferDoneHandler delegate when the event PreTriggerBufferDoneEvent occurs. BufferDoneEventArgs contains the data that is associated with the event, including the subsystem that raised the event, the time stamp of when the event occurred, and the completed OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class BufferDoneEventArgs : GeneralEventArgs
Visual Basic
Public Class BufferDoneEventArgs
    Inherits GeneralEventArgs

Remarks

For input operations, the event BufferDoneEvent is raised when the internal buffer of an OlBuffer object has been filled with post-trigger data. For output operations, this event is raised when all the data in the internal buffer of an OlBuffer object has been output.

If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current OlBuffer object and for up to eight inprocess OlBuffer objects before a QueueStoppedEvent event occurs.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.DeviceCollection..::..GeneralEventArgs
OpenLayers.DeviceCollection..::..BufferDoneEventArgs

See Also

BufferDoneEventArgs Members
OpenLayers.DeviceCollection Namespace


BufferDoneEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Members
BufferDoneEventArgs Class Methods Properties See Also Send Feedback

The BufferDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | OlBuffer | Returns the completed OlBuffer object.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

BufferDoneEventArgs Class
OpenLayers.DeviceCollection Namespace


BufferDoneEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Methods
BufferDoneEventArgs Class See Also Send Feedback

The BufferDoneEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BufferDoneEventArgs Class
OpenLayers.DeviceCollection Namespace


BufferDoneEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
BufferDoneEventArgs Properties
BufferDoneEventArgs Class See Also Send Feedback

The BufferDoneEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | OlBuffer | Returns the completed OlBuffer object.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

BufferDoneEventArgs Class
OpenLayers.DeviceCollection Namespace


BufferDoneEventArgs.OlBuffer Property

[image]

OpenLayers for .NET Documentation
BufferDoneEventArgs..::..OlBuffer Property
BufferDoneEventArgs Class See Also Send Feedback
Returns the completed OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer OlBuffer { get; }
Visual Basic
Public ReadOnly Property OlBuffer As OlBuffer
    Get

Property Value

Type: OlBuffer

See Also

BufferDoneEventArgs Class
BufferDoneEventArgs Members
OpenLayers.DeviceCollection Namespace


BufferDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
BufferDoneHandler Delegate
See Also Send Feedback
The BufferDoneHandler delegate is called when the event BufferDoneEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void BufferDoneHandler(
    Object sender,
    BufferDoneEventArgs eventArgs
)
Visual Basic
Public Delegate Sub BufferDoneHandler (
    sender As Object,
    eventArgs As BufferDoneEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..BufferDoneEventArgs
The BufferDoneEventArgs object that is associated with the event BufferDoneEvent.

Remarks

For input operations, the event BufferDoneEvent is raised when the internal buffer of an OlBuffer object has been filled with post-trigger data. For output operations, this event is raised when all the data in the internal buffer of the OlBuffer object has been output.

See Also

OpenLayers.DeviceCollection Namespace


BufferQueue Class

[image]

OpenLayers for .NET Documentation
BufferQueue Class
Members See Also Send Feedback
The BufferQueue class provides an interface for queuing OlBuffer objects to a device's subsystem for continuous I/O operations.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class BufferQueue
Visual Basic
Public Class BufferQueue

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..BufferQueue

See Also

BufferQueue Members
OpenLayers.DeviceCollection Namespace


BufferQueue Members

[image] [image]

OpenLayers for .NET Documentation
BufferQueue Members
BufferQueue Class Methods Properties See Also Send Feedback

The BufferQueue type exposes the following members.

Methods

 | Name | Description
Public method | DequeueBuffer | Removes the OlBuffer object from the front of the subsystem queue, and returns it to the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FreeAllQueuedBuffers | Removes all OlBuffer objects from the subsystem queue and deallocates the associated internal buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | QueueBuffer | Adds an OlBuffer object to the subsystem queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InProcessCount | Returns the number of OlBuffer objects that have been taken from subsystem queue and sent to the device for processing (buffers are in the inprocess state).
Public property | QueuedCount | Returns the number of OlBuffer objects that are on the subsystem queue (OlBuffer objects are in the queued state).

See Also

BufferQueue Class
OpenLayers.DeviceCollection Namespace


BufferQueue Methods

[image] [image]

OpenLayers for .NET Documentation
BufferQueue Methods
BufferQueue Class See Also Send Feedback

The BufferQueue type exposes the following members.

Methods

 | Name | Description
Public method | DequeueBuffer | Removes the OlBuffer object from the front of the subsystem queue, and returns it to the user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FreeAllQueuedBuffers | Removes all OlBuffer objects from the subsystem queue and deallocates the associated internal buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | QueueBuffer | Adds an OlBuffer object to the subsystem queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BufferQueue Class
OpenLayers.DeviceCollection Namespace


BufferQueue.DequeueBuffer Method

[image]

OpenLayers for .NET Documentation
BufferQueue..::..DequeueBuffer Method
BufferQueue Class See Also Send Feedback
Removes the OlBuffer object from the front of the subsystem queue, and returns it to the user.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer DequeueBuffer()
Visual Basic
Public Function DequeueBuffer As OlBuffer

Return Value

Type: OlBuffer
The OlBuffer object from the front of the queue.

See Also

BufferQueue Class
BufferQueue Members
OpenLayers.DeviceCollection Namespace


BufferQueue.FreeAllQueuedBuffers Method

[image]

OpenLayers for .NET Documentation
BufferQueue..::..FreeAllQueuedBuffers Method
BufferQueue Class See Also Send Feedback
Removes all OlBuffer objects from the subsystem queue and deallocates the associated internal buffer.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void FreeAllQueuedBuffers()
Visual Basic
Public Sub FreeAllQueuedBuffers

See Also

BufferQueue Class
BufferQueue Members
OpenLayers.DeviceCollection Namespace


BufferQueue.QueueBuffer Method

[image]

OpenLayers for .NET Documentation
BufferQueue..::..QueueBuffer Method
BufferQueue Class See Also Send Feedback
Adds an OlBuffer object to the subsystem queue.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void QueueBuffer(
    OlBuffer inBuffer
)
Visual Basic
Public Sub QueueBuffer (
    inBuffer As OlBuffer
)

Parameters

inBuffer
Type: OpenLayers.DeviceCollection..::..OlBuffer
The OlBuffer object to add to the subsystem queue.

Remarks

If the subsystem is incompatible with the specified OlBuffer object, an exception is raised.

See Also

BufferQueue Class
BufferQueue Members
OpenLayers.DeviceCollection Namespace


BufferQueue Properties

[image] [image]

OpenLayers for .NET Documentation
BufferQueue Properties
BufferQueue Class See Also Send Feedback

The BufferQueue type exposes the following members.

Properties

 | Name | Description
Public property | InProcessCount | Returns the number of OlBuffer objects that have been taken from subsystem queue and sent to the device for processing (buffers are in the inprocess state).
Public property | QueuedCount | Returns the number of OlBuffer objects that are on the subsystem queue (OlBuffer objects are in the queued state).

See Also

BufferQueue Class
OpenLayers.DeviceCollection Namespace


BufferQueue.InProcessCount Property

[image]

OpenLayers for .NET Documentation
BufferQueue..::..InProcessCount Property
BufferQueue Class See Also Send Feedback
Returns the number of OlBuffer objects that have been taken from subsystem queue and sent to the device for processing (buffers are in the inprocess state).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int InProcessCount { get; }
Visual Basic
Public ReadOnly Property InProcessCount As Integer
    Get

Property Value

Type: Int32

Remarks

When you start a continuous operation, the device takes up to eight OlBuffer objects from the subsystem queue and begins filling the associated internal buffers (for input operations) or outputting data from the associated internal buffers for output operations) at the specified clock rate. The state of these OlBuffer objects changes from queued to inprocess. Every time an OlBuffer object transitions from the queued state to the inprocess state, the value of the QueuedCount property decreases by one and the value of the InProcessCount property increases by 1. For example, assume that you call QueueBuffer for 10 OlBuffer objects; the QueuedCount is now 10 and the InProcessCount is 0. Once you call Start, up to 8 OlBuffer objects are moved from the queued state to the inprocess state. The QueuedCount is now 2 and the InProcessCount is now 8. As each OlBuffer object is completed, an event is generated allowing you to process the buffer. Assume that you do not put the OlBuffer objects back on the queue after processing them. In this case, the QueuedCount decreases while the InProcessCount remains the same (as a new inprocess OlBuffer object replaces a completed OlBuffer object) until the QueuedCount gets to 0, then the InProcessCount starts decreasing until all the OlBuffer objects are completed.

See Also

BufferQueue Class
BufferQueue Members
OpenLayers.DeviceCollection Namespace


BufferQueue.QueuedCount Property

[image]

OpenLayers for .NET Documentation
BufferQueue..::..QueuedCount Property
BufferQueue Class See Also Send Feedback
Returns the number of OlBuffer objects that are on the subsystem queue (OlBuffer objects are in the queued state).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int QueuedCount { get; }
Visual Basic
Public ReadOnly Property QueuedCount As Integer
    Get

Property Value

Type: Int32

Remarks

When you start a continuous operation, the device takes up to eight OlBuffer objects from the subsystem queue and begins filling the associated internal buffers (for input operations) or outputting data from the associated internal buffers (for output operations) at the specified clock rate. The state of these OlBuffer objects changes from queued to inprocess. Every time an OlBuffer object transitions from the queued state to the inprocess state, the value of the QueuedCount property decreases by one and the value of the InProcessCount property increases by 1. For example, assume that you call QueueBuffer for 10 OlBuffer objects; the QueuedCount is now 10 and the InProcessCount is 0. Once you call Start, up to 8 OlBuffer objects are moved from the queued state to the inprocess state. The QueuedCount is now 2 and the InProcessCount is now 8. As each OlBuffer object is completed, an event is generated allowing you to process the buffer. Assume that you do not put the OlBuffer objects back on the queue after processing them. In this case, the QueuedCount decreases while the InProcessCount remains the same (as a new inprocess OlBuffer object replaces a completed OlBuffer object) until the QueuedCount gets to 0, then the InProcessCount starts decreasing until all the OlBuffer objects are completed.

See Also

BufferQueue Class
BufferQueue Members
OpenLayers.DeviceCollection Namespace


ChannelDataType Enumeration

[image]

OpenLayers for .NET Documentation
ChannelDataType Enumeration
See Also Send Feedback
Contains the possible values for the ChannelDataType parameter that is used by the RawDataFormat property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ChannelDataType
Visual Basic
Public Enumeration ChannelDataType

Members

Member name | Value | Description
Int16 | 0 | Signed, 16-bit values.
Uint16 | 1 | Unsigned, 16-bit values.
Int32 | 2 | Signed, 32-bit values.
Float | 3 | 32-bit float values.
Double | 4 | 64-bit float (double bit) values.

See Also

OpenLayers.DeviceCollection Namespace


ChannelList Class

[image]

OpenLayers for .NET Documentation
ChannelList Class
Members Example See Also Send Feedback
A ChannelList specifies a collection of ChannelListEntry objects for use in a continuous I/O operation. Each ChannelListEntry object encapsulates a physical channel connection for a specific subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class ChannelList : CollectionBase
Visual Basic
Public Class ChannelList
    Inherits CollectionBase

Remarks

A ChannelList is typically used in continuous analog input and analog output operations. You can add and/or insert a channel to the ChannelList by physical channel number, by name, or as a ChannelListEntry object.

Examples

The following example demonstrates how to add and insert channels in the ChannelList, and set the gain for a channel.
C# Copy image Copy
// Get a DeviceMgr object and Device object.
DeviceMgr deviceMgr = DeviceMgr.Get();
device = deviceMgr.GetDevice (devicename);
// Get an AnalogInputSubsystem object.
AnalogInputSubsystem ainSS = device.AnalogInputSubsystem (0);
// Create a ChannelListEntry object for analog input channel 0.
ChannelListEntry ch0 = new ChannelListEntry ( ainSS.SupportedChannels.GetChannelInfo (SubsystemType.AnalogInput, 0 ) );
// Add the ChannelListEntry object ch0 to the ChannelList.
ainSS.ChannelList.Add (ch0);

// Insert analog input channel 1 as a physical channel into the first position (index 0) of the channel list.
// This will push ChannelListEntry object ch0 to the 2nd position (index 1) of the channel list.
ainSS.ChannelList.Insert (0, 1);

// For the ChannelListEntry at index 0 (which is analog input channel 1), change the gain to 2 using the Item property.
ainSS.ChannelList[0].Gain = 2;
Visual Basic Copy image Copy
' Get a DeviceMgr object
deviceMgr As DeviceMgr = DeviceMgr.Get()
' Allocate the device with the specified device number
device = deviceMgr.GetDevice(deviceName)
   ' Allocate the first element of the analog input subsystem
ainSS = device.AnalogInputSubsystem(0)
' Create a ChannelListEntry object for analog input channel 0.
Dim ch0 As New ChannelListEntry(ainSS.SupportedChannels.GetChannelInfo(SubsystemType.AnalogInput, 0))
' Add the ChannelListEntry object ch0 to the ChannelList.
ainSS.ChannelList.Add(ch0)

' Insert analog input channel 1 as a physical channel into the first position (index 0) of the channel list.
' This will push ChannelListEntry object ch0 to the 2nd position (index 1) of the channel list.
ainSS.ChannelList.Insert(0, 1)

' For the ChannelListEntry at index 0 (which is analog input channel 1), change the gain to 2 using the Item property.
ainSS.ChannelList(0).Gain = 2

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
OpenLayers.DeviceCollection..::..ChannelList

See Also

ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelList Members

[image] [image]

OpenLayers for .NET Documentation
ChannelList Members
ChannelList Class Methods Properties See Also Send Feedback

The ChannelList type exposes the following members.

Methods

 | Name | Description
Public method | Add(Int32) | Adds a channel to the end of the ChannelList.
Public method | Add(String) | Adds a channel to the end of the ChannelList.
Public method | Add(ChannelListEntry) | Adds a channel to the end of the ChannelList.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns True if the ChannelList contains a specific ChannelListEntry object; otherwise, returns False.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Int32) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | IndexOf(ChannelListEntry) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | Insert(Int32, ChannelListEntry) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, Int32) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, String) | Inserts a channel at the specified index of the ChannelList.
Public method | Remove | Removes the first occurrence of the specified ChannelListEntry object from the ChannelList.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | CGLDepth | Returns the maximum number of channels or ChannelListEntry objects that the ChannelList can contain.
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Returns or replaces the ChannelListEntry object at the specified index of the ChannelList.

See Also

ChannelList Class
OpenLayers.DeviceCollection Namespace


ChannelList Methods

[image] [image]

OpenLayers for .NET Documentation
ChannelList Methods
ChannelList Class See Also Send Feedback

The ChannelList type exposes the following members.

Methods

 | Name | Description
Public method | Add(Int32) | Adds a channel to the end of the ChannelList.
Public method | Add(String) | Adds a channel to the end of the ChannelList.
Public method | Add(ChannelListEntry) | Adds a channel to the end of the ChannelList.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Returns True if the ChannelList contains a specific ChannelListEntry object; otherwise, returns False.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(Int32) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | IndexOf(ChannelListEntry) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | Insert(Int32, ChannelListEntry) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, Int32) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, String) | Inserts a channel at the specified index of the ChannelList.
Public method | Remove | Removes the first occurrence of the specified ChannelListEntry object from the ChannelList.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChannelList Class
OpenLayers.DeviceCollection Namespace


ChannelList.Add Method

[image] [image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method
ChannelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(Int32) | Adds a channel to the end of the ChannelList.
Public method | Add(String) | Adds a channel to the end of the ChannelList.
Public method | Add(ChannelListEntry) | Adds a channel to the end of the ChannelList.

See Also

ChannelList Class
ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelList.Add Method (Int32)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method (Int32)
ChannelList Class Example See Also Send Feedback
Adds a channel to the end of the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Add(
    int physicalChannelNumber
)
Visual Basic
Public Function Add (
    physicalChannelNumber As Integer
) As ChannelListEntry

Parameters

physicalChannelNumber
Type: System..::..Int32
The number of the physical channel on the specified subsystem to add to the ChannelList.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was added. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Adds a channel, specified as a physical channel number, to the end of the ChannelList and returns a ChannelListEntry object for the channel.

This method provides a simple way to add channels into the ChannelList, particularly if you are adding channels that are native to the subsystem type (such as analog input channels on an analog input subsystem). For native channels, the physical channel number always equals the logical channel number. While non-native channels, such as digital inputs that are streamed through the analog input subsystem, can also be added this way, the physical channel number is not the same as the logical channel number, so you may find it easier to add a channel by name or by ChannelListEntry object instead.

Examples

This example demonstrates how to add a analog input channel 0 by physical channel number to the ChannelList.
C# Copy image Copy
ch = ainSS.ChannelList.Add (0);
Visual Basic Copy image Copy
ch = ainSS.ChannelList.Add(0)

See Also

ChannelList Class
ChannelList Members
Add Overload
OpenLayers.DeviceCollection Namespace


ChannelList.Add Method (String)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method (String)
ChannelList Class Example See Also Send Feedback
Adds a channel to the end of the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Add(
    string physicalChannelName
)
Visual Basic
Public Function Add (
    physicalChannelName As String
) As ChannelListEntry

Parameters

physicalChannelName
Type: System..::..String
The name of the channel to add to the ChannelList. The channel name must match a channel name contained in the SupportedChannels object for the specified subsystem.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was added. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Adds a channel, specified by name, to the end of the ChannelList and returns a ChannelListEntry object for the channel.

Examples

This example demonstrates how to add a channel by name to the ChannelList.
C# Copy image Copy
//Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels[1].Name = " Sensor";
//Add the channel named Sensor to the ChannelList.
ch = ainSS.ChannelList.Add("Sensor");
Visual Basic Copy image Copy
'Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels(1).Name = "Sensor"
'Add the channel named Sensor to the ChannelList.
ch = AinSS.ChannelList.Add("Sensor")

See Also

ChannelList Class
ChannelList Members
Add Overload
OpenLayers.DeviceCollection Namespace


ChannelList.Add Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Add Method (ChannelListEntry)
ChannelList Class Example See Also Send Feedback
Adds a channel to the end of the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Add(
    ChannelListEntry value
)
Visual Basic
Public Function Add (
    value As ChannelListEntry
) As Integer

Parameters

value
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object to add to the ChannelList.

Return Value

Type: Int32
The index at which the ChannelListEntry object has been added to the ChannelList.

Remarks

Adds the specified ChannelListEntry object to the end of the ChannelList.

Examples

This example demonstrates how to add a ChannelListEntry to the ChannelList.
C# Copy image Copy
// Create a ChannelListEntry object for analog input channel 2
// of the AnalogInputSubsystem (ainSS).
ChannelListEntry ch2 = new ChannelListEntry ( ainSS.SupportedChannels.GetChannelInfo (SubsystemType.AnalogInput, 2 ) );
// Add the ChannelListEntry object ch2 to the ChannelList.
ainSS.ChannelList.Add (ch2);
Visual Basic Copy image Copy
' Create a ChannelListEntry object for analog input channel 2
' of the AnalogInputSubsystem (ainSS).
Dim ch2 As New ChannelListEntry(ainSS.SupportedChannels.GetChannelInfo(SubsystemType.AnalogInput, 2))
' Add the ChannelListEntry object ch2 to the ChannelList.
ainSS.ChannelList.Add(ch2)

See Also

ChannelList Class
ChannelList Members
Add Overload
OpenLayers.DeviceCollection Namespace


ChannelList.Contains Method

[image]

OpenLayers for .NET Documentation
ChannelList..::..Contains Method
ChannelList Class See Also Send Feedback
Returns True if the ChannelList contains a specific ChannelListEntry object; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Contains(
    ChannelListEntry value
)
Visual Basic
Public Function Contains (
    value As ChannelListEntry
) As Boolean

Parameters

value
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
The ChannelListEntry object to locate in the ChannelList.

Return Value

Type: Boolean
Returns True if the ChannelList contains the ChannelListEntry object; otherwise, returns False.

See Also

ChannelList Class
ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelList.IndexOf Method

[image] [image]

OpenLayers for .NET Documentation
ChannelList..::..IndexOf Method
ChannelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(Int32) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.
Public method | IndexOf(ChannelListEntry) | Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.

See Also

ChannelList Class
ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelList.IndexOf Method (Int32)

[image]

OpenLayers for .NET Documentation
ChannelList..::..IndexOf Method (Int32)
ChannelList Class See Also Send Feedback
Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int IndexOf(
    int physicalChannelNumber
)
Visual Basic
Public Function IndexOf (
    physicalChannelNumber As Integer
) As Integer

Parameters

physicalChannelNumber
Type: System..::..Int32
The number of the physical channel for the associated subsystem to locate.

Return Value

Type: Int32
If found, returns the zero-based index of the first occurrence of the phyiscal channel number within the ChannelList; otherwise, returns -1.

Remarks

Searches for the specified physical channel number and returns the zero-based index of the first occurrence of the physical channel number within the ChannelList.

See Also

ChannelList Class
ChannelList Members
IndexOf Overload
OpenLayers.DeviceCollection Namespace


ChannelList.IndexOf Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
ChannelList..::..IndexOf Method (ChannelListEntry)
ChannelList Class See Also Send Feedback
Searches for the specified channel and returns the zero-based index of the first occurrence of the channel within the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int IndexOf(
    ChannelListEntry value
)
Visual Basic
Public Function IndexOf (
    value As ChannelListEntry
) As Integer

Parameters

value
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
The ChannelListEntry object to locate.

Return Value

Type: Int32
If found, returns the zero-based index of the first occurrence of the ChannelListEntry object within the ChannelList; otherwise, returns -1.

Remarks

Searches for the specified ChannelListEntry object and returns the zero-based index of the first occurrence of the ChannelListEntry object within the ChannelList.

See Also

ChannelList Class
ChannelList Members
IndexOf Overload
OpenLayers.DeviceCollection Namespace


ChannelList.Insert Method

[image] [image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method
ChannelList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Insert(Int32, ChannelListEntry) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, Int32) | Inserts a channel at the specified index of the ChannelList.
Public method | Insert(Int32, String) | Inserts a channel at the specified index of the ChannelList.

See Also

ChannelList Class
ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelList.Insert Method (Int32, ChannelListEntry)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method (Int32, ChannelListEntry)
ChannelList Class Example See Also Send Feedback
Inserts a channel at the specified index of the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Insert(
    int index,
    ChannelListEntry value
)
Visual Basic
Public Sub Insert (
    index As Integer,
    value As ChannelListEntry
)

Parameters

index
Type: System..::..Int32
Zero-based index at which to insert the ChannelListEntry object.
value
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
The ChannelListEntry object to insert.

Remarks

Inserts a ChannelListEntry object at the specified index of the ChannelList.

Examples

This example inserts ChannelListEntry ch3 at index 1 of the ChannelList for an AnalogInputSubsystem (ainSS).
C# Copy image Copy
// Create a ChannelListEntry object for analog input channel 3
// of the AnalogInputSubsystem (ainSS).
ChannelListEntry ch3 = new ChannelListEntry ( ainSS.SupportedChannels.GetChannelInfo (SubsystemType.AnalogInput, 3 ) );
// Insert the ChannelListEntry object ch3 at index 1 of the ChannelList.
ainSS.ChannelList.Insert (1, ch3);
Visual Basic Copy image Copy
' Create a ChannelListEntry object for analog input channel 3
' of the AnalogInputSubsystem (ainSS).
Dim ch3 As New ChannelListEntry(ainSS.SupportedChannels.GetChannelInfo(SubsystemType.AnalogInput, 3))
' Insert the ChannelListEntry object ch3 at index 1 of the ChannelList.
ainSS.ChannelList.Insert(1, ch3)

See Also

ChannelList Class
ChannelList Members
Insert Overload
OpenLayers.DeviceCollection Namespace


ChannelList.Insert Method (Int32, Int32)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method (Int32, Int32)
ChannelList Class Example See Also Send Feedback
Inserts a channel at the specified index of the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Insert(
    int index,
    int physicalChannelNumber
)
Visual Basic
Public Function Insert (
    index As Integer,
    physicalChannelNumber As Integer
) As ChannelListEntry

Parameters

index
Type: System..::..Int32
Zero-based index of the ChannelList at which to insert the ChannelListEntry object.
physicalChannelNumber
Type: System..::..Int32
The physical channel number of the specified subsystem to add to the ChannelList.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was inserted. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Inserts a channel, specified as a physical channel number, at the specified index of the ChannelList and returns a ChannelListEntry object for the channel.

This method provides a simple way to insert channels into the ChannelList, particularly if you are inserting channels that are native to the subsystem type (such as analog input channels on an analog input subsystem). For native channels, the physical channel number always equals the logical channel number. While non-native channels, such as digital inputs that are streamed through the analog input subsystem, can also be inserted this way, the physical channel number is not the same as the logical channel number, so you may find it easier to insert a channel by name or by ChannelListEntry object instead.

Examples

This example demonstrates how to insert analog input channel 3 (by physical channel number) at index 0 of the ChannelList.
C# Copy image Copy
ch = ainSS.ChannelList.Insert (0, 3);
Visual Basic Copy image Copy
ch = ainSS.ChannelList.Insert(0,3)

See Also

ChannelList Class
ChannelList Members
Insert Overload
OpenLayers.DeviceCollection Namespace


ChannelList.Insert Method (Int32, String)

[image]

OpenLayers for .NET Documentation
ChannelList..::..Insert Method (Int32, String)
ChannelList Class Example See Also Send Feedback
Inserts a channel at the specified index of the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry Insert(
    int index,
    string physicalChannelName
)
Visual Basic
Public Function Insert (
    index As Integer,
    physicalChannelName As String
) As ChannelListEntry

Parameters

index
Type: System..::..Int32
Zero-based index of the ChannelList at which to insert the ChannelListEntry object.
physicalChannelName
Type: System..::..String
The name of a channel on the specified subsystem to add to the ChannelList. The channel name must match the name of a channel contained in the SupportedChannels object for the specified subsystem type.

Return Value

Type: ChannelListEntry
A ChannelListEntry object for the physical channel that was inserted. You can then access this ChannelListEntry object through the ChannelList for the subsystem.

Remarks

Inserts a channel, specified by name, at the specified index of the ChannelList and returns a ChannelListEntry object for the channel.

Examples

This example inserts the analog input channel with the name Sensor at index 2 of the ChannelList and returns a ChannelListEntry object (ch).
C# Copy image Copy
//Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels[1].Name = " Sensor";
//Insert the channel named Sensor at index 2 of the ChannelList.
ch = ainSS.ChannelList.Insert(2, "Sensor");
///
Visual Basic Copy image Copy
'Define the name Sensor for analog input channel 1 of the AnalogInputSubsystem (ainSS).
ainSS.SupportedChannels(1).Name = "Sensor"
'Insert the channel named Sensor at index 2 of the ChannelList.
ch = AinSS.ChannelList.Insert(2, "Sensor")

See Also

ChannelList Class
ChannelList Members
Insert Overload
OpenLayers.DeviceCollection Namespace


ChannelList.Remove Method

[image]

OpenLayers for .NET Documentation
ChannelList..::..Remove Method
ChannelList Class Example See Also Send Feedback
Removes the first occurrence of the specified ChannelListEntry object from the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Remove(
    ChannelListEntry value
)
Visual Basic
Public Sub Remove (
    value As ChannelListEntry
)

Parameters

value
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
The ChannelListEntry object to remove from the ChannelList.

Examples

This example removes the first instance of ChannelListEntry object Ch0 from the ChannelList object.
C# Copy image Copy
AinSS.ChannelList.Remove(Ch0);
Visual Basic Copy image Copy
AinSS.ChannelList.Remove(Ch0)

See Also

ChannelList Class
ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelList Properties

[image] [image]

OpenLayers for .NET Documentation
ChannelList Properties
ChannelList Class See Also Send Feedback

The ChannelList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | CGLDepth | Returns the maximum number of channels or ChannelListEntry objects that the ChannelList can contain.
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Returns or replaces the ChannelListEntry object at the specified index of the ChannelList.

See Also

ChannelList Class
OpenLayers.DeviceCollection Namespace


ChannelList.CGLDepth Property

[image]

OpenLayers for .NET Documentation
ChannelList..::..CGLDepth Property
ChannelList Class See Also Send Feedback
Returns the maximum number of channels or ChannelListEntry objects that the ChannelList can contain.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int CGLDepth { get; }
Visual Basic
Public ReadOnly Property CGLDepth As Integer
    Get

Property Value

Type: Int32

See Also

ChannelList Class
ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelList.Item Property

[image]

OpenLayers for .NET Documentation
ChannelList..::..Item Property
ChannelList Class Example See Also Send Feedback
Returns or replaces the ChannelListEntry object at the specified index of the ChannelList.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As ChannelListEntry
    Get
    Set

Parameters

index
Type: System..::..Int32

Property Value

Type: ChannelListEntry

Remarks

Index must be less than ChannelList.Count.

Examples

This example replaces the ChannelListEntry at index 1 of the ChannelList with ChannelListEntry Ch3.
C# Copy image Copy
AinSS.ChannelList[1] = Ch3;
Visual Basic Copy image Copy
AinSS.ChannelList(1) = Ch3

See Also

ChannelList Class
ChannelList Members
OpenLayers.DeviceCollection Namespace


ChannelListEntry Class

[image]

OpenLayers for .NET Documentation
ChannelListEntry Class
Members See Also Send Feedback
A ChannelListEntry object encapsulates a physical channel connection that is associated with a specific subsystem. A ChannelList object is a collection of ChannelListEntry objects.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class ChannelListEntry
Visual Basic
Public Class ChannelListEntry

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..ChannelListEntry

See Also

ChannelListEntry Members
OpenLayers.DeviceCollection Namespace


ChannelListEntry Members

[image] [image]

OpenLayers for .NET Documentation
ChannelListEntry Members
ChannelListEntry Class Constructors Methods Properties See Also Send Feedback

The ChannelListEntry type exposes the following members.

Constructors

 | Name | Description
Public method | ChannelListEntry | Creates and returns a ChannelListEntry object for a specified channel, based on the SupportedChannelInfo information for that channel.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Gain | Gets and sets the gain to apply to the input signal of the associated ChannelListEntry object.
Public property | Inhibit | Gets and sets the inhibit state for the ChannelListEntry object. If True, the ChannelListEntry object takes up an entry in the ChannelList and is factored into the conversion time, but data is not returned for the ChannelListEntry object. If False (the default value), data is returned for the ChannelListEntry object.
Public property | Name | Gets the name of the channel that is associated with the ChannelListEntry object.
Public property | PhysicalChannelNumber | Returns the physical channel number for the ChannelListEntry object.
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, QuadratureDecoder, or Tachometer) for the ChannelListEntry object.

See Also

ChannelListEntry Class
OpenLayers.DeviceCollection Namespace


ChannelListEntry Constructor

[image]

OpenLayers for .NET Documentation
ChannelListEntry Constructor
ChannelListEntry Class See Also Send Feedback
Creates and returns a ChannelListEntry object for a specified channel, based on the SupportedChannelInfo information for that channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelListEntry(
    SupportedChannelInfo channelInfo
)
Visual Basic
Public Sub New (
    channelInfo As SupportedChannelInfo
)

Parameters

channelInfo
Type: OpenLayers.DeviceCollection..::..SupportedChannelInfo
The SupportedChannelInfo object to use when creating the ChannelListEntry object.

Remarks

If you add or insert a channel into a ChannelList by physical channel number or name (using the Add(Int32) or Insert(Int32, Int32) methods), the ChannelListEntry object is automatically created and returned.

See Also

ChannelListEntry Class
ChannelListEntry Members
OpenLayers.DeviceCollection Namespace


ChannelListEntry Methods

[image] [image]

OpenLayers for .NET Documentation
ChannelListEntry Methods
ChannelListEntry Class See Also Send Feedback

The ChannelListEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChannelListEntry Class
OpenLayers.DeviceCollection Namespace


ChannelListEntry Properties

[image] [image]

OpenLayers for .NET Documentation
ChannelListEntry Properties
ChannelListEntry Class See Also Send Feedback

The ChannelListEntry type exposes the following members.

Properties

 | Name | Description
Public property | Gain | Gets and sets the gain to apply to the input signal of the associated ChannelListEntry object.
Public property | Inhibit | Gets and sets the inhibit state for the ChannelListEntry object. If True, the ChannelListEntry object takes up an entry in the ChannelList and is factored into the conversion time, but data is not returned for the ChannelListEntry object. If False (the default value), data is returned for the ChannelListEntry object.
Public property | Name | Gets the name of the channel that is associated with the ChannelListEntry object.
Public property | PhysicalChannelNumber | Returns the physical channel number for the ChannelListEntry object.
Public property | SubsystemType | Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, QuadratureDecoder, or Tachometer) for the ChannelListEntry object.

See Also

ChannelListEntry Class
OpenLayers.DeviceCollection Namespace


ChannelListEntry.Gain Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..Gain Property
ChannelListEntry Class Example See Also Send Feedback
Gets and sets the gain to apply to the input signal of the associated ChannelListEntry object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Gain { get; set; }
Visual Basic
Public Property Gain As Double
    Get
    Set

Property Value

Type: Double

Remarks

The default value is 1. If the gain is not supported, the closest gain value that is supported by the subsystem is applied to the channel. Performing a get on this property after a set will return the actual gain applied to the channel.

Examples

This example sets the gain of the channel at index 0 of the ChannelList to 2.
C# Copy image Copy
ainSS.ChannelList[0].Gain = 2;
Visual Basic Copy image Copy
ainSS.ChannelList(0).Gain = 2

See Also

ChannelListEntry Class
ChannelListEntry Members
OpenLayers.DeviceCollection Namespace


ChannelListEntry.Inhibit Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..Inhibit Property
ChannelListEntry Class Example See Also Send Feedback
Gets and sets the inhibit state for the ChannelListEntry object. If True, the ChannelListEntry object takes up an entry in the ChannelList and is factored into the conversion time, but data is not returned for the ChannelListEntry object. If False (the default value), data is returned for the ChannelListEntry object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Inhibit { get; set; }
Visual Basic
Public Property Inhibit As Boolean
    Get
    Set

Property Value

Type: Boolean

Examples

This example sets the inhibit value to True for the channel at index 0 of the ChannelList.
C# Copy image Copy
ainSS.ChannelList[0].Inhibit = 1;
Visual Basic Copy image Copy
ainSS.ChannelList(0).Inhibit = 1

See Also

ChannelListEntry Class
ChannelListEntry Members
OpenLayers.DeviceCollection Namespace


ChannelListEntry.Name Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..Name Property
ChannelListEntry Class See Also Send Feedback
Gets the name of the channel that is associated with the ChannelListEntry object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Remarks

This information is included in the SupportedChannelInfo object associated with the channel.

See Also

ChannelListEntry Class
ChannelListEntry Members
OpenLayers.DeviceCollection Namespace


ChannelListEntry.PhysicalChannelNumber Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..PhysicalChannelNumber Property
ChannelListEntry Class See Also Send Feedback
Returns the physical channel number for the ChannelListEntry object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannelNumber { get; }
Visual Basic
Public ReadOnly Property PhysicalChannelNumber As Integer
    Get

Property Value

Type: Int32

See Also

ChannelListEntry Class
ChannelListEntry Members
OpenLayers.DeviceCollection Namespace


ChannelListEntry.SubsystemType Property

[image]

OpenLayers for .NET Documentation
ChannelListEntry..::..SubsystemType Property
ChannelListEntry Class See Also Send Feedback
Returns the subsystem type (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, QuadratureDecoder, or Tachometer) for the ChannelListEntry object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemType SubsystemType { get; }
Visual Basic
Public ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

Remarks

This information is included in the SupportedChannelInfo object associated with the channel.

See Also

ChannelListEntry Class
ChannelListEntry Members
OpenLayers.DeviceCollection Namespace


ChannelType Enumeration

[image]

OpenLayers for .NET Documentation
ChannelType Enumeration
See Also Send Feedback
Contains the possible values for the ChannelType property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ChannelType
Visual Basic
Public Enumeration ChannelType

Members

Member name | Value | Description
SingleEnded | 100 | Single-ended channel configuration. Use this configuration when you want to measure high-level signals, noise is insignificant, the source of the input is close to the device, and all the input signals are referred to the same common ground.
Differential | 101 | Differential channel configuration. Use this configuration when you want to measure low-level signals (less than 1 V), you are using an A/D converter with high resolution (greater than 12 bits), noise is a significant part of the signal, or common-mode voltage exists.

See Also

OpenLayers.DeviceCollection Namespace


Clock Class

[image]

OpenLayers for .NET Documentation
Clock Class
Members See Also Send Feedback
The Clock class provides an interface for controlling the clock of a subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class Clock
Visual Basic
Public Class Clock

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..Clock

See Also

Clock Members
OpenLayers.DeviceCollection Namespace


Clock Members

[image] [image]

OpenLayers for .NET Documentation
Clock Members
Clock Class Methods Properties See Also Send Feedback

The Clock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseClockFrequency | Returns the frequency of the base clock for the subsystem.
Public property | ExtClockDivider | Gets and sets the current value of the external clock divider.
Public property | Frequency | Gets and sets the frequency of the internal clock source.
Public property | MaxExtClockDivider | Returns the maximum allowable external clock divider value supported by the subsystem.
Public property | MaxFrequency | Returns the maximum allowable internal clock frequency supported by the subsystem.
Public property | MinExtClockDivider | Returns the minimum allowable external clock divider value supported by the subsystem.
Public property | MinFrequency | Returns the minimum allowable internal clock frequency supported by the subsystem.
Public property | Source | Gets and sets the current clock source (Internal or External).
Public property | SupportsExternalClock | Returns True if the subsystem supports an external clock source; otherwise, returns False.
Public property | SupportsInternalClock | Returns True if the subsystem supports an internal clock source; otherwise, returns False.
Public property | SupportsSimultaneousClocking | Returns True if the subsystem supports simultaneous clocking.

See Also

Clock Class
OpenLayers.DeviceCollection Namespace


Clock Methods

[image] [image]

OpenLayers for .NET Documentation
Clock Methods
Clock Class See Also Send Feedback

The Clock type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Clock Class
OpenLayers.DeviceCollection Namespace


Clock Properties

[image] [image]

OpenLayers for .NET Documentation
Clock Properties
Clock Class See Also Send Feedback

The Clock type exposes the following members.

Properties

 | Name | Description
Public property | BaseClockFrequency | Returns the frequency of the base clock for the subsystem.
Public property | ExtClockDivider | Gets and sets the current value of the external clock divider.
Public property | Frequency | Gets and sets the frequency of the internal clock source.
Public property | MaxExtClockDivider | Returns the maximum allowable external clock divider value supported by the subsystem.
Public property | MaxFrequency | Returns the maximum allowable internal clock frequency supported by the subsystem.
Public property | MinExtClockDivider | Returns the minimum allowable external clock divider value supported by the subsystem.
Public property | MinFrequency | Returns the minimum allowable internal clock frequency supported by the subsystem.
Public property | Source | Gets and sets the current clock source (Internal or External).
Public property | SupportsExternalClock | Returns True if the subsystem supports an external clock source; otherwise, returns False.
Public property | SupportsInternalClock | Returns True if the subsystem supports an internal clock source; otherwise, returns False.
Public property | SupportsSimultaneousClocking | Returns True if the subsystem supports simultaneous clocking.

See Also

Clock Class
OpenLayers.DeviceCollection Namespace


Clock.BaseClockFrequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..BaseClockFrequency Property
Clock Class See Also Send Feedback
Returns the frequency of the base clock for the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double BaseClockFrequency { get; }
Visual Basic
Public ReadOnly Property BaseClockFrequency As Double
    Get

Property Value

Type: Double

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.ExtClockDivider Property

[image]

OpenLayers for .NET Documentation
Clock..::..ExtClockDivider Property
Clock Class See Also Send Feedback
Gets and sets the current value of the external clock divider.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint ExtClockDivider { get; set; }
Visual Basic
Public Property ExtClockDivider As UInteger
    Get
    Set

Property Value

Type: UInt32

Remarks

The external clock divider is used to determine the frequency of the external clock source. The frequency of the external clock input divided by the external clock divider determines the frequency of at which to pace the operation.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.Frequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..Frequency Property
Clock Class See Also Send Feedback
Gets and sets the frequency of the internal clock source.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Frequency { get; set; }
Visual Basic
Public Property Frequency As Double
    Get
    Set

Property Value

Type: Double

Remarks

The driver sets the frequency of the internal clock as close as possible to the value that you specified in the Frequency property. You can determine the actual frequency that was set on the hardware by reading the value of the Frequency property after the subsystem has been configured (using the Config()()()() method).

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.MaxExtClockDivider Property

[image]

OpenLayers for .NET Documentation
Clock..::..MaxExtClockDivider Property
Clock Class See Also Send Feedback
Returns the maximum allowable external clock divider value supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaxExtClockDivider { get; }
Visual Basic
Public ReadOnly Property MaxExtClockDivider As Double
    Get

Property Value

Type: Double

Remarks

Set the external clock divider using the ExtClockDivider property.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.MaxFrequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..MaxFrequency Property
Clock Class See Also Send Feedback
Returns the maximum allowable internal clock frequency supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MaxFrequency { get; }
Visual Basic
Public ReadOnly Property MaxFrequency As Double
    Get

Property Value

Type: Double

Remarks

Set the frequency of the internal clock using the Frequency property.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.MinExtClockDivider Property

[image]

OpenLayers for .NET Documentation
Clock..::..MinExtClockDivider Property
Clock Class See Also Send Feedback
Returns the minimum allowable external clock divider value supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MinExtClockDivider { get; }
Visual Basic
Public ReadOnly Property MinExtClockDivider As Double
    Get

Property Value

Type: Double

Remarks

Set the external clock divider using the ExtClockDivider property.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.MinFrequency Property

[image]

OpenLayers for .NET Documentation
Clock..::..MinFrequency Property
Clock Class See Also Send Feedback
Returns the minimum allowable internal clock frequency supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double MinFrequency { get; }
Visual Basic
Public ReadOnly Property MinFrequency As Double
    Get

Property Value

Type: Double

Remarks

Set the frequency of the internal clock using the Frequency property.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.Source Property

[image]

OpenLayers for .NET Documentation
Clock..::..Source Property
Clock Class See Also Send Feedback
Gets and sets the current clock source (Internal or External).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ClockSource Source { get; set; }
Visual Basic
Public Property Source As ClockSource
    Get
    Set

Property Value

Type: ClockSource

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.SupportsExternalClock Property

[image]

OpenLayers for .NET Documentation
Clock..::..SupportsExternalClock Property
Clock Class See Also Send Feedback
Returns True if the subsystem supports an external clock source; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsExternalClock { get; }
Visual Basic
Public ReadOnly Property SupportsExternalClock As Boolean
    Get

Property Value

Type: Boolean

Remarks

Specify the clock source using the Source property.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.SupportsInternalClock Property

[image]

OpenLayers for .NET Documentation
Clock..::..SupportsInternalClock Property
Clock Class See Also Send Feedback
Returns True if the subsystem supports an internal clock source; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsInternalClock { get; }
Visual Basic
Public ReadOnly Property SupportsInternalClock As Boolean
    Get

Property Value

Type: Boolean

Remarks

Specify the clock source using the Source property.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


Clock.SupportsSimultaneousClocking Property

[image]

OpenLayers for .NET Documentation
Clock..::..SupportsSimultaneousClocking Property
Clock Class See Also Send Feedback
Returns True if the subsystem supports simultaneous clocking.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSimultaneousClocking { get; }
Visual Basic
Public ReadOnly Property SupportsSimultaneousClocking As Boolean
    Get

Property Value

Type: Boolean

Remarks

Some subsystems allow you to read or update multiple channels on a single clock pulse. This property allows you to determine whether multiple channels can be read or updated on a single clock pulse.

See Also

Clock Class
Clock Members
OpenLayers.DeviceCollection Namespace


ClockSource Enumeration

[image]

OpenLayers for .NET Documentation
ClockSource Enumeration
See Also Send Feedback
Contains the possible values for the Source property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ClockSource
Visual Basic
Public Enumeration ClockSource

Members

Member name | Value | Description
Internal | 400 | The internal clock is the clock source on the device that paces data acquisition or output for each channel in the ChannelList, or that is used in a counter/timer operation.
External | 401 | An external clock source is an input signal attached to the device that paces data acquisition or output for each channel in the ChannelList, or that is used in a counter/timer operation. This clock source is useful when you want to operate at rates not available with the internal clock or if you want to operate at uneven intervals.

See Also

OpenLayers.DeviceCollection Namespace


CouplingType Enumeration

[image]

OpenLayers for .NET Documentation
CouplingType Enumeration
See Also Send Feedback
Contains the possible values for the Coupling property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum CouplingType
Visual Basic
Public Enumeration CouplingType

Members

Member name | Value | Description
DC | 0 | DC coupling, where the DC offset is included.
AC | 1 | AC coupling, where the DC offset is removed.

See Also

OpenLayers.DeviceCollection Namespace


DataFlow Enumeration

[image]

OpenLayers for .NET Documentation
DataFlow Enumeration
See Also Send Feedback
Contains the possible values for the DataFlow property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum DataFlow
Visual Basic
Public Enumeration DataFlow

Members

Member name | Value | Description
Continuous | 800 | Use continuous mode when you want to acquire or output data from multiple channels continuously. For analog input operations, this is post-trigger mode. For maximum flexibility, you can specify other parameters, such as the ChannelList, clock source and frequency, buffer, and so on.
SingleValue | 801 | In a single-value operation, a single data value is read from or written to a single channel immediately, and then the operation stops. You specify only the channel to read or update, and the gain for the channel.
ContinuousPreTrigger | 804 | Use continuous pre-trigger mode when you want to continuously acquire data before a specific external trigger event occurs. For maximum flexibility, you can specify other parameters, such as the ChannelList, clock source and frequency, buffer, and so on.
ContinuousPrePostTrigger | 805 | Use continuous about-trigger mode when you want to continuously acquire data both before and after a specific external event occurs. This operation is equivalent to doing both a pre-trigger and a post-trigger acquisition For maximum flexibility, you can specify other parameters, such as the ChannelList, clock source and frequency, buffer, and so on.

See Also

OpenLayers.DeviceCollection Namespace


Device Class

[image]

OpenLayers for .NET Documentation
Device Class
Members See Also Send Feedback
A Device object encapsulates an Open Layers device collection and manages and distributes subsystems for the individual devices contained within the device collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class Device : IDisposable
Visual Basic
Public Class Device
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..Device

See Also

Device Members
OpenLayers.DeviceCollection Namespace


Device Members

[image] [image]

OpenLayers for .NET Documentation
Device Members
Device Class Constructors Methods Properties See Also Send Feedback

The Device type exposes the following members.

Constructors

 | Name | Description
Public method | Device | Returns a Device object for a specified Open Layers-compliant device collection.

Methods

 | Name | Description
Public method | AnalogInputSubsystem | Returns an AnalogInputSubsystem object.
Public method | AnalogOutputSubsystem | Returns an AnalogOutputSubsystem object.
Public method | Dispose | Terminates the connection to all devices contained in the device collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHardwareInfo | Returns hardware-specific information about the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumSubsystemElements | Returns the number of available subsystem elements for a given subsystem type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CollectionDevices | Returns an array of Device objects for each device in the collection. The array is ordered by the collection device numbers (0-n) with devices 0 and n being at each end of the sync bus chain.
Public property | DeviceName | Returns the user-defined name of the device collection. You can modify this name in the Open Layers Device Collection Manager application.
Public property | MasterIndex | Returns the index of the master Device object in the CollectionDevices array.
Public property | SimultaneousStart | Provides an interface to the SimultaneousStart object.

See Also

Device Class
OpenLayers.DeviceCollection Namespace


Device Constructor

[image]

OpenLayers for .NET Documentation
Device Constructor
Device Class See Also Send Feedback
Returns a Device object for a specified Open Layers-compliant device collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Device(
    string deviceName
)
Visual Basic
Public Sub New (
    deviceName As String
)

Parameters

deviceName
Type: System..::..String
Name of the device collection to open and initialize.

Return Value

Type:
The Device object for the specified device collection.

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device Methods

[image] [image]

OpenLayers for .NET Documentation
Device Methods
Device Class See Also Send Feedback

The Device type exposes the following members.

Methods

 | Name | Description
Public method | AnalogInputSubsystem | Returns an AnalogInputSubsystem object.
Public method | AnalogOutputSubsystem | Returns an AnalogOutputSubsystem object.
Public method | Dispose | Terminates the connection to all devices contained in the device collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHardwareInfo | Returns hardware-specific information about the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumSubsystemElements | Returns the number of available subsystem elements for a given subsystem type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Device Class
OpenLayers.DeviceCollection Namespace


Device.AnalogInputSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..AnalogInputSubsystem Method
Device Class See Also Send Feedback
Returns an AnalogInputSubsystem object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogInputSubsystem AnalogInputSubsystem(
    int element
)
Visual Basic
Public Function AnalogInputSubsystem (
    element As Integer
) As AnalogInputSubsystem

Parameters

element
Type: System..::..Int32
Instance of the analog input subsystem to open.

Return Value

Type: AnalogInputSubsystem
A new AnalogInputSubsystem object.

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device.AnalogOutputSubsystem Method

[image]

OpenLayers for .NET Documentation
Device..::..AnalogOutputSubsystem Method
Device Class See Also Send Feedback
Returns an AnalogOutputSubsystem object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public AnalogOutputSubsystem AnalogOutputSubsystem(
    int element
)
Visual Basic
Public Function AnalogOutputSubsystem (
    element As Integer
) As AnalogOutputSubsystem

Parameters

element
Type: System..::..Int32
Instance of the analog output subsystem to open.

Return Value

Type: AnalogOutputSubsystem
A new AnalogOutputSubsystem object.

Remarks

If the devices in the collection do not support D/A Synchronization, a Not Supported exception will be thrown.

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device.Dispose Method

[image]

OpenLayers for .NET Documentation
Device..::..Dispose Method
Device Class See Also Send Feedback
Terminates the connection to all devices contained in the device collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device.GetHardwareInfo Method

[image]

OpenLayers for .NET Documentation
Device..::..GetHardwareInfo Method
Device Class See Also Send Feedback
Returns hardware-specific information about the collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public HardwareInfo GetHardwareInfo()
Visual Basic
Public Function GetHardwareInfo As HardwareInfo

Return Value

Type: HardwareInfo
The Vendor Id, Collection Id, and Number of Devices within the HardwareInfo structure.

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device.GetNumSubsystemElements Method

[image]

OpenLayers for .NET Documentation
Device..::..GetNumSubsystemElements Method
Device Class See Also Send Feedback
Returns the number of available subsystem elements for a given subsystem type.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int GetNumSubsystemElements(
    SubsystemType ssType
)
Visual Basic
Public Function GetNumSubsystemElements (
    ssType As SubsystemType
) As Integer

Parameters

ssType
Type: OpenLayers.DeviceCollection..::..SubsystemType
The type of subsystem.

Return Value

Type: Int32
The number of elements for the specified subsystem type.

Remarks

Your device may support multiple instances, or elements, of the same subsystem type. Element numbering is zero-based; that is, the first instance of the subsystem is called element 0, the second instance of the subsystem is called element 1, and so on. For example, if your device has two digital input ports, two subsystems of type DigitalInput are available, differentiated as elements 0 and 1.

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device Properties

[image] [image]

OpenLayers for .NET Documentation
Device Properties
Device Class See Also Send Feedback

The Device type exposes the following members.

Properties

 | Name | Description
Public property | CollectionDevices | Returns an array of Device objects for each device in the collection. The array is ordered by the collection device numbers (0-n) with devices 0 and n being at each end of the sync bus chain.
Public property | DeviceName | Returns the user-defined name of the device collection. You can modify this name in the Open Layers Device Collection Manager application.
Public property | MasterIndex | Returns the index of the master Device object in the CollectionDevices array.
Public property | SimultaneousStart | Provides an interface to the SimultaneousStart object.

See Also

Device Class
OpenLayers.DeviceCollection Namespace


Device.CollectionDevices Property

[image]

OpenLayers for .NET Documentation
Device..::..CollectionDevices Property
Device Class See Also Send Feedback
Returns an array of Device objects for each device in the collection. The array is ordered by the collection device numbers (0-n) with devices 0 and n being at each end of the sync bus chain.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Device[] CollectionDevices { get; }
Visual Basic
Public ReadOnly Property CollectionDevices As Device()
    Get

Property Value

Type: array< Device >[]()[][]

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device.DeviceName Property

[image]

OpenLayers for .NET Documentation
Device..::..DeviceName Property
Device Class See Also Send Feedback
Returns the user-defined name of the device collection. You can modify this name in the Open Layers Device Collection Manager application.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string DeviceName { get; }
Visual Basic
Public ReadOnly Property DeviceName As String
    Get

Property Value

Type: String

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device.MasterIndex Property

[image]

OpenLayers for .NET Documentation
Device..::..MasterIndex Property
Device Class See Also Send Feedback
Returns the index of the master Device object in the CollectionDevices array.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int MasterIndex { get; }
Visual Basic
Public ReadOnly Property MasterIndex As Integer
    Get

Property Value

Type: Int32

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


Device.SimultaneousStart Property

[image]

OpenLayers for .NET Documentation
Device..::..SimultaneousStart Property
Device Class See Also Send Feedback
Provides an interface to the SimultaneousStart object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SimultaneousStart SimultaneousStart { get; }
Visual Basic
Public ReadOnly Property SimultaneousStart As SimultaneousStart
    Get

Property Value

Type: SimultaneousStart

See Also

Device Class
Device Members
OpenLayers.DeviceCollection Namespace


DeviceMgr Class

[image]

OpenLayers for .NET Documentation
DeviceMgr Class
Members See Also Send Feedback
The DeviceMgr is a singleton class that is responsible for managing Open Layers devices in the system and for assigning Device objects.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class DeviceMgr
Visual Basic
Public NotInheritable Class DeviceMgr

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..DeviceMgr

See Also

DeviceMgr Members
OpenLayers.DeviceCollection Namespace


DeviceMgr Members

[image] [image]

OpenLayers for .NET Documentation
DeviceMgr Members
DeviceMgr Class Methods See Also Send Feedback

The DeviceMgr type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Get | Returns a DeviceMgr object.
Public method | GetDevice | Returns a Device object for the specified device collection.
Public method | GetDeviceNames | Returns a list of all Open Layers-compatible device collections plugged into the system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HardwareAvailable | Returns a Boolean indicating whether an Open Layers-compatible device collection is plugged into the system.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceMgr Class
OpenLayers.DeviceCollection Namespace


DeviceMgr Methods

[image] [image]

OpenLayers for .NET Documentation
DeviceMgr Methods
DeviceMgr Class See Also Send Feedback

The DeviceMgr type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Get | Returns a DeviceMgr object.
Public method | GetDevice | Returns a Device object for the specified device collection.
Public method | GetDeviceNames | Returns a list of all Open Layers-compatible device collections plugged into the system.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HardwareAvailable | Returns a Boolean indicating whether an Open Layers-compatible device collection is plugged into the system.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeviceMgr Class
OpenLayers.DeviceCollection Namespace


DeviceMgr.Get Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..Get Method
DeviceMgr Class See Also Send Feedback
Returns a DeviceMgr object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static DeviceMgr Get()
Visual Basic
Public Shared Function Get As DeviceMgr

Return Value

Type: DeviceMgr
A DeviceMgr object.

Remarks

You must call this method before you can perform any operation in the Open Layers for .NET Class Library.

See Also

DeviceMgr Class
DeviceMgr Members
OpenLayers.DeviceCollection Namespace


DeviceMgr.GetDevice Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..GetDevice Method
DeviceMgr Class See Also Send Feedback
Returns a Device object for the specified device collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Device GetDevice(
    string deviceName
)
Visual Basic
Public Function GetDevice (
    deviceName As String
) As Device

Parameters

deviceName
Type: System..::..String
The name of the device collectoin as defined in the Open Layers Control Panel applet.

Return Value

Type: Device
A Device object.

Remarks

You must get a Device object for each Open Layers-compatible device collection that you want to use.

See Also

DeviceMgr Class
DeviceMgr Members
OpenLayers.DeviceCollection Namespace


DeviceMgr.GetDeviceNames Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..GetDeviceNames Method
DeviceMgr Class See Also Send Feedback
Returns a list of all Open Layers-compatible device collections plugged into the system.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string[] GetDeviceNames()
Visual Basic
Public Function GetDeviceNames As String()

Return Value

Type: array<String>[]()[][]
An array of strings with the active device collection names.

See Also

DeviceMgr Class
DeviceMgr Members
OpenLayers.DeviceCollection Namespace


DeviceMgr.HardwareAvailable Method

[image]

OpenLayers for .NET Documentation
DeviceMgr..::..HardwareAvailable Method
DeviceMgr Class See Also Send Feedback
Returns a Boolean indicating whether an Open Layers-compatible device collection is plugged into the system.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool HardwareAvailable()
Visual Basic
Public Function HardwareAvailable As Boolean

Return Value

Type: Boolean
Returns True if an Open Layers-compatible device collection is plugged into the system; otherwise, returns False.

See Also

DeviceMgr Class
DeviceMgr Members
OpenLayers.DeviceCollection Namespace


DeviceRemovedHandler Delegate

[image]

OpenLayers for .NET Documentation
DeviceRemovedHandler Delegate
See Also Send Feedback
The DeviceRemovedHandler delegate is called when the event DeviceRemovedEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void DeviceRemovedHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub DeviceRemovedHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event DeviceRemovedEvent.

Remarks

The event DeviceRemovedEvent is raised when a device is removed from your system while your application is running.

See Also

OpenLayers.DeviceCollection Namespace


DriverRunTimeErrorEventArgs Class

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Class
Members See Also Send Feedback
A DriverRunTimeErrorEventArgs object is passed to the DriverRunTimeErrorEventHandler delegate when when the event DriverRunTimeErrorEvent occurs. DriverRunTimeErrorEventArgs contains the error/warning that is generated by the device driver, an error message that describes the error/warning, the subsystem that raised the event, and the time stamp of when the event occurred.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class DriverRunTimeErrorEventArgs : GeneralEventArgs
Visual Basic
Public Class DriverRunTimeErrorEventArgs
    Inherits GeneralEventArgs

Remarks

The DriverRunTimeErrorEvent occurs when the device driver detects one of the following error conditions:

FifoOverflow - The driver could not read data from the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO overflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

FifoUnderflow - The driver could not write data to the device FIFO (or Windows USB FIFO) fast enough, resulting in FIFO underflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

DeviceOverClocked - The A/D clock (usually external clock) is running too fast on the device. To deal with this error, slow down the A/D clock.

TriggerError - The driver detected a trigger on the device but did not act on it.

DeviceError - Generated by the driver due to a USB bus or hardware problem. To deal with this error, stop connecting/disconnecting USB devices while streaming data to them.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.DeviceCollection..::..GeneralEventArgs
OpenLayers.DeviceCollection..::..DriverRunTimeErrorEventArgs

See Also

DriverRunTimeErrorEventArgs Members
OpenLayers.DeviceCollection Namespace


DriverRunTimeErrorEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Members
DriverRunTimeErrorEventArgs Class Methods Properties See Also Send Feedback

The DriverRunTimeErrorEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with the driver error.
Public property | Message | Returns the descriptive string for the driver error.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

DriverRunTimeErrorEventArgs Class
OpenLayers.DeviceCollection Namespace


DriverRunTimeErrorEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Methods
DriverRunTimeErrorEventArgs Class See Also Send Feedback

The DriverRunTimeErrorEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DriverRunTimeErrorEventArgs Class
OpenLayers.DeviceCollection Namespace


DriverRunTimeErrorEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs Properties
DriverRunTimeErrorEventArgs Class See Also Send Feedback

The DriverRunTimeErrorEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with the driver error.
Public property | Message | Returns the descriptive string for the driver error.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

DriverRunTimeErrorEventArgs Class
OpenLayers.DeviceCollection Namespace


DriverRunTimeErrorEventArgs.ErrorCode Property

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs..::..ErrorCode Property
DriverRunTimeErrorEventArgs Class See Also Send Feedback
Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with the driver error.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ErrorCode ErrorCode { get; }
Visual Basic
Public ReadOnly Property ErrorCode As ErrorCode
    Get

Property Value

Type: ErrorCode

See Also

DriverRunTimeErrorEventArgs Class
DriverRunTimeErrorEventArgs Members
OpenLayers.DeviceCollection Namespace


DriverRunTimeErrorEventArgs.Message Property

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventArgs..::..Message Property
DriverRunTimeErrorEventArgs Class See Also Send Feedback
Returns the descriptive string for the driver error.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get

Property Value

Type: String

See Also

DriverRunTimeErrorEventArgs Class
DriverRunTimeErrorEventArgs Members
OpenLayers.DeviceCollection Namespace


DriverRunTimeErrorEventHandler Delegate

[image]

OpenLayers for .NET Documentation
DriverRunTimeErrorEventHandler Delegate
See Also Send Feedback
The DriverRunTimeErrorEventHandler delegate is called when the DriverRunTimeErrorEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void DriverRunTimeErrorEventHandler(
    Object sender,
    DriverRunTimeErrorEventArgs eventArgs
)
Visual Basic
Public Delegate Sub DriverRunTimeErrorEventHandler (
    sender As Object,
    eventArgs As DriverRunTimeErrorEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..DriverRunTimeErrorEventArgs
The DriverRunTimeErrorEventArgs object that is associated with the DriverRunTimeErrorEvent.

Remarks

The DriverRunTimeErrorEvent occurs when the device driver detects one of the following error conditions during runtime:

FifoOverflow - The driver could not read data from the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO overflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

FifoUnderflow - The driver could not write data to the device FIFO (or Windows USB FIFO) fast enough, resulting in FIFO underflow condition. To deal with this error, increase the buffer sizes, slow down the sampling rate, or stop other CPU-intensive running programs.

DeviceOverClocked - The A/D clock (usually external clock) is running too fast on the device. To deal with this error, slow down the A/D clock.

TriggerError - The driver detected a trigger on the device but did not act on it.

DeviceError - Generated by the driver due to a USB bus or hardware problem. To deal with this error, stop connecting/disconnecting USB devices while streaming data to them.

See Also

OpenLayers.DeviceCollection Namespace


Encoding Enumeration

[image]

OpenLayers for .NET Documentation
Encoding Enumeration
See Also Send Feedback
Contains the possible values for the SubsystemBase.Encoding and OlBuffer.Encoding properties, and for the Encoding parameter of the VoltsToRawValue(Double, Encoding, Double, Double, Int32) and RawValueToVolts(Int32, Encoding, Double, Double, Int32) methods.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum Encoding
Visual Basic
Public Enumeration Encoding

Members

Member name | Value | Description
Binary | 200 | Binary data encoding
TwosComplement | 201 | Twos complement data encoding

See Also

OpenLayers.DeviceCollection Namespace


ErrorCode Enumeration

[image]

OpenLayers for .NET Documentation
ErrorCode Enumeration
See Also Send Feedback
Open Layers error codes that are accessible using an OlException object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ErrorCode
Visual Basic
Public Enumeration ErrorCode

Members

Member name | Value | Description
NoError | 0 | No error.
Success | 0 | The operation was successful.
InvalidElement | 2 | An invalid subsystem element was specified.
InvalidListSize | 5 | An attempt was made to set the ChannelList to an invalid size.
InvalidListEntry | 6 | An invalid ChannelListEntry entry was specified in the ChannelList.
InvalidChannel | 7 | An invalid ChannelListEntry object was specified.
InvalidChannelType | 8 | An invalid ChannelType was specified.
InvalidTrigger | 10 | An invalid TriggerType was specified.
InvalidResolution | 11 | An invalid Resolution was specified.
InvalidClockSource | 12 | An invalid clock Source was specified.
InvalidFrequency | 13 | An invalid clock Frequency was specified.
InvalidPulseType | 14 | An invalid PulseType was specified.
InvalidPulseWidth | 15 | An invalid PulseWidth was specified.
InvalidCounterMode | 16 | An invalid CounterMode was specified.
InvalidDataFlow | 18 | An invalid DataFlow mode was specified.
SubsystemInUse | 20 | An attempt was made to access a subsystem that is already in use.
SubsystemNotInUse | 21 | An operation was attempted on a subsystem that is not in use.
AlreadyRunning | 22 | An operation was attempted on a running subsystem.
NotConfigured | 26 | An operation was attempted on a subsystem that was not configured (see Config()()()()).
DataFlowMismatch | 27 | An invalid DataFlow mode was set for the current operation.
NotRunning | 28 | The subsystem is not running.
InvalidRange | 29 | An invalid VoltageRange was specified.
NotSupported | 36 | The operation is not supported.
InvalidDivider | 37 | An invalid ExtClockDivider was specified.
InvalidGate | 38 | An invalid GateType was set for the current operation.
InvalidChannelList | 45 | An invalid ChannelList channel entry was specified.
ADOverrun | 61 | Conversion is not complete within timeout period, resulting in A/D overrun condition.
NoQueuedBuffers | 64 | No OlBuffer objects were queued to the subsystem (see QueueBuffer(OlBuffer)).
CannotOpenDriver | 67 | The device driver cannot be initialized.
CantCascade | 72 | The subsystem cannot be cascaded (see CascadeMode).
WrongCounterMode | 82 | An invalid CounterMode was set for the current operation.
InvalidGain | 86 | An invalid Gain was set for the ChannelListEntry object.
InvalidRetriggerFrequency | 90 | An invalid RetriggerFrequency was requested for the current ChannelList.
CommandTimeout | 91 | A command timed out in the device driver.
EventCountOverFlow | 93 | An overflow occured while in event counting mode.
NoSubsystemsOnSimultaneousStartList | 104 | No subsystems have been put on the SimultaneousStart list.
NoChannelInhibitList | 105 | Subsystem does not support channel inhibition (see Inhibit).
NotPrestarted | 107 | The subsystem has not been prestarted on the simultaneous start list (see PreStart()()()()).
InvalidInhibitState | 113 | All ChannelListEntry entries in the ChannelList are inhibited (see Inhibit).
RequiredSubsystemInUse | 118 | The additional subsystem that is required for this operation is in use.
WrapModeMismatch | 119 | WrapSingleBuffer cannot be true for the requested operation.
BadRetriggerSource | 121 | An invalid RetriggerSource was specified.
BadMultiScanCount | 122 | The MultiScanCount value exceeds the maximum number of scans for the ChannelList.
InvalidRetrigger | 123 | Triggered scan is not supported when used with ContinuousPrePostTrigger mode or ContinuousPreTrigger mode. (See DataFlow).
InvalidPreTrigger | 124 | The PreTriggerSource must be Software when using ContinuousPrePostTrigger or ContinuousPreTrigger mode. (See DataFlow).
GeneralFailure | 125 | A general failure occurred in the device driver.
BadEdge | 128 | An invalid counter edge was specified for the current counter/timer mode (see StartEdge or StopEdge).
HalfCounterEntry | 129 | Only one 16-bit word of a 32-bit word was added to the ChannelList. Both words must be added.
InvalidX4IndexCombination | 131 | Invalid combination of IndexMode and X4Scaling was specified.
InvalidCouplingType | 132 | Invalid coupling type for the device.
InvalidCurrentSource | 133 | Invalid excitation current source for the device.
InvalidValue | 134 | Invalid value specified.
InvalidWhenADRunning | 135 | Operation is prohibited while the A/D is running. Refer to your device documentation for details.
InvalidSynchronizationMode | 140 | Invalid synchronization mode specified.
InvalidWhenDARunning | 142 | Operation is prohibited while the D/A is running. Refer to your device documentation for details.
CannotAllocateBuffer | 201 | Cannot allocate the requested OlBuffer object.
BufferAlreadyQueued | 205 | The OlBuffer object has already been queued to a subsystem.
BufferInProcess | 206 | The OlBuffer object has been removed from the queue and sent to the device driver for processing.
InvalidBufferSize | 208 | The OlBuffer The buffer size is invalid for the current operation.
OddSizeBuffer | 220 | The number of samples in the OlBuffer object must be a multiple of two for the current operation.
BufferNotAllocated | 221 | The OlBuffer object has been deallocated.
DataWidthMismatch | 400 | An OlBuffer object has been created using a data type that is not compatible with the subystem's Resolution.
NoValidSamples | 402 | The OlBuffer object has 0 ValidSamples.
ChannelNotInChannelList | 403 | The specified ChannelListEntry object is not in the ChannelList.
SourceBufferTooSmall | 404 | The user-specified array is too small for the requested operation.
DuplicateChannelName | 405 | Each SupportedChannelInfo object in SupportedChannels must have a unique name.
BufferInUse | 406 | The OlBuffer object is in use.
SubsystemIncompatible | 407 | The subsystem is incompatible with the data format of the OlBuffer object.
EmptyChannelList | 408 | The ChannelList must have at least one ChannelListEntry entry for continuous operations.
InvalidChannelListIndex | 409 | An invalid ChannelList index was specified.
SubsystemStopping | 410 | The subsystem is in the process of stopping or aborting. (See Stop()()()() and/or Abort()()()().)
FifoOverflow | 532 | The driver could not read data from the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO overflow condition.
FifoUnderflow | 533 | The driver could not write data to the device FIFO (or Windows USB FIFO) fast enough, resulting in a FIFO underflow condition.
DeviceOverClocked | 534 | The A/D clock (usually the external A/D clock) is running too fast on the device.
TriggerError | 535 | Generated by the driver when a trigger is detected but not acted on by the hardware.
DeviceError | 536 | Generated by the driver due to a USB bus problem or hardware problem.
InvalidError | 537 | An unknown error string was passed to GetErrorCode().
NoThermocoupleSupport | 538 | The subsystem does not support thermocouples.
NoCjcChannel | 539 | No CJC channel was specified in the ChannelList.
NoThermocoupleTypeSpecified | 540 | A ThermocoupleType was not specified for the requested channel.
ThermocoupleTypeSpecified | 541 | A ThermocoupleType was specified for the requested channel.
SetSingleValuesNotSupported | 542 | The SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) and SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][]) methods are not supported by this subsystem.
DuplicateChannelSpecified | 543 | A duplicate channel was specified for this operation.
AutoCalibrateNotSupported | 544 | Auto-calibrate is not supported by this device.
NoRTDSupport | 545 | The subsystem does not support RTDs.
NoRTDTypeSpecified | 546 | An RTDType was not specified for the requested channel.
RtdTypeSpecified | 547 | An RTDType was specified for the requested channel.
ReturnsOhmsNotSupported | 548 | The subsystem does not support returning values as Ohms.
AccessDenied | 549 | Access was denied to the subsystem or device.
TedsError | 550 | TEDs input streaming error.
NoThermistorSupport | 551 | The subsystem does not support Thermistor measurement.
CollectionNameMismatch | 552 | Device collection name mismatch. There is more than one collection present with the same name.
CollectionDeviceCountMismatch | 553 | Device collection device count mismatch. Not all devices in the collection were found.
ChannelNotOnMaster | 554 | The specified channel is invalid because it is not on the master device.
BufferSizeNotMultiple | 555 | The number samples in all queued OlBuffer objects must be a multiple of the number of channels in the ChannelList for a DeviceCollection.
CollectionNotFound | 556 | Device not found.
LastError | 557 | Last error code in the enumeration.

See Also

OpenLayers.DeviceCollection Namespace


ExcitationCurrentSource Enumeration

[image]

OpenLayers for .NET Documentation
ExcitationCurrentSource Enumeration
See Also Send Feedback
Contains the possible values for the ExcitationCurrentSource property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ExcitationCurrentSource
Visual Basic
Public Enumeration ExcitationCurrentSource

Members

Member name | Value | Description
Internal | 0 | Internal excitation current source.
External | 1 | External excitation current source.
Disabled | 2 | Excitation current source is disabled (no excitation is applied).

See Also

OpenLayers.DeviceCollection Namespace


GeneralEventArgs Class

[image]

OpenLayers for .NET Documentation
GeneralEventArgs Class
Members See Also Send Feedback
GeneralEventArgs is the base class for all event data. GeneralEventArgs contains the data that is passed to all events, including the subsystem that raised the event, and the time stamp of when the event occurred.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class GeneralEventArgs : EventArgs
Visual Basic
Public Class GeneralEventArgs
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.DeviceCollection..::..GeneralEventArgs
OpenLayers.DeviceCollection..::..BufferDoneEventArgs
OpenLayers.DeviceCollection..::..DriverRunTimeErrorEventArgs
OpenLayers.DeviceCollection..::..IOCompleteEventArgs

See Also

GeneralEventArgs Members
OpenLayers.DeviceCollection Namespace


GeneralEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
GeneralEventArgs Members
GeneralEventArgs Class Methods Properties See Also Send Feedback

The GeneralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred.
Public property | Subsystem | Returns the subsystem that raised the event.

See Also

GeneralEventArgs Class
OpenLayers.DeviceCollection Namespace


GeneralEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
GeneralEventArgs Methods
GeneralEventArgs Class See Also Send Feedback

The GeneralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeneralEventArgs Class
OpenLayers.DeviceCollection Namespace


GeneralEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
GeneralEventArgs Properties
GeneralEventArgs Class See Also Send Feedback

The GeneralEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred.
Public property | Subsystem | Returns the subsystem that raised the event.

See Also

GeneralEventArgs Class
OpenLayers.DeviceCollection Namespace


GeneralEventArgs.DateTime Property

[image]

OpenLayers for .NET Documentation
GeneralEventArgs..::..DateTime Property
GeneralEventArgs Class See Also Send Feedback
Returns the time stamp of when the associated event occurred.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DateTime DateTime { get; }
Visual Basic
Public ReadOnly Property DateTime As DateTime
    Get

Property Value

Type: DateTime

See Also

GeneralEventArgs Class
GeneralEventArgs Members
OpenLayers.DeviceCollection Namespace


GeneralEventArgs.Subsystem Property

[image]

OpenLayers for .NET Documentation
GeneralEventArgs..::..Subsystem Property
GeneralEventArgs Class See Also Send Feedback
Returns the subsystem that raised the event.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase Subsystem { get; }
Visual Basic
Public ReadOnly Property Subsystem As SubsystemBase
    Get

Property Value

Type: SubsystemBase

See Also

GeneralEventArgs Class
GeneralEventArgs Members
OpenLayers.DeviceCollection Namespace


GeneralFailureHandler Delegate

[image]

OpenLayers for .NET Documentation
GeneralFailureHandler Delegate
See Also Send Feedback
The GeneralFailureHandler delegate is called when the event GeneralFailureEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void GeneralFailureHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub GeneralFailureHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event GeneralFailureEvent.

Remarks

The event GeneralFailureEvent is raised when a general library failure occurs.

See Also

OpenLayers.DeviceCollection Namespace


HardwareInfo Structure

[image]

OpenLayers for .NET Documentation
HardwareInfo Structure
Members See Also Send Feedback
This structure is used by the GetHardwareInfo()()()() method to return information about a Open Layers-compliant device collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public struct HardwareInfo
Visual Basic
Public Structure HardwareInfo

See Also

HardwareInfo Members
OpenLayers.DeviceCollection Namespace


HardwareInfo Members

[image] [image]

OpenLayers for .NET Documentation
HardwareInfo Members
HardwareInfo Structure Methods Fields See Also Send Feedback

The HardwareInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | CollectionId | This field contains a unique collection ID value that is generated using the addition of the last two digits of the year multiplied by 10e7 (0 - 990000000) and the number of minutes into the current year (0 - 527040). Valid values for this field are 0 - 990527040;
Public field | NumberOfDevices | This field contains the number of devices in the collection.
Public field | VendorId | The identification number of the vendor. For most devices, this is 0x087 hexadecimal.

See Also

HardwareInfo Structure
OpenLayers.DeviceCollection Namespace


HardwareInfo Fields

[image] [image]

OpenLayers for .NET Documentation
HardwareInfo Fields
HardwareInfo Structure See Also Send Feedback

The HardwareInfo type exposes the following members.

Fields

 | Name | Description
Public field | CollectionId | This field contains a unique collection ID value that is generated using the addition of the last two digits of the year multiplied by 10e7 (0 - 990000000) and the number of minutes into the current year (0 - 527040). Valid values for this field are 0 - 990527040;
Public field | NumberOfDevices | This field contains the number of devices in the collection.
Public field | VendorId | The identification number of the vendor. For most devices, this is 0x087 hexadecimal.

See Also

HardwareInfo Structure
OpenLayers.DeviceCollection Namespace


HardwareInfo.CollectionId Field

[image]

OpenLayers for .NET Documentation
HardwareInfo..::..CollectionId Field
HardwareInfo Structure See Also Send Feedback
This field contains a unique collection ID value that is generated using the addition of the last two digits of the year multiplied by 10e7 (0 - 990000000) and the number of minutes into the current year (0 - 527040). Valid values for this field are 0 - 990527040;

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int CollectionId
Visual Basic
Public CollectionId As Integer

Field Value

Type: Int32

See Also

HardwareInfo Structure
HardwareInfo Members
OpenLayers.DeviceCollection Namespace


HardwareInfo.NumberOfDevices Field

[image]

OpenLayers for .NET Documentation
HardwareInfo..::..NumberOfDevices Field
HardwareInfo Structure See Also Send Feedback
This field contains the number of devices in the collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfDevices
Visual Basic
Public NumberOfDevices As Integer

Field Value

Type: Int32

See Also

HardwareInfo Structure
HardwareInfo Members
OpenLayers.DeviceCollection Namespace


HardwareInfo.VendorId Field

[image]

OpenLayers for .NET Documentation
HardwareInfo..::..VendorId Field
HardwareInfo Structure See Also Send Feedback
The identification number of the vendor. For most devices, this is 0x087 hexadecimal.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int VendorId
Visual Basic
Public VendorId As Integer

Field Value

Type: Int32

See Also

HardwareInfo Structure
HardwareInfo Members
OpenLayers.DeviceCollection Namespace


HardwareInfo Methods

[image] [image]

OpenLayers for .NET Documentation
HardwareInfo Methods
HardwareInfo Structure See Also Send Feedback

The HardwareInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

HardwareInfo Structure
OpenLayers.DeviceCollection Namespace


IOCompleteEventArgs Class

[image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Class
Members See Also Send Feedback
An IOCompleteEventArgs object is passed to the IOCompleteHandler delegate when the event IOCompleteEvent occurs. IOCompleteEventArgs contains the data associated with the event IOCompleteEvent. For analog input operations, this includes the total number of samples per channel that were acquired from the time acquisition was started to the last post-trigger sample, and the subsystem that raised the event. For analog output operations, this is the subsystem that raised the event.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class IOCompleteEventArgs : GeneralEventArgs
Visual Basic
Public Class IOCompleteEventArgs
    Inherits GeneralEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
OpenLayers.DeviceCollection..::..GeneralEventArgs
OpenLayers.DeviceCollection..::..IOCompleteEventArgs

See Also

IOCompleteEventArgs Members
OpenLayers.DeviceCollection Namespace


IOCompleteEventArgs Members

[image] [image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Members
IOCompleteEventArgs Class Methods Properties See Also Send Feedback

The IOCompleteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | LastSampleNumber | (For analog input operations only) returns the total number of samples per channel that were acquired from the time acquisition was started (with the start trigger) to the last post-trigger sample.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

IOCompleteEventArgs Class
OpenLayers.DeviceCollection Namespace


IOCompleteEventArgs Methods

[image] [image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Methods
IOCompleteEventArgs Class See Also Send Feedback

The IOCompleteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IOCompleteEventArgs Class
OpenLayers.DeviceCollection Namespace


IOCompleteEventArgs Properties

[image] [image]

OpenLayers for .NET Documentation
IOCompleteEventArgs Properties
IOCompleteEventArgs Class See Also Send Feedback

The IOCompleteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | DateTime | Returns the time stamp of when the associated event occurred. (Inherited from GeneralEventArgs.)
Public property | LastSampleNumber | (For analog input operations only) returns the total number of samples per channel that were acquired from the time acquisition was started (with the start trigger) to the last post-trigger sample.
Public property | Subsystem | Returns the subsystem that raised the event. (Inherited from GeneralEventArgs.)

See Also

IOCompleteEventArgs Class
OpenLayers.DeviceCollection Namespace


IOCompleteEventArgs.LastSampleNumber Property

[image]

OpenLayers for .NET Documentation
IOCompleteEventArgs..::..LastSampleNumber Property
IOCompleteEventArgs Class See Also Send Feedback
(For analog input operations only) returns the total number of samples per channel that were acquired from the time acquisition was started (with the start trigger) to the last post-trigger sample.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int LastSampleNumber { get; }
Visual Basic
Public ReadOnly Property LastSampleNumber As Integer
    Get

Property Value

Type: Int32

See Also

IOCompleteEventArgs Class
IOCompleteEventArgs Members
OpenLayers.DeviceCollection Namespace


IOCompleteHandler Delegate

[image]

OpenLayers for .NET Documentation
IOCompleteHandler Delegate
See Also Send Feedback
The IOCompleteHandler delegate is called when the event IOCompleteEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void IOCompleteHandler(
    Object sender,
    IOCompleteEventArgs eventArgs
)
Visual Basic
Public Delegate Sub IOCompleteHandler (
    sender As Object,
    eventArgs As IOCompleteEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..IOCompleteEventArgs
The IOCompleteEventArgs object that is associated with the event IOCompleteEvent.

Remarks

For analog input operations that use a reference trigger whose trigger type is something other than software (none), the event IOCompleteEvent is raised when the last post-trigger sample is copied into the user buffer. Devices that do not support a reference trigger will never receive this event for analog input operations.

For analog output operations, the event IOCompleteEvent is raised when the last data point has been output from an analog output channel; in some cases, this event is raised well after the data is transferred from the buffer (and, therefore, well after the events BufferDoneEvent and QueueDoneEvents are raised).

See Also

OpenLayers.DeviceCollection Namespace


IOType Enumeration

[image]

OpenLayers for .NET Documentation
IOType Enumeration
See Also Send Feedback
Contains the possible values for the IOType.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum IOType
Visual Basic
Public Enumeration IOType

Members

Member name | Value | Description
VoltageIn | 0 | The channel supports a voltage input.
VoltageOut | 1 | The channel supports a voltage output.
DigitalInput | 2 | The channel supports a digital input.
DigitalOutput | 3 | The channel supports a digital output.
QuadratureDecoder | 4 | The channel supports quadrature decoder operations.
CounterTimer | 5 | The channel supports counter/timer operations.
Tachometer | 6 | The channel supports a tachometer input.
Current | 7 | The channel supports a current input.
Thermocouple | 8 | The channel supports a thermocouple input.
Rtd | 9 | The channel supports an RTD input.
StrainGage | 10 | The channel supports a stain gage input.
Accelerometer | 11 | The channel supports an IEPE (accelerometer) input.
Bridge | 12 | The channel supports a bridge-based sensor or general-purpose bridge input.
Thermistor | 13 | The channel supports a thermistor input.
Resistance | 14 | The channel supports a resistance measurement input.
MultiSensor | 15 | The channel supports more than one sensor type. If the IOType propery is MultiSensor, use the MultiSensorType property or the SupportedMultiSensorTypes property to determine which sensor types are supported for the channel.

See Also

OpenLayers.DeviceCollection Namespace


OlBuffer Class

[image]

OpenLayers for .NET Documentation
OlBuffer Class
Members See Also Send Feedback
The OlBuffer class encapsulates a data buffer that is used in a continuous I/O operation.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class OlBuffer : IDisposable
Visual Basic
Public Class OlBuffer
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..OlBuffer

See Also

OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer Members

[image] [image]

OpenLayers for .NET Documentation
OlBuffer Members
OlBuffer Class Constructors Methods Properties See Also Send Feedback

The OlBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | OlBuffer | Creates and returns an OlBuffer object, and allocates an internal data buffer that will contain a specified number of samples.

Methods

 | Name | Description
Public method | Dispose | Deallocates the internal buffer of the OlBuffer object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataAsRawByte()()()() | Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawByte(ChannelListEntry) | Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).
Public method | GetDataAsRawInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).
Public method | GetDataAsRawUInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).
Public method | GetDataAsRawUInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).
Public method | GetDataAsRawUInt32()()()() | Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).
Public method | GetDataAsRawUInt32(ChannelListEntry) | Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).
Public method | GetDataAsRpm | For a specified ChannelListEntry, converts the tachometer data from the internal buffer of an OlBuffer object into RPM values, and then copies these values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsSensor(ChannelListEntry) | This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts()()()() | Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts(ChannelListEntry) | For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVoltsByte | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of bytes. Each voltage value is stored as an Int32, and takes 4 bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PutDataAsRaw(array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(ChannelListEntry, array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | Reallocate | Reallocates the internal data buffer of the OlBuffer object to contain the specified number of samples. The existing internal data buffer is deallocated and any data that it contained is lost.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BufferSizeInBytes | Returns the size of the internal data buffer, in bytes.
Public property | BufferSizeInSamples | Returns the size of the internal data buffer, in samples.
Public property | ChannelListOffset | Returns the index into the ChannelList that corresponds to the first sample in the internal buffer of the OlBuffer object.
Public property | Encoding | Returns the data encoding of the raw data (Binary or TwosComplement).
Public property | Item | Returns the data, as a raw count, at the specified index in the internal buffer of the OlBuffer object.
Public property | RawDataFormat | Returns the format of the raw data (Int16, Uint16, Int32, Float, or Double).
Public property | Resolution | Returns the resolution of the associated subsystem.
Public property | SampleSizeInBytes | Returns the size, in bytes, of the samples in the internal buffer of the OlBuffer object.
Public property | State | Returns the current state (Idle, Queued, InProcess, Completed, or Released) of the OlBuffer object.
Public property | Tag | Gets or sets a user-defined value.
Public property | ValidSamples | Returns the number of valid samples in the internal buffer of the OlBuffer object.
Public property | VoltageRange | Returns the upper and lower limits of the voltage range for the associated subsystem.

See Also

OlBuffer Class
OpenLayers.DeviceCollection Namespace


OlBuffer Constructor

[image]

OpenLayers for .NET Documentation
OlBuffer Constructor
OlBuffer Class See Also Send Feedback
Creates and returns an OlBuffer object, and allocates an internal data buffer that will contain a specified number of samples.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer(
    int inNumSamples,
    AnalogSubsystem inSubsystem
)
Visual Basic
Public Sub New (
    inNumSamples As Integer,
    inSubsystem As AnalogSubsystem
)

Parameters

inNumSamples
Type: System..::..Int32
Maximum number of samples that the internal buffer can contain. This parameter determines the size of the internal buffer.
inSubsystem
Type: OpenLayers.DeviceCollection..::..AnalogSubsystem
The subsystem (AnalogInputSubsystem or AnalogOutputSubsystem) with which the OlBuffer object is initially associated.

Remarks

The values for voltage range, channel list, data encoding, and resolution that are applied to the OlBuffer object are determined by the subsystem with which it is associated. Initially (and by default), these values are determined by the subsystem that is specified in the constructor above.

If, however, you later use the OlBuffer object with a different subsystem type, these values are determined by subsystem with which it is used. For example, if the OlBuffer object was initially associated with an analog output subsystem, and then put on an analog input subsystem queue, the values for voltage range, channel list, data encoding, and resolution will be updated to reflect the settings of the analog input subsystem when the OlBuffer object is completed by the device driver.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer Methods

[image] [image]

OpenLayers for .NET Documentation
OlBuffer Methods
OlBuffer Class See Also Send Feedback

The OlBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Deallocates the internal buffer of the OlBuffer object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDataAsRawByte()()()() | Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawByte(ChannelListEntry) | Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).
Public method | GetDataAsRawInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).
Public method | GetDataAsRawUInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).
Public method | GetDataAsRawUInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).
Public method | GetDataAsRawUInt32()()()() | Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).
Public method | GetDataAsRawUInt32(ChannelListEntry) | Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).
Public method | GetDataAsRpm | For a specified ChannelListEntry, converts the tachometer data from the internal buffer of an OlBuffer object into RPM values, and then copies these values into a user-declared array of 64-bit floating-point (double) values.
Public method | GetDataAsSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsSensor(ChannelListEntry) | This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts()()()() | Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts(ChannelListEntry) | For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVoltsByte | For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of bytes. Each voltage value is stored as an Int32, and takes 4 bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PutDataAsRaw(array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(ChannelListEntry, array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | Reallocate | Reallocates the internal data buffer of the OlBuffer object to contain the specified number of samples. The existing internal data buffer is deallocated and any data that it contained is lost.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OlBuffer Class
OpenLayers.DeviceCollection Namespace


OlBuffer.Dispose Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Dispose Method
OlBuffer Class See Also Send Feedback
Deallocates the internal buffer of the OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawByte Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawByte Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawByte()()()() | Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.
Public method | GetDataAsRawByte(ChannelListEntry) | Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawByte Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawByte Method
OlBuffer Class See Also Send Feedback
Copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public byte[] GetDataAsRawByte()
Visual Basic
Public Function GetDataAsRawByte As Byte()

Return Value

Type: array<Byte>[]()[][]
An array of raw counts represented as bytes.

Remarks

This method copies all the data, as raw counts, from the internal buffer into a user-declared array of bytes. This method is useful for file I/O operations. Since each sample takes more than one array entry, other uses may be limited.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawByte Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawByte Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawByte Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of bytes.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public byte[] GetDataAsRawByte(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawByte (
    channel As ChannelListEntry
) As Byte()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<Byte>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as bytes.

Remarks

Note that if the ChannelListEntry occurs more than once in the OlBuffer object, the data for each occurrence of the ChannelListEntry is copied. This method is useful for file I/O operations. Since each sample takes more than one array entry, other uses may be limited.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawByte Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawInt16 Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawInt16 Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).
Public method | GetDataAsRawInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawInt16 Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawInt16 Method
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of signed, 16-bit integers (short).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short[] GetDataAsRawInt16()
Visual Basic
Public Function GetDataAsRawInt16 As Short()

Return Value

Type: array<Int16>[]()[][]
An array of raw counts represented as signed 16-bit integers (short).

Remarks

This method copies all the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawInt16 Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawInt16 Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawInt16 Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is TwosComplement, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of signed 16-bit integers (short).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public short[] GetDataAsRawInt16(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawInt16 (
    channel As ChannelListEntry
) As Short()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<Int16>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as signed 16-bit integers (short).

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawInt16 Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawUInt16 Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt16 Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawUInt16()()()() | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).
Public method | GetDataAsRawUInt16(ChannelListEntry) | Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawUInt16 Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt16 Method
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies the data, as raw counts, from the internal data buffer of an OlBuffer object into a user-declared array of unsigned, 16-bit integers (ushort).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ushort[] GetDataAsRawUInt16()
Visual Basic
Public Function GetDataAsRawUInt16 As UShort()

Return Value

Type: array<UInt16>[]()[][]
An array of raw counts represented as unsigned 16-bit integers (ushort).

Remarks

This method copies all the data, as raw counts, from the internal buffer of the OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt16 Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawUInt16 Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt16 Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is 16 bits or less and when the data encoding is Binary, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 16-bit integers (ushort).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ushort[] GetDataAsRawUInt16(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawUInt16 (
    channel As ChannelListEntry
) As UShort()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<UInt16>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as unsigned 16-bit integers (ushort).

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt16 Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawUInt32 Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt32 Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsRawUInt32()()()() | Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).
Public method | GetDataAsRawUInt32(ChannelListEntry) | Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawUInt32 Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt32 Method
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is greater than 16 bits, copies the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned, 32-bit integers (uint).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint[] GetDataAsRawUInt32()
Visual Basic
Public Function GetDataAsRawUInt32 As UInteger()

Return Value

Type: array<UInt32>[]()[][]
An array of raw counts represented as unsigned 32-bit integers (uint).

Remarks

This method copies all the data, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt32 Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRawUInt32 Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRawUInt32 Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
Used when the resolution of the subsystem is greater than 16-bits, copies only the data associated with a specified ChannelListEntry, as raw counts, from the internal buffer of an OlBuffer object into a user-declared array of unsigned 32-bit integers (uint).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public uint[] GetDataAsRawUInt32(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsRawUInt32 (
    channel As ChannelListEntry
) As UInteger()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<UInt32>[]()[][]
An array of raw counts that are associated with a specified ChannelListEntry, represented as unsigned 32-bit integers (uint).

Remarks

Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsRawUInt32 Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsRpm Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsRpm Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the tachometer data from the internal buffer of an OlBuffer object into RPM values, and then copies these values into a user-declared array of 64-bit floating-point (double) values.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsRpm(
    ChannelListEntry channel,
    int pulsesPerRevolution
)
Visual Basic
Public Function GetDataAsRpm (
    channel As ChannelListEntry,
    pulsesPerRevolution As Integer
) As Double()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.
pulsesPerRevolution
Type: System..::..Int32
Specifies the number of pulses per revolution for the tachometer.

Return Value

Type: array<Double>[]()[][]
An array of RPM values, represented as 64-bit floating-point (double) values, that are associated with a specified ChannelListEntry.

Remarks

This method raises an exception if the SubsystemType is not a tachometer.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsSensor Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsSensor Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsSensor()()()() | Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsSensor(ChannelListEntry) | This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsSensor Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsSensor Method
OlBuffer Class See Also Send Feedback
Converts the data from the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsSensor()
Visual Basic
Public Function GetDataAsSensor As Double()

Return Value

Type: array<Double>[]()[][]
A user-specified array of sensor values, represented as 64-bit floating-point values (double).

Remarks

This method copies all the samples from the buffer into a user-declared array of 64-bit floating-point values (double).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsSensor Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsSensor Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsSensor Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
This method converts only the data for a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values (using the SensorGain and SensorOffset), and then copies these sensor values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsSensor(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsSensor (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry, which represents the channel whose data you want to copy.

Return Value

Type: array<Double>[]()[][]
A user-declared array of sensor values associated with all the samples for a given ChannelListEntry, represented as 64-bit floating-point values (double).

Remarks

This method converts only the data associated with a specified ChannelListEntry in the internal buffer of an OlBuffer object into sensor values, then copies this data into a user-declared array of 64-bit floating-point values (double). Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsSensor Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsVolts Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVolts Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDataAsVolts()()()() | Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).
Public method | GetDataAsVolts(ChannelListEntry) | For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsVolts Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVolts Method
OlBuffer Class See Also Send Feedback
Converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsVolts()
Visual Basic
Public Function GetDataAsVolts As Double()

Return Value

Type: array<Double>[]()[][]
Returns a user-specified array of voltage values, represented as 64-bit floating-point values (double).

Remarks

This method copies all the data, as voltages, from the internal buffer of an OlBuffer object into a user-declared array of 64-bit floating-point values (double).

See Also

OlBuffer Class
OlBuffer Members
GetDataAsVolts Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsVolts Method (ChannelListEntry)

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVolts Method (ChannelListEntry)
OlBuffer Class See Also Send Feedback
For a specific channel, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of 64-bit floating-point values (double).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] GetDataAsVolts(
    ChannelListEntry channel
)
Visual Basic
Public Function GetDataAsVolts (
    channel As ChannelListEntry
) As Double()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.

Return Value

Type: array<Double>[]()[][]
An array of voltages that are associated with a specified ChannelListEntry, represented as 64-bit floating-point values (double).

Remarks

This method converts only the data associated with a specified ChannelListEntry in the buffer into voltage values, and then copies this data into a user-declared array of 64-bit floating-point values (double). Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
GetDataAsVolts Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.GetDataAsVoltsByte Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..GetDataAsVoltsByte Method
OlBuffer Class See Also Send Feedback
For a specified ChannelListEntry, converts the data from the internal buffer of an OlBuffer object into voltage values, and then copies these voltage values into a user-declared array of bytes. Each voltage value is stored as an Int32, and takes 4 bytes.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public byte[] GetDataAsVoltsByte(
    ChannelListEntry channel,
    int scale
)
Visual Basic
Public Function GetDataAsVoltsByte (
    channel As ChannelListEntry,
    scale As Integer
) As Byte()

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to convert and copy.
scale
Type: System..::..Int32
The amount by which to scale each voltage value. By default, this is 1.

Return Value

Type: array<Byte>[]()[][]
An array of voltage values that is associated with a specified ChannelListEntry, represented as bytes.

Remarks

This method converts only the data associated with a specified ChannelListEntry in the buffer into voltage values, and then copies this data into a user-declared array of bytes. Note that if the ChannelListEntry occurs more than once in the buffer, the data for each occurrence of the ChannelListEntry is converted and copied.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsRaw Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PutDataAsRaw(array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt16>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsRaw(ChannelListEntry, array<UInt32>[]()[][]) | Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsRaw Method (UInt16[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (array<UInt16>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    ushort[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    data As UShort()
)

Parameters

data
Type: array<System..::..UInt16>[]()[][]
The user-specified array of raw counts to copy, represented as unsigned 16-bit integers (ushort).

Remarks

Used when the resolution of the subsystem is 16 bits or less, copies all the data, as raw counts, from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsRaw Method (UInt32[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (array<UInt32>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    uint[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    data As UInteger()
)

Parameters

data
Type: array<System..::..UInt32>[]()[][]
The user-specified array of raw counts to copy, represented as unsigned 32-bit integers (uint).

Remarks

Used when the resolution of the subsystem is greater than 16 bits, copies all the data, as raw counts, from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsRaw Method (ChannelListEntry, UInt16[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (ChannelListEntry, array<UInt16>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    ChannelListEntry channel,
    ushort[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    channel As ChannelListEntry,
    data As UShort()
)

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.
data
Type: array<System..::..UInt16>[]()[][]
The user-specified array containing the channel data, in raw counts, to copy. This data is represented as unsigned 16-bit integers (ushort).

Remarks

Used when the resolution of the subsystem is 16 bits or less, copies only the raw count values for a specified ChannelListEntry from a user-specified array into the internal buffer of an OlBuffer object.

Remarks

Note that if the ChannelListEntry occurs more than once in the array, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsRaw Method (ChannelListEntry, UInt32[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsRaw Method (ChannelListEntry, array<UInt32>[]()[][])
OlBuffer Class See Also Send Feedback
Copies raw counts from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsRaw(
    ChannelListEntry channel,
    uint[] data
)
Visual Basic
Public Sub PutDataAsRaw (
    channel As ChannelListEntry,
    data As UInteger()
)

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.
data
Type: array<System..::..UInt32>[]()[][]
The user-specified array containing the channel data, in raw counts, to copy. This data is represented as unsigned 32-bit integers (uint).

Remarks

Used when the resolution of the subsystem is greater than 16 bits, copies only the raw count values for a specified ChannelListEntry from a user-specified array into the internal buffer of an OlBuffer object.

Remarks

Note that if the ChannelListEntry occurs more than once in the array, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsRaw Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsVolts Method

[image] [image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsVolts Method
OlBuffer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PutDataAsVolts(array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.
Public method | PutDataAsVolts(ChannelListEntry, array<Double>[]()[][]) | Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsVolts Method (Double[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsVolts Method (array<Double>[]()[][])
OlBuffer Class See Also Send Feedback
Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsVolts(
    double[] data
)
Visual Basic
Public Sub PutDataAsVolts (
    data As Double()
)

Parameters

data
Type: array<System..::..Double>[]()[][]
The user-specified array containing the voltage values to copy. The data is represented as 64-bit floating-point values (double).

Remarks

This method copies all the voltage values from a user-specified array into the internal buffer of an OlBuffer object.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsVolts Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.PutDataAsVolts Method (ChannelListEntry, Double[])

[image]

OpenLayers for .NET Documentation
OlBuffer..::..PutDataAsVolts Method (ChannelListEntry, array<Double>[]()[][])
OlBuffer Class See Also Send Feedback
Copies voltages from a user-specified array into the internal buffer of an OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PutDataAsVolts(
    ChannelListEntry channel,
    double[] data
)
Visual Basic
Public Sub PutDataAsVolts (
    channel As ChannelListEntry,
    data As Double()
)

Parameters

channel
Type: OpenLayers.DeviceCollection..::..ChannelListEntry
ChannelListEntry object, which represents the channel whose data you want to copy.
data
Type: array<System..::..Double>[]()[][]
The user-specified array containing the channel data, in voltage, to copy. This data is represented as 64-bit floating-point values (double).

Remarks

This method copies only the voltage values for a specified ChannelListEntry from a user-specified array into the internal buffer of an OlBuffer object.

Remarks

Note that if the ChannelListEntry occurs more than once in the array, the data for each occurrence of the ChannelListEntry is copied.

See Also

OlBuffer Class
OlBuffer Members
PutDataAsVolts Overload
OpenLayers.DeviceCollection Namespace


OlBuffer.Reallocate Method

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Reallocate Method
OlBuffer Class See Also Send Feedback
Reallocates the internal data buffer of the OlBuffer object to contain the specified number of samples. The existing internal data buffer is deallocated and any data that it contained is lost.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool Reallocate(
    int inNumSamples
)
Visual Basic
Public Function Reallocate (
    inNumSamples As Integer
) As Boolean

Parameters

inNumSamples
Type: System..::..Int32
Maximum number of samples that the internal data buffer can contain. This parameter determines the size of the internal buffer.

Return Value

Type: Boolean
True if allocation was successful; otherwise, returns False.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer Properties

[image] [image]

OpenLayers for .NET Documentation
OlBuffer Properties
OlBuffer Class See Also Send Feedback

The OlBuffer type exposes the following members.

Properties

 | Name | Description
Public property | BufferSizeInBytes | Returns the size of the internal data buffer, in bytes.
Public property | BufferSizeInSamples | Returns the size of the internal data buffer, in samples.
Public property | ChannelListOffset | Returns the index into the ChannelList that corresponds to the first sample in the internal buffer of the OlBuffer object.
Public property | Encoding | Returns the data encoding of the raw data (Binary or TwosComplement).
Public property | Item | Returns the data, as a raw count, at the specified index in the internal buffer of the OlBuffer object.
Public property | RawDataFormat | Returns the format of the raw data (Int16, Uint16, Int32, Float, or Double).
Public property | Resolution | Returns the resolution of the associated subsystem.
Public property | SampleSizeInBytes | Returns the size, in bytes, of the samples in the internal buffer of the OlBuffer object.
Public property | State | Returns the current state (Idle, Queued, InProcess, Completed, or Released) of the OlBuffer object.
Public property | Tag | Gets or sets a user-defined value.
Public property | ValidSamples | Returns the number of valid samples in the internal buffer of the OlBuffer object.
Public property | VoltageRange | Returns the upper and lower limits of the voltage range for the associated subsystem.

See Also

OlBuffer Class
OpenLayers.DeviceCollection Namespace


OlBuffer.BufferSizeInBytes Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..BufferSizeInBytes Property
OlBuffer Class See Also Send Feedback
Returns the size of the internal data buffer, in bytes.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int BufferSizeInBytes { get; }
Visual Basic
Public ReadOnly Property BufferSizeInBytes As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.BufferSizeInSamples Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..BufferSizeInSamples Property
OlBuffer Class See Also Send Feedback
Returns the size of the internal data buffer, in samples.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int BufferSizeInSamples { get; }
Visual Basic
Public ReadOnly Property BufferSizeInSamples As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.ChannelListOffset Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..ChannelListOffset Property
OlBuffer Class See Also Send Feedback
Returns the index into the ChannelList that corresponds to the first sample in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ChannelListOffset { get; }
Visual Basic
Public ReadOnly Property ChannelListOffset As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.Encoding Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Encoding Property
OlBuffer Class See Also Send Feedback
Returns the data encoding of the raw data (Binary or TwosComplement).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Encoding Encoding { get; }
Visual Basic
Public ReadOnly Property Encoding As Encoding
    Get

Property Value

Type: Encoding

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.Item Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Item Property
OlBuffer Class See Also Send Feedback
Returns the data, as a raw count, at the specified index in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As Integer
    Get

Parameters

index
Type: System..::..Int32

Return Value

Type: Int32
The raw count, represented as a signed, 32-bit integer (int).

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.RawDataFormat Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..RawDataFormat Property
OlBuffer Class See Also Send Feedback
Returns the format of the raw data (Int16, Uint16, Int32, Float, or Double).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelDataType RawDataFormat { get; }
Visual Basic
Public ReadOnly Property RawDataFormat As ChannelDataType
    Get

Property Value

Type: ChannelDataType

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.Resolution Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Resolution Property
OlBuffer Class See Also Send Feedback
Returns the resolution of the associated subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.SampleSizeInBytes Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..SampleSizeInBytes Property
OlBuffer Class See Also Send Feedback
Returns the size, in bytes, of the samples in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int SampleSizeInBytes { get; }
Visual Basic
Public ReadOnly Property SampleSizeInBytes As Integer
    Get

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.State Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..State Property
OlBuffer Class See Also Send Feedback
Returns the current state (Idle, Queued, InProcess, Completed, or Released) of the OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlBuffer..::..BufferState State { get; }
Visual Basic
Public ReadOnly Property State As OlBuffer..::..BufferState
    Get

Property Value

Type: OlBuffer..::..BufferState

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.Tag Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..Tag Property
OlBuffer Class See Also Send Feedback
Gets or sets a user-defined value.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Tag { get; set; }
Visual Basic
Public Property Tag As Integer
    Get
    Set

Property Value

Type: Int32

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.ValidSamples Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..ValidSamples Property
OlBuffer Class See Also Send Feedback
Returns the number of valid samples in the internal buffer of the OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ValidSamples { get; }
Visual Basic
Public ReadOnly Property ValidSamples As Integer
    Get

Property Value

Type: Int32

Remarks

For analog input operations, the ValidSamples property is set to the number of samples in the completed buffer under normal circumstances. However, in some cases, like if Abort()()()() is called in the middle of an operation, ValidSamples reflects the number of samples in the buffer when Abort was called. In addition, if Abort or Stop()()()() is called, any OlBuffer objects whose state is Inprocess will have a ValidSamples of 0.

For analog output operations, ValidSamples is always equal to the maximum number of samples that the buffer was allocated to hold.

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.VoltageRange Property

[image]

OpenLayers for .NET Documentation
OlBuffer..::..VoltageRange Property
OlBuffer Class See Also Send Feedback
Returns the upper and lower limits of the voltage range for the associated subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range VoltageRange { get; }
Visual Basic
Public ReadOnly Property VoltageRange As Range
    Get

Property Value

Type: Range

See Also

OlBuffer Class
OlBuffer Members
OpenLayers.DeviceCollection Namespace


OlBuffer.BufferState Enumeration

[image]

OpenLayers for .NET Documentation
OlBuffer..::..BufferState Enumeration
OlBuffer Class See Also Send Feedback
Contains the possible values for the state of an OlBuffer object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum BufferState
Visual Basic
Public Enumeration BufferState

Members

Member name | Value | Description
Idle | 0 | The OlBuffer object has been created, but has not been queued to a subsystem.
Queued | 1 | The OlBuffer object has been queued to a subsystem.
InProcess | 2 | The OlBuffer object has been sent to the device driver for processing. A maximum of eight OlBuffer objects can be in process at one time.
Completed | 3 | For an input operation, the internal buffer of the OlBuffer object has been filled with data, and has not been put back on the queue for the subsystem. For an output operation, all the data in the internal buffer of the OlBuffer object has been output, and the OlBuffer object has not been put back on the queue for the subsystem.
Released | 4 | The internal buffer of the OlBuffer object has been deallocated.

See Also

OpenLayers.DeviceCollection Namespace


OlError Class

[image]

OpenLayers for .NET Documentation
OlError Class
Members See Also Send Feedback
An OlError object encapsulates an Open Layers error code.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class OlError
Visual Basic
Public Class OlError

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..OlError

See Also

OlError Members
OpenLayers.DeviceCollection Namespace


OlError Members

[image] [image]

OpenLayers for .NET Documentation
OlError Members
OlError Class Constructors Methods See Also Send Feedback

The OlError type exposes the following members.

Constructors

 | Name | Description
Public method | OlError | Creates and returns an OlError object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetErrorCode | Returns the error code that is associated with a specified error message in the DT-Open Layers for .NET Class Library.
 | GetErrorString | Returns a description for the specified error code in the DT-Open Layers for .NET Class Library.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OlError Class
OpenLayers.DeviceCollection Namespace


OlError Constructor

[image]

OpenLayers for .NET Documentation
OlError Constructor
OlError Class See Also Send Feedback
Creates and returns an OlError object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlError(
    ErrorCode errorCode
)
Visual Basic
Public Sub New (
    errorCode As ErrorCode
)

Parameters

errorCode
Type: OpenLayers.DeviceCollection..::..ErrorCode
The Open Layers ErrorCode that is accessible using an OlException object.

See Also

OlError Class
OlError Members
OpenLayers.DeviceCollection Namespace


OlError Methods

[image] [image]

OpenLayers for .NET Documentation
OlError Methods
OlError Class See Also Send Feedback

The OlError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetErrorCode | Returns the error code that is associated with a specified error message in the DT-Open Layers for .NET Class Library.
 | GetErrorString | Returns a description for the specified error code in the DT-Open Layers for .NET Class Library.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OlError Class
OpenLayers.DeviceCollection Namespace


OlError.GetErrorCode Method

[image]

OpenLayers for .NET Documentation
OlError..::..GetErrorCode Method
OlError Class See Also Send Feedback
Returns the error code that is associated with a specified error message in the DT-Open Layers for .NET Class Library.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static ErrorCode GetErrorCode(
    string ErrString
)
Visual Basic
Public Shared Function GetErrorCode (
    ErrString As String
) As ErrorCode

Parameters

ErrString
Type: System..::..String
The error message for which to return the error code.

Return Value

Type: ErrorCode
The error code that is associated with the specified error message.

See Also

OlError Class
OlError Members
OpenLayers.DeviceCollection Namespace


OlError.GetErrorString Method

[image]

OpenLayers for .NET Documentation
OlError..::..GetErrorString Method
OlError Class See Also Send Feedback
Returns a description for the specified error code in the DT-Open Layers for .NET Class Library.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public static string GetErrorString(
    ErrorCode ErrCode
)
Visual Basic
Public Shared Function GetErrorString (
    ErrCode As ErrorCode
) As String

Parameters

ErrCode
Type: OpenLayers.DeviceCollection..::..ErrorCode
The error code for which to return the description.

Return Value

Type: String
A description of the specified error code.

See Also

OlError Class
OlError Members
OpenLayers.DeviceCollection Namespace


OlException Class

[image]

OpenLayers for .NET Documentation
OlException Class
Members See Also Send Feedback
The OlException class provides properites for handling Open Layers errors that can be generated in the OpenLayers.DeviceCollection namespace.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
[SerializableAttribute]
public class OlException : SystemException,
    ISerializable
Visual Basic
<SerializableAttribute>
Public Class OlException
    Inherits SystemException
    Implements ISerializable

Inheritance Hierarchy

System..::..Object
System..::..Exception
System..::..SystemException
OpenLayers.DeviceCollection..::..OlException

See Also

OlException Members
OpenLayers.DeviceCollection Namespace


OlException Members

[image] [image]

OpenLayers for .NET Documentation
OlException Members
OlException Class Constructors Methods Properties See Also Send Feedback

The OlException type exposes the following members.

Constructors

 | Name | Description
Public method | OlException | For internal use only.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with this exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns the descriptive string for the exception. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | Subsystem | Returns the subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that raised the exception. If the exception is not related to a specific subsystem, returns null.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OlException Class
OpenLayers.DeviceCollection Namespace


OlException Constructor

[image]

OpenLayers for .NET Documentation
OlException Constructor
OlException Class See Also Send Feedback
For internal use only.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public OlException(
    SerializationInfo si,
    StreamingContext context
)
Visual Basic
Public Sub New (
    si As SerializationInfo,
    context As StreamingContext
)

Parameters

si
Type: System.Runtime.Serialization..::..SerializationInfo
Serialization information.
context
Type: System.Runtime.Serialization..::..StreamingContext
Streaming context.

See Also

OlException Class
OlException Members
OpenLayers.DeviceCollection Namespace


OlException Methods

[image] [image]

OpenLayers for .NET Documentation
OlException Methods
OlException Class See Also Send Feedback

The OlException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

OlException Class
OpenLayers.DeviceCollection Namespace


OlException Properties

[image] [image]

OpenLayers for .NET Documentation
OlException Properties
OlException Class See Also Send Feedback

The OlException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with this exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Returns the descriptive string for the exception. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | Subsystem | Returns the subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that raised the exception. If the exception is not related to a specific subsystem, returns null.
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OlException Class
OpenLayers.DeviceCollection Namespace


OlException.ErrorCode Property

[image]

OpenLayers for .NET Documentation
OlException..::..ErrorCode Property
OlException Class See Also Send Feedback
Returns the ErrorCode from the Open Layers for .NET Class Library that is associated with this exception.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ErrorCode ErrorCode { get; }
Visual Basic
Public ReadOnly Property ErrorCode As ErrorCode
    Get

Property Value

Type: ErrorCode

See Also

OlException Class
OlException Members
OpenLayers.DeviceCollection Namespace


OlException.Message Property

[image]

OpenLayers for .NET Documentation
OlException..::..Message Property
OlException Class See Also Send Feedback
Returns the descriptive string for the exception.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_Exception..::..Message

See Also

OlException Class
OlException Members
OpenLayers.DeviceCollection Namespace


OlException.Subsystem Property

[image]

OpenLayers for .NET Documentation
OlException..::..Subsystem Property
OlException Class See Also Send Feedback
Returns the subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that raised the exception. If the exception is not related to a specific subsystem, returns null.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase Subsystem { get; }
Visual Basic
Public ReadOnly Property Subsystem As SubsystemBase
    Get

Property Value

Type: SubsystemBase

See Also

OlException Class
OlException Members
OpenLayers.DeviceCollection Namespace


PreTriggerBufferDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
PreTriggerBufferDoneHandler Delegate
See Also Send Feedback
The PreTriggerBufferDoneHandler delegate is called when the event PreTriggerBufferDoneEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void PreTriggerBufferDoneHandler(
    Object sender,
    BufferDoneEventArgs eventArgs
)
Visual Basic
Public Delegate Sub PreTriggerBufferDoneHandler (
    sender As Object,
    eventArgs As BufferDoneEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..BufferDoneEventArgs
The BufferDoneEventArgs object that is associated with the event PreTriggerBufferDoneEvent.

Remarks

The event PreTriggerBufferDone is raised when the internal buffer of an OlBuffer object is filled with pre-trigger data (for an input operation only).

See Also

OpenLayers.DeviceCollection Namespace


QueueDoneHandler Delegate

[image]

OpenLayers for .NET Documentation
QueueDoneHandler Delegate
See Also Send Feedback
The QueueDoneHandler delegate is called when the event QueueDoneEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void QueueDoneHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub QueueDoneHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event QueueDoneEvent.

Remarks

The event QueueDoneEvent is raised when no OlBuffer objects are available on the queue and the operation stops.

See Also

OpenLayers.DeviceCollection Namespace


QueueStoppedHandler Delegate

[image]

OpenLayers for .NET Documentation
QueueStoppedHandler Delegate
See Also Send Feedback
The QueueStoppedHandler delegate is called when the event QueueStoppedEvent occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public delegate void QueueStoppedHandler(
    Object sender,
    GeneralEventArgs eventArgs
)
Visual Basic
Public Delegate Sub QueueStoppedHandler (
    sender As Object,
    eventArgs As GeneralEventArgs
)

Parameters

sender
Type: System..::..Object
The subsystem that raised the event.
eventArgs
Type: OpenLayers.DeviceCollection..::..GeneralEventArgs
The GeneralEventArgs object that is associated with the event QueueStoppedEvent.

Remarks

A QueueStoppedEvent is raised when Stop or Abort is called for a continuous analog I/O operation. The event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.

See Also

OpenLayers.DeviceCollection Namespace


Range Class

[image]

OpenLayers for .NET Documentation
Range Class
Members See Also Send Feedback
This class is used by the VoltageRange and SupportedVoltageRanges methods to return the lower and upper limits of the voltage range for an analog subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class Range
Visual Basic
Public Class Range

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..Range

See Also

Range Members
OpenLayers.DeviceCollection Namespace


Range Members

[image] [image]

OpenLayers for .NET Documentation
Range Members
Range Class Constructors Methods Properties See Also Send Feedback

The Range type exposes the following members.

Constructors

 | Name | Description
Public method | Range | Initializes a new instance of a Range object with the specified lower and upper limits of the voltage range.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | High | Gets or sets the upper limit of the voltage range.
Public property | Low | Gets or sets the lower limit of the voltage range.

See Also

Range Class
OpenLayers.DeviceCollection Namespace


Range Constructor

[image]

OpenLayers for .NET Documentation
Range Constructor
Range Class See Also Send Feedback
Initializes a new instance of a Range object with the specified lower and upper limits of the voltage range.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Range(
    double low,
    double high
)
Visual Basic
Public Sub New (
    low As Double,
    high As Double
)

Parameters

low
Type: System..::..Double
Gets or sets the lower limit of the voltage range.
high
Type: System..::..Double
Gets or sets the upper limit of the voltage range.

See Also

Range Class
Range Members
OpenLayers.DeviceCollection Namespace


Range Methods

[image] [image]

OpenLayers for .NET Documentation
Range Methods
Range Class See Also Send Feedback

The Range type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Range Class
OpenLayers.DeviceCollection Namespace


Range Properties

[image] [image]

OpenLayers for .NET Documentation
Range Properties
Range Class See Also Send Feedback

The Range type exposes the following members.

Properties

 | Name | Description
Public property | High | Gets or sets the upper limit of the voltage range.
Public property | Low | Gets or sets the lower limit of the voltage range.

See Also

Range Class
OpenLayers.DeviceCollection Namespace


Range.High Property

[image]

OpenLayers for .NET Documentation
Range..::..High Property
Range Class See Also Send Feedback
Gets or sets the upper limit of the voltage range.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double High { get; set; }
Visual Basic
Public Property High As Double
    Get
    Set

Property Value

Type: Double

See Also

Range Class
Range Members
OpenLayers.DeviceCollection Namespace


Range.Low Property

[image]

OpenLayers for .NET Documentation
Range..::..Low Property
Range Class See Also Send Feedback
Gets or sets the lower limit of the voltage range.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Low { get; set; }
Visual Basic
Public Property Low As Double
    Get
    Set

Property Value

Type: Double

See Also

Range Class
Range Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger Class

[image]

OpenLayers for .NET Documentation
ReferenceTrigger Class
Members See Also Send Feedback
The ReferenceTrigger class provides an interface for controlling the reference trigger of a subsystem. For devices that support a reference trigger, pre-trigger data acquisition stops and post-trigger acquisition starts when the reference trigger event occurs. Post-trigger acquisition stops when the number of samples you specify for the post-trigger scan count has been reached.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class ReferenceTrigger
Visual Basic
Public NotInheritable Class ReferenceTrigger

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..ReferenceTrigger

See Also

ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger Members

[image] [image]

OpenLayers for .NET Documentation
ReferenceTrigger Members
ReferenceTrigger Class Methods Properties See Also Send Feedback

The ReferenceTrigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets and sets the threshold value for the reference trigger. By default, the threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings for the reference trigger.
Public property | PostTriggerScanCount | Gets and sets the samples per channel to acquire after the reference trigger occurs.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent reference trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg reference trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg reference trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos reference trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos reference trigger type; otherwise, returns False.
Public property | SupportsPostTriggerScanCount | Returns True if the subsystem supports acquiring a specified number of samples after the reference trigger occurs; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg reference trigger event.
Public property | TriggerType | Gets and sets the reference trigger type (None, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

ReferenceTrigger Class
OpenLayers.DeviceCollection Namespace


ReferenceTrigger Methods

[image] [image]

OpenLayers for .NET Documentation
ReferenceTrigger Methods
ReferenceTrigger Class See Also Send Feedback

The ReferenceTrigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceTrigger Class
OpenLayers.DeviceCollection Namespace


ReferenceTrigger Properties

[image] [image]

OpenLayers for .NET Documentation
ReferenceTrigger Properties
ReferenceTrigger Class See Also Send Feedback

The ReferenceTrigger type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets and sets the threshold value for the reference trigger. By default, the threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings for the reference trigger.
Public property | PostTriggerScanCount | Gets and sets the samples per channel to acquire after the reference trigger occurs.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent reference trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg reference trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg reference trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos reference trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos reference trigger type; otherwise, returns False.
Public property | SupportsPostTriggerScanCount | Returns True if the subsystem supports acquiring a specified number of samples after the reference trigger occurs; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg reference trigger event.
Public property | TriggerType | Gets and sets the reference trigger type (None, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

ReferenceTrigger Class
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.Level Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..Level Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the threshold value for the reference trigger. By default, the threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings for the reference trigger.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Level { get; set; }
Visual Basic
Public Property Level As Double
    Get
    Set

Property Value

Type: Double

Remarks

This propery is valid only if TriggerType property is ThresholdPos or ThresholdNeg trigger type. The threshold level set by this property is the value after the gain is a applied to the threshold trigger channel. For example, if the voltage range of the subsystem is ±10 V, and the specified gain is 1, specify a threshold voltage level within ±10 V. Likewise, if the voltage range of the subsystem is ±10 V, and the specified gain is 10, specify a threshold voltage level within ±1 V.

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.PostTriggerScanCount Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..PostTriggerScanCount Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the samples per channel to acquire after the reference trigger occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PostTriggerScanCount { get; set; }
Visual Basic
Public Property PostTriggerScanCount As Integer
    Get
    Set

Property Value

Type: Int32

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.SupportedThresholdTriggerChannels Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportedThresholdTriggerChannels Property
ReferenceTrigger Class See Also Send Feedback
Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int[] SupportedThresholdTriggerChannels { get; }
Visual Basic
Public ReadOnly Property SupportedThresholdTriggerChannels As Integer()
    Get

Property Value

Type: array<Int32>[]()[][]

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.SupportsDigitalEventTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsDigitalEventTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a DigitalEvent reference trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDigitalEventTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsDigitalEventTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.SupportsNegExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsNegExternalTTLTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a TTLNeg reference trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.SupportsNegThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsNegThresholdTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdNeg reference trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.SupportsPosExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsPosExternalTTLTrigger Property
ReferenceTrigger Class See Also Send Feedback
Return True if the subsystem supports a TTLPos reference trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.SupportsPosThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsPosThresholdTrigger Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdPos reference trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the reference trigger type using the TriggerType property.

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.SupportsPostTriggerScanCount Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..SupportsPostTriggerScanCount Property
ReferenceTrigger Class See Also Send Feedback
Returns True if the subsystem supports acquiring a specified number of samples after the reference trigger occurs; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPostTriggerScanCount { get; }
Visual Basic
Public ReadOnly Property SupportsPostTriggerScanCount As Boolean
    Get

Property Value

Type: Boolean

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.ThresholdTriggerChannel Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..ThresholdTriggerChannel Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg reference trigger event.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ThresholdTriggerChannel { get; set; }
Visual Basic
Public Property ThresholdTriggerChannel As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

This propery is valid only if the TriggerType property is ThresholdPos or ThresholdNeg.

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTrigger.TriggerType Property

[image]

OpenLayers for .NET Documentation
ReferenceTrigger..::..TriggerType Property
ReferenceTrigger Class See Also Send Feedback
Gets and sets the reference trigger type (None, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ReferenceTriggerType TriggerType { get; set; }
Visual Basic
Public Property TriggerType As ReferenceTriggerType
    Get
    Set

Property Value

Type: ReferenceTriggerType

See Also

ReferenceTrigger Class
ReferenceTrigger Members
OpenLayers.DeviceCollection Namespace


ReferenceTriggerType Enumeration

[image]

OpenLayers for .NET Documentation
ReferenceTriggerType Enumeration
See Also Send Feedback
Contains the possible values for the TriggerType property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum ReferenceTriggerType
Visual Basic
Public Enumeration ReferenceTriggerType

Members

Member name | Value | Description
None | 300 | Triggering is disabled.
TTLPos | 301 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the rising edge of the digital TTL signal.
DigitalEvent | 304 | A trigger is generated when an external digital event occurs.
TTLNeg | 306 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the falling edge of the digital TTL signal.
ThresholdPos | 1200 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A positive analog threshold trigger occurs when the device detects a positive-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.
ThresholdNeg | 1201 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A negative analog threshold trigger occurs when the device detects a negative-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.

See Also

OpenLayers.DeviceCollection Namespace


SimultaneousStart Class

[image]

OpenLayers for .NET Documentation
SimultaneousStart Class
Members See Also Send Feedback
The SimultaneousStart class provides an interface for simultaneously starting multiple subsystems.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class SimultaneousStart
Visual Basic
Public NotInheritable Class SimultaneousStart

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..SimultaneousStart

See Also

SimultaneousStart Members
OpenLayers.DeviceCollection Namespace


SimultaneousStart Members

[image] [image]

OpenLayers for .NET Documentation
SimultaneousStart Members
SimultaneousStart Class Methods See Also Send Feedback

The SimultaneousStart type exposes the following members.

Methods

 | Name | Description
Public method | AddSubsystem | Adds a subsystem to the list of subsystems to simultaneously start.
Public method | Clear | Removes all subsystems from the simultaneous start list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubsystemList | Returns an array of subsystems that are currently on the simultaneous start list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStart | Simultaneously prestarts all subsystems on the simultaneous start list.
Public method | RemoveSubsystem | Removes a subsystem from the list of subsystems to simultaneously start.
Public method | Start | Simultaneously starts all subsystems on the simultaneous start list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimultaneousStart Class
OpenLayers.DeviceCollection Namespace


SimultaneousStart Methods

[image] [image]

OpenLayers for .NET Documentation
SimultaneousStart Methods
SimultaneousStart Class See Also Send Feedback

The SimultaneousStart type exposes the following members.

Methods

 | Name | Description
Public method | AddSubsystem | Adds a subsystem to the list of subsystems to simultaneously start.
Public method | Clear | Removes all subsystems from the simultaneous start list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSubsystemList | Returns an array of subsystems that are currently on the simultaneous start list.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PreStart | Simultaneously prestarts all subsystems on the simultaneous start list.
Public method | RemoveSubsystem | Removes a subsystem from the list of subsystems to simultaneously start.
Public method | Start | Simultaneously starts all subsystems on the simultaneous start list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SimultaneousStart Class
OpenLayers.DeviceCollection Namespace


SimultaneousStart.AddSubsystem Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..AddSubsystem Method
SimultaneousStart Class See Also Send Feedback
Adds a subsystem to the list of subsystems to simultaneously start.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void AddSubsystem(
    SubsystemBase subsystem
)
Visual Basic
Public Sub AddSubsystem (
    subsystem As SubsystemBase
)

Parameters

subsystem
Type: OpenLayers.DeviceCollection..::..SubsystemBase
The subsystem to add to the simultaneous start list.

See Also

SimultaneousStart Class
SimultaneousStart Members
OpenLayers.DeviceCollection Namespace


SimultaneousStart.Clear Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..Clear Method
SimultaneousStart Class See Also Send Feedback
Removes all subsystems from the simultaneous start list.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear

See Also

SimultaneousStart Class
SimultaneousStart Members
OpenLayers.DeviceCollection Namespace


SimultaneousStart.GetSubsystemList Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..GetSubsystemList Method
SimultaneousStart Class See Also Send Feedback
Returns an array of subsystems that are currently on the simultaneous start list.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase[] GetSubsystemList()
Visual Basic
Public Function GetSubsystemList As SubsystemBase()

Return Value

Type: array< SubsystemBase >[]()[][]
An array of subsystems that are currently on the simultaneous start list.

See Also

SimultaneousStart Class
SimultaneousStart Members
OpenLayers.DeviceCollection Namespace


SimultaneousStart.PreStart Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..PreStart Method
SimultaneousStart Class See Also Send Feedback
Simultaneously prestarts all subsystems on the simultaneous start list.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void PreStart()
Visual Basic
Public Sub PreStart

See Also

SimultaneousStart Class
SimultaneousStart Members
OpenLayers.DeviceCollection Namespace


SimultaneousStart.RemoveSubsystem Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..RemoveSubsystem Method
SimultaneousStart Class See Also Send Feedback
Removes a subsystem from the list of subsystems to simultaneously start.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void RemoveSubsystem(
    SubsystemBase subsystem
)
Visual Basic
Public Sub RemoveSubsystem (
    subsystem As SubsystemBase
)

Parameters

subsystem
Type: OpenLayers.DeviceCollection..::..SubsystemBase
The subsystem to remove.

See Also

SimultaneousStart Class
SimultaneousStart Members
OpenLayers.DeviceCollection Namespace


SimultaneousStart.Start Method

[image]

OpenLayers for .NET Documentation
SimultaneousStart..::..Start Method
SimultaneousStart Class See Also Send Feedback
Simultaneously starts all subsystems on the simultaneous start list.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Start()
Visual Basic
Public Sub Start

See Also

SimultaneousStart Class
SimultaneousStart Members
OpenLayers.DeviceCollection Namespace


SingleValuesInfoRaw Structure

[image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Structure
Members See Also Send Feedback
Used with SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]), specifies the analog output channel to update and the raw count value to output on that channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public struct SingleValuesInfoRaw
Visual Basic
Public Structure SingleValuesInfoRaw

See Also

SingleValuesInfoRaw Members
OpenLayers.DeviceCollection Namespace


SingleValuesInfoRaw Members

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Members
SingleValuesInfoRaw Structure Methods Fields See Also Send Feedback

The SingleValuesInfoRaw type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | RawValue | The raw count value to output on the specified analog output channel.

See Also

SingleValuesInfoRaw Structure
OpenLayers.DeviceCollection Namespace


SingleValuesInfoRaw Fields

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Fields
SingleValuesInfoRaw Structure See Also Send Feedback

The SingleValuesInfoRaw type exposes the following members.

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | RawValue | The raw count value to output on the specified analog output channel.

See Also

SingleValuesInfoRaw Structure
OpenLayers.DeviceCollection Namespace


SingleValuesInfoRaw.PhysicalChannel Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw..::..PhysicalChannel Field
SingleValuesInfoRaw Structure See Also Send Feedback
The number of the physical analog output channel to update.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannel
Visual Basic
Public PhysicalChannel As Integer

Field Value

Type: Int32

See Also

SingleValuesInfoRaw Structure
SingleValuesInfoRaw Members
OpenLayers.DeviceCollection Namespace


SingleValuesInfoRaw.RawValue Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw..::..RawValue Field
SingleValuesInfoRaw Structure See Also Send Feedback
The raw count value to output on the specified analog output channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int RawValue
Visual Basic
Public RawValue As Integer

Field Value

Type: Int32

See Also

SingleValuesInfoRaw Structure
SingleValuesInfoRaw Members
OpenLayers.DeviceCollection Namespace


SingleValuesInfoRaw Methods

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoRaw Methods
SingleValuesInfoRaw Structure See Also Send Feedback

The SingleValuesInfoRaw type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SingleValuesInfoRaw Structure
OpenLayers.DeviceCollection Namespace


SingleValuesInfoVolts Structure

[image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Structure
Members See Also Send Feedback
Used with SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][]), specifies the analog output channel to update and the voltage value to output on that channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public struct SingleValuesInfoVolts
Visual Basic
Public Structure SingleValuesInfoVolts

See Also

SingleValuesInfoVolts Members
OpenLayers.DeviceCollection Namespace


SingleValuesInfoVolts Members

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Members
SingleValuesInfoVolts Structure Methods Fields See Also Send Feedback

The SingleValuesInfoVolts type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | Voltage | The voltage value to output on the specified analog output channel.

See Also

SingleValuesInfoVolts Structure
OpenLayers.DeviceCollection Namespace


SingleValuesInfoVolts Fields

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Fields
SingleValuesInfoVolts Structure See Also Send Feedback

The SingleValuesInfoVolts type exposes the following members.

Fields

 | Name | Description
Public field | PhysicalChannel | The number of the physical analog output channel to update.
Public field | Voltage | The voltage value to output on the specified analog output channel.

See Also

SingleValuesInfoVolts Structure
OpenLayers.DeviceCollection Namespace


SingleValuesInfoVolts.PhysicalChannel Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts..::..PhysicalChannel Field
SingleValuesInfoVolts Structure See Also Send Feedback
The number of the physical analog output channel to update.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannel
Visual Basic
Public PhysicalChannel As Integer

Field Value

Type: Int32

See Also

SingleValuesInfoVolts Structure
SingleValuesInfoVolts Members
OpenLayers.DeviceCollection Namespace


SingleValuesInfoVolts.Voltage Field

[image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts..::..Voltage Field
SingleValuesInfoVolts Structure See Also Send Feedback
The voltage value to output on the specified analog output channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public float Voltage
Visual Basic
Public Voltage As Single

Field Value

Type: Single

See Also

SingleValuesInfoVolts Structure
SingleValuesInfoVolts Members
OpenLayers.DeviceCollection Namespace


SingleValuesInfoVolts Methods

[image] [image]

OpenLayers for .NET Documentation
SingleValuesInfoVolts Methods
SingleValuesInfoVolts Structure See Also Send Feedback

The SingleValuesInfoVolts type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SingleValuesInfoVolts Structure
OpenLayers.DeviceCollection Namespace


SubsystemBase Class

[image]

OpenLayers for .NET Documentation
SubsystemBase Class
Members See Also Send Feedback
The SubsystemBase class is an abstract base class that is accessible from the following derived classes: AnalogSubsystem (and its derived classes AnalogInputSubsystem and AnalogOutputSubsystem),

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public abstract class SubsystemBase : IDisposable
Visual Basic
Public MustInherit Class SubsystemBase
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..SubsystemBase
OpenLayers.DeviceCollection..::..AnalogSubsystem

See Also

SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase Members

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Members
SubsystemBase Class Methods Properties Events See Also Send Feedback

The SubsystemBase type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately.
Public method | Config | Configures the subsystem based on the current property settings.
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration.
Public method | Start | Starts an operation on the subsystem.
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem.
Public property | BufferQueue | Provides an interface to a BufferQueue object.
Public property | ChannelList | Provides an interface to a ChannelList object.
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem.
Public property | Clock | Provides an interface to a Clock object.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem.
Public property | Device | Returns the Device object that is associated with the subsystem.
Public property | Element | Returns the element number of the subsystem.
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem.
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False.
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem.
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem.
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object.
Public property | Resolution | Gets and sets the resolution of the subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete).
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs).
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput).
Public property | SupportedChannels | Provides an interface to a SupportedChannels object.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False.
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False.
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False.
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False.
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False.
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False.
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False.
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False.
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False.
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False.
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize.
Public property | Trigger | Provides an interface to a Trigger object.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops.
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied.

See Also

SubsystemBase Class
OpenLayers.DeviceCollection Namespace


SubsystemBase Methods

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Methods
SubsystemBase Class See Also Send Feedback

The SubsystemBase type exposes the following members.

Methods

 | Name | Description
Public method | Abort | Stops an operation on the subsystem immediately.
Public method | Config | Configures the subsystem based on the current property settings.
Public method | Dispose | Releases the subsystem’s connection to the Open Layers device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration.
Public method | Start | Starts an operation on the subsystem.
Public method | Stop | Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubsystemBase Class
OpenLayers.DeviceCollection Namespace


SubsystemBase.Abort Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Abort Method
SubsystemBase Class See Also Send Feedback
Stops an operation on the subsystem immediately.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Abort()
Visual Basic
Public Overridable Sub Abort

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Config Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Config Method
SubsystemBase Class See Also Send Feedback
Configures the subsystem based on the current property settings.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Config()
Visual Basic
Public Overridable Sub Config

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Dispose Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Dispose Method
SubsystemBase Class See Also Send Feedback
Releases the subsystem’s connection to the Open Layers device.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Reset Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Reset Method
SubsystemBase Class See Also Send Feedback
Stops a continuous operation on a subsystem immediately without waiting for the current buffer to be filled or output, and reinitializes the subsystem to the default configuration.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Start Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Start Method
SubsystemBase Class See Also Send Feedback
Starts an operation on the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Start()
Visual Basic
Public Overridable Sub Start

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Stop Method

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Stop Method
SubsystemBase Class See Also Send Feedback
Stops an operation on the subsystem after the current buffer has been filled for input operations or output for output operations.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual void Stop()
Visual Basic
Public Overridable Sub Stop

Remarks

This method is overridden in derived classes.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase Properties

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Properties
SubsystemBase Class See Also Send Feedback

The SubsystemBase type exposes the following members.

Properties

 | Name | Description
Public property | AsynchronousStop | Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem.
Public property | BufferQueue | Provides an interface to a BufferQueue object.
Public property | ChannelList | Provides an interface to a ChannelList object.
Public property | ChannelType | Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem.
Public property | Clock | Provides an interface to a Clock object.
Public property | DataFlow | Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem.
Public property | Device | Returns the Device object that is associated with the subsystem.
Public property | Element | Returns the element number of the subsystem.
Public property | Encoding | Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem.
Public property | FifoSize | Returns the size of the FIFO on the device that is associated with the subsystem.
Public property | IsRunning | Returns True if the subsystem is currently running; otherwise, returns False.
Public property | MaxDifferentialChannels | Returns the total number of Differential channels supported by the subsystem.
Public property | MaxSingleEndedChannels | Returns the total number of SingleEnded channels supported by the subsystem.
Public property | NumberOfChannels | Returns the total number of channels that are supported by the subsystem.
Public property | NumberOfResolutions | Returns the number of resolutions that are supported by the subsystem.
Public property | ReferenceTrigger | Provides an interface to ReferenceTrigger object.
Public property | Resolution | Gets and sets the resolution of the subsystem.
Public property | ReturnsFloats | Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values.
Public property | State | Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete).
Public property | StopOnError | Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs).
Public property | SubsystemType | Returns the subsystem type (AnalogInput or AnalogOutput).
Public property | SupportedChannels | Provides an interface to a SupportedChannels object.
Public property | SupportedResolutions | Returns an array of available resolutions that are supported by the subsystem.
Public property | SupportsBinaryEncoding | Returns True if the subsystem supports Binary data encoding; otherwise, returns False.
Public property | SupportsBuffering | Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False.
Public property | SupportsChannelListInhibit | Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False.
Public property | SupportsContinuous | Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False.
Public property | SupportsContinuousPrePostTrigger | Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False.
Public property | SupportsContinuousPreTrigger | Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False.
Public property | SupportsCurrentOutput | Returns True if the subsystem supports current outputs; otherwise, returns False.
Public property | SupportsDifferential | Returns True if the subsystem supports Differential channels; otherwise, returns False.
Public property | SupportsProgrammableGain | Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False.
Public property | SupportsSetSingleValues | Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False.
Public property | SupportsSimultaneousStart | Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False.
Public property | SupportsSingleEnded | Returns True if the subsystem supports SingleEnded channels; otherwise, returns False.
Public property | SupportsSingleValue | Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False.
Public property | SupportsSoftwareResolution | Returns True if the subsystem supports software-programmable resolution; otherwise, returns False.
Public property | SupportsTwosCompEncoding | Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False.
Public property | SupportsWaveformModeOnly | Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize.
Public property | Trigger | Provides an interface to a Trigger object.

See Also

SubsystemBase Class
OpenLayers.DeviceCollection Namespace


SubsystemBase.AsynchronousStop Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..AsynchronousStop Property
SubsystemBase Class See Also Send Feedback
Gets or sets the stop behavior (synchronous or asynchronous) of the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool AsynchronousStop { get; set; }
Visual Basic
Public Property AsynchronousStop As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If you set the AsynchronousStop property to True, control returns to your program after Stop()()()() is called. If you set the AsynchronousStop property to False (the default setting), control does not return to your program after Stop is called until the OlBuffer object completes. (It is recommended that you do not wait more than 20 seconds for the stop to complete.) If you try to perform another operation while the stop is in progress, an exception is raised with the error code "SubsystemStopping" and the exception message "The subsystem is in the process of stopping or aborting".

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.BufferQueue Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..BufferQueue Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a BufferQueue object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public BufferQueue BufferQueue { get; }
Visual Basic
Public ReadOnly Property BufferQueue As BufferQueue
    Get

Property Value

Type: BufferQueue

Remarks

For continuous analog I/O operations, use this interface to add OlBuffer objects to the subsystem's buffer queue.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.ChannelList Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ChannelList Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a ChannelList object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelList ChannelList { get; set; }
Visual Basic
Public Property ChannelList As ChannelList
    Get
    Set

Property Value

Type: ChannelList

Remarks

Use this interface to set up a channel list for a continuous analog input or output operation.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.ChannelType Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ChannelType Property
SubsystemBase Class See Also Send Feedback
Gets and sets the ChannelType (SingleEnded or Differential) for the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ChannelType ChannelType { get; set; }
Visual Basic
Public Property ChannelType As ChannelType
    Get
    Set

Property Value

Type: ChannelType

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Clock Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Clock Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a Clock object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Clock Clock { get; }
Visual Basic
Public ReadOnly Property Clock As Clock
    Get

Property Value

Type: Clock

Remarks

Use this interface to configure how a subsystem is clocked.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.DataFlow Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..DataFlow Property
SubsystemBase Class See Also Send Feedback
Gets and sets the DataFlow mode (Continuous, SingleValue, ContinuousPreTrigger, or ContinuousPrePostTrigger) of the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public DataFlow DataFlow { get; set; }
Visual Basic
Public Property DataFlow As DataFlow
    Get
    Set

Property Value

Type: DataFlow

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Device Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Device Property
SubsystemBase Class See Also Send Feedback
Returns the Device object that is associated with the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Device Device { get; }
Visual Basic
Public ReadOnly Property Device As Device
    Get

Property Value

Type: Device

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Element Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Element Property
SubsystemBase Class See Also Send Feedback
Returns the element number of the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual int Element { get; }
Visual Basic
Public Overridable ReadOnly Property Element As Integer
    Get

Property Value

Type: Int32

Remarks

Your device may support multiple instances, called elements, of the same subsystem type. Element numbering is zero-based; that is, the first instance of the subsystem is called element 0, the second instance of the subsystem is called element 1, and so on. For example, if your device has two digital input ports, two subsystems of type DigitalInput are available, differentiated as elements 0 and 1.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Encoding Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Encoding Property
SubsystemBase Class See Also Send Feedback
Gets and sets the data Encoding (Binary or TwosComplement) of the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Encoding Encoding { get; set; }
Visual Basic
Public Property Encoding As Encoding
    Get
    Set

Property Value

Type: Encoding

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.FifoSize Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..FifoSize Property
SubsystemBase Class See Also Send Feedback
Returns the size of the FIFO on the device that is associated with the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int FifoSize { get; }
Visual Basic
Public ReadOnly Property FifoSize As Integer
    Get

Property Value

Type: Int32

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.IsRunning Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..IsRunning Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem is currently running; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool IsRunning { get; }
Visual Basic
Public ReadOnly Property IsRunning As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.MaxDifferentialChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..MaxDifferentialChannels Property
SubsystemBase Class See Also Send Feedback
Returns the total number of Differential channels supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int MaxDifferentialChannels { get; }
Visual Basic
Public ReadOnly Property MaxDifferentialChannels As Integer
    Get

Property Value

Type: Int32

Remarks

Use the ChannelType property to set the channel configuration to Differential.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.MaxSingleEndedChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..MaxSingleEndedChannels Property
SubsystemBase Class See Also Send Feedback
Returns the total number of SingleEnded channels supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int MaxSingleEndedChannels { get; }
Visual Basic
Public ReadOnly Property MaxSingleEndedChannels As Integer
    Get

Property Value

Type: Int32

Remarks

Use the ChannelType property to set the channel configuration to SingleEnded.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.NumberOfChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..NumberOfChannels Property
SubsystemBase Class See Also Send Feedback
Returns the total number of channels that are supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfChannels { get; }
Visual Basic
Public ReadOnly Property NumberOfChannels As Integer
    Get

Property Value

Type: Int32

Remarks

This total number of channels includes both native and non-native channels that are supported for the subsystem. For example, if the analog input subsystem supports the ability to stream both analog and digital input data, the digital input channels will be included with the analog input channels in the total channel count. See also and .

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace
OpenLayers.DeviceCollection..::..ChannelListEntry
OpenLayers.DeviceCollection..::..SupportedChannels


SubsystemBase.NumberOfResolutions Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..NumberOfResolutions Property
SubsystemBase Class See Also Send Feedback
Returns the number of resolutions that are supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int NumberOfResolutions { get; }
Visual Basic
Public ReadOnly Property NumberOfResolutions As Integer
    Get

Property Value

Type: Int32

Remarks

To get an array of available resolutions that are supported by the subsystem, use the SupportedResolutions property. Use the Resolution property to specify the resolution for the subsystem.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.ReferenceTrigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ReferenceTrigger Property
SubsystemBase Class See Also Send Feedback
Provides an interface to ReferenceTrigger object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ReferenceTrigger ReferenceTrigger { get; }
Visual Basic
Public ReadOnly Property ReferenceTrigger As ReferenceTrigger
    Get

Property Value

Type: ReferenceTrigger

Remarks

Use this interface to configure how a subsystem is triggered using stop trigger.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Resolution Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Resolution Property
SubsystemBase Class See Also Send Feedback
Gets and sets the resolution of the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual short Resolution { get; set; }
Visual Basic
Public Overridable Property Resolution As Short
    Get
    Set

Property Value

Type: Int16

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.ReturnsFloats Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..ReturnsFloats Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem returns data as floating-point values; otherwise, returns False indicating that the subsystem returns data as integer values.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool ReturnsFloats { get; }
Visual Basic
Public ReadOnly Property ReturnsFloats As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.State Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..State Property
SubsystemBase Class See Also Send Feedback
Returns the current state of the subsystem (Initialized, ConfiguredForSingleValue, ConfiguredForContinuous, PreStarted, Running, Stopping, Aborting, or IoComplete).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase..::..States State { get; }
Visual Basic
Public ReadOnly Property State As SubsystemBase..::..States
    Get

Property Value

Type: SubsystemBase..::..States

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.StopOnError Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..StopOnError Property
SubsystemBase Class See Also Send Feedback
Gets or sets the stop-on-error condition (stop if overrun or underrun occurs, or continue if overrun or underrun occurs).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic
Public Property StopOnError As Boolean
    Get
    Set

Property Value

Type: Boolean

Remarks

If StopOnError is True, the subsystem automatically stops when an overrun or underrun error occurs. If StopOnError is False, the subsystem continues to run when an overrun or underrun error occurs.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SubsystemType Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SubsystemType Property
SubsystemBase Class See Also Send Feedback
Returns the subsystem type (AnalogInput or AnalogOutput).

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public virtual SubsystemType SubsystemType { get; }
Visual Basic
Public Overridable ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportedChannels Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportedChannels Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a SupportedChannels object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannels SupportedChannels { get; }
Visual Basic
Public ReadOnly Property SupportedChannels As SupportedChannels
    Get

Property Value

Type: SupportedChannels

Remarks

Use this interface to get information about each channel that is supported by the specified subsystem.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportedResolutions Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportedResolutions Property
SubsystemBase Class See Also Send Feedback
Returns an array of available resolutions that are supported by the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double[] SupportedResolutions { get; }
Visual Basic
Public ReadOnly Property SupportedResolutions As Double()
    Get

Property Value

Type: array<Double>[]()[][]

Remarks

Use the Resolution property to specify the resolution for the subsystem.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsBinaryEncoding Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsBinaryEncoding Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports Binary data encoding; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsBinaryEncoding { get; }
Visual Basic
Public ReadOnly Property SupportsBinaryEncoding As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Encoding property to set the data encoding to Binary.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsBuffering Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsBuffering Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports continuous acquisition to or from OlBuffer objects; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsBuffering { get; }
Visual Basic
Public ReadOnly Property SupportsBuffering As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the OlBuffer and BufferQueue classes to set up buffering for your operation.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsChannelListInhibit Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsChannelListInhibit Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports inhibition of a ChannelList entry; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsChannelListInhibit { get; }
Visual Basic
Public ReadOnly Property SupportsChannelListInhibit As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Inhibit property to set the inhibit state for a ChannelListEntry object.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsContinuous Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsContinuous Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports Continuous data flow mode; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsContinuous { get; }
Visual Basic
Public ReadOnly Property SupportsContinuous As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to Continuous.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsContinuousPrePostTrigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsContinuousPrePostTrigger Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports ContinuousPrePostTrigger data flow mode; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsContinuousPrePostTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsContinuousPrePostTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to ContinuousPrePostTrigger.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsContinuousPreTrigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsContinuousPreTrigger Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports ContinuousPreTrigger data flow mode; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsContinuousPreTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsContinuousPreTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to ContinuousPreTrigger.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsCurrentOutput Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsCurrentOutput Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports current outputs; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsCurrentOutput { get; }
Visual Basic
Public ReadOnly Property SupportsCurrentOutput As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsDifferential Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsDifferential Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports Differential channels; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDifferential { get; }
Visual Basic
Public ReadOnly Property SupportsDifferential As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the ChannelType property to set the channel configuration to Differential.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsProgrammableGain Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsProgrammableGain Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports programmable gain for the ChannelListEntry objects; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsProgrammableGain { get; }
Visual Basic
Public ReadOnly Property SupportsProgrammableGain As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Gain property to set the gain for a ChannelListEntry object.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsSetSingleValues Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSetSingleValues Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports updating multiple channels simultaneously with a single value (using SetSingleValuesAsRaw(array<SingleValuesInfoRaw>[]()[][]) or SetSingleValuesAsVolts(array<SingleValuesInfoVolts>[]()[][])); otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSetSingleValues { get; }
Visual Basic
Public ReadOnly Property SupportsSetSingleValues As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsSimultaneousStart Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSimultaneousStart Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports starting multiple subsystems simultaneously; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSimultaneousStart { get; }
Visual Basic
Public ReadOnly Property SupportsSimultaneousStart As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the SimultaneousStart class to set up and manage the simultaneous start list.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsSingleEnded Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSingleEnded Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports SingleEnded channels; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSingleEnded { get; }
Visual Basic
Public ReadOnly Property SupportsSingleEnded As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the ChannelType property to set the channel configuration to SingleEnded.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsSingleValue Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSingleValue Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports SingleValue data flow mode; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSingleValue { get; }
Visual Basic
Public ReadOnly Property SupportsSingleValue As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the DataFlow property to set the data flow mode to SingleValue.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsSoftwareResolution Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsSoftwareResolution Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports software-programmable resolution; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSoftwareResolution { get; }
Visual Basic
Public ReadOnly Property SupportsSoftwareResolution As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Resolution property to specify the resolution for the subsystem.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsTwosCompEncoding Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsTwosCompEncoding Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports TwosComplement data encoding; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsTwosCompEncoding { get; }
Visual Basic
Public ReadOnly Property SupportsTwosCompEncoding As Boolean
    Get

Property Value

Type: Boolean

Remarks

Use the Encoding property to set the data encoding to TwosComplement.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.SupportsWaveformModeOnly Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..SupportsWaveformModeOnly Property
SubsystemBase Class See Also Send Feedback
Returns True if the subsystem supports waveform-based operations using the onboard FIFO only; otherwise, returns False. If this property is True, the buffer wrap mode must be set to WrapSingleBuffer. In addition, the buffer size must be less than or equal to the FifoSize.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsWaveformModeOnly { get; }
Visual Basic
Public ReadOnly Property SupportsWaveformModeOnly As Boolean
    Get

Property Value

Type: Boolean

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.Trigger Property

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..Trigger Property
SubsystemBase Class See Also Send Feedback
Provides an interface to a Trigger object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public Trigger Trigger { get; }
Visual Basic
Public ReadOnly Property Trigger As Trigger
    Get

Property Value

Type: Trigger

Remarks

Use this interface to configure how a subsystem is triggered.

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase Events

[image] [image]

OpenLayers for .NET Documentation
SubsystemBase Events
SubsystemBase Class See Also Send Feedback

The SubsystemBase type exposes the following members.

Events

 | Name | Description
Public event | BufferDoneEvent | For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.
Public event | DeviceRemovedEvent | Occurs when a device is removed from your system while your application is running.
Public event | GeneralFailureEvent | Occurs when a general library failure is encountered.
Public event | QueueDoneEvent | Occurs when no OlBuffer objects are available on the queue and the operation stops.
Public event | QueueStoppedEvent | For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied.

See Also

SubsystemBase Class
OpenLayers.DeviceCollection Namespace


SubsystemBase.BufferDoneEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..BufferDoneEvent Event
SubsystemBase Class See Also Send Feedback
For input operations, occurs when the OlBuffer object has been filled with post-trigger data. For output operations, occurs when all the data in the OlBuffer object has been output. If you stop an analog I/O operation, the event BufferDoneEvent is generated for the current buffer and for up to eight inprocess buffers before a QueueStoppedEvent event occurs.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event BufferDoneHandler BufferDoneEvent
Visual Basic
Public Event BufferDoneEvent As BufferDoneHandler

Value

Type: OpenLayers.DeviceCollection..::..BufferDoneHandler

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.DeviceRemovedEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..DeviceRemovedEvent Event
SubsystemBase Class See Also Send Feedback
Occurs when a device is removed from your system while your application is running.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event DeviceRemovedHandler DeviceRemovedEvent
Visual Basic
Public Event DeviceRemovedEvent As DeviceRemovedHandler

Value

Type: OpenLayers.DeviceCollection..::..DeviceRemovedHandler

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.GeneralFailureEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..GeneralFailureEvent Event
SubsystemBase Class See Also Send Feedback
Occurs when a general library failure is encountered.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event GeneralFailureHandler GeneralFailureEvent
Visual Basic
Public Event GeneralFailureEvent As GeneralFailureHandler

Value

Type: OpenLayers.DeviceCollection..::..GeneralFailureHandler

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.QueueDoneEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..QueueDoneEvent Event
SubsystemBase Class See Also Send Feedback
Occurs when no OlBuffer objects are available on the queue and the operation stops.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event QueueDoneHandler QueueDoneEvent
Visual Basic
Public Event QueueDoneEvent As QueueDoneHandler

Value

Type: OpenLayers.DeviceCollection..::..QueueDoneHandler

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.QueueStoppedEvent Event

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..QueueStoppedEvent Event
SubsystemBase Class See Also Send Feedback
For analog input operations, occurs when a pre- or post-trigger acquisition operation completes or when you stop a continuous analog input operation. For analog output operations, occurs when a continuous analog output operation stops and the queue is emptied.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public event QueueStoppedHandler QueueStoppedEvent
Visual Basic
Public Event QueueStoppedEvent As QueueStoppedHandler

Value

Type: OpenLayers.DeviceCollection..::..QueueStoppedHandler

See Also

SubsystemBase Class
SubsystemBase Members
OpenLayers.DeviceCollection Namespace


SubsystemBase.States Enumeration

[image]

OpenLayers for .NET Documentation
SubsystemBase..::..States Enumeration
SubsystemBase Class See Also Send Feedback
Returns the current state of the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum States
Visual Basic
Public Enumeration States

Members

Member name | Value | Description
Initialized | 1000 | The subsystem is initialized, but not configured.
ConfiguredForSingleValue | 1001 | The subsystem is configured for a single-value operation.
ConfiguredForContinuous | 1002 | The subsystem is configured for a continuous operation.
PreStarted | 1003 | The subsystem was prestarted for a continuous operation.
Running | 1004 | The subsystem is running.
Stopping | 1005 | The subsystem is in the process of stopping.
Aborting | 1006 | The subsystem is in the process of aborting.
IoComplete | 1007 | The final analog output sample has been written from the FIFO on the device.

See Also

OpenLayers.DeviceCollection Namespace


SubsystemType Enumeration

[image]

OpenLayers for .NET Documentation
SubsystemType Enumeration
See Also Send Feedback
Contains the possible values for the SubsystemType property.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum SubsystemType
Visual Basic
Public Enumeration SubsystemType

Members

Member name | Value | Description
AnalogInput | 0 | Analog input subsystem
AnalogOutput | 1 | Analog output subsystem
DigitalInput | 2 | Digital input subsystem
DigitalOutput | 3 | Digital output subsystem
QuadratureDecoder | 4 | Quadrature decoder subsystem
CounterTimer | 5 | Counter/timer subsystem
Tachometer | 6 | Tachometer subsystem

See Also

OpenLayers.DeviceCollection Namespace


SupportedChannelInfo Class

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo Class
Members See Also Send Feedback
The SupportedChannelInfo class describes a specific channel of a subsystem. You access a SupportedChannelInfo object using the SupportedChannels class.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class SupportedChannelInfo
Visual Basic
Public Class SupportedChannelInfo

Remarks

When you get a subsystem of a specified type, the software automatically determines the number of available channels for the subsystem and creates a SupportedChannelInfo object for each channel, containing the following information: physical channel number, logical channel number, logical channel word, channel name, sensor gain, and sensor offset.

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..SupportedChannelInfo

See Also

SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo Members

[image] [image]

OpenLayers for .NET Documentation
SupportedChannelInfo Members
SupportedChannelInfo Class Methods Properties See Also Send Feedback

The SupportedChannelInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Coupling | Gets and sets the CouplingType to apply to the channel.
Public property | ExcitationCurrentSource | Gets and sets the ExcitationCurrentSource to apply to the channel.
Public property | ExcitationCurrentValue | Gets and sets the value of the excitation current source to apply to the channel.
Public property | IOType | Gets the measurement IOType that is supported by the channel.
Public property | LogicalChannelNumber | Returns the zero-based logical channel number that is associated with this channel.
Public property | LogicalChannelWord | For channels with multi-word data (such as a 32-bit counter), returns the zero-based word number that is associated with this channel. For channels without multi-word data, returns -1.
Public property | Name | Gets and sets the name of the associated channel.
Public property | PhysicalChannelNumber | Returns the physical channel number that is associated with this channel.
Public property | SensorGain | Gets and sets the gain value to apply to the sensor that is connected to this channel.
Public property | SensorOffset | Gets and sets the offset value to apply to the sensor that is connected to this channel.
Public property | Subsystem | Returns the subsystem object (AnalogInputSubsystem, AnalogOutputSubsystem, that is associated with this channel.
Public property | SubsystemType | Returns the type of subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that is associated with this channel.

See Also

SupportedChannelInfo Class
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo Methods

[image] [image]

OpenLayers for .NET Documentation
SupportedChannelInfo Methods
SupportedChannelInfo Class See Also Send Feedback

The SupportedChannelInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupportedChannelInfo Class
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo Properties

[image] [image]

OpenLayers for .NET Documentation
SupportedChannelInfo Properties
SupportedChannelInfo Class See Also Send Feedback

The SupportedChannelInfo type exposes the following members.

Properties

 | Name | Description
Public property | Coupling | Gets and sets the CouplingType to apply to the channel.
Public property | ExcitationCurrentSource | Gets and sets the ExcitationCurrentSource to apply to the channel.
Public property | ExcitationCurrentValue | Gets and sets the value of the excitation current source to apply to the channel.
Public property | IOType | Gets the measurement IOType that is supported by the channel.
Public property | LogicalChannelNumber | Returns the zero-based logical channel number that is associated with this channel.
Public property | LogicalChannelWord | For channels with multi-word data (such as a 32-bit counter), returns the zero-based word number that is associated with this channel. For channels without multi-word data, returns -1.
Public property | Name | Gets and sets the name of the associated channel.
Public property | PhysicalChannelNumber | Returns the physical channel number that is associated with this channel.
Public property | SensorGain | Gets and sets the gain value to apply to the sensor that is connected to this channel.
Public property | SensorOffset | Gets and sets the offset value to apply to the sensor that is connected to this channel.
Public property | Subsystem | Returns the subsystem object (AnalogInputSubsystem, AnalogOutputSubsystem, that is associated with this channel.
Public property | SubsystemType | Returns the type of subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that is associated with this channel.

See Also

SupportedChannelInfo Class
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.Coupling Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..Coupling Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the CouplingType to apply to the channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public CouplingType Coupling { get; set; }
Visual Basic
Public Property Coupling As CouplingType
    Get
    Set

Property Value

Type: CouplingType

Remarks

By default, DC coupling is selected for all channels.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.ExcitationCurrentSource Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ExcitationCurrentSource Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the ExcitationCurrentSource to apply to the channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public ExcitationCurrentSource ExcitationCurrentSource { get; set; }
Visual Basic
Public Property ExcitationCurrentSource As ExcitationCurrentSource
    Get
    Set

Property Value

Type: ExcitationCurrentSource

Remarks

By default, the excitation current source is disabled for all channels.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.ExcitationCurrentValue Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..ExcitationCurrentValue Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the value of the excitation current source to apply to the channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double ExcitationCurrentValue { get; set; }
Visual Basic
Public Property ExcitationCurrentValue As Double
    Get
    Set

Property Value

Type: Double

Remarks

This value is applicable only when the excitation current source is internal.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.IOType Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..IOType Property
SupportedChannelInfo Class See Also Send Feedback
Gets the measurement IOType that is supported by the channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public IOType IOType { get; }
Visual Basic
Public ReadOnly Property IOType As IOType
    Get

Property Value

Type: IOType

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.LogicalChannelNumber Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..LogicalChannelNumber Property
SupportedChannelInfo Class See Also Send Feedback
Returns the zero-based logical channel number that is associated with this channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int LogicalChannelNumber { get; }
Visual Basic
Public ReadOnly Property LogicalChannelNumber As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.LogicalChannelWord Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..LogicalChannelWord Property
SupportedChannelInfo Class See Also Send Feedback
For channels with multi-word data (such as a 32-bit counter), returns the zero-based word number that is associated with this channel. For channels without multi-word data, returns -1.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int LogicalChannelWord { get; }
Visual Basic
Public ReadOnly Property LogicalChannelWord As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.Name Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..Name Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the name of the associated channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

Remarks

Each SupportedChannelInfo object in a SupportedChannels collection object must have a unique name. By default, the channels have the following names, which you can modify, if you wish: For analog input channels, the channels are named Ain0, Ain1, and so on. For analog output channels, the channels are named Aout0, Aout1, and so on. For digital input channels, the channels are named Din0, Din1, and so on. For counter/timer channels, the channels are named CT0 Word 0, CT0 Word 1, CT1 Word 0, CT1 Word 1, and so on. For quadrature decoder channels, the channels are named Quad0 Word 0, Quad0 Word 1, Quad1 Word 0, Quad1 Word 1, and so on.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.PhysicalChannelNumber Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..PhysicalChannelNumber Property
SupportedChannelInfo Class See Also Send Feedback
Returns the physical channel number that is associated with this channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int PhysicalChannelNumber { get; }
Visual Basic
Public ReadOnly Property PhysicalChannelNumber As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.SensorGain Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SensorGain Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the gain value to apply to the sensor that is connected to this channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double SensorGain { get; set; }
Visual Basic
Public Property SensorGain As Double
    Get
    Set

Property Value

Type: Double

Remarks

By default, the sensor gain is 1. The sensor gain and offset are used to scale a sample from raw counts to a value in the engineering units of the sensor. The scaling occurs in two steps. First, the raw count value is converted to prescaled voltage using the gain applied to the input signal. Then, the prescaled voltage is scaled using the following equation: y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.SensorOffset Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SensorOffset Property
SupportedChannelInfo Class See Also Send Feedback
Gets and sets the offset value to apply to the sensor that is connected to this channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double SensorOffset { get; set; }
Visual Basic
Public Property SensorOffset As Double
    Get
    Set

Property Value

Type: Double

Remarks

By default, the sensor offset is 0. The sensor gain and offset are used to scale a sample from raw counts to a value in the engineering units of the sensor. The scaling occurs in two steps. First, the raw count value is converted to prescaled voltage using the gain applied to the input signal. Then, the prescaled voltage is scaled using the following equation: y = mx + b, where y is the scaled sensor value, m is the sensor gain, x is the prescaled value in voltage, and b is the sensor offset.

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.Subsystem Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..Subsystem Property
SupportedChannelInfo Class See Also Send Feedback
Returns the subsystem object (AnalogInputSubsystem, AnalogOutputSubsystem, that is associated with this channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemBase Subsystem { get; }
Visual Basic
Public ReadOnly Property Subsystem As SubsystemBase
    Get

Property Value

Type: SubsystemBase

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannelInfo.SubsystemType Property

[image]

OpenLayers for .NET Documentation
SupportedChannelInfo..::..SubsystemType Property
SupportedChannelInfo Class See Also Send Feedback
Returns the type of subsystem (AnalogInput, AnalogOutput, DigitalInput, DigitalOutput, CounterTimer, or QuadratureDecoder) that is associated with this channel.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SubsystemType SubsystemType { get; }
Visual Basic
Public ReadOnly Property SubsystemType As SubsystemType
    Get

Property Value

Type: SubsystemType

See Also

SupportedChannelInfo Class
SupportedChannelInfo Members
OpenLayers.DeviceCollection Namespace


SupportedChannels Class

[image]

OpenLayers for .NET Documentation
SupportedChannels Class
Members Example See Also Send Feedback
The SupportedChannels class describes, through a collection of SupportedChannelInfo objects, the channels available for a particular subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public class SupportedChannels
Visual Basic
Public Class SupportedChannels

Remarks

It is often the case that a subsystem of one type is capable of including data in its data stream from a different subsystem type. For example, an analog input subsystem, which has its own native analog input channels, may also stream data from non-native channels, such as a digital input port or counter/timer channel. Typically, these non-native channels are described in a channel list with numbers beyond the range of its native channels. The Open Layers for .NET Class Library allows you to deal with non-native channels more easily by describing channels in terms of subsystem type and logical channel numbers or channel names.

Examples

Copy image Copy
// rename channel 0
ainSS.SupportedChannels[0].Name = "Pressure Sensor";

// add all available channels to the channel select list
int numChannels = ainSS.SupportedChannels.Count;
for (int i=0; i != numChannels-1; ++i)
{
    // get the channel using the physical channel number
    SupportedChannelInfo curChannel = ainSS.SupportedChannels[i];
    lbAin.Items.Add (curChannel.Name);
}

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..SupportedChannels

See Also

SupportedChannels Members
OpenLayers.DeviceCollection Namespace


SupportedChannels Members

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels Members
SupportedChannels Class Methods Properties See Also Send Feedback

The SupportedChannels type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChannelInfo(Int32) | Returns the SupportedChannelInfo object for the specified physical channel number.
Public method | GetChannelInfo(String) | Returns the SupportedChannelInfo object for the specified channel name.
Public method | GetChannelInfo(SubsystemType, Int32) | Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.
Public method | GetChannelInfo(SubsystemType, Int32, Int32) | Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Returns the number of SupportedChannelInfo objects in the SupportedChannels collection.
Public property | Item | Returns the SupportedChannelInfo object at the specified index ([index]) of the SupportedChannels object.

See Also

SupportedChannels Class
OpenLayers.DeviceCollection Namespace


SupportedChannels Methods

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels Methods
SupportedChannels Class See Also Send Feedback

The SupportedChannels type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetChannelInfo(Int32) | Returns the SupportedChannelInfo object for the specified physical channel number.
Public method | GetChannelInfo(String) | Returns the SupportedChannelInfo object for the specified channel name.
Public method | GetChannelInfo(SubsystemType, Int32) | Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.
Public method | GetChannelInfo(SubsystemType, Int32, Int32) | Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SupportedChannels Class
OpenLayers.DeviceCollection Namespace


SupportedChannels.GetChannelInfo Method

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method
SupportedChannels Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChannelInfo(Int32) | Returns the SupportedChannelInfo object for the specified physical channel number.
Public method | GetChannelInfo(String) | Returns the SupportedChannelInfo object for the specified channel name.
Public method | GetChannelInfo(SubsystemType, Int32) | Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.
Public method | GetChannelInfo(SubsystemType, Int32, Int32) | Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.

See Also

SupportedChannels Class
SupportedChannels Members
OpenLayers.DeviceCollection Namespace


SupportedChannels.GetChannelInfo Method (Int32)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (Int32)
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object for the specified physical channel number.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    int physicalChannel
)
Visual Basic
Public Function GetChannelInfo (
    physicalChannel As Integer
) As SupportedChannelInfo

Parameters

physicalChannel
Type: System..::..Int32
Physical channel number of the subsystem.

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the specified channel.

Remarks

If the channel has multiple logical channel words, this method returns the SupportedChannelInfo object for logical channel word 0.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload
OpenLayers.DeviceCollection Namespace


SupportedChannels.GetChannelInfo Method (String)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (String)
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object for the specified channel name.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    string name
)
Visual Basic
Public Function GetChannelInfo (
    name As String
) As SupportedChannelInfo

Parameters

name
Type: System..::..String
Channel name

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the specified channel.

Remarks

If the channel has multiple logical channel words, this method returns the SupportedChannelInfo object for logical channel word 0.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload
OpenLayers.DeviceCollection Namespace


SupportedChannels.GetChannelInfo Method (SubsystemType, Int32)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (SubsystemType, Int32)
SupportedChannels Class See Also Send Feedback
Returns a SupportedChannelInfo object for the specified subsystem type and logical channel number.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    SubsystemType ssType,
    int subsystemChannel
)
Visual Basic
Public Function GetChannelInfo (
    ssType As SubsystemType,
    subsystemChannel As Integer
) As SupportedChannelInfo

Parameters

ssType
Type: OpenLayers.DeviceCollection..::..SubsystemType
Subsystem type.
subsystemChannel
Type: System..::..Int32
Logical channel number for the subsystem type.

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the specified channel.

Remarks

If the channel has multiple logical channel words, this method returns the SupportedChannelInfo object for logical channel word 0.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload
OpenLayers.DeviceCollection Namespace


SupportedChannels.GetChannelInfo Method (SubsystemType, Int32, Int32)

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..GetChannelInfo Method (SubsystemType, Int32, Int32)
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object for the specified subsystem type, logical channel, and logical channel word.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo GetChannelInfo(
    SubsystemType ssType,
    int subsystemChannel,
    int channelWord
)
Visual Basic
Public Function GetChannelInfo (
    ssType As SubsystemType,
    subsystemChannel As Integer,
    channelWord As Integer
) As SupportedChannelInfo

Parameters

ssType
Type: OpenLayers.DeviceCollection..::..SubsystemType
Subsystem type.
subsystemChannel
Type: System..::..Int32
Logical channel number for the subsystem type.
channelWord
Type: System..::..Int32
Logical channel word for the specified logical channel number.

Return Value

Type: SupportedChannelInfo
SupportedChannelInfo object associated with the logical channel word.

Remarks

For channels like 32-bit counter/timers that return multi-word data, the logical channel word, which is zero-based, maps the physical channel to the data word that it returns. For example, a logical channel word of 0 indicates that this channel returns the first 16-bits of data. A logical channel word of 1 indicates that this channel returns the second 16-bits of data. For channels that do not return multi-word data, the value of the logical channel word is -1.

See Also

SupportedChannels Class
SupportedChannels Members
GetChannelInfo Overload
OpenLayers.DeviceCollection Namespace


SupportedChannels Properties

[image] [image]

OpenLayers for .NET Documentation
SupportedChannels Properties
SupportedChannels Class See Also Send Feedback

The SupportedChannels type exposes the following members.

Properties

 | Name | Description
Public property | Count | Returns the number of SupportedChannelInfo objects in the SupportedChannels collection.
Public property | Item | Returns the SupportedChannelInfo object at the specified index ([index]) of the SupportedChannels object.

See Also

SupportedChannels Class
OpenLayers.DeviceCollection Namespace


SupportedChannels.Count Property

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..Count Property
SupportedChannels Class See Also Send Feedback
Returns the number of SupportedChannelInfo objects in the SupportedChannels collection.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

See Also

SupportedChannels Class
SupportedChannels Members
OpenLayers.DeviceCollection Namespace


SupportedChannels.Item Property

[image]

OpenLayers for .NET Documentation
SupportedChannels..::..Item Property
SupportedChannels Class See Also Send Feedback
Returns the SupportedChannelInfo object at the specified index ([index]) of the SupportedChannels object.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public SupportedChannelInfo this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    index As Integer
) As SupportedChannelInfo
    Get

Parameters

index
Type: System..::..Int32

Property Value

Type: SupportedChannelInfo

See Also

SupportedChannels Class
SupportedChannels Members
OpenLayers.DeviceCollection Namespace


Trigger Class

[image]

OpenLayers for .NET Documentation
Trigger Class
Members See Also Send Feedback
The Trigger class provides an interface for controlling how a subsystem is triggered. For devices that support a start trigger and a reference trigger, the Trigger class is used to set up the start trigger, which starts pre-trigger data acquisition. Use the ReferenceTrigger class to control the reference trigger.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public sealed class Trigger
Visual Basic
Public NotInheritable Class Trigger

Inheritance Hierarchy

System..::..Object
OpenLayers.DeviceCollection..::..Trigger

See Also

Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger Members

[image] [image]

OpenLayers for .NET Documentation
Trigger Members
Trigger Class Methods Properties See Also Send Feedback

The Trigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Level | Gets and sets the trigger threshold value. By default, the trigger threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings.
Public property | PreTriggerSource | Gets and sets the pre-trigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem when using ContinuousPreTrigger or ContinuousPrePostTrigger mode.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos trigger type; otherwise, returns False.
Public property | SupportsSoftwareTrigger | Returns True if the subsystem supports a Software trigger type; otherwise, returns False.
Public property | SupportsSvNegExternalTTLTrigger | Return True if the subsystem supports a TTLNeg trigger type for a single-value operation; otherwise, returns False.
Public property | SupportsSvPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type for a single-value operation; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg trigger event.
Public property | TriggerType | Gets and sets the trigger type (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

Trigger Class
OpenLayers.DeviceCollection Namespace


Trigger Methods

[image] [image]

OpenLayers for .NET Documentation
Trigger Methods
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Trigger Class
OpenLayers.DeviceCollection Namespace


Trigger Properties

[image] [image]

OpenLayers for .NET Documentation
Trigger Properties
Trigger Class See Also Send Feedback

The Trigger type exposes the following members.

Properties

 | Name | Description
Public property | Level | Gets and sets the trigger threshold value. By default, the trigger threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings.
Public property | PreTriggerSource | Gets and sets the pre-trigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem when using ContinuousPreTrigger or ContinuousPrePostTrigger mode.
Public property | SupportedThresholdTriggerChannels | Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.
Public property | SupportsDigitalEventTrigger | Returns True if the subsystem supports a DigitalEvent trigger type; otherwise, returns False.
Public property | SupportsNegExternalTTLTrigger | Returns True if the subsystem supports a TTLNeg trigger type; otherwise, returns False.
Public property | SupportsNegThresholdTrigger | Returns True if the subsystem supports a ThresholdNeg trigger type; otherwise, returns False.
Public property | SupportsPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type; otherwise, returns False.
Public property | SupportsPosThresholdTrigger | Returns True if the subsystem supports a ThresholdPos trigger type; otherwise, returns False.
Public property | SupportsSoftwareTrigger | Returns True if the subsystem supports a Software trigger type; otherwise, returns False.
Public property | SupportsSvNegExternalTTLTrigger | Return True if the subsystem supports a TTLNeg trigger type for a single-value operation; otherwise, returns False.
Public property | SupportsSvPosExternalTTLTrigger | Return True if the subsystem supports a TTLPos trigger type for a single-value operation; otherwise, returns False.
Public property | ThresholdTriggerChannel | Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg trigger event.
Public property | TriggerType | Gets and sets the trigger type (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

See Also

Trigger Class
OpenLayers.DeviceCollection Namespace


Trigger.Level Property

[image]

OpenLayers for .NET Documentation
Trigger..::..Level Property
Trigger Class See Also Send Feedback
Gets and sets the trigger threshold value. By default, the trigger threshold value is in voltage unless specified otherwise for the device; see the user's manual for your device for valid threshold value settings.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public double Level { get; set; }
Visual Basic
Public Property Level As Double
    Get
    Set

Property Value

Type: Double

Remarks

This propery is valid only if TriggerType property is ThresholdPos or ThresholdNeg trigger type. The threshold level set by this property is the value after the gain is a applied to the threshold trigger channel. For example, if the voltage range of the subsystem is ±10 V, and the specified gain is 1, specify a threshold voltage level within ±10 V. Likewise, if the voltage range of the subsystem is ±10 V, and the specified gain is 10, specify a threshold voltage level within ±1 V.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.PreTriggerSource Property

[image]

OpenLayers for .NET Documentation
Trigger..::..PreTriggerSource Property
Trigger Class See Also Send Feedback
Gets and sets the pre-trigger source (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem when using ContinuousPreTrigger or ContinuousPrePostTrigger mode.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TriggerType PreTriggerSource { get; set; }
Visual Basic
Public Property PreTriggerSource As TriggerType
    Get
    Set

Property Value

Type: TriggerType

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportedThresholdTriggerChannels Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportedThresholdTriggerChannels Property
Trigger Class See Also Send Feedback
Returns an array containing the channels that can be used for ThresholdPos or ThresholdNeg TriggerTypes.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int[] SupportedThresholdTriggerChannels { get; }
Visual Basic
Public ReadOnly Property SupportedThresholdTriggerChannels As Integer()
    Get

Property Value

Type: array<Int32>[]()[][]

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsDigitalEventTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsDigitalEventTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a DigitalEvent trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsDigitalEventTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsDigitalEventTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsNegExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsNegExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a TTLNeg trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsNegThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsNegThresholdTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdNeg trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsNegThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsNegThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsPosExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsPosExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Return True if the subsystem supports a TTLPos trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsPosThresholdTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsPosThresholdTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a ThresholdPos trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsPosThresholdTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsPosThresholdTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsSoftwareTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsSoftwareTrigger Property
Trigger Class See Also Send Feedback
Returns True if the subsystem supports a Software trigger type; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSoftwareTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsSoftwareTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsSvNegExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsSvNegExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Return True if the subsystem supports a TTLNeg trigger type for a single-value operation; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSvNegExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsSvNegExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.SupportsSvPosExternalTTLTrigger Property

[image]

OpenLayers for .NET Documentation
Trigger..::..SupportsSvPosExternalTTLTrigger Property
Trigger Class See Also Send Feedback
Return True if the subsystem supports a TTLPos trigger type for a single-value operation; otherwise, returns False.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public bool SupportsSvPosExternalTTLTrigger { get; }
Visual Basic
Public ReadOnly Property SupportsSvPosExternalTTLTrigger As Boolean
    Get

Property Value

Type: Boolean

Remarks

Set the trigger type using the TriggerType property.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.ThresholdTriggerChannel Property

[image]

OpenLayers for .NET Documentation
Trigger..::..ThresholdTriggerChannel Property
Trigger Class See Also Send Feedback
Gets and sets the number of the channel that the device monitors for the ThresholdPos or ThresholdNeg trigger event.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public int ThresholdTriggerChannel { get; set; }
Visual Basic
Public Property ThresholdTriggerChannel As Integer
    Get
    Set

Property Value

Type: Int32

Remarks

This propery is valid only if the TriggerType property is ThresholdPos or ThresholdNeg.

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


Trigger.TriggerType Property

[image]

OpenLayers for .NET Documentation
Trigger..::..TriggerType Property
Trigger Class See Also Send Feedback
Gets and sets the trigger type (Software, TTLPos, TTLNeg, DigitalEvent, ThresholdPos, or ThresholdNeg) for the subsystem.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public TriggerType TriggerType { get; set; }
Visual Basic
Public Property TriggerType As TriggerType
    Get
    Set

Property Value

Type: TriggerType

See Also

Trigger Class
Trigger Members
OpenLayers.DeviceCollection Namespace


TriggerType Enumeration

[image]

OpenLayers for .NET Documentation
TriggerType Enumeration
See Also Send Feedback
Contains the possible values for the TriggerType, PreTriggerSource, and RetriggerSource properties.

Namespace: OpenLayers.DeviceCollection
Assembly: OpenLayers.Base (in OpenLayers.Base.dll) Version: 1.6.20.37

Syntax

C#
public enum TriggerType
Visual Basic
Public Enumeration TriggerType

Members

Member name | Value | Description
Software | 300 | Software (internal) trigger. The trigger occurs when the Start()()()() method is executed.
TTLPos | 301 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the rising edge of the digital TTL signal.
DigitalEvent | 304 | A trigger is generated when an external digital event occurs.
TTLNeg | 306 | An external digital (TTL) signal attached to the device. The trigger occurs when the device detects a transition on the falling edge of the digital TTL signal.
ThresholdPos | 1200 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A positive analog threshold trigger occurs when the device detects a positive-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.
ThresholdNeg | 1201 | Either an analog signal from an analog input channel or an external analog signal attached to the device. A negative analog threshold trigger occurs when the device detects a negative-going signal that crosses a threshold value. The threshold level is generally set using an analog output subsystem on the device.

See Also

OpenLayers.DeviceCollection Namespace


OpenLayers.Signals Namespace

[image]

OpenLayers for .NET Documentation
OpenLayers.Signals Namespace
Send Feedback
Contains a list of signals that can be applied to the DT-Display user control.

Classes

 | Class | Description
Public class | MemorySignal | MemorySignal is the base class of all memory-resident signal data.
Public class | MemorySignalList | Collection of MemorySignal objects.
Public class | Signal | Signal is the base class of all signal data.


MemorySignal Class

[image]

OpenLayers for .NET Documentation
MemorySignal Class
Members See Also Send Feedback
MemorySignal is the base class of all memory-resident signal data.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public class MemorySignal : Signal
Visual Basic
Public Class MemorySignal
    Inherits Signal

Remarks

The data for the signal is contained in the Data field of this class.

Inheritance Hierarchy

System..::..Object
OpenLayers.Signals..::..Signal
OpenLayers.Signals..::..MemorySignal

See Also

MemorySignal Members
OpenLayers.Signals Namespace


MemorySignal Members

[image] [image]

OpenLayers for .NET Documentation
MemorySignal Members
MemorySignal Class Constructors Methods Fields Properties Events See Also Send Feedback

The MemorySignal type exposes the following members.

Constructors

 | Name | Description
Public method | MemorySignal | Initializes a new instance of the MemorySignal class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Data | Contains the signal data as a memory-resident array of doubles.

Properties

 | Name | Description
Public property | CurrentRangeMax | Gets or sets the upper limit of the y-axis that is visible. (Inherited from Signal.)
Public property | CurrentRangeMin | Gets or sets the lower limit of the y-axis that is visible. (Inherited from Signal.)
Public property | Length | Returns the number of elements in the Data field.
Public property | Name | Gets or sets the name of the signal. This name will be displayed on the y-axis. (Inherited from Signal.)
Public property | RangeMax | Gets or sets the maximum value that can be displayed on the y-axis. (Inherited from Signal.)
Public property | RangeMin | Gets or sets the minimum value that can be displayed on the y-axis. (Inherited from Signal.)
Public property | Unit | Gets or sets the engineering units (such as Volts or Ampere) for the signal. These units will be displayed on the y-axis. (Inherited from Signal.)

Events

 | Name | Description
Public event | SignalUpdated | Occurs whenever the Signal object is updated. (Inherited from Signal.)

See Also

MemorySignal Class
OpenLayers.Signals Namespace


MemorySignal Constructor

[image]

OpenLayers for .NET Documentation
MemorySignal Constructor
MemorySignal Class See Also Send Feedback
Initializes a new instance of the MemorySignal class

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public MemorySignal()
Visual Basic
Public Sub New

See Also

MemorySignal Class
MemorySignal Members
OpenLayers.Signals Namespace


MemorySignal Fields

[image] [image]

OpenLayers for .NET Documentation
MemorySignal Fields
MemorySignal Class See Also Send Feedback

The MemorySignal type exposes the following members.

Fields

 | Name | Description
Public field | Data | Contains the signal data as a memory-resident array of doubles.

See Also

MemorySignal Class
OpenLayers.Signals Namespace


MemorySignal.Data Field

[image]

OpenLayers for .NET Documentation
MemorySignal..::..Data Field
MemorySignal Class Example See Also Send Feedback
Contains the signal data as a memory-resident array of doubles.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double[] Data
Visual Basic
Public Data As Double()

Field Value

Type: array<Double>[]()[][]

Remarks

You use this field to assign data to a MemorySignal object. The number of samples for each signal must be the same, and is specified using the SignalBufferLength property.

Examples

This example assigns data to a MemorySignal object using the Signals property. In this example, each channel in a buffer of analog input data (collected using the Open Layers for .NET Class Library) is assigned to a MemorySignal object in the MemorySignalList collection.
Copy image Copy
<SPAN class="lang">[C#]</SPAN>
             //Get voltage data from an analog input channel
             double[] voltagedata = buffer.GetDataAsVolts (ainSS.ChannelList[channel]);
             //Assign this data to a MemorySignal object
             display1.Signals[channel].Data = voltagedata;

             <SPAN class="lang">[Visual Basic]</SPAN>
             'Get voltage data from an analog input channel
             Dim voltagedata As Double() = buffer.GetDataAsVolts(ainSS.ChannelList(channel))
             'Assign this data to a MemorySignal object
             display1.Signals(channel).Data = voltagedata

See Also

MemorySignal Class
MemorySignal Members
OpenLayers.Signals Namespace


MemorySignal Methods

[image] [image]

OpenLayers for .NET Documentation
MemorySignal Methods
MemorySignal Class See Also Send Feedback

The MemorySignal type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemorySignal Class
OpenLayers.Signals Namespace


MemorySignal Properties

[image] [image]

OpenLayers for .NET Documentation
MemorySignal Properties
MemorySignal Class See Also Send Feedback

The MemorySignal type exposes the following members.

Properties

 | Name | Description
Public property | CurrentRangeMax | Gets or sets the upper limit of the y-axis that is visible. (Inherited from Signal.)
Public property | CurrentRangeMin | Gets or sets the lower limit of the y-axis that is visible. (Inherited from Signal.)
Public property | Length | Returns the number of elements in the Data field.
Public property | Name | Gets or sets the name of the signal. This name will be displayed on the y-axis. (Inherited from Signal.)
Public property | RangeMax | Gets or sets the maximum value that can be displayed on the y-axis. (Inherited from Signal.)
Public property | RangeMin | Gets or sets the minimum value that can be displayed on the y-axis. (Inherited from Signal.)
Public property | Unit | Gets or sets the engineering units (such as Volts or Ampere) for the signal. These units will be displayed on the y-axis. (Inherited from Signal.)

See Also

MemorySignal Class
OpenLayers.Signals Namespace


MemorySignal.Length Property

[image]

OpenLayers for .NET Documentation
MemorySignal..::..Length Property
MemorySignal Class See Also Send Feedback
Returns the number of elements in the Data field.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public long Length { get; }
Visual Basic
Public ReadOnly Property Length As Long
    Get

Property Value

Type: Int64

See Also

MemorySignal Class
MemorySignal Members
OpenLayers.Signals Namespace


MemorySignal Events

[image] [image]

OpenLayers for .NET Documentation
MemorySignal Events
MemorySignal Class See Also Send Feedback

The MemorySignal type exposes the following members.

Events

 | Name | Description
Public event | SignalUpdated | Occurs whenever the Signal object is updated. (Inherited from Signal.)

See Also

MemorySignal Class
OpenLayers.Signals Namespace


MemorySignalList Class

[image]

OpenLayers for .NET Documentation
MemorySignalList Class
Members See Also Send Feedback
Collection of MemorySignal objects.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public class MemorySignalList : CollectionBase
Visual Basic
Public Class MemorySignalList
    Inherits CollectionBase

Inheritance Hierarchy

System..::..Object
System.Collections..::..CollectionBase
OpenLayers.Signals..::..MemorySignalList

See Also

MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList Members

[image] [image]

OpenLayers for .NET Documentation
MemorySignalList Members
MemorySignalList Class Constructors Methods Properties Events See Also Send Feedback

The MemorySignalList type exposes the following members.

Constructors

 | Name | Description
Public method | MemorySignalList | Initializes a new instance of the MemorySignalList class

Methods

 | Name | Description
Public method | Add | Adds a MemorySignal object to the MemorySignalList collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether a MemorySignalList collection contains a specific MemorySignal object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a MemorySignal object in the MemorySignalList collection.
Public method | Insert | Inserts a MemorySignal object into the MemorySignalList collection.
Public method | Remove | Deletes a MemorySignal object from the MemorySignalList collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Returns or selects a MemorySignal object within the MemorySignalList collection.

Events

 | Name | Description
Public event | SignalListUpdated | Occurs whenever the MemorySignalList count is updated.

See Also

MemorySignalList Class
OpenLayers.Signals Namespace


MemorySignalList Constructor

[image]

OpenLayers for .NET Documentation
MemorySignalList Constructor
MemorySignalList Class See Also Send Feedback
Initializes a new instance of the MemorySignalList class

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public MemorySignalList()
Visual Basic
Public Sub New

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList Methods

[image] [image]

OpenLayers for .NET Documentation
MemorySignalList Methods
MemorySignalList Class See Also Send Feedback

The MemorySignalList type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a MemorySignal object to the MemorySignalList collection.
Public method | Clear | Removes all objects from the CollectionBase instance. This method cannot be overridden. (Inherited from CollectionBase.)
Public method | Contains | Determines whether a MemorySignalList collection contains a specific MemorySignal object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Returns the index of a MemorySignal object in the MemorySignalList collection.
Public method | Insert | Inserts a MemorySignal object into the MemorySignalList collection.
Public method | Remove | Deletes a MemorySignal object from the MemorySignalList collection.
Public method | RemoveAt | Removes the element at the specified index of the CollectionBase instance. This method is not overridable. (Inherited from CollectionBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MemorySignalList Class
OpenLayers.Signals Namespace


MemorySignalList.Add Method

[image]

OpenLayers for .NET Documentation
MemorySignalList..::..Add Method
MemorySignalList Class Example See Also Send Feedback
Adds a MemorySignal object to the MemorySignalList collection.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public int Add(
    MemorySignal value
)
Visual Basic
Public Function Add (
    value As MemorySignal
) As Integer

Parameters

value
Type: OpenLayers.Signals..::..MemorySignal
The MemorySignal object to add.

Return Value

Type: Int32
The index of the added MemorySignal object in the MemorySignalList collection.

Remarks

The data array of each added signal is set to the length defined by the SignalBufferLength property.

Examples

This example creates and adds a MemorySignal object to the MemorySignalList collection.
Copy image Copy
<SPAN class="lang">[C#]</SPAN>
             OpenLayers.Signals.MemorySignal memorySignal1 = new OpenLayers.Signals.MemorySignal();
             memorySignal1.CurrentRangeMax = 100;
             memorySignal1.CurrentRangeMin = 0;
             memorySignal1.Name = "SignalName";
             memorySignal1.RangeMax = 100;
             memorySignal1.RangeMin = 0;
             memorySignal1.Unit = "SignalUnit";
             this.display1.Signals.Add(memorySignal1);

             <SPAN class="lang">[Visual Basic]</SPAN>
             Dim MemorySignal1 As OpenLayers.Signals.MemorySignal = New OpenLayers.Signals.MemorySignal
             MemorySignal1.CurrentRangeMax = 100
             MemorySignal1.CurrentRangeMin = 0
             MemorySignal1.Name = "SignalName"
             MemorySignal1.RangeMax = 100
             MemorySignal1.RangeMin = 0
             MemorySignal1.Unit = "SignalUnit"
             Me.Display1.Signals.Add(MemorySignal1)

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList.Contains Method

[image]

OpenLayers for .NET Documentation
MemorySignalList..::..Contains Method
MemorySignalList Class Example See Also Send Feedback
Determines whether a MemorySignalList collection contains a specific MemorySignal object.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public bool Contains(
    MemorySignal value
)
Visual Basic
Public Function Contains (
    value As MemorySignal
) As Boolean

Parameters

value
Type: OpenLayers.Signals..::..MemorySignal
The MemorySignal object to search for in the MemorySignalList collection.

Return Value

Type: Boolean
True if the specified MemorySignal object is in the MemorySignalList collection; otherwise, returns False.

Examples

This example returns a Boolean value indicating whether MemorySignal1 is in the MemorySignalList collection.
Copy image Copy
<SPAN class="lang">[C#]</SPAN>
             Flag = this.display1.Signals.Contains(memorySignal1);

             <SPAN class="lang">[Visual Basic]</SPAN>
             Dim bFlag As Boolean = Me.Display1.Signals.Contains(MemorySignal1)

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList.IndexOf Method

[image]

OpenLayers for .NET Documentation
MemorySignalList..::..IndexOf Method
MemorySignalList Class Example See Also Send Feedback
Returns the index of a MemorySignal object in the MemorySignalList collection.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public int IndexOf(
    MemorySignal value
)
Visual Basic
Public Function IndexOf (
    value As MemorySignal
) As Integer

Parameters

value
Type: OpenLayers.Signals..::..MemorySignal
The MemorySignal object whose index you want.

Return Value

Type: Int32
The index of the specified MemorySignal object.

Examples

This example returns the index of MemorySignal1 in the MemorySignalList collection.
Copy image Copy
<SPAN class="lang">[C#]</SPAN>
             Value = this.display1.Signals.IndexOf(memorySignal1);

             <SPAN class="lang">[Visual Basic]</SPAN>
             Dim Value As Int32 = Me.Display1.Signals.IndexOf(MemorySignal1)

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList.Insert Method

[image]

OpenLayers for .NET Documentation
MemorySignalList..::..Insert Method
MemorySignalList Class Example See Also Send Feedback
Inserts a MemorySignal object into the MemorySignalList collection.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void Insert(
    int index,
    MemorySignal value
)
Visual Basic
Public Sub Insert (
    index As Integer,
    value As MemorySignal
)

Parameters

index
Type: System..::..Int32
The index of the MemorySignalList collection at which to insert the MemorySignal object.
value
Type: OpenLayers.Signals..::..MemorySignal
The MemorySignal object to insert.

Remarks

The data array of each inserted signal is set to the length defined by the SignalBufferLength property.

Examples

This example inserts MemorySignal3 at index 0 of the MemorySignalList collection.
Copy image Copy
<SPAN class="lang">[C#]</SPAN>
             this.display1.Signals.Insert(0, memorySignal3);

             <SPAN class="lang">[Visual Basic]</SPAN>
             Me.Display1.Signals.Insert(0, MemorySignal3)

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList.Remove Method

[image]

OpenLayers for .NET Documentation
MemorySignalList..::..Remove Method
MemorySignalList Class Example See Also Send Feedback
Deletes a MemorySignal object from the MemorySignalList collection.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public void Remove(
    MemorySignal value
)
Visual Basic
Public Sub Remove (
    value As MemorySignal
)

Parameters

value
Type: OpenLayers.Signals..::..MemorySignal
The MemorySignal object to delete from the MemorySignalList collection.

Examples

This example removes MemorySignal1 from the MemorySignalList collection.
Copy image Copy
<SPAN class="lang">[C#]</SPAN>
             this.display1.Signals.Remove(memorySignal1);

             <SPAN class="lang">[Visual Basic]</SPAN>
             Me.Display1.Signals.Remove(MemorySignal1)

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList Properties

[image] [image]

OpenLayers for .NET Documentation
MemorySignalList Properties
MemorySignalList Class See Also Send Feedback

The MemorySignalList type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
Public property | Count | Gets the number of elements contained in the CollectionBase instance. This property cannot be overridden. (Inherited from CollectionBase.)
Public property | Item | Returns or selects a MemorySignal object within the MemorySignalList collection.

See Also

MemorySignalList Class
OpenLayers.Signals Namespace


MemorySignalList.Item Property

[image]

OpenLayers for .NET Documentation
MemorySignalList..::..Item Property
MemorySignalList Class See Also Send Feedback
Returns or selects a MemorySignal object within the MemorySignalList collection.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public MemorySignal this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item (
    index As Integer
) As MemorySignal
    Get
    Set

Parameters

index
Type: System..::..Int32

Property Value

Type: MemorySignal

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


MemorySignalList Events

[image] [image]

OpenLayers for .NET Documentation
MemorySignalList Events
MemorySignalList Class See Also Send Feedback

The MemorySignalList type exposes the following members.

Events

 | Name | Description
Public event | SignalListUpdated | Occurs whenever the MemorySignalList count is updated.

See Also

MemorySignalList Class
OpenLayers.Signals Namespace


MemorySignalList.SignalListUpdated Event

[image]

OpenLayers for .NET Documentation
MemorySignalList..::..SignalListUpdated Event
MemorySignalList Class See Also Send Feedback
Occurs whenever the MemorySignalList count is updated.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public event EventHandler SignalListUpdated
Visual Basic
Public Event SignalListUpdated As EventHandler

Value

Type: System..::..EventHandler

See Also

MemorySignalList Class
MemorySignalList Members
OpenLayers.Signals Namespace


Signal Class

[image]

OpenLayers for .NET Documentation
Signal Class
Members See Also Send Feedback
Signal is the base class of all signal data.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public class Signal
Visual Basic
Public Class Signal

Inheritance Hierarchy

System..::..Object
OpenLayers.Signals..::..Signal
OpenLayers.Signals..::..MemorySignal

See Also

Signal Members
OpenLayers.Signals Namespace


Signal Members

[image] [image]

OpenLayers for .NET Documentation
Signal Members
Signal Class Constructors Methods Properties Events See Also Send Feedback

The Signal type exposes the following members.

Constructors

 | Name | Description
Public method | Signal | Initializes and returns a Signal object with the following default values: Name = SignalName, Unit = SignalUnit, RangeMin = 0, RangeMax = 100, CurrentRangeMin = 0, CurrentRangeMax = 100.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentRangeMax | Gets or sets the upper limit of the y-axis that is visible.
Public property | CurrentRangeMin | Gets or sets the lower limit of the y-axis that is visible.
Public property | Name | Gets or sets the name of the signal. This name will be displayed on the y-axis.
Public property | RangeMax | Gets or sets the maximum value that can be displayed on the y-axis.
Public property | RangeMin | Gets or sets the minimum value that can be displayed on the y-axis.
Public property | Unit | Gets or sets the engineering units (such as Volts or Ampere) for the signal. These units will be displayed on the y-axis.

Events

 | Name | Description
Public event | SignalUpdated | Occurs whenever the Signal object is updated.

See Also

Signal Class
OpenLayers.Signals Namespace


Signal Constructor

[image]

OpenLayers for .NET Documentation
Signal Constructor
Signal Class See Also Send Feedback
Initializes and returns a Signal object with the following default values:
Name = SignalName, Unit = SignalUnit,
RangeMin = 0, RangeMax = 100,
CurrentRangeMin = 0, CurrentRangeMax = 100.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public Signal()
Visual Basic
Public Sub New

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace


Signal Methods

[image] [image]

OpenLayers for .NET Documentation
Signal Methods
Signal Class See Also Send Feedback

The Signal type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Signal Class
OpenLayers.Signals Namespace


Signal Properties

[image] [image]

OpenLayers for .NET Documentation
Signal Properties
Signal Class See Also Send Feedback

The Signal type exposes the following members.

Properties

 | Name | Description
Public property | CurrentRangeMax | Gets or sets the upper limit of the y-axis that is visible.
Public property | CurrentRangeMin | Gets or sets the lower limit of the y-axis that is visible.
Public property | Name | Gets or sets the name of the signal. This name will be displayed on the y-axis.
Public property | RangeMax | Gets or sets the maximum value that can be displayed on the y-axis.
Public property | RangeMin | Gets or sets the minimum value that can be displayed on the y-axis.
Public property | Unit | Gets or sets the engineering units (such as Volts or Ampere) for the signal. These units will be displayed on the y-axis.

See Also

Signal Class
OpenLayers.Signals Namespace


Signal.CurrentRangeMax Property

[image]

OpenLayers for .NET Documentation
Signal..::..CurrentRangeMax Property
Signal Class See Also Send Feedback
Gets or sets the upper limit of the y-axis that is visible.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double CurrentRangeMax { get; set; }
Visual Basic
Public Property CurrentRangeMax As Double
    Get
    Set

Property Value

Type: Double

Remarks

The RangeMin and RangeMax properties specify the entire range that can be displayed on the y-axis. By setting the CurrentRangeMax and CurrentRangeMax properties you define a subset of this range that will be displayed on the y-axis; this is called the current visible range. In general, the value of this propery should be less than or equal to the value of the RangeMax property. By default, the value of this property is 100.

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace


Signal.CurrentRangeMin Property

[image]

OpenLayers for .NET Documentation
Signal..::..CurrentRangeMin Property
Signal Class See Also Send Feedback
Gets or sets the lower limit of the y-axis that is visible.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double CurrentRangeMin { get; set; }
Visual Basic
Public Property CurrentRangeMin As Double
    Get
    Set

Property Value

Type: Double

Remarks

The RangeMin and RangeMax properties specify the entire range that can be displayed on the y-axis. By setting the CurrentRangeMin and CurrentRangeMax properties you define a subset of this range that will be displayed on the y-axis; this is called the current visible range. In general, the value of CurrentRangeMin should be greater than or equal to the value of the RangeMin property. By default, the value of this property is 0.

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace


Signal.Name Property

[image]

OpenLayers for .NET Documentation
Signal..::..Name Property
Signal Class See Also Send Feedback
Gets or sets the name of the signal. This name will be displayed on the y-axis.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

Property Value

Type: String

Remarks

By default, the value of this property is SignalName.

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace


Signal.RangeMax Property

[image]

OpenLayers for .NET Documentation
Signal..::..RangeMax Property
Signal Class See Also Send Feedback
Gets or sets the maximum value that can be displayed on the y-axis.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double RangeMax { get; set; }
Visual Basic
Public Property RangeMax As Double
    Get
    Set

Property Value

Type: Double

Remarks

The RangeMin and RangeMax properties specify the entire range that can be displayed on the y-axis. You can display a subset of this range, called the current visible range, by setting the CurrentRangeMin and CurrentRangeMax properties. By default, the value of this property is 100.

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace


Signal.RangeMin Property

[image]

OpenLayers for .NET Documentation
Signal..::..RangeMin Property
Signal Class See Also Send Feedback
Gets or sets the minimum value that can be displayed on the y-axis.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public double RangeMin { get; set; }
Visual Basic
Public Property RangeMin As Double
    Get
    Set

Property Value

Type: Double

Remarks

The RangeMin and RangeMax properties specify the entire range that can be displayed on the y-axis. You can display a subset of this range, called the current visible range, by setting the CurrentRangeMin and CurrentRangeMax properties. By default, the value of this property is 0.

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace


Signal.Unit Property

[image]

OpenLayers for .NET Documentation
Signal..::..Unit Property
Signal Class See Also Send Feedback
Gets or sets the engineering units (such as Volts or Ampere) for the signal. These units will be displayed on the y-axis.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public string Unit { get; set; }
Visual Basic
Public Property Unit As String
    Get
    Set

Property Value

Type: String

Remarks

By default, the value of this property is SignalUnit.

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace


Signal Events

[image] [image]

OpenLayers for .NET Documentation
Signal Events
Signal Class See Also Send Feedback

The Signal type exposes the following members.

Events

 | Name | Description
Public event | SignalUpdated | Occurs whenever the Signal object is updated.

See Also

Signal Class
OpenLayers.Signals Namespace


Signal.SignalUpdated Event

[image]

OpenLayers for .NET Documentation
Signal..::..SignalUpdated Event
Signal Class See Also Send Feedback
Occurs whenever the Signal object is updated.

Namespace: OpenLayers.Signals
Assembly: OpenLayers.Controls (in OpenLayers.Controls.dll) Version: 1.0.0.0

Syntax

C#
public virtual event EventHandler SignalUpdated
Visual Basic
Public Overridable Event SignalUpdated As EventHandler

Value

Type: System..::..EventHandler

See Also

Signal Class
Signal Members
OpenLayers.Signals Namespace